Subject: Update and move of codimd

From: Robert Sparks <[email-masked]>
Date: Fri, 6 Aug 2021 14:40:02 -0500

FYI -

Next Tuesday 10 Aug, around 2000 UTC, we will be moving where 
codimd.ietf.org is running, and moving to the latest version (which will 
reflect the rename of the project to Hedgedoc). Editing and reading 
notes during that time may be interrupted.

RjS

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 7 Aug 2021 09:19:05 +1000

Just a suggestion - can we use a host name that reflects the function, rather than the product used?  Eg ‘pad.ietf.org’?

Sent from my iPhone

> On 7 Aug 2021, at 5:40 am, Robert Sparks <[email-masked]> wrote:
> 
> FYI -
> 
> Next Tuesday 10 Aug, around 2000 UTC, we will be moving where codimd.ietf.org is running, and moving to the latest version (which will reflect the rename of the project to Hedgedoc). Editing and reading notes during that time may be interrupted.
> 
> RjS
> 
> 
>

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 6 Aug 2021 19:21:35 -0400

CNAMEs are wonderful things!

On Fri, Aug 6, 2021 at 7:19 PM Mark Nottingham <[email-masked]> wrote:

> Just a suggestion - can we use a host name that reflects the function,
> rather than the product used?  Eg ‘pad.ietf.org’?
>
> Sent from my iPhone
>
> reflect the rename of the project to Hedgedoc). Editing and reading notes
> during that time may be interrupted.
> >
> > RjS
> >
> >
> >
>
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 10 Aug 2021 15:59:21 -0500

This is done.

The result is at notes.ietf.org.

RjS

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 11 Aug 2021 09:38:14 +1000

Nice!

Are we planning to update the front page to IETF-brand it?

> On 11 Aug 2021, at 6:59 am, Robert Sparks <[email-masked]> wrote:
> 
> This is done.
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Jay Daley <[email-masked]>
Date: Wed, 11 Aug 2021 12:01:38 +1200

Looping in Greg as the person responsible for adding IETF branding to new services.

I believe a custom /intro.md is supported so this is possible.

Jay

> On 11/08/2021, at 11:38 AM, Mark Nottingham <[email-masked]> wrote:
> 
> Nice!
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Greg Wood <[email-masked]>
Date: Wed, 11 Aug 2021 09:32:30 -0400

Hi Mark (and everyone),

I’m looking into what’s possible at the moment, but if there are specific attributes you think would make the “Intro” page more useful, please feel free to send suggestions directly to me.

-Greg

> On 10, Aug2021, at 20:01, Jay Daley <[email-masked]> wrote:
>

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 11 Aug 2021 18:18:24 +0200

I would like to see a clear description of the expected rules of use:

e.g.:

Q: is everything put into notes.ietf.org deemed public ?
Q: If not deemed public, then what exactly is the deemed level of
   confidentiality ? "AD-hoc - if you do not share a page name, its kinda confidential ?"

Q: Would it be permissible for IETF to create a public list of all pages ?
Q: Wold it be permissible for IETF to make content older than some time (e.g.: 3 years) public ?

Q: Is there an expectation for pages to be archived ?

Q: If there is no expectation of archival of pages, how long
   will pages be guaranteed not to be changed/taken-down by IETF ?

Q: If pages are not deemed public, how then would use of this tool
   go along with the IETF note well ?

Aka: IMHO, all pages should be deemed public, there actually should be a
list/search across them, and that way archiving and IETF note well are not an issue.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 11 Aug 2021 13:13:29 -0400

Andrew G. Malis <[email-masked]>
1:10 PM (1 minute ago)
to Toerless, Mark, Working, Robert
Toerless,

Repeating the point that I made on the other thread on this topic, you
currently need to use your Datatracker login to access CodIMD/HedgeDoc, so
it's actually not public. And I think that's the correct way to do it, as
it's intended for meeting participants (who all have Datatracker logins in
order to participate) to provide notes regarding IETF meetings and work.

If you really do want it to be public, then I suspect that's something to
take up with the IESG rather than making the point on this list.

And your list of questions are also for the IESG, not for this list.

Cheers,
Andy

On Wed, Aug 11, 2021 at 12:19 PM Toerless Eckert <[email-masked]> wrote:

> > I’m looking into what’s possible at the moment, but if there are
> specific attributes you think would make the “Intro” page more useful,
> please feel free to send suggestions directly to me.
> >
> > -Greg
> >
> >
> > >>>> Just a suggestion - can we use a host name that reflects the
> function, rather than the product used?  Eg ‘pad.ietf.org’?
> > >>>>
> > >>>> Sent from my iPhone
> > >>>>