Subject: Turning off Etherpad

From: Robert Sparks <[email-masked]>
Date: Tue, 10 Aug 2021 16:01:51 -0500

Chairs -

We are making plans to turn down etherpad.ietf.org in a few weeks. Let 
me know of any concerns or need for delay.

RjS

---

From: Fred Baker <[email-masked]>
Date: Tue, 10 Aug 2021 18:05:34 -0700

People use it in recording our minutes. Losing it would be unfortunate.

> On Aug 10, 2021, at 2:01 PM, Robert Sparks <[email-masked]> wrote:
> 
> Chairs -
> 
> We are making plans to turn down etherpad.ietf.org in a few weeks. Let me know of any concerns or need for delay.
> 
> RjS
>

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 11 Aug 2021 03:24:24 +0200

So, what is he plan for archiving etherpad.ietf.org ?
Can/will the be made read-only/no new data ?

Or is all that content that may still have URLs in emails and other places
pointing to it deemed to be lost except for the subset of pages that
where converted into IETF meeting minuts by WG chairs ?

If all this content is meant to be lost because it is too difficult to
change to read-only, is this the same strategy for codimd ? Aka:
if you do not save it, it will be lost at some point in time ?

If converting to read-only is too difficult, maybe the whole tree
can just be put up for download as a tar file for any future researchers...
However, i am not sure if all the content is meant to be public, or if
we did assume some degree of possible confidentiality because of non-searchable
namespace.

Btw: I think it would be great if codimd would solve these issues:
You can only create new names under whatever.ietf.org/2021/<your-string-here>
and after 2 years the whole years directory tree turns read-only with
indexing/search...

Cheers
    Toeless

-- 
---
[email-masked]

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 11 Aug 2021 11:27:41 +1000

My understanding was always that etherpad was a best-effort, ephemeral service; i.e., there was no guarantee (implicit or explicit) of stability or availability. That's probably the right policy, given that there able to be edited by *anyone on the Internet*.

We might consider a somewhat more formal and explicit policy on service stability and availability (on a service-by-service basis), so that folks aren't surprised by this in the future. E.g., the W3C has:
  https://www.w3.org/Consortium/Persistence

Cheers,

> On 11 Aug 2021, at 11:24 am, Toerless Eckert <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Robert Sparks <[email-masked]>
Date: Tue, 10 Aug 2021 21:25:32 -0500

To be clear, _this_ message was specifically about etherpad - the older 
technology that we haven't linked to from agendas for many meetings now.

Codimd, now notes.ietf.org, is not what this message was about.

---

From: Robert Sparks <[email-masked]>
Date: Tue, 10 Aug 2021 21:30:40 -0500

> My understanding was always that etherpad was a best-effort, ephemeral service; i.e., there was no guarantee (implicit or explicit) of stability or availability. That's probably the right policy, g…

This has always been the expectation of both etherpad, and codimd. While 
we work to keep these notepads available for as long as we can, things 
that should stay around "forever" should be captured in artifacts, like 
minutes, that end up in meeting proceedings.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 11 Aug 2021 18:11:05 +0200

> My understanding was always that etherpad was a best-effort, ephemeral service; i.e., there was no guarantee (implicit or explicit) of stability or availability. That's probably the right policy, g…

Yes. But my comments where not about the intent of etherpad,
but if/what we would want to do now to preserve history, even
if that was not a desire when we started using it.

The main question IMHO is whether we could publish the whole content
of etherpad or not. I would like to see that question answered. If
the answer is yes, then we can discuss if and/or how to do that.

If the answer is no, then i guss a tar file could still go into the
IETF vault, and later generations could figure out if/who might
be able to take a look at it.

>   https://www.w3.org/Consortium/Persistence

Right. My suggestion for codimd was exactly around that IMHO:

- declare CodiMD content to be public.
- automatically make older CodiMD content read-only

The conflict between this goal and the design of etherpad/codiMD is that
boh seem to be based on confidentiality by obscurity, e.g.: no
public search and/or list of pages...

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 11 Aug 2021 13:10:08 -0400

Toerless,

Note that you currently need to use your Datatracker login to access
CodIMD/HedgeDoc, so it's actually not public. And I think that's the
correct way to do it, as it's intended for meeting participants (who all
have Datatracker logins in order to participate) to provide notes regarding
IETF meetings and work.

If you really do want it to be public, then I suspect that's something to
take up with the IESG rather than making the point on this list.

Cheers,
Andy

On Wed, Aug 11, 2021 at 12:12 PM Toerless Eckert <[email-masked]> wrote:

> > My understanding was always that etherpad was a best-effort, ephemeral
> service; i.e., there was no guarantee (implicit or explicit) of stability
> or availability. That's probably the right policy, given that there able to
> be edited by *anyone on the Internet*.
>
> > We might consider a somewhat more formal and explicit policy on service
> stability and availability (on a service-by-service basis), so that folks
> aren't surprised by this in the future. E.g., the W3C has:
> > >>> We are making plans to turn down etherpad.ietf.org in a few weeks.
> Let me know of any concerns or need for delay.
> > >>>
> > >>> RjS
> > >>>
> > >
> > > --
> > > ---
> > > [email-masked]
> > >
> >
> > --

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 11 Aug 2021 17:13:42 +0000

*   Note that you currently need to use your Datatracker login to access CodIMD/HedgeDoc, so it's actually not public. And I think that's the correct way to do it, as it's intended for meeting participants (who all have Datatracker logins in order to participate) to provide notes regarding IETF meetings and work.

If you know the URL, then anyone can read the doc. But you have to have a login to modify.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 11 Aug 2021 13:15:32 -0400

Rich,

Thanks for the clarification.

Cheers,
Andy

On Wed, Aug 11, 2021 at 1:13 PM Salz, Rich <[email-masked]> wrote:

>
>    - Note that you currently need to use your Datatracker login to access

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 11 Aug 2021 13:22:35 -0400

Robert: 

IDR plans to hold an interim on  Monday 8/23/2021 (listed on IETF upcoming page).   Would you make sure to announce the change time 5 days ahead of the change?  

We have used the codimd for our interims as well as IETF. 
I have found it to be an improvement on etherpad. 

Thank you for your hard work to create this application. 

Sue 

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Robert Sparks
Sent: Tuesday, August 10, 2021 5:02 PM
To: Working Chairs
Subject: Turning off Etherpad

Chairs -

RjS

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 12 Aug 2021 15:41:05 +0200

Public viewing ;-)

And given how AFAIK everybody can get a daatracker account,
it effectively is also public but authenticated writing.