Subject: Re: Update and move of codimd

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 11 Aug 2021 19:07:41 +0000

Hi

The contents of notes.ietf.org should all be covered by Notewell (https://www.ietf.org/about/note-well/)  since they are part of an IETF meeting or interim meeting and Notewell applies to those meetings.

The IETF Trust will own the copyright just like it does for the videos recorded of the meeting sessions.

It might make sense to add some boiler plate noting the Notewell applies at the top of new notes when first created.  I realize that this can be edited out, but placing it there is a nice reminder.

In terms of archiving, that might be redundant (and unneeded) since once the group chairs submit it the notes to Datatracker they get the Datatracker treatment that the other Contributions to the IETF get.

-glenn

On 8/11/21, 9:19 AM, "WGChairs on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    I would like to see a clear description of the expected rules of use:

    e.g.:

    Q: is everything put into notes.ietf.org deemed public ?
    Q: If not deemed public, then what exactly is the deemed level of
       confidentiality ? "AD-hoc - if you do not share a page name, its kinda confidential ?"

    Q: Would it be permissible for IETF to create a public list of all pages ?
    Q: Wold it be permissible for IETF to make content older than some time (e.g.: 3 years) public ?

    Q: Is there an expectation for pages to be archived ?

    Q: If there is no expectation of archival of pages, how long
       will pages be guaranteed not to be changed/taken-down by IETF ?

    Q: If pages are not deemed public, how then would use of this tool
       go along with the IETF note well ?

    Aka: IMHO, all pages should be deemed public, there actually should be a
    list/search across them, and that way archiving and IETF note well are not an issue.

    Cheers
        Toerless

    On Wed, Aug 11, 2021 at 09:32:30AM -0400, Greg Wood wrote:
    > Hi Mark (and everyone),
    > 
    > I’m looking into what’s possible at the moment, but if there are specific attributes you think would make the “Intro” page more useful, please feel free to send suggestions directly to me.
    > 
    > -Greg
    > 
    > 
    > > On 10, Aug2021, at 20:01, Jay Daley <[email-masked]> wrote:
    > > 
    > > Looping in Greg as the person responsible for adding IETF branding to new services.
    > > 
    > > I believe a custom /intro.md is supported so this is possible.
    > > 
    > > Jay
    > > 
    > >> On 11/08/2021, at 11:38 AM, Mark Nottingham <[email-masked]> wrote:
    > >> 
    > >> Nice!
    > >> 
    > >> Are we planning to update the front page to IETF-brand it?
    > >> 
    > >> 
    > >>> On 11 Aug 2021, at 6:59 am, Robert Sparks <[email-masked]> wrote:
    > >>> 
    > >>> This is done.
    > >>> 
    > >>> The result is at notes.ietf.org.
    > >>> 
    > >>> RjS
    > >>> 
    > >>> On 8/6/21 6:19 PM, Mark Nottingham wrote:
    > >>>> Just a suggestion - can we use a host name that reflects the function, rather than the product used?  Eg ‘pad.ietf.org’?
    > >>>> 
    > >>>> Sent from my iPhone
    > >>>> 
    > >>>>> On 7 Aug 2021, at 5:40 am, Robert Sparks <[email-masked]> wrote:
    > >>>>> 
    > >>>>> FYI -
    > >>>>> 
    > >>>>> Next Tuesday 10 Aug, around 2000 UTC, we will be moving where codimd.ietf.org is running, and moving to the latest version (which will reflect the rename of the project to Hedgedoc). Editing and reading notes during that time may be interrupted.
    > >>>>> 
    > >>>>> RjS
    > >>>>> 
    > >>>>> 
    > >>>>> 
    > >> 
    > >> --
    > >> Mark Nottingham   https://urldefense.com/v3/__https://www.mnot.net/__;!!PIZeeW5wscynRQ!56nGoBi0eqPWWA3dJcFs3T2Oq84z2CBtmspNWnd9SEXpMMZVo8ZsrPaaY0bKJdri$ 
    > >> 
    > > 
    > > -- 
    > > Jay Daley
    > > IETF Executive Director
    > > [email-masked]
    > > 

    -- 
    ---
    [email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 11 Aug 2021 21:52:01 +0200

Thanks Glenn,

I don't think etherpad was ever limited to just meeting minutes even
when its main offical use was such. I have seen it being used also 
to track ongoing discussions of technical items and as such pages 
being updated sometimes over months (i think).

We simply need a declaration as to what the tools team does and does
not commit to do.

E.g.: if i put something into a notes.ietf.org page, what period
of time will IETF attempt to keep up that pages content before it might
get erased by IETF activity for whatever reason (new software versions,
change of server/URL, whatever). 

Maybe we want to discourage to use this for ongoing edits longer than
e.g.:2 months, or whatever the reasonable prepare, live and post-edit phase
for meeting minutes is. Even if declaring that intent is the only thing we
do, and the content (like on codimd) hangs around opportunistically forever -
or until somebody thinks we need a better tool in 2 years ;-)

Cheers
    toerless

-- 
---
[email-masked]