Subject: Proposal: an "important-news" IETF announcement list

From: IETF Chair <[email-masked]>
Date: Fri, 24 Sep 2021 10:25:55 +0300

Hi,

at the moment, ietf-announce is the main announcement list of the IETF,
seeing regular posts from various roles and bodies in the organization,
and from the Datatracker. Over the last year, ietf-announce has seen
around 1200 emails, averaging around 4.6 emails per workday.

The ietf-announce lists currently distributes the following types of
announcements. All but the first type are automatically generated by
various tools:

1.  Announcements sent manually by the IETF Chair, the IAB Chair, the
    IRTF Chair, the Chair of the LLC Board, the IETF Executive Director,
    the NomCom Chair, and the IETF Secretariat
2.  Announcements of new and updated WG charters
3.  WG closure announcements
4.  Announcements of new non-WG mailing lists
5.  Announcements of new RFCs
6.  IESG and LLC telechat announcements
7.  Announcements of document actions
8.  Announcements of IESG conflict-review results
9.  Last call announcements for I-Ds
10. Interim WG meeting announcements

The ietf-announce list currently has 3095 subscribers, which is a
fraction of the overall IETF community. Only 961 of these subscribers
have Datatracker accounts; out of 13311 overall Datatracker account
holders. When asking IETF participants about why they are not
subscribed, the volume of email on the list
- especially automatically-generated Datatracker email - is the most often
mentioned reason.

The IESG is therefore considering creating a new mailing list for
important organizational announcements only. We are hoping that a
subscription to a new low-volume mailing list will be acceptable to
IETF participants that find ietf-announce too noisy, and will help us
disseminate important news and announcements more widely and effectively.

Here are the details about this proposal:

* The name of the new mailing list is important-news.

  - The ietf-announce mailing list will continue to operate as-is.

  - Posting rights to important-news are restricted to the same set of
    roles as for ietf-announce.

  - All emails sent to important-news will be CC’ed to ietf-announce.

* Posts

  - important-news will only receive the first type of announcements in
    the numbered list above, i.e., important announcements that are
    manually sent by various organizational roles.

  - important-news will not receive any of the other types of email sent
    to ietf-announce. In the rare case that one of these is of
    sufficiently broad community interest to be distributed via
    important-news, this will occur as a manual action by one of the
    roles authorized to post to important-news.

* Subscriptions

  - Every participant with a current Datatracker account will be
    automatically subscribed to important-news.

  - Every participant creating a new Datatracker account will
    automatically be subscribed to important-news.

  - important-news is also open to manual subscriptions to anyone
    without a Datatracker account. A welcome message will be sent to
    new important-news subscribers, explaining what it’s for and that
    we’d hope they stay subscribed. It will also include instructions
    or ideally a link for unsubscribing.

  - Any important-news subscriber can unsubscribe at any time.

The IESG is inviting community feedback to [email-masked] about this
proposal by 7 October 2021.

Lars Eggert
IETF Chair (on behalf of the IESG)

---

From: Melchior Aelmans <[email-masked]>
Date: Fri, 24 Sep 2021 16:11:33 +0200

I think  this would be helpful to make sure no important messages are
missed.
Thanks for the effort!

Cheers,
Melchior

On Fri, Sep 24, 2021 at 9:27 AM IETF Chair <[email-masked]> wrote:

> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Sep 2021 21:15:07 +0200

The idea is not bad, but i think there is another division which would
be more helfull:

a) IETF calendar stream
   For events and event related deadlines

b) IETF WG and document stream
   For WG/BOF status/charter and document related announcements/deadlines

I think what would help most participants to easier participate in IETF
work would really be to work on solutions for an IETF calendar:

- main meetings, interims, workshops (IAB and other), public directorate
  meetings, IESG/IAB offsites, IESG telechats, etc. pp. And deadlines
  related to them.

  Even if some of the events are non public, its always good to know
  when e.g.: leadership is absent for e.g.: offsites and the like. And
  several meetings are non-public to attend but public streamed. And/or
  streams/recordings are available afterwards. All of this is right now
  scattered around different places for different type of events,
  so it is hard to find. Especially afterwards for streams/minutes

Maybe in before building such a web tool, just think about two simple
starting points:

- ietf-calendar mailing list that bundles all the relevant announcements
  we already have as well as the ones we are missing. E.g.: there are
  directorate and other public meetings that are NOT announced to
  community-wide mailing lists, maybe because they feel tthere is no
  good list to do so.

- "Next Week in IETF newsletter". List of next weeks IETF events/deadlines
  to be sent as email by friday morning the prior week. 
  
  This would ultimately be the easies, most compact form of information,
  and likely will be more read than even "important-news".

  And of course, with a name like that it could easily include any
  more specific non-calendar information leadership feels to be most
  important.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Sat, 25 Sep 2021 09:03:19 -0700

Lars, IESG,

I have some questions that would be helpful to know before evaluating this proposal.  See below.

Bob

> On Sep 24, 2021, at 12:25 AM, IETF Chair <[email-masked]> wrote:
> 
> Hi,
> 

Like what Brian and other have said, 4.6 emails per workday doesn’t seem like a burden to me.  BTW, assuming “workday” means Monday-Friday, it’s only 3.3 emails per day over a year.

> 10. Interim WG meeting announcements

Please break this down further.   That is, how many emails of each type per year.  It’s hard to evaluate this proposal without knowing that.

> holders.

This is disturbing.   How can one function in the IETF when you aren’t getting information about meetings, draft deadlines, new working groups, BOFs, etc.?

How many of these data tracker accounts are active?    I wouldn’t be surprised that a large portion of them haven’t been used for a while, or sent email, etc.

> When asking IETF participants about why they are not

How many "automatically-generated Datatracker email” are there?  Are all except for 1. in the numbered lists data tracker generated?

> * The name of the new mailing list is important-news.

Suggest “ietf-important-news”, like “ietf-announce”.

---

From: Christian Huitema <[email-masked]>
Date: Sat, 25 Sep 2021 10:59:41 -0700

I think I am with Bob and Brian on this one. With some nuances.

> Like what Brian and other have said, 4.6 emails per workday doesn’t seem like a burden to me.  BTW, assuming “workday” means Monday-Friday, it’s only 3.3 emails per day over a year.
The problem is that if most of those emails feel like noise, the 
receivers will most likely filter the mailing list and either ignore it 
all or put it in some folder for "view that when I have time". Noisy 
mailing lists get ignored, or just not subscribed.
> Please break this down further.   That is, how many emails of each type per year.  It’s hard to evaluate this proposal without knowing that.
It feels like a lot of this looks like "the log of the IETF". Rather 
than splitting the mailing list in parts, have we considered not using a 
mailing list in the first place? If the point is to have a log, then 
have a log on the web site, and use keywords so people can quickly view 
"what is new in transport or security", or some such preferences.
> How many of these data tracker accounts are active?    I wouldn’t be surprised that a large portion of them haven’t been used for a while, or sent email, etc.
How many of the subscribers do actually read it?
>> proposal by 7 October 2021.

I have two different sources of mixed feelings about this.

First, If we create an "important" list, will more people unsubscribe 
from the "announce" list? Is that the desired effect? If we do this 
experiment, will we monitor the "announce" list?

Second, who exactly defines what is important? Is that another way to 
empower people in elected positions, relative to the average participant?

-- Christian Huitema

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 25 Sep 2021 21:36:40 +0100

I promised I wouldn't get sucked in, but reading Bob's latest I find myself typing anyway.

> Suggest “ietf-important-news”, like “ietf-announce”.

Can we avoid mailing list title inflation?
Just "ietf-news" should do the job.

>>  - All emails sent to important-news will be CC’ed to ietf-announce.

Really? Why? This seems to totally deny the value of a new list. It is also not very pleasant in the context of the "mandatory subscription" described below because now people will get two copies of emails.

>>    automatically subscribed to important-news.

Please don't do that. It is inertia subscription. That is not nice in my opinion.

How about sending each Datatracker account registered email address an email offering them "click here to subscribe"?

>>    automatically be subscribed to important-news.

This can be handled with a check box during account creation so that the account holder has the option.

>>  - Any important-news subscriber can unsubscribe at any time.

Which is fine, but requires opt-out action which should not be the default.

Ciao,
Adrian

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 26 Sep 2021 10:17:55 +1300

Hi Adrian,
On 26-Sep-21 09:36, Adrian Farrel wrote:
> Really? Why? This seems to totally deny the value of a new list. 

Possibly, but it's more friendly to people who are perfectly happy with the existing list.

> It is also not very pleasant in the context of the "mandatory subscription" described below because now people will get two copies of emails.

Not if you set the "no duplicates" option in mailman. I set it globally years ago and it improved my life considerably.

> Please don't do that. It is inertia subscription. That is not nice in my opinion.

I assume it would be an opt-out setting for new accounts. I think it's a reasonable strategy for existing accounts; how else will people know, because most of them aren't on ietf-announce?
 
> How about sending each Datatracker account registered email address an email offering them "click here to subscribe"?

Better, include a "click here to unsubscribe" at the end of the welcome message.
 
> This can be handled with a check box during account creation so that the account holder has the option.

... to opt out.

> Which is fine, but requires opt-out action which should not be the default.

I disagree. This isn't like a commercial advertising exercise; it's trying to get people to actually be members of our community.

   Brian

---

From: Eliot Lear <[email-masked]>
Date: Sun, 26 Sep 2021 10:13:04 +0200

“All problems in computer science can be solved by another level of indirection”

— Butler Lampson

“All problems can be solved with an additional mailing list.” 

— The IESG

Below

> First, If we create an "important" list, will more people unsubscribe from the "announce" list? Is that the desired effect? If we do this experiment, will we monitor the "announce" list?

I vaguely recall -announce being created for important announcements. And now it seems that we have cluttered that list. A better approach would be to unclutter it.

Also, I don’t know about the rest of you, but there are so many IETF lists that I just dump them all into one folder, so this won’t make any difference to me, aside from mildly annoying duplicates that my UA really should do a better job at handling.

Eliot

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 26 Sep 2021 13:26:51 +0000

*   I vaguely recall -announce being created for important announcements. And now it seems that we have cluttered that list. A better approach would be to unclutter it.

Strongly agree with this!

---

From: David Noveck <[email-masked]>
Date: Sun, 26 Sep 2021 10:32:01 -0400

I agree as well but it is hard to get agreement about what, specifically,
is clutter and what is not.  That can easily turn into a non-terminating
discussion.

In order to provide the desirable uncluttering, without getting into a
discussion about what people consider clutter, I propose that we extend
Lars's proposal and put each of the ten classes of items into its own list
so that we have ietf-announce-{news, charters, closures, new-lists,
new-rfcs, telechats, doc-actions, conflict-reviews, last-calls,
interim-meetings} allowing people to subscribe what they want to see
without getting what *they *consider clutter.

On Sun, Sep 26, 2021 at 9:28 AM Salz, Rich <rsalz=
[email-masked]> wrote:

>
>    - I vaguely recall -announce being created for important
>    announcements. And now it seems that we have cluttered that list. A better
>    approach would be to unclutter it.
>
>
>

---

From: Tim Wicinski <[email-masked]>
Date: Sun, 26 Sep 2021 10:54:04 -0400

As someone who files ietf-announce into a folder because there are too many
messages, I feel most able to respond to this....

I propose the name be "ietf-announce-announce" because it tells me as a
consumer that "this is more important messages that must be read, rather
than the regular important messages like Yet Another interim for anima or
cbor (*)".

I do think that the whole focus on Datatracker accounts is really the wrong
way to look at engagement.

tim

(*) no offenses to anima or cbor working groups, they do fine work.

On Sat, Sep 25, 2021 at 12:03 PM Bob Hinden <[email-masked]> wrote:

> Like what Brian and other have said, 4.6 emails per workday doesn’t seem
> like a burden to me.  BTW, assuming “workday” means Monday-Friday, it’s
> only 3.3 emails per day over a year.
>
> Please break this down further.   That is, how many emails of each type
> per year.  It’s hard to evaluate this proposal without knowing that.
>
> This is disturbing.   How can one function in the IETF when you aren’t
> getting information about meetings, draft deadlines, new working groups,
> BOFs, etc.?
>
> How many of these data tracker accounts are active?    I wouldn’t be
> surprised that a large portion of them haven’t been used for a while, or
> sent email, etc.
>
>
> How many "automatically-generated Datatracker email” are there?  Are all
> except for 1. in the numbered lists data tracker generated?
>
> >

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 26 Sep 2021 16:24:09 +0100

> without getting what *they *consider clutter.

If that would happen, then I wouldn't subscribe to them simply because the
UX is terrible and the act of subscribing/unsubscribing is entirely
tedious. Seriously, do I need to confirm the same email address *every*
time I want to subscribe.

Cheers,
Lucas

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 Sep 2021 13:14:00 -0400

--On Sunday, 26 September, 2021 10:13 +0200 Eliot Lear
<[email-masked]> wrote:

> "All problems in computer science can be solved by another
> level of indirection"
> 
> — Butler Lampson
> 
> "All problems can be solved with an additional mailing
> list." 
> 
> — The IESG
> 
> Below
> 
>> First, If we create an "important" list, will more people
>> unsubscribe from the "announce" list? Is that the desired
>> effect? If we do this experiment, will we monitor the
>> "announce" list?
> 
> I vaguely recall -announce being created for important
> announcements. And now it seems that we have cluttered that
> list. A better approach would be to unclutter it.

Indeed.

Let me suggest one small example:  When a WG decides to schedule
an interim meeting, that announcement should go to the WG list
and _maybe_ to an Area-wide list for the relevant area, not to
IETF-announce.  Posting a calendar of upcoming meetings to
IETF-announce every month or so would seem reasonable even
though most of us know where to find that.

I also hope that most of us have at least half-competent MUAs
with either decent filtering capabilities, have gotten really
good at finding and hitting the "delete" key, or both.  Being
more careful about the design of subject lines for automated
announcements would help a lot with clutter management.  For
example, organizing subject lines something like

   Virtual meeting: <Area> <WG> <date and time info>

would make it _much_ easier to filter things according to
personal needs and inclinations than the current setup.  We
could also get better at dealing with the "only interested in
one class of things" issue that Bron identified by thinking
enough about metadata and categories enough that he (and I) are
put at least risk of missing something that is really important
to us because, for example, a decision was made many years ago
that work related to the DNS was an Internet Area issue rather
than an applications one and that work on email encryption was
about Security and not email: in both cases much of it quite
reasonably is, but some things aren't.  

So, while some tuning of the mailing lists may be appropriate,
let's put more energy, as Eliot suggests, into reducing clutter
rather than spreading it around.  And let's try to improve
information accessibility and the ability of people to
selectively get the information they need and manage it while we
are doing that.

Finally, I don't share Ned's pessimism (at least one most days)
and continue to believe that we should not make it extra-easy
for people to narrowly focus on one specific topic or set of
documents and ignore everything else.

best,
   john

---

From: tom petch <[email-masked]>
Date: Mon, 27 Sep 2021 09:37:29 +0100

> How about sending each Datatracker account registered email address an email offering them "click here to subscribe"?

No, because there is nothing to click in plain text and anyone using 
html is inviting breaches of security.

Tom Petch

> .

---

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Sep 2021 13:40:49 +0300

Hi,

thanks for the feedback!

> Like what Brian and other have said, 4.6 emails per workday doesn’t seem like a burden to me.  BTW, assuming “workday” means Monday-Friday, it’s only 3.3 emails per day over a year.

Correct. While that amount of email is OK to some, it seems to not be OK for others. And participants in the latter group seem to unsubscribe rather investing the time to tweak their filters, which is their choice.

> Please break this down further.   That is, how many emails of each type per year.  It’s hard to evaluate this proposal without knowing that.

OK, this is based on the monthly ietf-announce mbox files, starting with 2020-10.mail, so the counts are slightly different than in the original email. I did this manually with tags in mutt, so take this with a grain of salt:

1196 total messages

1.  Announcements sent manually
	34	by the IETF Chair/ED
	39	the IAB Chair
	0	the IRTF Chair
	0 	the Chair of the LLC Board
	136	the IETF Executive Director
	20	the NomCom Chair
	13	the IETF Tools support
	3	IANA
	1	ISOC
	38	and the IETF Secretariat
2.  Announcements of new and updated WG charters
	44
3.  WG closure announcements
	(included in above 44)
4.  Announcements of new non-WG mailing lists
	13
5.  Announcements of new RFCs
	275
6.  IESG and LLC telechat announcements
	39
7.  Announcements of document actions
	175
8.  Announcements of IESG conflict-review results
	14
9.  Last call announcements for I-Ds
	174 (+ 4 for other actions)
10. Interim WG meeting announcements
	256

> How many of these data tracker accounts are active?    I wouldn’t be surprised that a large portion of them haven’t been used for a while, or sent email, etc.

I don't have that data, but I will ask. See my response to Brian on that we maybe want to come to agreement on a definition of an "active participant", for these and other reasons.

> How many "automatically-generated Datatracker email” are there?  Are all except for 1. in the numbered lists data tracker generated?

Everything in my list above except those under (1) are automatically-generated. Roughly 1000.

Thanks,
Lars

---

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Sep 2021 13:49:47 +0300

Hi,

thanks for the feedback!

On 2021-9-25, at 20:59, Christian Huitema <[email-masked]> wrote:
> The problem is that if most of those emails feel like noise, the receivers will most likely filter the mailing list and either ignore it all or put it in some folder for "view that when I have time". Noisy mailing lists get ignored, or just not subscribed.

or, given that many MUAs now offer one-click unsubscriptions, they unsubscribe if the first few messages seem irrelevant to them.

> First, If we create an "important" list, will more people unsubscribe from the "announce" list? Is that the desired effect? If we do this experiment, will we monitor the "announce" list?

That's of course not the desired effect, and your suggestion to monitor the ietf-announce list is a good one. My personal belief is that people who are subscribed to ietf-announce see the value and would hence not unsubscribe, but that we might reach some of those people who are at the moment not subscribing to ietf-announce with a more focused list.

> Second, who exactly defines what is important?

The current proposal is that important-news would have all manual postings by the various organizational roles, i.e., everything under (1):

We would ask those posters to determine on a case-by-case basis whether a given announcement meets their bar for important-news or nor.

>  Is that another way to empower people in elected positions, relative to the average participant?

I'm not sure I follow. The "average participant" cannot post to ietf-announce now, and they wouldn't be able to post to important-news either. That ability was always restricted to certain org roles?

Thanks,
Lars

---

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Sep 2021 13:55:49 +0300

Hi,

thanks for the feedback!

> Really? Why? This seems to totally deny the value of a new list. It is also not very pleasant in the context of the "mandatory subscription" described below because now people will get two copies o…

The value of the new list is in hopefully reaching IETF participants who choose not to subscribe to ietf-announce.

I do see your point about two copies of emails. We'll discuss if that can be addressed.

> Which is fine, but requires opt-out action which should not be the default.

On the points above, we'll discuss more if opt-in or opt-out should be the default.

Thanks,
Lars

---

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Sep 2021 13:59:24 +0300

Hi,

thanks for the feedback!

> I vaguely recall -announce being created for important announcements. And now it seems that we have cluttered that list. A better approach would be to unclutter it.

we discussed that (at length) in the IESG. There were very different opinions on which content should remain on ietf-announce and which should be moved elsewhere. I think I've seen signs in the feedback thread that there are probably very different views on that in the broader community as well. Hence the decision to propose a new mailing list.

Thanks,
Lars

---

From: Eliot Lear <[email-masked]>
Date: Mon, 27 Sep 2021 17:36:15 +0200

Hi Lars,

I'm sorry, but this is a corollary to Housley's Law, which borrows from 
many, including Benjamin Franklin:

    I have already made this paper too long, for which I must crave
    pardon, not having now time to make it shorter.

In an admirable effort to be transparent, we have inundated this list in 
particular with data.  We now need to take the time to reduce that data  
to usable information.  Please take another swing.

Eliot

---

From: Lars Eggert <[email-masked]>
Date: Wed, 29 Sep 2021 15:11:31 +0300

Hi,

On 2021-9-27, at 18:36, Eliot Lear <[email-masked]> wrote:
> In an admirable effort to be transparent, we have inundated this list in particular with data.  We now need to take the time to reduce that data  to usable information.  Please take another swing.

the IESG certainly could. But I'm also pretty convinced that whatever proposal we came up with would get improved by the community pretty immediately.

So maybe we could try the opposite, and see if the community has some consensus on what information they would like to retain on ietf-announce, under the assumption that that would then remain our lists for broad announcements.

For reference, here's again the list of posting classes that currently go there, and the count of messages in each class in the last year:

1.  Announcements sent manually by <various roles> = 284
2.  Announcements of new and updated WG charters & WG closures = 44
3.  (included in above 44)
4.  Announcements of new non-WG mailing lists =	13
5.  Announcements of new RFCs =	275
6.  IESG and LLC telechat announcements = 39
7.  Announcements of document actions = 175
8.  Announcements of IESG conflict-review results = 14
9.  Last call announcements for I-Ds = 174 (+ 4 for other actions)
10. Interim WG meeting announcements = 256

The "important-news" proposal would only retain those under (1) above. (We could have a conversation if some of those could also be moved elsewhere, but that's maybe a separate discussion.)

For any type of posting we'd remove, we could of course create a new list, so that the information was still shared. I understand that when we move to mailman3, we'll get a much better web-based subscription interface that will make managing subscriptions much more straightforward.

Thanks,
Lars

---

From: "MORTON JR., AL" <[email-masked]>
Date: Wed, 29 Sep 2021 12:57:21 +0000

Hi Lars,

following-up on "reduce the data to usable information":

It occurred to me that when I see several separate (#10) Interim Meeting announcement e-mails for the *same* WG, that a consolidated announcement for all the meetings would suffice. (One press of the delete key for those who are uninterested.)

Then, any announcement that is purely an announcement (no e-mail discussion thread follows) could be combined with others (#4,6,7,8) when they are prepared/ready close in time.

We retain the same info on ietf-announce with fewer messages.

Al

> -----Original Message-----
> From: WGChairs <[email-masked]> On Behalf Of Lars Eggert
> Sent: Wednesday, September 29, 2021 8:12 AM
> To: Eliot Lear <[email-masked]>
> Cc: Working Chairs <[email-masked]>; Christian Huitema
> <[email-masked]>; IETF <[email-masked]>
> Subject: Re: Proposal: an "important-news" IETF announcement list
> 
> Hi,
> 
> particular with data.  We now need to take the time to reduce that data  to
> usable information.  Please take another swing.
> 
> the IESG certainly could. But I'm also pretty convinced that whatever proposal
> we came up with would get improved by the community pretty immediately.
> 
> So maybe we could try the opposite, and see if the community has some
> consensus on what information they would like to retain on ietf-announce,
> under the assumption that that would then remain our lists for broad
> announcements.
> 
> For reference, here's again the list of posting classes that currently go
> there, and the count of messages in each class in the last year:
> 
> The "important-news" proposal would only retain those under (1) above. (We
> could have a conversation if some of those could also be moved elsewhere, but
> that's maybe a separate discussion.)
> 
> For any type of posting we'd remove, we could of course create a new list, so
> that the information was still shared. I understand that when we move to
> mailman3, we'll get a much better web-based subscription interface that will
> make managing subscriptions much more straightforward.
> 
> Thanks,
> Lars

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 29 Sep 2021 14:05:48 +0100

Hiya,

On 29/09/2021 13:11, Lars Eggert wrote:
> consensus on what information they would like to retain on
> ietf-announce, under the assumption that that would then remain our
> lists for broad announcements.

I don't consider the suggested new list worth the
effort. Nor would it be terrible.

I somewhat agree with those who worry about this
pattern: "subset of people have problem with list
traffic => correct answer is make new list and
split traffic between new and old lists."

A bit of de-duping and reducing the frequency of
announcing the now much more common interim meetings
would be good. (A weekly summary message of all
scheduled interims could be an option.)

Cheers,
S.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 29 Sep 2021 13:08:21 +0000

> For reference, here's again the list of posting classes that currently go there, and
> the count of messages in each class in the last year:
> 

I wonder... if 2 - 10 could all be sent to other list(s) and then a single weekly summary email sent to ietf-announce that has the list of subject lines with a link to the email in the archive.
This could even be done with a lot of emails from category 1.
Barbara

---

From: Eliot Lear <[email-masked]>
Date: Wed, 29 Sep 2021 15:13:03 +0200

Hi Al,

I would go further, and consolidate all interim announcements into one 
per week on announce, and remind people to subscribe to the IETF 
calendar (WGs could still see the non-consolidated). Similarly 
consolidate document actions to one per week.  Similarly with RFCs.  
That reduces the #s considerably.

Eliot

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Sep 2021 15:17:53 +0200

> scheduled interims could be an option.)

I don’t need that, that’s what 

https://datatracker.ietf.org/meeting/upcoming

is for.

Much more interesting is the calendar integration (which now also exists).

The mail announcements usually have outdated information by the time I read them, so their net value is actually negative.

16 years ago, there used to be a way to do this kind of announcement properly (RFC 4287, if you don’t remember), but that seems to have fallen out of fashion…

Grüße, Carsten

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 29 Sep 2021 06:21:33 -0700

Maybe in the form of a weekly newsletter (email and RSS with full content), i.e. not just concatenation of messages and links, but classified by topics with a one sentence summary.

On 9/29/21 6:13 AM, Eliot Lear wrote:
> Hi Al,
> 
> I would go further, and consolidate all interim announcements into one per week on announce, and remind people to subscribe to the IETF calendar (WGs could still see the non-consolidated). Similarly consolidate document actions to one per week.  Similarly with RFCs. That reduces the #s considerably.
> 
> Eliot
> 

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Barry Leiba <[email-masked]>
Date: Wed, 29 Sep 2021 10:08:11 -0400

> The "important-news" proposal would only retain those under (1) above.

I think that 1, 4, and 6 should all be retained as is (and in the new
list, if it's created).

I think that 2, 5, 7, 8, 9, and 10 should be in a weekly summary, one
single message per week.

I think that when those under 10 are in a pattern (first Tuesdays,
every second Wednesday) there should be one message that says that,
and those messages should be immediately posted to the relevant
working group lists and not wait for the weekly summary.

If we do that, there's probably no need for a new list, but I don't
object to the new list.

Barry

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 29 Sep 2021 15:32:42 +0100

Hi Barry,

> I think that 2, 5, 7, 8, 9, and 10 should be in a weekly summary, one

I have a slight problem with this proposal because if it is implemented 
it would not be possible to find last call announcements by draft name. 
I think this is a rather important feature when searching archive.

Unfortunately I don't have a solution for this problem.

Best Regards,

Alexey

---

From: "MORTON JR., AL" <[email-masked]>
Date: Wed, 29 Sep 2021 14:49:06 +0000

> From: WGChairs <[email-masked]> On Behalf Of Alexey Melnikov
> Sent: Wednesday, September 29, 2021 10:33 AM
> To: Barry Leiba <[email-masked]>; Lars Eggert <[email-masked]>
> Cc: Working Chairs <[email-masked]>; IETF <[email-masked]>
[acm] 
Yes, any message that initiates an e-mail thread (like Last Call) should not be consolidated with other announcements. 
I was trying to avoid that with a smaller list for consolidation. Also, I have no problem seeing new RFCs announced individually, because it is the successful end of a long process for the authors, WGs usually celebrate these accomplishments, etc.

Al

---

From: Robert Sparks <[email-masked]>
Date: Wed, 29 Sep 2021 09:52:54 -0500

On 9/29/21 9:32 AM, Alexey Melnikov wrote:
> I have a slight problem with this proposal because if it is 
> implemented it would not be possible to find last call announcements 
> by draft name. I think this is a rather important feature when 
> searching archive.

This aspect - search for "thing" by looking for it in email Subject 
lines is what's driven so much of what people are now proposing to 
condense. Alexey points to a big use case - since people _reply_ to Last 
Call messages, searching for the subject is an easy way to find threads. 
Note the CCs on the Last Call messages currently going to IETF Announce.

Similarly, the "string of interims announcements" that was brought up is 
the way it is now because people _asked_ for one message per session 
that they could easily search for and easily visually scan for these 
(with the date) by subject. It started as one message. I'm happy to 
change this to whatever/wherever, but recognize that what's happening 
now was shaped by community feedback.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 29 Sep 2021 11:07:00 -0400

> I think that 2, 5, 7, 8, 9, and 10 should be in a weekly summary, one

Mailman has a digest mode.  Would that suffice?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 29 Sep 2021 15:14:16 +0000

> Unfortunately I don't have a solution for this problem.

I thought we were discussing changes to ietf-announce and not last-call. All these emails already exist on the last-call list and don't need to be repeated in their entirety on ietf-announce. A summary email to ietf-announce should be sufficient. Anybody wanting to subscribe to last-call has the ability to do so. 
Barbara

---

From: John C Klensin <[email-masked]>
Date: Wed, 29 Sep 2021 11:33:55 -0400

--On Wednesday, September 29, 2021 09:52 -0500 Robert Sparks
<[email-masked]> wrote:

>...
> Similarly, the "string of interims announcements" that was
> brought up is the way it is now because people _asked_ for one
> message per session that they could easily search for and
> easily visually scan for these (with the date) by subject. It
> started as one message. I'm happy to change this to
> whatever/wherever, but recognize that what's happening now was
> shaped by community feedback.

Robert,

I think this is a perfect example of where more careful thinking
about the problem is important and where "more lists" are
perhaps just a distraction.  Probably this categorization is not
quite right two, but, for the interim announcements for a given
WG, I suggest that there are the following kinds of IETF
participants:

(1) Participants in the WG and (hence) subscribers to its
mailing list.
(2) People in the same area (small-"a") of work [1] who want to
track the WG but rarely, if ever, participate in any active way.
(3) People in other areas who might be curious about what is
going on.
(4) People who don't care whether that WG is meeting or not and
might prefer to not be told about it.

Now, for (1), separate, per-meeting, announcements might be just
right and, if people want them that way, they should continue to
go the per-WG mailing lists.  For (2) and (3) one announcement
for multiple interim meetings is likely just fine and that
announcement would be much more useful (and probably read more
often) if the announcement contained tentative agendas.  And,
for (4), the announcements are just noise, noise which those
people might prefer to have sent only to the unimportant-news
list to which almost no one would subscribe.

And, while I can't recommend either (partially because of the
tooling and complexity involved), the combination of groups (1)
and (2) are a case for either separate "announce" and
"discussion" lists for each WG or for being able to subscribe to
particular announcement postings based on metadata like topic
keywords, Area, and so on rather than treating these issues as
ones that can be solved by the rather blunt instrument of
fragmenting lists.

best,
    john

[1] This will often conform to our Areas, but not always, and
that is another issue.

---

From: Barry Leiba <[email-masked]>
Date: Wed, 29 Sep 2021 12:02:28 -0400

Exactly: the separate last call messages would continue to be posted
immediately to the last-call list, and the summary to ietf-announce would
serve as a reminder and as notice to those who don’t watch last-call
closely (or at all).

Barry

On Wed, Sep 29, 2021 at 11:14 AM STARK, BARBARA H <[email-masked]> wrote:

> I thought we were discussing changes to ietf-announce and not last-call.
> All these emails already exist on the last-call list and don't need to be
> repeated in their entirety on ietf-announce. A summary email to
> ietf-announce should be sufficient. Anybody wanting to subscribe to
> last-call has the ability to do so.
> Barbara
>

---

From: Barry Leiba <[email-masked]>
Date: Wed, 29 Sep 2021 12:04:27 -0400

The problem with mailman digests is that you either get separate messages
or you get digests, and you can’t be more selective.  I don’t know whether
mailman 3 has more options in that regard.

Barry

---

From: John C Klensin <[email-masked]>
Date: Wed, 29 Sep 2021 12:05:45 -0400

--On Wednesday, September 29, 2021 10:08 -0400 Barry Leiba
<[email-masked]> wrote:

> I think that 1, 4, and 6 should all be retained as is (and in
> the new list, if it's created).
> 
> I think that 2, 5, 7, 8, 9, and 10 should be in a weekly
> summary, one single message per week.
> 
> I think that when those under 10 are in a pattern (first
> Tuesdays, every second Wednesday) there should be one message
> that says that, and those messages should be immediately
> posted to the relevant working group lists and not wait for
> the weekly summary.
> 
> If we do that, there's probably no need for a new list, but I
> don't object to the new list.

Barry, 

I generally agree, but wonder about 6 and 9 because...

6.  IESG and LLC telechats (especially the former) occur on a
fixed schedule (as much or more so than the subset of 10 you
mention) so, while links and exceptions may be important, the
announcements ought to be routine and part of a summary (and, as
others have suggested, an available and downloadable calendar).

9. There are problems with pushing Last Call announcements for
I-Ds, especially I-Ds proposed for standards track or BCP
action, into a weekly summary. We would, I think, like to
encourage people to watch those things and step in on ones on
which they might have informed opinions, even if, for a given
participant, such Last Calls are only a few percent of the total
and all of the others will be deleted after skimming the subject
line.  However, consider the timing.  If the Last Call is for a
WG document and announced to the WG list on, say, a Monday, the
digest does not appear until Friday, and first announcement
starts the clock, we've cut the time that interested participant
has to read the document and comment by almost half.  Different
permutations of dates just affect different people and documents
badly unless we make other changes.  I can think about ways
around that but most involve tinkering with timing of LC
announcements or which ones count -- these are not just matters
of creating new lists or shuffling content distribution.  Of
course, Alexey's concern about searching by draft name is a
different aspect of much the same problem.

That brings me close to Eliot's consolidation suggestion but is
also a reminder of what others have said -- that, inevitably,
different people are going to find different things important
and hence that efforts beyond a certain point to really
fine-tune things may be doomed.  I'm also confident we could
come up with a different list of categories of announcements:
probably not much better than the one Lars posted, but probably
not much worse either.  

If we can concentrate on improving the S/N ratio on the
Announcement list --selective digests, avoiding four separate
interim meeting postings at the same time for the same WG,
encouraging calendar subscriptions, etc.-- then I think we
address the real problem while splitting up lists even more just
create distractions.

best,
   john

---

From: tom petch <[email-masked]>
Date: Wed, 29 Sep 2021 17:16:34 +0100

Barbara

I think not.  Last Call announcements from the IESG go to many places 
but not the Last Call list.  I find this odd, raised it as a comment 
when the discussion about whether or not to persist with Last Call list 
but in vain.

Reply to is set to Last Call but that is all

Tom Petch

---

From: tom petch <[email-masked]>
Date: Wed, 29 Sep 2021 17:30:44 +0100

> The "important-news" proposal would only retain those under (1) above. (We could have a conversation if some of those could also be moved elsewhere, but that's maybe a separate discussion.)

I believe that it is a mistake to entitle something important; that is 
subjective, depends on the sender and is likely not true for the 
recipient.  Perhaps significant, noteworthy, you may be interested to 
know, anything that leaves the reader with his judgement unimpugned.

As to what, then I was thinking that the Admin announcements are the 
most irrelevant, except when they tell me of an impending outage, or one 
that just happened, or a possible one due to a migration.  These are 
rare but I would class them as Critical.

After that, Last Call announcements. A key feature of the IETF is 
cross-area review IMHO and the Last Call announcements make that point. 
  They could be summarised, since a last call is two weeks or more then 
a weekly e-mail of Last Call announcements made in the last seven days 
would cut the frequency by a factor of three on the IETF list with 
individual e-mails still going out on a not-so-significant IETF list.

After the, announcements about the creation or potential creation or 
winding up of a Working Group.  Again, working in Working Groups is a 
key feature of the IETF so they matter more.

Tom Petch

---

From: Michael Richardson <[email-masked]>
Date: Wed, 29 Sep 2021 13:08:31 -0400

> mailman 3 has more options in that regard.

The setting is on a per-list basis.
Perhaps for the important-news, a default to weekly digest might appeal.
So if 2,3,5,7,8,9,10 was in a single list, then that would work?

---

From: Michael Richardson <[email-masked]>
Date: Wed, 29 Sep 2021 13:20:13 -0400

> address the real problem while splitting up lists even more just

On the topic of calendaring, and "upcoming" being more useful for planning.
I've asked for the various area meetings, such as the RTG Chairs Chat, IESG
telechat, IoT Directorate, etc. to be on the calendar.

My purpose is allow people who are planning meetings to know what else is
occuring.   Maybe we can do a "this week at the IETF" page.

There are tooling issues for some of these requests.
But, the major pushback I got was that some of these events are not open to
anyone, and so shouldn't be listed.  I disagree :-)

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Sep 2021 10:12:57 +1300

> Mailman has a digest mode.  Would that suffice?

No, because from observation, most people who reply to a digest don't change the Subject to a useful string. This would be disastrous for Last Call workflows in particular.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Sep 2021 10:13:45 +1300

> I thought we were discussing changes to ietf-announce and not last-call. All these emails already exist on the last-call list and don't need to be repeated in their entirety on ietf-announce. A sum…

Unfortunately that doesn't compute. If someone sees the Last Call announcement on announce @ietf, they can simply reply and it will go where it needs to go. The whole point of last calls is they go to *everybody* so that *anybody* can reply. This is why I believe that Last Calls are possibly the most important content on announce@ and should definitely not be dropped.

I'm not against weekly summaries for most of the categories Lars listed, but I suggest that the model should be, for category X, that the raw messages go to [email-masked], and the summary comes labelled "X-announce messages for the week ending $DATE".

(And yes, I know there would be complaints about too many summary messages. Or too few.)

   Brian

---

From: Jay Daley <[email-masked]>
Date: Thu, 30 Sep 2021 11:28:54 +1300

> On 30/09/2021, at 10:13 AM, Brian E Carpenter <[email-masked]> wrote:
> 

I don’t mean to pick on you, but your use of the word "everybody" highlights what I see as  two huge misconceptions that are affecting this discussion.  

The first is the misconception that ietf-announce reaches, approximately reaches, or could theoretically reach the entire IETF community.  It currently reaches a small fraction of the community (somewhere between 5-10% depending on how we define the community) and all the evidence is that it will never reach even 25% because they don’t want all those emails.

The second is the misconception of just how much we can create an engaged community by pushing messages at them.  The experience from every organisation I have ever seen try this is that it’s a Pareto distribution and if you want a list that reaches everybody then it must receive virtually no messages at all otherwise people unsubscribe in such numbers that it rapidly drops below any usable approximation of everybody.

So far, I’ve heard the following broad reasons for not breaking up ietf-announce into multiple lists:

a) a detrimental effect on the process of subscribing to and managing subscription to multiple lists
b) a detrimental effect on reading/searching/finding email once those messages have been received
c) a detrimental effect on understanding what message is important and what is not and making sure nothing important is missed
d) a view that separate lists reduces overall engagement
e) a view that separate lists reduce cross-area discussion

I understand a) and c) - we need a much better interface for managing subscriptions to 100+ lists that also helps us understand the subject matter, volume and perceived importance of any list as well as what other lists are related.

For b), d) and e), while list organisation plays a part, in most practical situations there are other factors that are much more important.

Jay

> 
> I'm not against weekly summaries for most of the categories Lars listed, but I suggest that the model should be, for category X, that the raw messages go to [email-masked] <mailto:[email-masked]>, and the summary comes labelled "X-announce messages for the week ending $DATE".
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Sep 2021 11:49:47 +1300

On 30-Sep-21 11:28, Jay Daley wrote:
> 
> 
>> On 30/09/2021, at 10:13 AM, Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> Unfortunately that doesn't compute. If someone sees the Last Call announcement on announce @ietf, they can simply reply and it will go where it 
needs to go. The whole point of last calls is they go to *everybody* so that *anybody* can reply. This is why I believe that Last Calls are possibly the most important content on announce@ and should definitely not be dropped.
> I don’t mean to pick on you, but your use of the word "everybody" highlights what I see as  two huge misconceptions that are affecting this discussion.

No worries, I don't feel picked upon.

> The first is the misconception that ietf-announce reaches, approximately reaches, or could theoretically reach the entire IETF community.  It currently reaches a small fraction of the community (somewhere between 
5-10% depending on how we define the community) and all the evidence is that it will never reach even 25% because they don’t want all those emails.

Indeed. That's why I understand the goal of significantly reducing the list traffic.

> The second is the misconception of just how much we can create an engaged community by pushing messages at them.  The experience from every 
organisation I have ever seen try this is that it’s a Pareto distribution and if you want a list that reaches everybody then it must receive virtually no messages at all otherwise people unsubscribe in such numbers that it rapidly drops below any usable approximation of everybody.

Sure. (Nevertheless, the traffic on the announce list is so tiny compared 
to my daily spam load that it's very hard to perceive it as a problem.)

> So far, I’ve heard the following broad reasons for not breaking 
up ietf-announce into multiple lists:

I'm not arguing against that, when linked to weekly summary messages. I'm 
arguing that Last Call messages are of such importance to the standards-making goal of the IETF that we really do have to send them to as much of the community as we can.
 
> For b), d) and e), while list organisation plays a part, in most practical situations there are other factors that are much more important.

Yes.
   Brian
    
> [email-masked] <mailto:[email-masked]>
>

---

From: Barry Leiba <[email-masked]>
Date: Wed, 29 Sep 2021 19:07:40 -0400

> I'm arguing that Last Call messages are of such importance to the
> standards-making goal of the IETF that we really do have to send them
> to as much of the community as we can.

The trouble with that is that if you really believe that and take it
completely, we would be posting last-call announcements to every mailing
list we have: all the WG lists, all the non-WG lists, all the lists that
remain from closed groups, and whatever else.  I think few of us would like
that.

If my last sentence is correct, then we really do have to understand that
it’s more important to make sure that participants understand the
importance of last call and where to find the last-call announcements… and
then leave it to the community to do what they’re willing to do with that.
And that does not meal trying to force those announcements on people who
don’t want them.

It was different when the IETF was smaller.  We need to accept that things
have changed.

Barry

On Wed, Sep 29, 2021 at 6:50 PM Brian E Carpenter <
[email-masked]> wrote:

> >> On 30/09/2021, at 10:13 AM, Brian E Carpenter <
> [email-masked] <mailto:[email-masked]>> wrote:
> >>
> implemented
> >>> I thought we were discussing changes to ietf-announce and not
> last-call. All these emails already exist on the last-call list and don't
> need to be repeated in their entirety on ietf-announce. A summary email to
> >> Unfortunately that doesn't compute. If someone sees the Last Call
> announcement on announce @ietf, they can simply reply and it will go where
> it
> needs to go. The whole point of last calls is they go to *everybody* so
> that *anybody* can reply. This is why I believe that Last Calls are
> possibly the most important content on announce@ and should definitely
> not be dropped.
> >
> > I don’t mean to pick on you, but your use of the word "everybody"
> highlights what I see as  two huge misconceptions that are affecting this
> discussion.
>
> > The first is the misconception that ietf-announce reaches, approximately
> reaches, or could theoretically reach the entire IETF community.  It
> currently reaches a small fraction of the community (somewhere between
> 5-10% depending on how we define the community) and all the evidence is
> that it will never reach even 25% because they don’t want all those emails.
>
> > The second is the misconception of just how much we can create an
> engaged community by pushing messages at them.  The experience from every
> organisation I have ever seen try this is that it’s a Pareto distribution
> and if you want a list that reaches everybody then it must receive
> virtually no messages at all otherwise people unsubscribe in such numbers
> that it rapidly drops below any usable approximation of everybody.
>
> arguing that Last Call messages are of such importance to the
> standards-making goal of the IETF that we really do have to send them to as
> much of the community as we can.
>
> > c) a detrimental effect on understanding what message is important and
> what is not and making sure nothing important is missed
> > I understand a) and c) - we need a much better interface for managing
> subscriptions to 100+ lists that also helps us understand the subject
> matter, volume and perceived importance of any list as well as what other
> lists are related.
> >
> > For b), d) and e), while list organisation plays a part, in most
> practical situations there are other factors that are much more important.
>
> Yes.
>    Brian
>
> >
> > Jay
> >
> >
> >>
> >> I'm not against weekly summaries for most of the categories Lars
> listed, but I suggest that the model should be, for category X, that the
> raw messages go to [email-masked] <mailto:[email-masked]>, and
> the summary comes labelled "X-announce messages for the week ending $DATE".
> >>

---

From: Jay Daley <[email-masked]>
Date: Thu, 30 Sep 2021 12:17:06 +1300

> On 30/09/2021, at 11:49 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> 

I think you are still misunderstanding how this works.  

No matter what we do, we cannot change the inherent level of interest that people have in particular categories of messages.  If we push messages to people for which they have a low level of interest then they adapt their behaviour in response and we cannot stop that.  Generally this means unsubscribing, not reading specific messages, or simply becoming frustrated, and the more messages they are not interested in they receive, then the more they do that.  

This means that  we simply cannot tell how much that happens with any reliability and so with a list many different types of message we end up mistaking X subscribers to a list as X readers of each message sent to it, when the reality could be quite different.

By contrast, if we separate out those categories and people choose to subscribe then we get closer to X subscribers = X readers, correctly reflecting the inherent level of interest in those messages and minimising the message avoidance behaviours above.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 30 Sep 2021 09:40:31 +1000

On Thu, Sep 30, 2021, at 09:17, Jay Daley wrote:
> No matter what we do, we cannot change the inherent level of interest 
> that people have in particular categories of messages.  

What Jay said.

I subscribe to these lists, but deliberately ignore all traffic from them unless some other event causes me to search for a message.  I might not immediately mark announcements as read and file them away to be ignored if a more targeted list existed.  (https://xkcd.com/1205/ says that if I can spend a few minutes setting up an ignore rule and save 30s per day deleting/ignoring emails, it's a BIG win.)

Indeed, I would almost look for a separate list for each of the 10 categories Lars identified on that basis.  Of course, subscribing to multiple lists in mailman is a huge pain, but we shouldn't let something that might easily be fixed decide what is right.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Sep 2021 14:00:15 +1300

On 30-Sep-21 12:07, Barry Leiba wrote:
> The trouble with that is that if you really believe that and take it completely, we would be posting last-call announcements to every mailing list we have: all the WG lists, all the non-WG lists, all the lists that remain from closed groups, and whatever else.  I think few of us would 
like that.
> 
> If my last sentence is correct, then we really do have to understand that it’s more important to make sure that participants understand the importance of last call and where to find the last-call announcements… and then leave it to the community to do what they’re willing to do with that.  And that does not meal trying to force those announcements on people who don’t want them.
> 
> It was different when the IETF was smaller.  We need to accept that things have changed.

Absolutely. But that's exactly why I'm banging on about last calls, because the IETF is bigger than it was in 1995 and because we have multiple silos. I'm all in favour of reducing mundane announcements, so that people actually see the ones from outside their silo that are not mundane.

How would it be if a year's tally looked like this?

1.  Announcements sent manually by <various roles> = 284
2.  Last call announcements for I-Ds = 174 (+ 4 for other actions)
3.  Weekly summaries of other announcements = 52

I make that a 60% reduction in traffic.

  Brian

---

From: John C Klensin <[email-masked]>
Date: Wed, 29 Sep 2021 21:49:56 -0400

--On Wednesday, September 29, 2021 13:20 -0400 Michael
Richardson <[email-masked]> wrote:

>     > Announcement list --selective digests, avoiding four
> separate     > interim meeting postings at the same time for
> the same WG,     > encouraging calendar subscriptions, etc.--
> then I think we     > address the real problem while splitting
> up lists even more just     > create distractions.
> 
> On the topic of calendaring, and "upcoming" being more useful
> for planning. I've asked for the various area meetings, such
> as the RTG Chairs Chat, IESG telechat, IoT Directorate, etc.
> to be on the calendar.
> 
> My purpose is allow people who are planning meetings to know
> what else is occuring.   Maybe we can do a "this week at the
> IETF" page.
> 
> But, the major pushback I got was that some of these events
> are not open to anyone, and so shouldn't be listed.  I
> disagree :-)

I do too, for at least two reasons.  One is that transparency
suggests that we should not be secretive about which closed
meetings are being held.  The other, more important, is that
including the closed meetings makes it much easier for those who
might be involved in, or concerned about, them to spot potential
or actual conflicts.

  john

---

From: Warren Kumari <[email-masked]>
Date: Wed, 29 Sep 2021 20:43:54 -0700

> might be involved in, or concerned about, them to spot potential

+1.

I think that the transparency of having closed meetings listed will also
cause people to reconsider if their meeting *really* has to be closed.

W

>   john
Perhaps they really do strive for incomprehensibility in their specs.
After all, when the liturgy was in Latin, the laity knew their place.
-- Michael Padlipsky

---

From: Barry Leiba <[email-masked]>
Date: Thu, 30 Sep 2021 09:29:39 -0400

Indeed: very strong agreement from me with John and Warren.

Barry

On Wed, Sep 29, 2021 at 11:45 PM Warren Kumari <[email-masked]> wrote:
> I think that the transparency of having closed meetings listed will also cause people to reconsider if their meeting *really* has to be closed.
>
> W
>>
>>
>>   john
>>
> --

---

From: tom petch <[email-masked]>
Date: Thu, 30 Sep 2021 16:46:55 +0100

On 29/09/2021 17:30, tom petch wrote:
>>> In an admirable effort to be transparent, we have inundated this list
>>> in particular with data.  We now need to take the time to reduce that
>>> data  to usable information.  Please take another swing.
>>
>> the IESG certainly could. But I'm also pretty convinced that whatever
>> proposal we came up with would get improved by the community pretty
>> immediately.
>>
>> For reference, here's again the list of posting classes that currently
>> go there, and the count of messages in each class in the last year:
>>
>> (We could have a conversation if some of those could also be moved
>> elsewhere, but that's maybe a separate discussion.)

I said before that the e-mails of least general interest IMHO are those 
from the Director, which seem to make up almost half of category 1) most 
of which I see as being of little or no immediate concern.  The 
exception I made was for outages of our infrastructure, past, present 
and future, since I see those as bringing work to a grinding halt.

Yet today I see notice of an outage of a key part of our infrastructure 
on October 4th that has not been posted to ietf, ietf-announce or any 
such list AFAICT.

Weird.

Tom Petch

<snip>
> Tom Petch
>
>> For any type of posting we'd remove, we could of course create a new
>> list, so that the information was still shared. I understand that when
>> we move to mailman3, we'll get a much better web-based subscription
>> interface that will make managing subscriptions much more
>> straightforward.
>>
>> Thanks,
>> Lars
>>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 30 Sep 2021 14:05:38 -0400

> No, because from observation, most people who reply to a digest don't
    > change the Subject to a useful string. This would be disastrous for
    > Last Call workflows in particular.

The categories proposed that would be on a list that would be digestable

>>>> 10. Interim WG meeting announcements = 256

So, we'd need to not include Last Call Announcements in that list.
Then would it work for you?

A thing that I like about the digest option is that the archives (and IMAP)
would have the individual messages.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 1 Oct 2021 09:01:40 +1300

> Then would it work for you?

Not if it ever leads me to receive a message with a subject like

Re: document-actions Digest, Vol 52, Issue 41

That one would take many times longer before I could hit delete than

Re: Document Action: 'Boring Stuff' to Informational RFC (draft-ietf-boring-stuff-10.txt)
 
> would have the individual messages.

But in my experience people reply directly to the digest.

The bottom line is that people's workflows and email habits vary widely,
so there is no one-size-fits-all solution.

   Brian