Subject: Re: Turning off Etherpad

From: Robert Sparks <[email-masked]>
Date: Wed, 15 Sep 2021 13:19:10 -0500

Mark -

I want to note that your policy suggestion is being discussed. I am 
bringing it up with some frequency - I don't think that we'll have such 
a policy in the near future, but I do think we'll be working towards 
one. I will be sending a note about the expectations around the notes 
service momentarily.

RjS

On 8/10/21 8:27 PM, Mark Nottingham wrote:
> My understanding was always that etherpad was a best-effort, ephemeral service; i.e., there was no guarantee (implicit or explicit) of stability or availability. That's probably the right policy, given that there able to be edited by *anyone on the Internet*.
>
> We might consider a somewhat more formal and explicit policy on service stability and availability (on a service-by-service basis), so that folks aren't surprised by this in the future. E.g., the W3C has:
>    https://www.w3.org/Consortium/Persistence
>
> Cheers,
>
>
>> On 11 Aug 2021, at 11:24 am, Toerless Eckert <[email-masked]> wrote:
>>
>> So, what is he plan for archiving etherpad.ietf.org ?
>> Can/will the be made read-only/no new data ?
>>
>> Or is all that content that may still have URLs in emails and other places
>> pointing to it deemed to be lost except for the subset of pages that
>> where converted into IETF meeting minuts by WG chairs ?
>>
>> If all this content is meant to be lost because it is too difficult to
>> change to read-only, is this the same strategy for codimd ? Aka:
>> if you do not save it, it will be lost at some point in time ?
>>
>> If converting to read-only is too difficult, maybe the whole tree
>> can just be put up for download as a tar file for any future researchers...
>> However, i am not sure if all the content is meant to be public, or if
>> we did assume some degree of possible confidentiality because of non-searchable
>> namespace.
>>
>> Btw: I think it would be great if codimd would solve these issues:
>> You can only create new names under whatever.ietf.org/2021/<your-string-here>
>> and after 2 years the whole years directory tree turns read-only with
>> indexing/search...
>>
>> Cheers
>>     Toeless
>>
>> On Tue, Aug 10, 2021 at 06:05:34PM -0700, Fred Baker wrote:
>>> People use it in recording our minutes. Losing it would be unfortunate.
>>>
>>>> On Aug 10, 2021, at 2:01 PM, Robert Sparks <[email-masked]> wrote:
>>>>
>>>> Chairs -
>>>>
>>>> We are making plans to turn down etherpad.ietf.org in a few weeks. Let me know of any concerns or need for delay.
>>>>
>>>> RjS
>>>>
>> -- 
>> ---
>> [email-masked]
>>
> --
> Mark Nottingham   https://www.mnot.net/
>

---

From: Robert Sparks <[email-masked]>
Date: Wed, 15 Sep 2021 13:31:05 -0500

Toerless -

The tools team discussed the suggestions to try to archive what was in 
etherpad, and, with input from the leadership, decided not to do so. 
You'll see from the other notes that I just sent what should happen with 
any content that people feel should be preserved.

We are looking at ways to signal strongly to new users of notes.ietf.org 
that the content is not archival.

RjS

On 8/11/21 11:11 AM, Toerless Eckert wrote:
> On Wed, Aug 11, 2021 at 11:27:41AM +1000, Mark Nottingham wrote:
> Yes. But my comments where not about the intent of etherpad,
> but if/what we would want to do now to preserve history, even
> if that was not a desire when we started using it.
>
> The main question IMHO is whether we could publish the whole content
> of etherpad or not. I would like to see that question answered. If
> the answer is yes, then we can discuss if and/or how to do that.
>
> If the answer is no, then i guss a tar file could still go into the
> IETF vault, and later generations could figure out if/who might
> be able to take a look at it.
>
> Right. My suggestion for codimd was exactly around that IMHO:
>
> - declare CodiMD content to be public.
> - automatically make older CodiMD content read-only
>
> The conflict between this goal and the design of etherpad/codiMD is that
> boh seem to be based on confidentiality by obscurity, e.g.: no
> public search and/or list of pages...
>
> Cheers
>      Toerless
>
>> Cheers,
>>
>>

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 15 Sep 2021 22:22:57 +0200

Thanks Robert. I think i understand some of the policy rasons,
as we discussed in the thread. We also ran into similar problems
with old mailin lists in discussion on the internet-history mailing
list.

I will stick to my suggestion for the successor system going forward:

  -> have a button to create a freezed copy of a page unde a new URL.
  -> with the option "public searchable: [Y/N]

The public searchable frozen cpy URL would be what would be archived
publically!

Cheers
    Toerless

On Wed, Sep 15, 2021 at 01:31:05PM -0500, Robert Sparks wrote:
> etherpad, and, with input from the leadership, decided not to do so. You'll
> see from the other notes that I just sent what should happen with any
> content that people feel should be preserved.
> 

-- 
---
[email-masked]

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 16 Sep 2021 09:43:54 +1000

Thanks!

> On 16 Sep 2021, at 4:19 am, Robert Sparks <[email-masked]> wrote:
> 
> Mark -
> 
> I want to note that your policy suggestion is being discussed. I am bringing it up with some frequency - I don't think that we'll have such a policy in the near future, but I do think we'll be working towards one. I will be sending a note about the expectations around the notes service momentarily.
> 
> RjS
>