Subject: Terms in RFC 2418

From: "Salz, Rich" <[email-masked]>
Date: Mon, 13 Sep 2021 19:24:20 +0000

Hey there peers.

I was looking at RFC 2418 and I have some questions. If you know of any working groups that have deployed a “Working Group Consultant”[1]
Or a “WG Facilitator” [2] in the past decade, please let me know.

[1] https://datatracker.ietf.org/doc/html/rfc2418#section-6.6
[2] https://datatracker.ietf.org/doc/html/rfc2418#section-6.4

---

From: "MORTON JR., AL" <[email-masked]>
Date: Mon, 13 Sep 2021 19:33:15 +0000

Hi Rich,

It seems to me there was a WG I followed where you were the Security Advisor, or something like that title.
Maybe there was a particular set of drafts on which you were asked to provide advice during development.  It’s the only time I remember something like a WG consultant, below.  It may have been more than a decade ago...

Al

From: WGChairs <[email-masked]> On Behalf Of Salz, Rich
Sent: Monday, September 13, 2021 3:24 PM
To: 'WG Chairs' <[email-masked]>
Subject: Terms in RFC 2418

Hey there peers.

[1] https://datatracker.ietf.org/doc/html/rfc2418#section-6.6<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/rfc2418*section-6.6__;Iw!!BhdT!y8WaHFtoams6h8qegtI66lAnda2d91IMZM9NKL6QBYArXUKRUyenpgsRdkbr6aE$>
[2] https://datatracker.ietf.org/doc/html/rfc2418#section-6.4<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/rfc2418*section-6.4__;Iw!!BhdT!y8WaHFtoams6h8qegtI66lAnda2d91IMZM9NKL6QBYArXUKRUyenpgsRYh_5Vsg$>

---

From: Barry Leiba <[email-masked]>
Date: Mon, 13 Sep 2021 15:37:48 -0400

> Or a “WG Facilitator” [2] in the past decade, please let me know.

I'm not aware of "Facilitator" being used, but working groups do
occasionally have a "Consultant" role, which shows up in the
datatracker as "Tech Advisors".  Anima, Mboned, and Mops, at least,
currently have some.

Barry

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 13 Sep 2021 19:38:50 +0000

Thanks!  Query closed :)

---

From: Lars Eggert <[email-masked]>
Date: Tue, 14 Sep 2021 11:21:56 +0300

Hi,

> datatracker as "Tech Advisors".  Anima, Mboned, and Mops, at least,

+1

https://datatracker.ietf.org/wg/nfsv4/about/ shows Leif Johansson as "Tech Advisor" at the moment, too.

Thanks,
Lars

---

From: Leif Johansson <[email-masked]>
Date: Tue, 14 Sep 2021 11:32:07 +0200

> https://datatracker.ietf.org/wg/nfsv4/about/ shows Leif Johansson as "Tech Advisor" at the moment, too.

Dear god, I forgot about that. I have never been asked to do anything tho :-)

	Cheers Leif

---

From: Robert Sparks <[email-masked]>
Date: Tue, 14 Sep 2021 11:28:51 -0500

Fwiw, across all time that the datatracker has modeled:

In [3]: from collections import Counter; from ietf.group.models import 
Role; 
Counter(Role.objects.filter(group__type='wg').values_list('name',flat=True))
Out[3]:
Counter({'ad': 555,
          'chair': 1664,
          'delegate': 6,
          'editor': 13,
          'liaison_contact': 79,
          'matman': 2,
          'secr': 41,
          'techadv': 100})

Facilitator and consultant have not been used (as far as the datatracker 
knows).

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 14 Sep 2021 20:43:36 +0200

Now you have to tell us what a “delegate” and a “matman” is :-)

Grüße, Carsten

> On 14. Sep 2021, at 18:28, Robert Sparks <[email-masked]> wrote:
> 
> In [3]: from collections import Counter; from ietf.group.models import Role; Counter(Role.objects.filter(group__type='wg').values_list('name',flat=True))
> Out[3]:
> Counter({'ad': 555,
>          'chair': 1664,
>          'delegate': 6,
>          'editor': 13,
>          'liaison_contact': 79,
>          'matman': 2,
>          'secr': 41,
>          'techadv': 100})
> 
> Facilitator and consultant have not been used (as far as the datatracker knows).
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 14 Sep 2021 14:48:59 -0500

> Now you have to tell us what a “delegate” and a “matman” is :-)

Yeah

Delegates are people who chairs have delegated chair datatracker 
abilities to.

Materials Managers, well, manage materials (and your next question is 
'what materials?') - that's really used for other types of groups 
besides working groups, as you see from the count of 2 below. It might 
be better to explain indirectly thus:

In [2]: Role.objects.filter(name='matman')
Out[2]: <QuerySet [<Role: Karen O'Donoghue is Materials Manager in edu>, 
<Role: Jari Arkko is Materials Manager in iasa20>, <Role: Alissa Cooper 
is Materials Manager in iasa20>, <Role: Aaron Falk is Materials Manager 
in hotrfc>]>

RjS