Subject: Spreadsheet to aid agenda planning

From: Marco Tiloca <[email-masked]>
Date: Wed, 8 Sep 2021 22:55:17 +0200

Hi all,

During a WG Chair training session this week, we also discussed 
approaches for planning a meeting agenda, especially for WG sessions at 
main IETF meetings.

Some suggested me to share on this list about a pretty frugal "tool" I 
mentioned, that I've been using for a while, i.e., a simple spreadsheet.

Not fancy at all, but I found it helpful for "simulating" the agenda 
slots and their duration all in front of me at a glance, while quickly 
and easily adjusting the duration of agenda slots to fit the overall 
time budget.

So, please find the spreadsheet attached to this mail. The "How likely?" 
green/yellow/red indicator is just a qualitative, aggregated estimator 
of factors that influence an inclusion in the agenda, e.g., a topic's 
urgency/priority or chances to actually have updates to present/discuss 
about a (resubmitted) draft.

Admittedly, this may just be an overkill for some WGs, depending on 
their current workload, patterns, dynamics and so on. However, it was 
pretty useful to early devise the sessions for the CoRE WG in the last 
few IETF meetings, and then adjust and refine the plan as things evolved 
towards an eventual agenda.

Hope this helps!

Best,
/Marco

-- 
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System
Department: Computer Science
Unit: Cybersecurity

RISE Research Institutes of Sweden
https://www.ri.se

Phone: +46 (0)70 60 46 501
Isafjordsgatan 22 / Kistagången 16
SE-164 40 Kista (Sweden)

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 8 Sep 2021 16:58:54 -0400

We use one of these in DNSOP that I think I stole from Warren.  It has the
advantage of doing
some math in the columns, because you know, math is hard

https://docs.google.com/spreadsheets/d/1Yv_AD2TfPo8WY8UKjpl78Y5hzY5U1qAvdCOM_hWVwq0/edit?usp=sharing

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 8 Sep 2021 22:12:00 +0100

Thanks for sharing these.

After the session, Chris Wood and I were chatting about how nice it would
be if the datatracker supported an agenda management feature a bit like
this. There's a minor benefit from avoiding people to invent their own
means of agenda planning; this might be good for newer chairs that didn't
learn some tricks yet. The real benefit would come from a common structured
data format that could integrate natively with other information already in
the datatracker. UI affordances are a cherry on top. A cursory search
didn't yield any standards for meeting agenda breakdowns, everything seemed
more coarse grain at the event envelope level. Happy if someone points me
at an existing RFC for just this type of thing.

Cheers
Lucsa

---

From: tjw ietf <[email-masked]>
Date: Wed, 8 Sep 2021 17:17:29 -0400

I’m the priority scale it’s a nice to have. I don’t mind using the googles and would prefer we don’t reimplement something. 

I think the hardest part is the chairs remember the link to the googles

Sent from my iPhone

> On Sep 8, 2021, at 17:12, Lucas Pardue <[email-masked]> wrote:
> 
> 
> After the session, Chris Wood and I were chatting about how nice it would be if the datatracker supported an agenda management feature a bit like this. There's a minor benefit from avoiding people to invent their own means of agenda planning; this might be good for newer chairs that didn't learn some tricks yet. The real benefit would come from a common structured data format that could integrate natively with other information already in the datatracker. UI affordances are a cherry on top. A cursory search didn't yield any standards for meeting agenda breakdowns, everything seemed more coarse grain at the event envelope level. Happy if someone points me at an existing RFC for just this type of thing.
> 
> Cheers
> Lucsa
> 
>> We use one of these in DNSOP that I think I stole from Warren.  It has the advantage of doing
>>> On Wed, Sep 8, 2021 at 4:56 PM Marco Tiloca <marco.tiloca=[email-masked]> wrote:
>>> Hi all,
>>>

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 8 Sep 2021 17:22:28 -0400

Actually what might be useful is something which chairs can see where we
can put links, etc.

On Wed, Sep 8, 2021 at 5:17 PM tjw ietf <[email-masked]> wrote:

> I’m the priority scale it’s a nice to have. I don’t mind using the googles
> and would prefer we don’t reimplement something.
>

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 8 Sep 2021 17:30:42 -0400

I believe Warren recently asked for the ability for chairs to assign
actions like ADs can do.
But I think he secretly wants to boss us around, which we don't mind
because it makes him happy

On Wed, Sep 8, 2021 at 5:22 PM Tim Wicinski <[email-masked]> wrote:

>> I’m the priority scale it’s a nice to have. I don’t mind using the
>> googles and would prefer we don’t reimplement something.
>>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 09 Sep 2021 12:58:47 -0400

Thanks for this spreadsheet. If it helps us even have one session that isn't
oversubscribed, then it's worthwhile.

I've been previously skeptical that WG chairs actually need any help building
agendas from the DT, but the number of times when the agenda is just lacking
the basics is upsetting to me.  So, if the agenda builder can prompt chairs
to remember to put in all the relevant things, that would help.

Given conflicts for meetings, it's really helpful if one knows approximately
when a relevant draft will be discussed.

In particular, for virtual interims, I think that I should be able to go from
my calendar program to all the places I need: meetecho/webex link,
codimd/notes link. I should have the time (in UTC) and the date in the
agenda, so that I can forward to others.
On a desktop it's not as critical: on those times when I have to use a phone
I really need it all in the same place.  I don't want to use my phone, but
sometimes, shit happens, and one isn't where one expected to be, or one has
to do the browser-restart dance.

Yes, many of these things are on the DT, but the link that goes out with
upcoming.ics doesn't lead to the right page (maybe we can fix that).
The DT is still not as fast to load as I'd like.   The Agenda should get
copied into the codimd with all the links, so if you can just get one link
right, then you can find the others.

Tim Wicinski <[email-masked]> wrote:
    > We use one of these in DNSOP that I think I stole from Warren.  It has
    > the advantage of doing some math in the columns, because you know, math
    > is hard

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Bob Hinden <[email-masked]>
Date: Thu, 9 Sep 2021 11:25:40 -0700

Marco,

In the w.g. I co-chair, we use a google sheet for this, it allows easy collaboration between chairs.   You can see this at:

https://docs.google.com/spreadsheets/d/1_cp-Ny2toj1YfCmQ3nS5xs6wW9jsSi0iMpALG9IxIEc/edit?usp=sharing

We first setup the time of the session(s), and the duration of the session(s).

Then we add requests to the “Requested” section with title, draft, presenter, and requested time.  This allows for seeing how much time has been requested vs. time in the the session.  Also space for our notes/comments/etc.

Then we move items to the “Session” section.    The colors are Green for w.g. document, Blue for documents with active discussion, and Yellow for new documents.

We also have a section for w.g. documents, useful to see if we missed anything.

This works well for us.  Feel free to copy or modify for your own use.

Bob

> On Sep 8, 2021, at 1:55 PM, Marco Tiloca <marco.tiloca=[email-masked]> wrote:
> 
> Hi all,
> 
> During a WG Chair training session this week, we also discussed approaches for planning a meeting agenda, especially for WG sessions at main IETF meetings.
> 
> Some suggested me to share on this list about a pretty frugal "tool" I mentioned, that I've been using for a while, i.e., a simple spreadsheet.
> 
> Not fancy at all, but I found it helpful for "simulating" the agenda slots and their duration all in front of me at a glance, while quickly and easily adjusting the duration of agenda slots to fit the overall time budget.
> 
> So, please find the spreadsheet attached to this mail. The "How likely?" green/yellow/red indicator is just a qualitative, aggregated estimator of factors that influence an inclusion in the agenda, e.g., a topic's urgency/priority or chances to actually have updates to present/discuss about a (resubmitted) draft.
> 
> Admittedly, this may just be an overkill for some WGs, depending on their current workload, patterns, dynamics and so on. However, it was pretty useful to early devise the sessions for the CoRE WG in the last few IETF meetings, and then adjust and refine the plan as things evolved towards an eventual agenda.
> 
> Hope this helps!
> 
> Best,
> /Marco
> 
> --
> Marco Tiloca
> Ph.D., Senior Researcher
> 
> Division: Digital System
> <agenda_planning_template.ods>

---

From: Marco Tiloca <[email-masked]>
Date: Fri, 10 Sep 2021 22:05:28 +0200

Thank you all for the great feedback and pointers!

Best,
/Marco

-- 
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System