Subject: Re: Please look at your groups' charters rendered through markdown

From: Harald Alvestrand <[email-masked]>
Date: Mon, 11 Oct 2021 09:59:01 +0200

Two errors in 
https://datatracker.ietf.org/group/mediaman/about/rendertest/ - both due 
to markdown requiring a blank line before the first item of a bulleted list.

On 9/20/21 7:34 PM, Robert Sparks wrote:
> Chairs -
>
> I have added a page that shows how the current charter for a group 
> renders with markdown, comparing side-by-side with the current rendering.
>
> See, for example, 
> https://datatracker.ietf.org/group/stir/about/rendertest/
>
> Please look the variant of that page for all of the groups you are 
> responsible for (and feel free to explore others).
>
> Bring any issues with the markdown rendering of the current charter 
> text to me.
>
> If we don't have major issues to address with any existing charter 
> text, I plan to switch the main /about page (and the charter document 
> view page) to render through markdown with the next datatracker release.
>
> RjS
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 11 Oct 2021 10:46:01 +0200

For maprg the listing is showing up in a box and using courier (code style). Not sure why that is… maybe because we use “*” for the listing?

https://datatracker.ietf.org/group/maprg/about/rendertest/

> On 11. Oct 2021, at 09:59, Harald Alvestrand <[email-masked]> wrote:
> 
> Two errors in https://datatracker.ietf.org/group/mediaman/about/rendertest/ - both due to markdown requiring a blank line before the first item of a bulleted list.
> 
>> I have added a page that shows how the current charter for a group renders with markdown, comparing side-by-side with the current rendering.
>> 
>> See, for example, https://datatracker.ietf.org/group/stir/about/rendertest/
>> 
>> Please look the variant of that page for all of the groups you are responsible for (and feel free to explore others).
>> 
>> Bring any issues with the markdown rendering of the current charter text to me.
>> 
>> If we don't have major issues to address with any existing charter text, I plan to switch the main /about page (and the charter document view page) to render through markdown with the next datatracker release.
>> 
>> RjS
>> 
> 
>

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 11 Oct 2021 12:00:57 +0300

Hi Robert,

one issue with https://datatracker.ietf.org/wg/dots/about/rendertest/ :

the first bulleted list on the page is not rendered correctly - list items don't start 
from new line. In contrast, the second list, which looks identical to the first,
is rendered correctly.

Regards,
Valery.

> If we don't have major issues to address with any existing charter text,
> I plan to switch the main /about page (and the charter document view
> page) to render through markdown with the next datatracker release.
> 
> RjS

---

From: Robert Sparks <[email-masked]>
Date: Mon, 11 Oct 2021 08:47:53 -0500

> https://datatracker.ietf.org/group/maprg/about/rendertest/
Its because it is indented with 4 spaces in the plaintext version

> gain from contacts with the IETF. The Measurement and Analysis for
> Protocols Research Group Research Group (MAPRG) aims to provide a
> forum for interchange between these two communities, supporting:
>
>      * exchange of measurement-derived insight; discussion of
>        techniques and best practices for measurement relevant to
>        protocol
>
>      * engineering and network operations;
>
>      * collaborations to share data supporting these measurements; and
>
>      * a "landing pad" for the Internet measurement community to
>        introduce its efforts to the * IETF.
>
> Membership
which means to markdown means its a quote block.

>
>> On 11. Oct 2021, at 09:59, Harald Alvestrand<[email-masked]>  wrote:
>>
>> Two errors inhttps://datatracker.ietf.org/group/mediaman/about/rendertest/  - both due to markdown requiring a blank line before the first item of a bulleted list.
>>
>>> See, for example,https://datatracker.ietf.org/group/stir/about/rendertest/
>>>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 11 Oct 2021 16:03:36 +0200

Ah, okay, didn’t realise that. I guess you can just fix that (without rechartering ;-) )?

Mirja

> On 11. Oct 2021, at 15:47, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
>>> https://datatracker.ietf.org/group/mediaman/about/rendertest/
>>>  - both due to markdown requiring a blank line before the first item of a bulleted list.
>>>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 11 Oct 2021 11:42:29 -0400

I don't understand what the goal is here.

I *guess* the idea is to switch to having the authoritative form of 
charters be written in markup notation, so that they can then be 
rendered using the derived html.

Currently they charters are (always / mostly ?) in text form.

Is the intent to declare the existing text forms to be markup? And they 
to have chairs fixup any problems that arise when that text doesn't 
render well when treated as markup?

Or is the intent to allow the charters to be posted with an extension 
indicating it is markup, and have some sort of conversion process?

Or ...???

	Thanks,
	Paul

---

From: Robert Sparks <[email-masked]>
Date: Mon, 11 Oct 2021 11:25:45 -0500

> I don't understand what the goal is here.
See the very start of the thread (at the bottom of this message) - I 
think the goal was explained there, but will clarify more here.
> Currently they charters are (always / mostly ?) in text form.
They are all in text form, but many have been using markdown-style 
markup already
>
> Is the intent to declare the existing text forms to be markup? And 
> they to have chairs fixup any problems that arise when that text 
> doesn't render well when treated as markup?
The intent is to move to having the charters always be rendered in 
markdown. To be clear, that means that the intent is to always treat 
charter document contents as markdown source. This test page is to help 
us understand what would be needed to get there. From what we've seen so 
far, if we are going to proceed, there's a strong indication of a need a 
way to make cosmetic changes to charters without going through a 
recharter process - I'll be talking to the IESG about that over the next 
few days. There may or may not be a small set of tweaks we can apply 
automatically, once an acceptable process is in place, fixing linebreaks 
and lists for instance.
>>>> For maprg the listing is showing up in a box and using courier 
>>>> (code style). Not sure why that is… maybe because we use “*” for 
>>>> the listing?
>>>>
>>>>
>>>>>> I have added a page that shows how the current charter for a 
>>>>>> group renders with markdown, comparing side-by-side with the 
>>>>>> current rendering.
>>>>>>
>>>>>> See, for example,
>>>>>> Please look the variant of that page for all of the groups you 
>>>>>> are responsible for (and feel free to explore others).
>>>>>>
>>>>>> If we don't have major issues to address with any existing 
>>>>>> charter text, I plan to switch the main /about page (and the 
>>>>>> charter document view page) to render through markdown with the 
>>>>>> next datatracker release.
>>>>>>
>>>>>> RjS
>>>>>>
>>>>>>
>>>>>
>>
>

---

From: Anna Brunström <[email-masked]>
Date: Mon, 11 Oct 2021 20:30:44 +0000

For rmcat https://datatracker.ietf.org/group/rmcat/about/rendertest/ all items in the lists are merged together as one block of text due to missing blank lines.

BR,
Anna

-----Original Message-----
From: WGChairs <[email-masked]> On Behalf Of Harald Alvestrand
Sent: den 11 oktober 2021 09:59
To: Robert Sparks <[email-masked]>; Working Chairs <[email-masked]>
Subject: Re: Please look at your groups' charters rendered through markdown

Two errors in
https://datatracker.ietf.org/group/mediaman/about/rendertest/ - both due to markdown requiring a blank line before the first item of a bulleted list.

> view page) to render through markdown with the next datatracker release.

När du skickar e-post till Karlstads universitet behandlar vi dina personuppgifter<https://www.kau.se/gdpr>.
When you send an e-mail to Karlstad University, we will process your personal data<https://www.kau.se/en/gdpr>.

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Mon, 11 Oct 2021 20:46:33 +0000

COINRG looks good but reminded me that we need to edit it :)

Marie-José Montpetit, Ph.D.
[email-masked]

From: Anna Brunström <[email-masked]> <[email-masked]>
Reply: Anna Brunström <[email-masked]> <[email-masked]>
Date: October 11, 2021 at 4:31:16 PM
To: Robert Sparks <[email-masked]> <[email-masked]>, Working
Chairs <[email-masked]> <[email-masked]>
Subject:  Re: [irsg] Please look at your groups' charters rendered through
markdown

datatracker.ietf.org/group/mediaman/about/rendertest

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Tue, 12 Oct 2021 09:29:25 +0000

https://datatracker.ietf.org/group/lsvr/about/rendertest/

Looks slightly different, however all looks correct, if not nicer. 
Is there anything alse to be done next?

G/

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 13 Oct 2021 13:30:52 +0000

HTTPAPI looks fine.

CURDLE, and I think I reported this earlier, gets the list of links at the end wrong.

---

From: Dieter Sibold <[email-masked]>
Date: Wed, 13 Oct 2021 23:35:04 +0200

NTP only has an issue with the numbered list at the end of the last paragraph.
https://datatracker.ietf.org/group/ntp/about/rendertest/

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Thu, 14 Oct 2021 13:50:44 +0200

Hi,

The 6Lo charter has a similar issue with a list of bullets at the end of
the first paragraph:
https://datatracker.ietf.org/group/6lo/about/rendertest/

(The rest looks good!)

Thanks,

Shwetha and Carles