Subject: IESG experiment to conduct 360-degree reviews for ADs

From: IETF Chair <[email-masked]>
Date: Fri, 15 Oct 2021 17:01:33 +0300

Hi,

the IESG has started an experiment to conduct 360-degree reviews [1] of current
Area Directors, to give them direct feedback allowing them to develop their
method of working and behaviors. The feedback is entirely anonymous and we are
not collecting tracking information. These types of IETF participants have been
asked to provide feedback on the ADs they interacted with:

* IAB, LLC, secretariat and IESG members will receive a survey for each AD

* Each working group chair will receive a survey for their responsible ADs

* Shepherds of drafts that went to the ballot in the past 12 months will receive
  a survey for the responsible AD, if still active

* Shepherds of drafts that spent any time in the AD Evaluation state in the past
  12 months will receive a survey for the responsible AD, if still active

The IETF Secretariat will collect the responses and aggregate them as follows:
Individual survey responses will be kept anonymous. Each Area Director will
receive a summary of all responses to their survey, and the IESG as a whole will
receive a rollup of the results of all surveys. The IESG will publicly release
the aggregate result for the entire IESG.

If this experiment provides useful input to current Area Directors, the IESG may
decide to continue 360-degree reviews in future years, possibly extend the
survey to reach more of the community, or take other actions. A successful
experiment may also lead to discussions on whether similar activities for IAB
members, Working Group chairs or other roles may be useful to undertake.

If you have been emailed feedback forms, the IESG would appreciate your input
by Monday 25 October 2021.

Lars Eggert
IETF Chair (on behalf of the IESG)

[1] https://en.wikipedia.org/wiki/360-degree_feedback

---

From: Bob Hinden <[email-masked]>
Date: Fri, 15 Oct 2021 08:30:00 -0700

Lars,

I responded to the survey after I received it.   I am fine with doing surveys.  However this one appears to have been written with a very negative slant.  For example (removed the name of the AD it asked about:

Q7. What best describes the quality of Internet-Drafts that XXXX XXXXX reviewed and submitted to IETF Last Call?

I was expecting to select between answers like high quality to low quality, but the questions are:

	More significant problems than average
	About the same severity of probems
	Fewer Significant problems than average
	No opinion.

It might have as well just asked “when did you stop beating your wife”.

I think this survey needs to be rewritten provide for neutral answers.  The current ones appear to assume there are problems.  It’s really bad in my view.

So far IMHO, the experiment is a “fail”.

Bob

> On Oct 15, 2021, at 7:01 AM, IETF Chair <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Rifaat Shekh-Yusef <[email-masked]>
Date: Fri, 15 Oct 2021 12:40:03 -0400

While I agree with Bob that some of the questions were weirdly formulated,
I do *not* think that the experiment is a "fail".

Regards,
 Rifaat

On Fri, Oct 15, 2021 at 11:30 AM Bob Hinden <[email-masked]> wrote:

> Lars,
>
> I responded to the survey after I received it.   I am fine with doing
> surveys.  However this one appears to have been written with a very
> negative slant.  For example (removed the name of the AD it asked about:
>
> Q7. What best describes the quality of Internet-Drafts that XXXX XXXXX
> reviewed and submitted to IETF Last Call?
>
> I think this survey needs to be rewritten provide for neutral answers.
> The current ones appear to assume there are problems.  It’s really bad in
> my view.
>

---

From: "MORTON JR., AL" <[email-masked]>
Date: Fri, 15 Oct 2021 17:32:28 +0000

If we can agree on the list of questions that didn’t quite reveal the opinions sought, we could agree to exclude those questions from further analysis and proceed with remaining questions that were more clear.

Al

From: WGChairs <[email-masked]> On Behalf Of Rifaat Shekh-Yusef
Sent: Friday, October 15, 2021 12:40 PM
To: Bob Hinden <[email-masked]>
Cc: Working Chairs <[email-masked]>; IETF Chair <[email-masked]>
Subject: Re: IESG experiment to conduct 360-degree reviews for ADs

While I agree with Bob that some of the questions were weirdly formulated, I do not think that the experiment is a "fail".

Regards,
 Rifaat

On Fri, Oct 15, 2021 at 11:30 AM Bob Hinden <[email-masked]<mailto:[email-masked]>> wrote:
Lars,

Bob

> On Oct 15, 2021, at 7:01 AM, IETF Chair <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi,
>
> [1] https://en.wikipedia.org/wiki/360-degree_feedback<https://urldefense.com/v3/__https:/en.wikipedia.org/wiki/360-degree_feedback__;!!BhdT!12Lkb_JO5gcyTIj4bO6LmPeZxr4OQvMYiR3GYkgvqUz18s4kyPUUgepdFo1uZ9k$>
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ietf-announce<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/ietf-announce__;!!BhdT!12Lkb_JO5gcyTIj4bO6LmPeZxr4OQvMYiR3GYkgvqUz18s4kyPUUgepdhYCVfLE$>

---

From: Christian Hopps <[email-masked]>
Date: Sun, 17 Oct 2021 02:22:20 -0400

So this is leaving me uninspired to spend time filling the survey request I received out. :)

Thanks,
Chris.

"MORTON JR., AL" <[email-masked]> writes:

> If we can agree on the list of questions that didn’t quite reveal the
> opinions sought, we could agree to exclude those questions from
> further analysis and proceed with remaining questions that were more
> clear.
>
>
>
> Al
>
>
>
> While I agree with Bob that some of the questions were weirdly
> formulated, I do not think that the experiment is a "fail".
>
>
>
> Regards,
>
>  Rifaat
>
>
>
>
>
>     I responded to the survey after I received it.   I am fine with
>     doing surveys.  However this one appears to have been written
>     with a very negative slant.  For example (removed the name of the
>     AD it asked about:
>
>     Q7. What best describes the quality of Internet-Drafts that XXXX
>     XXXXX reviewed and submitted to IETF Last Call?
>
>     I think this survey needs to be rewritten provide for neutral
>     answers.  The current ones appear to assume there are problems.
>     It’s really bad in my view.
>

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 17 Oct 2021 17:18:00 +0000

The questions aren't perfect.  So what.  Nothing is.  Someone can interate in the future.

Is it better than nothing?  Will it help?  In my view yes, so I filled out the surveys.  If you disagree, don't.  If you're waiting for it to be fixed or worry about what they're going to do, you're spending time on the wrong things.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Sun, 17 Oct 2021 18:29:42 +0000

> Is it better than nothing?  Will it help?  In my view yes, so I filled out the surveys.
> If you disagree, don't.  If you're waiting for it to be fixed or worry about what
> they're going to do, you're spending time on the wrong things.

I just filled out a questionnaire. It took me less than 10 minutes. One of the big comments I got from last year's "current position" nominees (as the 2020 NomCom chair, during my one-on-one post-NomCom feedback sessions) was that (1) NomCom was the only means they had for getting feedback on how well they were doing and (2) they wanted and would really like a better feedback mechanism.

It's pretty easy to mark "No Opinion" on the questions you don't like and then use the single text box at the end to provide any piece of meaningful and relevant feedback you want. 

The ask being made of us in order to work towards a means of eventually supplying leadership with good and meaningful feedback isn't a big time investment. So please just do it. And then provide suggestions for improving the feedback mechanism.
Barbara