Subject: codimd -> agenda

From: "Aaron Falk" <[email-masked]>
Date: Thu, 21 Oct 2021 14:57:07 -0400

So, I just did a little experiment. I appreciate a well-formatted agenda 
with hyperlinks and such and I’ve found the workflow on a Mac to be 
tedious as there’s something broken about how browsers tag the MIME 
type of markdown files in a way the agenda import magic doesn’t 
respect.  Anyway, I had hoped that CodiMD would be a solution.  So, I 
created and downloaded my agenda using the 
[markdown](https://datatracker.ietf.org/meeting/112/materials/agenda-112-hotrfc-sessa-07), 
[html](https://datatracker.ietf.org/meeting/112/materials/agenda-112-hotrfc-sessa-08), 
and [raw 
html](https://datatracker.ietf.org/meeting/112/materials/agenda-112-hotrfc-sessa-06) 
options.  As you can see there are oddities in the markdown and html.  
The raw html is the most correct and I guess attractive if your idea of 
good html aesthetics is rooted in the 1990s.  Just passing this on in 
case it is helpful.

--aaron

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Oct 2021 21:20:35 +0200

On 2021-10-21, at 20:57, Aaron Falk <[email-masked]> wrote:
> oddities in the markdown

If you use hedgedoc (nee codimd) in its default configuration, it is configured for hard newlines.  Markdown is usually soft newlines.  The tool de-gfm in kramdown-rfc2629 can fix that for you.

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Thu, 21 Oct 2021 15:12:10 -0500

> If you use hedgedoc (nee codimd) in its default configuration, it is configured for hard newlines.  Markdown is usually soft newlines.  The tool de-gfm in kramdown-rfc2629 can fix that for you.

I am working on

* making it so that the datatracker can pull things out of 
notes.ietf.org for you, applying de-gfm automatically

* making it easier for people on OS/X who haven't installed something 
that tells the OS that markdown is a thing in the world upload markdown 
without suffering the apparent mime-type impedance. (This will probably 
look like a "Please rename my .txt upload to .md for me and treat it as 
markdown once you have it" option.)

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Oct 2021 23:00:31 +0200

On 2021-10-21, at 22:12, Robert Sparks <[email-masked]> wrote:
> 
> * making it so that the datatracker can pull things out of notes.ietf.org for you, applying de-gfm automatically

Nice!

> * making it easier for people on OS/X who haven't installed something that tells the OS that markdown is a thing in the world upload markdown without suffering the apparent mime-type impedance. (This will probably look like a "Please rename my .txt upload to .md for me and treat it as markdown once you have it" option.)

We macOS users do name the files .md (or .mkd) usually, and associate that ending with applications (Marked in my case).
It’s just hard to convince a browser that this must lead to a specific upload media type; in macOS that seems to go through the bowels of an application, and we don’t all have the same applications (or the same browsers, for that matter).

So a simple recognition of the file name ending with [.]mk?d might help; a check box to persuade some chronic cases might be appropriate as a last resort.

Grüße, Carsten