Subject: Accepting email on any IETF list with a single subscription

From: Paul Wouters <[email-masked]>
Date: Mon, 8 Nov 2021 21:45:26 -0500

Hi,

I know each list / WG can configure whether to accept email from IETF participants subscribed to other ietf list without being held for moderation. In my own transitioning of email address I am finding that most WGs have not enabled this option.

Does anyone have bad experiences doing this?

Is it just that the default is off ?

Should a request me made to enable this on all IETF lists ?

Paul

---

From: Barry Leiba <[email-masked]>
Date: Mon, 8 Nov 2021 22:38:34 -0500

Yes, there is a "global whitelist", and I think it had to be opted
into by each list.  I thought that at one point the IESG had asked the
Secretariat to set each new list up with the global whitelist in use
by default... but I could be wrong.

Barry

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 04:43:44 +0100

My memory is that new lists are now created with this option enabled,
but old lists where not updated. I remember vauely asking some other WG chair
to click the option on his WG mailing list this year....

---

From: Barry Leiba <[email-masked]>
Date: Mon, 8 Nov 2021 22:55:10 -0500

> to click the option on his WG mailing list this year....

And the way this is done is to go into the Mailman Admin interface for
the list, go to "Privacy options", then go to "Sender filters".  Make
sure that "@global-whitelist" is listed in the
"accept_these_nonmembers" field.

Barry

---

From: Lars Eggert <[email-masked]>
Date: Tue, 9 Nov 2021 09:05:01 +0200

Hi,

> I know each list / WG can configure whether to accept email from IETF participants subscribed to other ietf list without being held for moderation. In my own transitioning of email address I am fin…

this is not an answer for the question you asked, but you can change your email address globally, i.e., for all mailman lists at ietf.org. Would that address your issue?

Thanks,
Lars

---

From: Paul Wouters <[email-masked]>
Date: Tue, 9 Nov 2021 08:46:30 -0500 (EST)

> this is not an answer for the question you asked, but you can change your email address globally, i.e., for all mailman lists at ietf.org. Would that address your issue?

In my personal case, no. My receiving path and sending path are different.

But I didn't want to make this just about my use case / situation here.
In general, we will see people who can't send email to a list even if
they read the lists using our IMAP servers, eg they are not subscribed.

I feel the idea of subscribing to one allows you to mail to all of them
is an important feature. We kind of made it but then we seem to have
crippled it by making it a WG opt-in.

Paul

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 14:52:42 +0100

Cc'ing tools-discuss at the marginal hope, that the work to upgrade
our mailman solution might get us to a point where one could actually
validate not only email addresses to which messages should be sent to,
but also send-only addresses, from which the list should accept
emails.

Aka: i have run very often into this same sender != receiver mailbox
problem. For example on this very mailbox of mine there are still weird
historic artefacts that makes email get originated from other aliases.

Don't even know right now the right place to submit an RFE for something like this.
Implementation wise it might be as simple as subscribing with an address
and a new delivery option: "NO delivery" (subscriber web interface).

Cheers
   Toerless

---

From: Jay Daley <[email-masked]>
Date: Wed, 10 Nov 2021 03:01:22 +1300

> On 10/11/2021, at 2:52 AM, Toerless Eckert <[email-masked]> wrote:
> 

Take a look at 

	https://www.ietf.org/media/documents/Mail_Subscription_Mockup_2021-10-12.pdf

as explained in 

	https://mailarchive.ietf.org/arch/msg/tools-discuss/tczQzcpBhe6ppdu8VDN4OzWbPtA/

to see if that addresses your requirements.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Paul Wouters <[email-masked]>
Date: Tue, 9 Nov 2021 09:11:05 -0500 (EST)

> "accept_these_nonmembers" field.

If all new lists have been created with this for a while now, clearly
this option is safe and could be retro-actively enabled on all existing
lists ?

Because it of course is more prevalent on lists people have been on
longer than their dayjob/vanity domain :)

Paul

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 15:33:43 +0100

Great. Yes. Seems to also support the kitchen-sink feature.

Any timeline for when this may go into trial phase ?

Cheers
   Toerless

-- 
---
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Wed, 10 Nov 2021 03:51:37 +1300

> On 10/11/2021, at 3:33 AM, Toerless Eckert <[email-masked]> wrote:
> 

Not yet.  Robert is organising some community workshops to discuss mail features and after that we have some dependencies (mailman upgrade) and planning to complete first.

Jay

> [email-masked] <mailto:[email-masked]>
-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jared Mauch <[email-masked]>
Date: Tue, 9 Nov 2021 10:56:56 -0500

> On Nov 9, 2021, at 8:52 AM, Toerless Eckert <[email-masked]> wrote:
> 

I think the issue is that the people who do these interesting things are a subset of the users.  The rest of us know that we must send from the same address we are subscribed from, or at least have the mailers configured (eg: mutt send-hooks) to match this.

- Jared

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 17:22:12 +0100

> I think the issue is that the people who do these interesting things are a subset of the users.  The rest of us know that we must send from the same address we are subscribed from, or at least have…

Given how this was already on the work plan from RjS, it
seems we have a sufficiently large subset. Or maybe just one
important enough user (usually wih a similar name than the developer ? ;-))

Cheers
    toerless

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 9 Nov 2021 17:30:12 +0100

Quite some people use the IMAP server to read lists and are not subscribed anymore.

> On 9. Nov 2021, at 17:22, Toerless Eckert <[email-masked]> wrote:
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 17:33:36 +0100

> Quite some people use the IMAP server to read lists and are not subscribed anymore.

If i could just figure out how to make mutt start up, and not load messages older
than e.g.: 5 months, i would go that way too. Right now it can be painfully slow for
many of the lists i read.