Subject: Github services update

From: Mark Nottingham <[email-masked]>
Date: Thu, 2 Dec 2021 10:33:35 +1100

Hi Chairs,

I think most folks are aware of the GitHub activity summaries tool, now used by about 20 groups:
  https://github.com/ietf-github-services/activity-summary

For example:
  https://mailarchive.ietf.org/arch/msg/tls/xkvkBuFTQ6hUf5x-hNNtsNNJB0c/

We also now have a tool that tweets activity from the datatracker:
  https://github.com/ietf-github-services/datatracker-tweet

The HTTP WG has been using this for a little while:
  https://twitter.com/http_wg

Unlike the activity summary, you don't submit a PR to add your group; you need to fork the repo (or use it as a template). However, just like the activity summary, it operates only on GitHub actions, so you don't need any local infrastructure.

Happy to answer any questions, etc.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Tim Wicinski <[email-masked]>
Date: Sat, 4 Dec 2021 15:18:32 -0500

Thanks Mark for putting this together (though DNSOP chairs are still
expecting our pony okthx).

Benno and I have started looking into the datatracker/twitter integration.
My thought after setting
an account up is using the name 'ietf-wg-dnsop' to be more consistent with
the consensus suggestions
in using github services.  However twitter only allows the '_' and not the
'-'.

tim

On Wed, Dec 1, 2021 at 6:33 PM Mark Nottingham <[email-masked]> wrote:

> Unlike the activity summary, you don't submit a PR to add your group; you
> need to fork the repo (or use it as a template). However, just like the
> activity summary, it operates only on GitHub actions, so you don't need any
> local infrastructure.
>

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 5 Dec 2021 17:53:52 +0000

So yeah, ietf_wg_dnsop seems the obvious choice.

Happy holidays.

From: Tim Wicinski <[email-masked]>
Date: Saturday, December 4, 2021 at 3:19 PM
To: Mark Nottingham <[email-masked]>
Cc: 'WG Chairs' <[email-masked]>
Subject: Re: Github services update

Thanks Mark for putting this together (though DNSOP chairs are still expecting our pony okthx).

Benno and I have started looking into the datatracker/twitter integration.  My thought after setting
an account up is using the name 'ietf-wg-dnsop' to be more consistent with the consensus suggestions
in using github services.  However twitter only allows the '_' and not the '-'.

tim

On Wed, Dec 1, 2021 at 6:33 PM Mark Nottingham <[email-masked]<mailto:[email-masked]>> wrote:
Hi Chairs,

I think most folks are aware of the GitHub activity summaries tool, now used by about 20 groups:
  https://github.com/ietf-github-services/activity-summary<https://urldefense.com/v3/__https:/github.com/ietf-github-services/activity-summary__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mBFU6TLk$>

For example:
  https://mailarchive.ietf.org/arch/msg/tls/xkvkBuFTQ6hUf5x-hNNtsNNJB0c/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/tls/xkvkBuFTQ6hUf5x-hNNtsNNJB0c/__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mBw-V-ZY$>

We also now have a tool that tweets activity from the datatracker:
  https://github.com/ietf-github-services/datatracker-tweet<https://urldefense.com/v3/__https:/github.com/ietf-github-services/datatracker-tweet__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mBDa2_xe$>

The HTTP WG has been using this for a little while:
  https://twitter.com/http_wg<https://urldefense.com/v3/__https:/twitter.com/http_wg__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mItF8zrk$>

Cheers,

--
Mark Nottingham   https://www.mnot.net/<https://urldefense.com/v3/__https:/www.mnot.net/__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mAbP7yxm$>

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 9 Dec 2021 00:54:32 +0000

Thanks for putting the service together Mark.

Following the instructions I set this up for https://twitter.com/quicwg and
its working for us now. Mark and I debugged some teething issues offline
but those should all be fixed in the base repo and things should be smooth
sailing for others.

Cheers
Lucas

On Sun, Dec 5, 2021 at 5:54 PM Salz, Rich <rsalz=[email-masked]>
wrote:

> *From: *Tim Wicinski <[email-masked]>
> *Date: *Saturday, December 4, 2021 at 3:19 PM
> *To: *Mark Nottingham <[email-masked]>
> *Cc: *'WG Chairs' <[email-masked]>
> *Subject: *Re: Github services update
>
>
>
> <https://urldefense.com/v3/__https:/github.com/ietf-github-services/activity-summary__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mBFU6TLk$>
>
> For example:
> <https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/tls/xkvkBuFTQ6hUf5x-hNNtsNNJB0c/__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mBw-V-ZY$>
>
> <https://urldefense.com/v3/__https:/github.com/ietf-github-services/datatracker-tweet__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mBDa2_xe$>
>
> <https://urldefense.com/v3/__https:/twitter.com/http_wg__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mItF8zrk$>
>
> <https://urldefense.com/v3/__https:/www.mnot.net/__;!!GjvTz_vk!G0dLweb_IJXQIX_Rv3kEB0lq4S1KWvawAX8JqQvz8GmPKsJK4gq1mAbP7yxm$>
>
>

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 9 Dec 2021 11:56:34 +1100

For the other folks who have set up -- please pull from upstream (see `Install.md`).

Cheers,

> On 9 Dec 2021, at 11:54 am, Lucas Pardue <[email-masked]> wrote:
> 
> Following the instructions I set this up for https://twitter.com/quicwg and its working for us now. Mark and I debugged some teething issues offline but those should all be fixed in the base repo and things should be smooth sailing for others.
> 
> Cheers
> Lucas
> 
> On Sun, Dec 5, 2021 at 5:54 PM Salz, Rich <rsalz=[email-masked]> wrote: