Subject: REMINDER - IETF 113 - Working Group/BOF/IRTF Scheduling

From: IETF Agenda <[email-masked]>
Date: Fri, 14 Jan 2022 10:56:28 -0800

-----------------------------------------------------------------
IETF 113 – Vienna, Austria
Meeting Dates: March 19-25, 2022
-----------------------------------------------------------------

We are accepting scheduling requests for all Working Groups and Research Groups until Friday, February 4, 2022 and BOF requests until Friday, January 21, 2022.

Note: There is a bug in the session request confirmation emails which lists the length of your session as "unspecified" in the email. A fix for this is in progress; in the meantime, you can check the length of the session you requested by visiting https://datatracker.ietf.org/meeting/requests.

===========================================================
What’s New for IETF 113

IETF 113 will be our first meeting with an in-person component since 2019 [1]. In order to accommodate the number of people who are expected to participate online, the IESG will aim to maintain a schedule that is similar to past fully-online meetings, i.e., with approximately six hours of session time on most days. Exact details of the daily schedule and the scheduling of other meeting related activities are still under development and will be announced as they are confirmed. 

The session request form will ask you to estimate the number of people attending. Please make your best guess, based on your last several online sessions, as to the total number of participants. When we assign conference rooms at the meeting, we will make room size estimates based on the proportion of in-person registrations.

Requests for more than two hours of total meeting time are unlikely to succeed. In special cases, you may request more than two hours of meeting time, but the IESG will likely request a rationale, and scheduling pressure may still make it impossible to grant any additional meeting slots. Please see this email from the IESG [2] for more detailed guidance on how to structure your session requests. 

As of IETF 112, BOFs are now requested via the Datatracker instead of the wiki. Please see the BoF section of this email below for more details. 

[1] https://mailarchive.ietf.org/arch/msg/ietf-announce/eEgVx3PsP4u6JVoM21by9aj4b3M/
[2] https://mailarchive.ietf.org/arch/msg/wgchairs/_x2nc9Xqa5i1U4SuEFs3eggTCyk/

===========================================================
How to Request a WG or RG Session

Requests to schedule Working Group or Research Group sessions should be submitted using the "IETF Meeting Session Request Tool." The URL for the tool is:

https://datatracker.ietf.org/secr/sreq/

If you require an account on this tool, or assistance in using it, then please send a message to [email-masked].  If you are unable to use the tool, then you may send your request via email to [email-masked], with a copy to the appropriate Area Director(s).

As a reminder, the conflict list options are:

- Chair Conflict: to indicate other WGs the Chairs also lead, or will be active participants in the upcoming meeting

- Technology Overlap: to indicate WGs with a related technology or a closely related charter

- Key Participant Conflict (e.g., presenter, Secretary, etc.): to indicate WGs with which key participation may overlap in the upcoming meeting

The Special Request field will continue to be available for more specific needs, and Responsible AD conflicts are already taken into consideration. Please make sure you take a few minutes to check your conflict lists carefully!

===========================================================
How to Request a BOF

The BOF deadline is a little earlier than normal, on January 21. The intent of this earlier deadline is to allow BOF proponents time to work more closely with the IESG and IAB to develop their proposal before final approval determinations. If your initial proposal needs further work you may submit revised BoF proposals until February 4. 

BOFs will NOT be scheduled unless the Area Director approves the BOF. The proponents behind a BOF need to contact a relevant Area Director, preferably well in advance of the BOF approval deadline date. The AD needs to have the full name of the BOF, its acronym, suggested names of chairs, an agenda, full description of the BOF and the information below. Please refer to https://datatracker.ietf.org/doc/bof-requests/new/ for more information about planning a BOF. You will need a Datatracker account to submit a BOF request.

You MUST provide the following information before a BOF session will be scheduled:

a. BOF full name with acronym in brackets 
b. AREA under which the BOF appears
c. CONFLICTS you wish to avoid, please be as specific as possible
d. Special requests
e. Number of sessions
f. Length of session: 60 minutes or 120 minutes

===========================================================
Deadlines
Cut-off dates are subject to change.

• 2021-12-22 (Wednesday): Working Group and BOF scheduling begins.
• 2022-01-21 (Friday): Cut-off date for BOF proposal requests.
• 2022-02-04 (Friday): Cut-off date for revised BOF proposal requests to Area Directors at UTC 23:59.
• 2022-02-04 (Friday): Cut-off date for requests to schedule Working Group meetings at UTC 23:59. 
• 2022-02-11 (Friday): Cut-off date for Area Directors to approve BOFs at UTC 23:59.
• 2022-02-18 (Friday): Preliminary agenda published for comment.
• 2022-02-23 (Wednesday): Cut-off date for requests to reschedule Working Group and BOF meetings UTC 23:59.
• 2022-02-25 (Friday): Final agenda to be published.
• 2022-03-09 (Wednesday): Draft Working Group agendas due by UTC 23:59.
• 2022-03-14  (Monday): Revised Working Group agendas due by UTC 23:59.

===========================================================

Submitting Session Agendas

Please submit the agendas for your sessions as early as possible using the "IETF Meeting Materials Management Tool," a Web-based tool for making your meeting agenda, minutes, and presentation slides available to the community before, during, and after an IETF meeting.  If you are a BOF chair, then you may use the tool to submit a revised agenda as well as other materials for your BOF once the BOF has been approved.

The URL for the tool is:

https://datatracker.ietf.org/secr/proceedings/

Agendas submitted via the tool will be available to the public on the "IETF Meeting Materials" webpage as soon as they are submitted.

The URL for the "IETF 113 Meeting Materials" Web page is:

https://datatracker.ietf.org/meeting/113/materials.html

If you are a Working Group chair, then you already have accounts on the "IETF Meeting Session Request Tool" and the "IETF Meeting Materials Management Tool."  The same User ID and password will work for both tools.  If you are a BOF chair who is not also a Working Group chair, then you will be given an account on the "IETF Meeting Materials Management Tool" when your BOF has been approved.  If you require assistance in using either tool, or wish to report a bug, then please send a message to [email-masked].

===============================================================
Area Director Contact Information

IETF Chair
Lars Eggert <[email-masked]>

Applications and Real-Time Area (art)
Murray Kucherawy <[email-masked]>
Francesca Palombini <[email-masked]>

Internet Area (int)
Erik Kline <[email-masked]>
Éric Vyncke <[email-masked]>

Operations & Management Area (ops)
Warren Kumari <[email-masked]>
Robert Wilton <[email-masked]>

Routing Area (rtg)
John Scudder <[email-masked]>
Alvaro Retana <[email-masked]>
Martin Vigoureux <[email-masked]>

Security Area (sec) 
Roman Danyliw <[email-masked]>
Benjamin Kaduk <[email-masked]>

Transport Area (tsv)
Martin Duke <[email-masked]>
Zaheduzzaman Sarker <[email-masked]>

---

From: Michael Richardson <[email-masked]>
Date: Sat, 15 Jan 2022 18:05:51 -0500

IETF Agenda <[email-masked]> wrote:
    > Requests for more than two hours of total meeting time are unlikely to
    > succeed. In special cases, you may request more than two hours of
    > meeting time, but the IESG will likely request a rationale, and
    > scheduling pressure may still make it impossible to grant any
    > additional meeting slots. Please see this email from the IESG [2] for
    > more detailed guidance on how to structure your session requests.

I want to start by thanking the IESG for being more rigorous here.

I would like the IESG to encourage any WG asking for 2hr (or more) present a clear
agenda for the time usage, and that no more than 50% that time be for
presentations and/or status updates.
The bulk of the time should be for discussion, ideally relating to identified
issues.  I don't think that this is a new request, I just think it's worth repeating.

I'd like to suggest that we have no 2hr slots (like we did on Thursday at
IETF112), and that all requests for 2hrs be turned into two requests for 1hr.

Even if I don't get to travel in the end, I'm excited for 113.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Gorry (erg)" <[email-masked]>
Date: Sun, 16 Jan 2022 09:40:50 +0000

I am pleased the IESG are looking and thinking about this…

> On 15 Jan 2022, at 23:06, Michael Richardson <[email-masked]> wrote:
> 
> 
My 2c:
I have chaired many sessions over the years and I have observed the variety of ways working groups can use sessions depending on the needs of the group. Suggesting ways that might work  is definitely good - I would really be against mandating a specific standard format - and urge ADs to talk to each group to see what they may best do.

Gorry

---

From: Fred Baker <[email-masked]>
Date: Sun, 16 Jan 2022 20:43:07 -0800

> IETF112), and that all requests for 2hrs be turned into two requests for 1hr.

That makes it difficult for some of us. At this instant, V6Ops might fit in a one hour slot. But we get most of our drafts just under the wire, and have had more than one meeting in which the expectation of a short session meant that we had a stampeded session.

If I were to have this imposed on me, I would have to give my working group a much earlier submission deadline than the IETF imposes.

I appreciate what you’re trying to accomplish, but I don’t think this approach will work.

---

From: Leonard Giuliano <[email-masked]>
Date: Tue, 18 Jan 2022 15:05:06 -0800

I'd prefer to see a few more options, as we used to when we had in person 
mtgs.  EG, in MBONED we have consistently found 1hr is not long enough, 
but 2 hrs is overkill.  90 mins would be perfect, but we are stuck taking 
a 2hr slot.

How did we arrive at this two-size fits all mode, and can we consider more 
options for next time?

-Lenny 

On Sun, 16 Jan 2022, Fred Baker wrote:

| 
| 
| On Jan 15, 2022, at 3:06 PM, Michael Richardson <[email-masked]> wrote:
| >
| > I'd like to suggest that we have no 2hr slots (like we did on Thursday at
| > IETF112), and that all requests for 2hrs be turned into two requests for 1hr.
| 
| That makes it difficult for some of us. At this instant, V6Ops might fit in a one hour slot. But we get most of our drafts just under the wire, and have had more than one meeting in which the expectation of a short session meant that we had a stampeded session.
| 
| If I were to have this imposed on me, I would have to give my working group a much earlier submission deadline than the IETF imposes.
| 
| I appreciate what you?re trying to accomplish, but I don?t think this approach will work.
|

---

From: James <[email-masked]>
Date: Wed, 19 Jan 2022 00:25:45 +0100

It's not really "two sizes fits all", and we're not obligated to follow Parkinson's law - we can always end meetings early if we're done. It's not a waste if a session booked for two hours doesn't use the last 30 minutes. Adding more variation in time slots just makes things way more difficult for organisers - Tetris is an easier game to play if there's only two types of bricks.

- J

> On 19 Jan 2022, at 00:05, Leonard Giuliano <lenny=[email-masked]> wrote:
> 
>

---

From: Leonard Giuliano <[email-masked]>
Date: Wed, 19 Jan 2022 04:56:56 -0800

James- this is a helpful point and I won't feel as bad now requesting a 
slot that we won't fill completely.

Thaks,
Lenny

On Wed, 19 Jan 2022, James wrote:

| 
| 
| It's not really "two sizes fits all", and we're not obligated to follow 
| Parkinson's law - we can always end meetings early if we're done. It's 
| not a waste if a session booked for two hours doesn't use the last 30 
| minutes. Adding more variation in time slots just makes things way more 
| difficult for organisers - Tetris is an easier game to play if there's 
| only two types of bricks.
| 
| - J
| 
| > On 19 Jan 2022, at 00:05, Leonard Giuliano <lenny=[email-masked]> wrote:
| >
| >
| > I'd prefer to see a few more options, as we used to when we had in person
| > mtgs.  EG, in MBONED we have consistently found 1hr is not long enough,
| > but 2 hrs is overkill.  90 mins would be perfect, but we are stuck taking
| > a 2hr slot.
| >
| > How did we arrive at this two-size fits all mode, and can we consider more
| > options for next time?
| >
| > -Lenny
| >
| > On Sun, 16 Jan 2022, Fred Baker wrote:
| >
| > |
| > |
| > | On Jan 15, 2022, at 3:06 PM, Michael Richardson <[email-masked]> wrote:
| > | >
| > | > I'd like to suggest that we have no 2hr slots (like we did on Thursday at
| > | > IETF112), and that all requests for 2hrs be turned into two requests for 1hr.
| > |
| > | That makes it difficult for some of us. At this instant, V6Ops might fit in a one hour slot. But we get most of our drafts just under the wire, and have had more than one meeting in which the expectation of a short session meant that we had a stampeded session.
| > |
| > | If I were to have this imposed on me, I would have to give my working group a much earlier submission deadline than the IETF imposes.
| > |
| > | I appreciate what you?re trying to accomplish, but I don?t think this approach will work.
| > |
| >
| 
|

---

From: Michael Richardson <[email-masked]>
Date: Wed, 19 Jan 2022 12:15:02 -0500

> slot that we won't fill completely.

But, still, consider requesting two 1hr slots, and ending both at the :45
minute point.  Establishing your agenda early means that people who have
conflicts will now be better able to judge which of your two slots they will
prioritize.

Tetris is even easier if there is only one size of block.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 19 Jan 2022 18:49:19 +0100

In CoRE, we always found it easier to have two meetings with ample time between them, so we could solve difficult problems between the slots (of course, this works only for the ones that are on the first slot’s agenda).

The disadvantage for “all the world is 1 hour slots” is, of course, the larger loss in setup time.  The Tetris analogy doesn’t quite work here, because our real Tetris is juggling agenda items in the slots.

(Another advantage is having more break time; this is really needed to get those hallway discussions completed.)

Finally, all WGs are different, so there may be some that actually work better in 2-hour slots (say, dispatch?  SAAG?  RG meetings?)

Grüße, Carsten

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 24 Jan 2022 19:04:50 -0500

Michael: 

IDR is one of the WG that requests 2 meetings (normally 1 meeting with 2
hours and 1 meeting with 1 hour).    

In the past with in person meetings, we ran discussions during the IDR
meetings in the IETF.  Also, we ran small group discussions within the week.
We also ran interims if they were needed. 

During the periods of online IETF meetings,  we try to updates on draft and
new work into the 2 meetings.  Often times status reports come from the
wiki.  
During the period of online IETF meetings,  have run 2-3 interims between
the meetings with lengthy discussions (time period 2-2.5 hours).    Our work
is schedule against large items (BGP-LS, SR-Routing, Flow Specification v2,
CAR/DT, Auto-configuration) with the ability to fit emerging work needed for
BGP. 

We are continual communication with our AD about how to best use our time. 

May I suggest that we are adhering to the spirit of your idea, but the form.
One of the best things IETF is that different areas and different ADs is
that we can take the spirit of the idea, and not get tied down to specific
forms. 

Sue 

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Michael
Richardson
Sent: Saturday, January 15, 2022 6:06 PM
To: Working Group Chairs; [email-masked]
Subject: 2hr sessions and agendas

I would like the IESG to encourage any WG asking for 2hr (or more) present a
clear agenda for the time usage, and that no more than 50% that time be for
presentations and/or status updates.
The bulk of the time should be for discussion, ideally relating to
identified issues.  I don't think that this is a new request, I just think
it's worth repeating.

I'd like to suggest that we have no 2hr slots (like we did on Thursday at
IETF112), and that all requests for 2hrs be turned into two requests for
1hr.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 25 Jan 2022 09:38:48 -0600

Michael,

I'm backing up to your original suggestion.

On Sat, Jan 15, 2022 at 5:06 PM Michael Richardson <[email-masked]>
wrote:

> * I would like the IESG to encourage any WG asking for 2hr (or more)
> present a clear agenda for the time usage*, and that no more than 50%
> that time be for

At a minimum, I'd suggest that the IESG (and, of course, Colin for the IRTF
- research groups also ask for slots out of the same pool of slots) ask for
a fairly firm agenda for at least one hour of a two-hour request.

Susan described her working group as using just about every tool a working
group has to move work items forward (discussion slots, side meetings, and
interim meetings) if virtually face to face discussion time is required for
that work item. I'd encourage chairs to consider interims if they need two
or more hours and aren't holding interims now.

*I note that Michael's suggestion was " encourage", not "require". *If your
group falls into this category, your AD/Colin  likely knows that, and it's
unlikely that an AD/Colin would tie a group down in a procrustean bed(*)
because of a rule that only applies 80 percent of the time.

(*) https://en.wikipedia.org/wiki/Procrustes

> identified

It's worth noting that all chairs can do this now, with no IESG/secretariat
action required, if that's the right thing to do for your working
group/research group. If it's not the right thing to do, you probably know
that, and your AD (or Colin) probably knows that as well as you do.

My experience (and Gorry has already chimed in on this thread) is that the
secretariat will work diligently to satisfy "special requests" - TSVWG has
been requesting two slots, with at least one day in between, for years - so
I'd expect that if requesting two one-hour slots back to back for your
group is the right thing to do, that will happen if it's at all possible.

So I would encourage all chairs to Do The Right Thing for their groups,
with maybe a little more awareness of the impact of our decisions on other
groups that also need slots taken from a single and limited pool.

Make good choices, of course.

Best,

Spencer

---

From: Michael Richardson <[email-masked]>
Date: Tue, 25 Jan 2022 11:06:20 -0500

Susan Hares <[email-masked]> wrote:
    > During the periods of online IETF meetings, we try to updates on draft
    > and new work into the 2 meetings.  Often times status reports come from
    > the wiki.  During the period of online IETF meetings, have run 2-3

This is really awesome.

    > May I suggest that we are adhering to the spirit of your idea, but the

I didn't tell you how to run your meeting :-)
I asked the IESG to vet the requests for more time against actual agenda
requirements.
I'm asking the IESG to be a bit more rigorous in observing the spirit.

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 25 Jan 2022 13:41:15 -0500

Michael: 

I realized that you were not telling me how to run IDR meetings.   My example was to show you that the IDR AD (Alvaro Retana) has been pro-actively working with us to vet the agenda ahead of time.    Alvaro also encourages the IDR chairs to make active use of IDR wiki and Cross-WG chair meetings. 

I responded to your first message to show how much Alvaro as the IDR AD has been proactively working.  Like you, I hope other ADs on the IESG will be as vigorous in observing spirit of the process.

I'm pleased you are asking these questions of the IESG. 

Sue 

-----Original Message-----
From: WGChairs [mailto:[email-masked]] On Behalf Of Michael Richardson
Sent: Tuesday, January 25, 2022 11:06 AM
To: Susan Hares
Cc: 'Working Group Chairs'
Subject: Re: 2hr sessions and agendas

This is really awesome.

    > May I suggest that we are adhering to the spirit of your idea, but the

I didn't tell you how to run your meeting :-) I asked the IESG to vet the requests for more time against actual agenda requirements.
I'm asking the IESG to be a bit more rigorous in observing the spirit.