Subject: Re: Survey on implementation status tracking

From: Tommy Pauly <[email-masked]>
Date: Wed, 12 Jan 2022 07:39:07 -0800

Hello Chairs,

If you’re interested in joining the discussion in the EDM program about the results of this survey, please fill out the Doodle poll referenced below!

Best,
Tommy

> Begin forwarded message:
> 
> From: Tommy Pauly <tpauly=[email-masked]>
> Subject: [Edm] Scheduling the next EDM program meeting
> Date: January 12, 2022 at 7:35:00 AM PST
> To: [email-masked]
> 
> Hello EDM,
> 
> We’d like to schedule a virtual meeting for the EDM program (between the week of January 24 and the week of February 7).
> 
> Please fill out the following Doodle with your availability. (I’ve provided more time options than previous meetings.)
> 
> https://doodle.com/poll/msn8bnms5g7nxxrg?utm_source=poll&utm_medium=link <https://doodle.com/poll/msn8bnms5g7nxxrg?utm_source=poll&utm_medium=link>
> 
> We’ll be covering the following topics:
> 
> - Results of the survey sent out to WG chairs about tools to track interoperability and implementations
> 	- Follow-up discussion for experiments to do with tooling / GitHub / Datatracker / hackathon
> - Plan for progressing draft-iab-protocol-maintenance (https://datatracker.ietf.org/doc/draft-iab-protocol-maintenance/ <https://datatracker.ietf.org/doc/draft-iab-protocol-maintenance/>)
> 
> Best,
> Tommy & David

> On Nov 11, 2021, at 7:13 AM, Tommy Pauly <tpauly=[email-masked]> wrote:
> 
> Hello Chairs!
> 
> Just a quick reminder—if you haven’t filled out this survey, we’d still love to hear from you. If you can fill this out by the end of next week, we’ll be able to use it in our IAB program discussions.
> 
> Best,
> Tommy
> 
>> On Oct 29, 2021, at 9:10 AM, Tommy Pauly <tpauly=[email-masked] <mailto:tpauly=[email-masked]>> wrote:
>> 
>> Hi Working Group Chairs,
>> 
>> I’m sharing a quick survey that I’d love to get input from all working groups on. Please take a moment prior to IETF 112, if possible, to share your thoughts!
>> 
>> The EDM IAB program is discussing ways to help make implementation status and running code more discoverable and accessible, for use by the working group during protocol development and by implementors as they work on interoperability and deployment. We’d like your help to understand how your working group views implementation status.
>> 
>> https://ietf.iad1.qualtrics.com/jfe/form/SV_agA3BiEJ96Jdzlc <https://ietf.iad1.qualtrics.com/jfe/form/SV_agA3BiEJ96Jdzlc>
>> 
>> Best,
>> Tommy & David
>

---

From: Daniel Migault <[email-masked]>
Date: Thu, 13 Jan 2022 09:40:55 -0500

Hi,

I also believe that having a look at this effort (Code Match [1]) is a good
start - we may not need much more. From what I can recall, the concept was
good, and draft authors made the effort to register their code, but the
tooling was very unstable, so people stopped doing it.

Yours,
Daniel

[1]
https://www.ietf.org/proceedings/92/slides/slides-92-iesg-opsplenary-2.pdf

On Thu, Nov 11, 2021 at 11:13 AM Kathleen Moriarty <
[email-masked]> wrote:

> Hi Tommy!
>
> There is code from the prior effort to do this as well as design
> requirements.  It was intended to be tied to drafts or RFCs.  Copying
> Christian as he may know where that code is now.
>
> Best regards,
> Kathleen
>
> Sent from my mobile device
>
> On Nov 11, 2021, at 10:13 AM, Tommy Pauly <tpauly=
> [email-masked]> wrote:
>
> Hello Chairs!
>
> Just a quick reminder—if you haven’t filled out this survey, we’d still
> love to hear from you. If you can fill this out by the end of next week,
> we’ll be able to use it in our IAB program discussions.
>
> Best,
> Tommy
>
> On Oct 29, 2021, at 9:10 AM, Tommy Pauly <
> tpauly=[email-masked]> wrote:
>
> Hi Working Group Chairs,
>
> I’m sharing a quick survey that I’d love to get input from all working
> groups on. Please take a moment prior to IETF 112, if possible, to share
> your thoughts!
>
> The EDM IAB program is discussing ways to help make implementation status
> and running code more discoverable and accessible, for use by the working
> group during protocol development and by implementors as they work on
> interoperability and deployment. We’d like your help to understand how your
> working group views implementation status.
>
> https://ietf.iad1.qualtrics.com/jfe/form/SV_agA3BiEJ96Jdzlc
>
> Best,
> Tommy & David
>
>
>

-- 
Daniel Migault
Ericsson

---

From: Christian O'Flaherty <[email-masked]>
Date: Mon, 17 Jan 2022 18:57:56 +0000

Hi Daniel,

I also believe that having a look at this effort (Code Match [1]) is a good start - we may not need much more. From what I can recall, the concept was good, and draft authors made the effort to register their code, but the tooling was very unstable, so people stopped doing it.

That's correct. The tool was unstable at the beginning because it was being developed. Then, when the code was "stable", the tool kept having issues because it wasn't part of the "main" datatracker. Instead, it had its own instance of datatracker using the Database in readonly mode. The problem was that changes in Datatracker sometimes affected the tool until we did the update to the "local" Datatracker.

I tried to bring it online some weeks ago, but I couldn't. If this is something worth the effort I can further investigate or ask for help.

Christian

On Thu, Nov 11, 2021 at 11:13 AM Kathleen Moriarty <[email-masked]<mailto:[email-masked]>> wrote:
Hi Tommy!

There is code from the prior effort to do this as well as design requirements.  It was intended to be tied to drafts or RFCs.  Copying Christian as he may know where that code is now.

Best regards,
Kathleen

On Nov 11, 2021, at 10:13 AM, Tommy Pauly <tpauly=[email-masked]<mailto:[email-masked]>> wrote:
Hello Chairs!

Best,
Tommy

On Oct 29, 2021, at 9:10 AM, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>> wrote:

Hi Working Group Chairs,

Best,
Tommy & David

--
Daniel Migault
Ericsson

---

From: Daniel Migault <[email-masked]>
Date: Mon, 17 Jan 2022 22:07:53 -0500

Hi,

Thanks for the response. Currently, from my perspective, and assuming I
would be the only potential user, I do not think that is worth the effort.
My point was rather for David and Tommy to mention potential analyses what
can be learnt from this experience, and as a user, I would put some
emphasis on simplicity and stability.

Yours,
Daniel

On Mon, Jan 17, 2022 at 1:57 PM Christian O'Flaherty <[email-masked]>
wrote:

> Hi Daniel,
>
>
>
> I also believe that having a look at this effort (Code Match [1]) is a
> good start - we may not need much more. From what I can recall, the concept
> was good, and draft authors made the effort to register their code, but the
> That's correct. The tool was unstable at the beginning because it was
> being developed. Then, when the code was "stable", the tool kept having
> issues because it wasn't part of the "main" datatracker. Instead, it had
> its own instance of datatracker using the Database in readonly mode. The
> problem was that changes in Datatracker sometimes affected the tool until
> we did the update to the "local" Datatracker.
>
>
>
> I tried to bring it online some weeks ago, but I couldn't. If this is
> something worth the effort I can further investigate or ask for help.
>
>
>
> Christian
>
>
>

-- 
Daniel Migault
Ericsson

---

From: Christian O'Flaherty <[email-masked]>
Date: Tue, 18 Jan 2022 13:59:10 +0000

Thanks for the response. Currently, from my perspective, and assuming I would be the only potential user, I do not think that is worth the effort.  My point was rather for David and Tommy to mention potential analyses what can be learnt from this experience, and as a user, I would put some emphasis on simplicity and stability.

I fully agree with you...
What I learnt is that it's easier and more effective to add several minor features to Datatracker than creating a new app to "merge it" later on.

The decision made sense when we started the project because we also wanted to change the look & feel (we assumed it was required to engage students).

I'll let you know if I can put it back online.

Christian

On Mon, Jan 17, 2022 at 1:57 PM Christian O'Flaherty <[email-masked]<mailto:[email-masked]>> wrote:
Hi Daniel,

Christian

Best regards,
Kathleen

Best,
Tommy

Hi Working Group Chairs,

Best,
Tommy & David

--
Daniel Migault
Ericsson

--
Daniel Migault
Ericsson

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 18 Jan 2022 08:39:27 -0800

If you’re interested in joining, this meeting has now been scheduled.

Best,
Tommy

EDM Program Meeting
Hosted by EDM Program

https://ietf.webex.com/ietf/j.php?MTID=m2820a67dad8a399620a8aab3af9f52de
Tuesday, Feb 1, 2022 12:00 pm | 1 hour | (UTC-08:00) Pacific Time (US & Canada)
Meeting number: 2424 673 7084
Password: CSq9Pu6UHV5

Join by video system
Dial [email-masked]
You can also dial 173.243.2.68 and enter your meeting number.

Join by phone
1-650-479-3208 Call-in toll number (US/Canada)

Access code: 242 467 37084

> On Jan 12, 2022, at 7:39 AM, Tommy Pauly <tpauly=[email-masked]> wrote:
> 
> Hello Chairs,
> 
>> From: Tommy Pauly <tpauly=[email-masked] <mailto:tpauly=[email-masked]>>
>> To: [email-masked] <mailto:[email-masked]>
>> 
>> Hello EDM,
>> 
>> On Nov 11, 2021, at 7:13 AM, Tommy Pauly <tpauly=[email-masked] <mailto:tpauly=[email-masked]>> wrote:
>> 
>> Hello Chairs!
>>