Subject: local mute button in meetecho

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Jan 2022 10:11:21 -0500

Hi, many WG chairs are discovering that when using meetecho it is best to
keep the MIC button on for frequent speakers, and then use the local-mute
button in the lower right to do a local mute.   The delay in turning
MIC/audio stream on/off is rather annoying, and often results in short
statements being lost.

I don't think that the local mute status gets transmitted.
I wonder if it would be worth transmitting the local mute status to the
server, and changing the icon slightly when the person has a local mute
enabled.
We get Speaking: ... and the bubble on the persons avatar, but maybe it
should go on the MIC button instead?

I started this email as being to [email-masked], but then decided to send
to wgchairs instead.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 26 Jan 2022 11:02:14 -0500

For sessions I chair, I leave myself as a speaker and then use my mic's hardware mute.

To some extent what we need is acknowledgment that your mic has been patched in and words aren't going to get lost.

-- Jeff

> On Jan 26, 2022, at 10:11 AM, Michael Richardson <[email-masked]> wrote:
> 
>

---

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 27 Jan 2022 08:18:46 +1100

Obviously if you're using a local physical mute button which isn't plumbed through to the browser as "this input it muted" then there's no way for meetecho to know that your words will be lost!  It's sending the data stream that your soundcard is handing it.

But I totally agree that a "local mute" rather than requiring the hardware to be continually re-authorised by the browser is the better approach, maybe even for video feeds but absolutely for sound feeds.  And visible indicators of state are valuable for everybody.

Cheers,

Bron.

On Thu, Jan 27, 2022, at 03:02, Jeffrey Haas wrote:
> > On Jan 26, 2022, at 10:11 AM, Michael Richardson <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > 
> > Michael Richardson <[email-masked] <mailto:[email-masked]>>   . o O ( IPv6 IøT consulting )

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 26 Jan 2022 21:34:05 +0000

I recall from a presentation the MeetEcho team gave about their system that they were doing some clever tiering approach for audio delivery to make it all scale.   When you are in the  "listener" tier focused on delivering audio to you - but not sharing your audio to the group  - it would have to move you to the "sending audio" tier when you wanted to use your mic.   

The practical result was sometimes a slight delay while this switch was made when you go off mute and the audio actually flowing to the session.  It's thus more complex than the local mute status being communicated, it's tied to what audio group you are in:  Group 1 - listeners, Group 2- audio senders

-glenn

On 1/26/22, 8:02 AM, "WGChairs on behalf of Jeffrey Haas" <[email-masked] on behalf of [email-masked]> wrote:

    -- Jeff

---

From: Christian Hopps <[email-masked]>
Date: Wed, 26 Jan 2022 17:06:32 -0500

"Deen, Glenn (NBCUniversal)" <[email-masked]> writes:

> I recall from a presentation the MeetEcho team gave about their system that they
> were doing some clever tiering approach for audio delivery to make it all scale.
> When you are in the "listener" tier focused on delivering audio to you - but not
> sharing your audio to the group - it would have to move you to the "sending
> audio" tier when you wanted to use your mic.

Ah.. so that's why the audio quality totally changes when I cycle between muted and not muted.

> The practical result was sometimes a slight delay while this switch was made
> when you go off mute and the audio actually flowing to the session. It's thus
> more complex than the local mute status being communicated, it's tied to what
> audio group you are in: Group 1 - listeners, Group 2- audio senders

This has actually been a noticeable delay for me, and also a noticeable loss of the audio stream during the switch.. While performing as a WG chair it's not good for me to be missing what the person is saying right as I'm about to reply to that thing they are saying. I wish it didn't happen.

Thanks,
Chris.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 26 Jan 2022 23:27:07 +0100

> For sessions I chair, I leave myself as a speaker and then use my mic's hardware mute.

Hardware mute means that the echo compensation of your OS will detrain.
So you will echo others when you unmute.
(Not a consideration if you are using sound-tight headphones, but some of us do make use of the fact that headphones are not needed for conferencing any more.)

I once had a student whose headset was making a loud pop each time he hardware-unmuted.
Certainly a way to announce that you will be saying something :-)
Make sure your’s doesn’t.

Grüße, Carsten

---

From: Barry Leiba <[email-masked]>
Date: Wed, 26 Jan 2022 18:11:55 -0500

> Obviously if you're using a local physical mute button which isn't plumbed through to the browser as
> "this input it muted" then there's no way for meetecho to know that your words will be lost!  It's sending
> the data stream that your soundcard is handing it.

Actually, meetecho will warn you if you have your meetecho mic on but
meetecho isn't getting audio from you -- which is what will happen in
this case.  You should see a message to the effect of "I don't hear
you."

Barry

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 27 Jan 2022 06:59:18 -0500

> On Jan 26, 2022, at 5:27 PM, Carsten Bormann <[email-masked]> wrote:
> 

It hasn't for the years I've used it.

I generally refer everyone to use a headset.  It provides a significantly better experience for those who have to listen to the speaker.

-- Jeff

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 27 Jan 2022 13:15:38 +0100

> I generally refer everyone to use a headset.  It provides a significantly better experience for those who have to listen to the speaker.

Generally, the condenser microphone on my desk (my wife’s setup uses a boundary microphone, similar observation) sounds a lot better (read: provides more legible and more pleasant sound) than the microphones on the $8 headsets that many people seem to use.  Also, quite a few people breathe and pop into headset microphones, which can be quite distracting.  While there are people with decent headsets that also happen to know how to use them, this is the minority (certainly among the people who still need advice on this issue after two years of home office).
So I can’t agree with this statement on the technical side.

More importantly, your experience will be much better when listening to a speaker that is not terminally annoyed by having to wear a headset over the whole course of a day.  

When we started with mbone in the early 1990s, there was no echo compensation (we were lucky that our SPARCstations were fast enough to do the multiplications for the GSM 13 kbit/s codec).
So we used headsets.
That was almost 30 years ago.
(But, yes, you can still buy laptops and install operating systems that are not much better than that; there your advice does apply.)

Grüße, Carsten

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 27 Jan 2022 07:27:00 -0500

> On Jan 27, 2022, at 7:15 AM, Carsten Bormann <[email-masked]> wrote:
> 

Yes, you can buy terrible headsets.  Or more unfortunately, call the usual dangling mic that come with most mobile handsets a "headset".

Open air mics, even with good suppression technologies, tend to concentrate background echoing effects.  Much of the time, it sounds like listening to someone talking to a microphone set a distance away from them in a subway station.  This form of background echo tends to be problematic with people with certain forms of hearing loss, like myself. I know I certainly am not alone among the chairs for this problem.

I'd personally prefer to deal with training people out of plosives for a mis-aimed boom mic or "Darth Vadering" than strain for hours on a good quality audio than strain to understand people.  We have enough other issues with audio fidelity, quiet speakers, noisy background environments, and unfamiliar accents to work with.

Clearly your criteria may be different.

-- Jeff

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 27 Jan 2022 13:49:40 +0100

> Open air mics, even with good suppression technologies, tend to concentrate background echoing effects.  

Yep.  Mandatory reading:

https://en.wikipedia.org/wiki/Critical_distance

> Much of the time, it sounds like listening to someone talking to a microphone set a distance away from them in a subway station.  This form of background echo tends to be problematic with people with certain forms of hearing loss, like myself. I know I certainly am not alone among the chairs for this problem.

Too much reverberation is also very problematic for listeners that have to process other than their native languages.  (How do I know…)

> I'd personally prefer to deal with training people out of plosives for a mis-aimed boom mic or "Darth Vadering" than strain for hours on a good quality audio than strain to understand people.  

I can’t quite parse that sentence, but the gist for me is that it is not impolite for a chair to point out bad audio *right away*.  Actually, *not* pointing out bad audio is impolite both to everybody else and to the speaker who is the only one who cannot hear themselves and suddenly is exposed to an audience that is annoyed and on the verge of becoming aggressive (or simply tunes out).

> We have enough other issues with audio fidelity, quiet speakers, noisy background environments,

Headsets are definitely better if you need to work from a helicopter.

For a normal desktop in a reasonably quiet home office, get a condenser mike on a boom [1] that is not more than 20-30 cm away from your mouth.  That should do (outside rooms that have the acoustics of toilet booths).  If your desk cannot do that, Lavaliers can also work quite well, but they can have issues with scratching on clothes and you’ll forget to unclip them when standing up (wireless Lavaliers [2] fix the latter problem but need to be charged).

Grüße, Carsten

[1]: https://nerdtechy.com/best-boom-microphone-arm
(But mount it so it is above line of sight to the screen(s).
That also gets rid of any residual popping.)

[2]: https://www.rode.com/microphones/wireless/wirelessgo
Wireless lavs are perfect for in-person attendance in hybrid meetings:
Just clip them to your FFP2 [3].

[3]: https://twitter.com/c4bo/status/1447498455451160580
Well, maybe that works better with a picogear [4].

[4]: https://www.picogear.com

---

From: Michael Richardson <[email-masked]>
Date: Thu, 27 Jan 2022 09:31:28 -0500

My experience is that the people who actually have Mac laptops with good
mics, and who actually know how to use them sound fine, and do not cause echo
into the conference from their offices.

The problem is that, those people, set an example for people who are
clueless, whose laptops or operating systems do not do good echo
cancellation.

Many many many presentations feature the CEO, thinking he knows what he is
doing (due to Dunning-Kruger Effect) is there without a headset, and clueless that
the echo that everyone hears is coming from his end.  Of course, the echo
never occurs when he speaks, just when the technical person in the room
speaks (who is likely wearing a headset), and the CEO, of course, can't even
find his mute button.

So my take is: use a headset, because it sets a good example for the
clueless.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 27 Jan 2022 15:37:41 +0100

Why are you hanging out on so many presentations with CEOs ?