Subject: Are your working groups missing the auto-generated "Weekly github digest" emails in February?

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 14 Feb 2022 10:40:28 -0600

I'm not entirely sure who to report this to, but I thought it would be
helpful if I checked if anyone thought it was still working for their
working group)

I just noticed that my working group, Cellar, hasn't had a "Weekly github
digest" email since January 30, and when I looked across all the email
lists I'm subscribed to, I don't see anything for other working groups that
is dated later than the 30th, either.

Of course, I don't know if other working groups have activity to digest,
but I know Cellar does, in ietf-wg-cellar/flac-specification.

Should I be reporting this? (And, if so, to whom? I cc:ed Mark Nottingham
on this email, but I'm not sure if anyone at the secretariat should be
noticing this)

Best,

Spencer

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 14 Feb 2022 12:00:55 -0600

What is “Weekly GitHub digest” emails? I know our WG has a GitHub account, and some kind-of-active repos in them, but I did not know that there were digest emails sent out regarding them. Or am I misreading the intention of this and the digest emails?

> On Feb 14, 2022, at 10:40 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> I'm not entirely sure who to report this to, but I thought it would be helpful if I checked if anyone thought it was still working for their working group)
> 
> I just noticed that my working group, Cellar, hasn't had a "Weekly github digest" email since January 30, and when I looked across all the email lists I'm subscribed to, I don't see anything for other working groups that is dated later than the 30th, either. 
> 
> Of course, I don't know if other working groups have activity to digest, but I know Cellar does, in ietf-wg-cellar/flac-specification.
> 
> Should I be reporting this? (And, if so, to whom? I cc:ed Mark Nottingham on this email, but I'm not sure if anyone at the secretariat should be noticing this)
> 
> Best,
> 
> Spencer

Mahesh Jethanandani
[email-masked]

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 14 Feb 2022 18:22:44 +0000

Hi Spencer and Mahesh,

With GitHub, people can subscribe to repositories if they like. However,
the IETF operates a service where a Working Group can create a digest of
all relevant Repositories. The source to this service is
https://github.com/ietf-github-services/activity-summary. And having been
the one to "touch it last" via a commit that roughly matches Spencer's
timeline, I'm going to assume I broke it. I don't know what the problem is
but I'll do what I can to fix it.

Cheers,
Lucas

On Mon, Feb 14, 2022 at 6:01 PM Mahesh Jethanandani <[email-masked]>
wrote:

> What is “Weekly GitHub digest” emails? I know our WG has a GitHub account,
> and some kind-of-active repos in them, but I did not know that there were
> digest emails sent out regarding them. Or am I misreading the intention of
> this and the digest emails?
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 14 Feb 2022 12:24:22 -0600

Hi, Mahesh, and anyone else I confused by not providing background
information ...

> this and the digest emails?

Sending digest emails to your mailing list, or otherwise making changes to
working group drafts visible on your mailing list, is Doing The Right
Thing, but it's not automatic.

If you'd like to start this process for your working group, the activity
summary is produced from the mls.json at
https://github.com/ietf-github-services/activity-summary. So you'd add your
working group, mailing list, any repos you'd like summarized, and a few
other things using a PR, that gets merged in pretty quickly (in my
experience). The README.md is pretty helpful.

This was provided by Mark Nottingham (thank you, Mark), and I'm not quite
sure what the status is now - that's why I was checking here.

Best,

Spencer

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 14 Feb 2022 18:25:44 +0000

Looking at the workflow logs, it reported success at the top level but if I
drill down to github-notify-ml task [1]

WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')

So that's a hint at least.

[1] -
https://github.com/ietf-github-services/activity-summary/runs/5082266750?check_suite_focus=true

On Mon, Feb 14, 2022 at 6:22 PM Lucas Pardue <[email-masked]>
wrote:

> On Mon, Feb 14, 2022 at 6:01 PM Mahesh Jethanandani <
> [email-masked]> wrote:
>
>> What is “Weekly GitHub digest” emails? I know our WG has a GitHub
>> account, and some kind-of-active repos in them, but I did not know that
>> there were digest emails sent out regarding them. Or am I misreading the
>> intention of this and the digest emails?
>>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 14 Feb 2022 12:26:43 -0600

Hi, Lucas,

> but I'll do what I can to fix it.

Carsten sent me a link to
https://mailarchive.ietf.org/arch/msg/lake/7HpwU7Peqp7dlbfvOl8myzSn__w
privately, which WAS produced on time, so you might not be the guilty
party!

But thank you for taking a look at this.

Best,

Spencer

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 14 Feb 2022 12:40:25 -0600

Hi, Lucas,

On Mon, Feb 14, 2022 at 12:25 PM Lucas Pardue <[email-masked]>
wrote:

> Looking at the workflow logs, it reported success at the top level but if
> I drill down to github-notify-ml task [1]
>

Thanks for this. I'm seeing

Run cd github-notify-ml
  cd github-notify-ml
  python index.py Sunday
  shell: /usr/bin/bash -e {0}
  env:
    pythonLocation: /opt/hostedtoolcache/Python/3.7.12/x64
    GH_OAUTH_TOKEN: ***
    SMTP_HOST: smtp.fastmail.com
    SMTP_USERNAME: [email-masked]
    SMTP_PASSWORD: ***
    SMTP_SSL: true
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')
WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from
this header address')

and I'm seeing the same number of WARNINGs from yesterday, and from a week
ago yesterday.

 No warnings from two weeks ago, and (looking more closely) I don't see
lake-wg in
https://github.com/ietf-github-services/activity-summary/blob/main/mls.json
- so maybe LAKE isn't getting its summary from the same place? Looking more
closely, LAKE is getting its summary from Webmaster via GitHub API <
[email-masked]>, so I'm pretty sure it's not.

The mystery deepens!

Best,

Spencer

>> https://github.com/ietf-github-services/activity-summary. And having
>> been the one to "touch it last" via a commit that roughly matches Spencer's
>>> I just noticed that my working group, Cellar, hasn't had a "Weekly
>>> github digest" email since January 30, and when I looked across all the
>>> email lists I'm subscribed to, I don't see anything for other working
>>> groups that is dated later than the 30th, either.
>>>
>>> Should I be reporting this? (And, if so, to whom? I cc:ed Mark
>>> Nottingham on this email, but I'm not sure if anyone at the secretariat
>>> should be noticing this)
>>>
>>> Best,
>>>
>>> Spencer
>>>
>>>
>>>
>>> Mahesh Jethanandani
>>> [email-masked]
>>>
>>>
>>>
>>>
>>>
>>>
>>>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 15 Feb 2022 09:02:21 +1100

Hi Spencer,

Just to be clear -- this is a service NOT run by the IETF, as stated in the org description. Best place for support is on the issue queue of the repo.

I think what's happening is that my e-mail provider (Fastmail) has been under some pretty significant DDoS attacks recently, and they're taking steps to mitigate them in a way that might be impacting us. 

Luckily, I know someone there... will look into it.

Cheers,

> On 15 Feb 2022, at 5:40 am, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Lucas, 
> 
> On Mon, Feb 14, 2022 at 12:25 PM Lucas Pardue <[email-masked]> wrote:
> Looking at the workflow logs, it reported success at the top level but if I drill down to github-notify-ml task [1]
> 
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> 
> [1] - https://github.com/ietf-github-services/activity-summary/runs/5082266750?check_suite_focus=true
> 
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> WARNING: SMTP sendmail error: (551, b'5.7.1 Not authorised to send from this header address')
> 
> and I'm seeing the same number of WARNINGs from yesterday, and from a week ago yesterday. 
> 
>  No warnings from two weeks ago, and (looking more closely) I don't see lake-wg in https://github.com/ietf-github-services/activity-summary/blob/main/mls.json - so maybe LAKE isn't getting its summary from the same place? Looking more closely, LAKE is getting its summary from Webmaster via GitHub API <[email-masked]>, so I'm pretty sure it's not. 
> 
> The mystery deepens!
> 
> Best,
> 
> Spencer
> 
> On Mon, Feb 14, 2022 at 6:22 PM Lucas Pardue <[email-masked]> wrote:
> Hi Spencer and Mahesh,
> 
> With GitHub, people can subscribe to repositories if they like. However, the IETF operates a service where a Working Group can create a digest of all relevant Repositories. The source to this service is https://github.com/ietf-github-services/activity-summary. And having been the one to "touch it last" via a commit that roughly matches Spencer's timeline, I'm going to assume I broke it. I don't know what the problem is but I'll do what I can to fix it.
> 
> Cheers,
> Lucas
> 
> On Mon, Feb 14, 2022 at 6:01 PM Mahesh Jethanandani <[email-masked]> wrote:

--
Mark Nottingham   https://www.mnot.net/

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 14 Feb 2022 22:37:53 +0000

Hiya,

> privately, which WAS produced on time, so you might not be the guilty

That mightn't signify. IIRC I setup some local cronjob
thing for lake, not knowing enough githubbery to get it
to work otherwise. (Another minor pyrrhic victory for
self-hosting:-)

I can delve for detail if that helps debug something
elsewhere.

Cheers,
S.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 15 Feb 2022 15:58:23 +1100

OK, I think I found the problem -- the combination of an unrelated change in my account and an anti-spam measure by my mail host.

Hopefully things will be back to normal next week.

Thanks,

> On 15 Feb 2022, at 9:02 am, Mark Nottingham <[email-masked]> wrote:
> 
> Hi Spencer,
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 15 Feb 2022 18:26:39 -0600

Hi, Mark,

On Mon, Feb 14, 2022 at 10:58 PM Mark Nottingham <[email-masked]> wrote:

> OK, I think I found the problem -- the combination of an unrelated change
> in my account and an anti-spam measure by my mail host.
>
> > Just to be clear -- this is a service NOT run by the IETF, as stated in
> the org description. Best place for support is on the issue queue of the
> repo.
>

Thank you for the quick response, and for keeping us up to date on the
status of this very helpful service.

Best,

Spencer

> >
> > I think what's happening is that my e-mail provider (Fastmail) has been
> under some pretty significant DDoS attacks recently, and they're taking
> steps to mitigate them in a way that might be impacting us.
> >
> >> Looking at the workflow logs, it reported success at the top level but
> if I drill down to github-notify-ml task [1]
> >>
> >> With GitHub, people can subscribe to repositories if they like.
> However, the IETF operates a service where a Working Group can create a
> digest of all relevant Repositories. The source to this service is
> >>> Of course, I don't know if other working groups have activity to
> digest, but I know Cellar does, in ietf-wg-cellar/flac-specification.
> >>>