Subject: Update "Contributors" section in a bis?

From: Kent Watsen <[email-masked]>
Date: Wed, 2 Feb 2022 21:58:04 +0000

Fellow Chairs,

The NETMOD WG is processing rfc6991-bis.   One thing that came up was that the original RFC 6991 contained a “Contributors” section as follows:

	7.  Contributors

	  The following people contributed significantly to the initial version
	  of this document:

	   - Andy Bierman (Brocade)
	   - Martin Bjorklund (Tail-f Systems)
	   - Balazs Lengyel (Ericsson)
	   - David Partain (Ericsson)
	   - Phil Shafer (Juniper Networks)

However, none of the above are “contributors” to the -bis effort and many no longer have the same affiliations today.  What to do?  RFC 7322 seems to provide no guidelines for this.  What are the IETF rules for such things?   Should the section be kept as is for historic reasons, or should be updated, or even removed by moving the “contributors” to a statement in the Acknowledgements section?

Thanks,
Kent

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 2 Feb 2022 17:14:04 -0500

I would put a statement (that they were contributors to RFC 6991) and list
of names in an acknowledgements section.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

On Wed, Feb 2, 2022 at 4:58 PM Kent Watsen <[email-masked]> wrote:

> Fellow Chairs,
>
> The NETMOD WG is processing rfc6991-bis.   One thing that came up was that
> the original RFC 6991 contained a “Contributors” section as follows:
>
>         7.  Contributors
>
> However, none of the above are “contributors” to the -bis effort and many
> no longer have the same affiliations today.  What to do?  RFC 7322 seems to
> provide no guidelines for this.  What are the IETF rules for such things?
>  Should the section be kept as is for historic reasons, or should be
> updated, or even removed by moving the “contributors” to a statement in the
> Acknowledgements section?
>
> Thanks,
> Kent
>
>

---

From: Bob Hinden <[email-masked]>
Date: Wed, 2 Feb 2022 14:18:47 -0800

I agree, we have done that in several “bis” documents.

Bob

> On Feb 2, 2022, at 2:14 PM, Donald Eastlake <[email-masked]> wrote:
> 
> I would put a statement (that they were contributors to RFC 6991) and list of names in an acknowledgements section.
> 
> Thanks,
> Donald

---

From: Russ Housley <[email-masked]>
Date: Wed, 2 Feb 2022 17:27:58 -0500

I had this problem with Acknowledgments in a bis document that will obsolete two RFCs if it is approved.  I did this:

11.  Acknowledgments

11.1.  Acknowledgments from RFC XXXX

   ...

11.2.  Acknowledgments from RFC YYYY

   ...

11.3.  Additional Acknowledgments

   ...

Russ

On Wed, Feb 2, 2022 at 4:58 PM Kent Watsen <[email-masked] <mailto:[email-masked]>> wrote:
Fellow Chairs,

        7.  Contributors

           - Andy Bierman (Brocade)

Thanks,
Kent

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 2 Feb 2022 22:38:47 +0000

FWIW, I use Acknowledgements. If I deem it worthwhile, I will say 
	We gratefully acknowledge everyone who contributed to the previous version of this document, [VERIFY].
 And then list any notable contributors, often
	In addition to the WG mailing list, Joe and Sue ....
Kind of thing.

---

From: Kent Watsen <[email-masked]>
Date: Wed, 2 Feb 2022 22:39:58 +0000

Thanks all.  We’ll move them to the Acknowledgments section. 

K. 

> On Feb 2, 2022, at 5:28 PM, Russ Housley <[email-masked]> wrote:
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 03 Feb 2022 14:17:43 -0500

I want to say that if you are using kramdown (or xml v3), that you can do:

contributor:
  - name: First Last
    email: [email-masked]
  - ..

after the author: section, and this results in XML that is way easier for
future systems to parse.

I'm not sure if we can assign roles (reviewer, ...), but going forward it
would be very nice to be able to provide more machine readable credit.
I think that this will help get more reviews, and to get employers to support
the time required for reviews if there is more clear acknowledgement.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 3 Feb 2022 20:27:18 +0100

I think at some point in time Cabo showed how to create XMLv3 <contact>
output, but i've misplaced it. Once you know how to do that,
i think it should be too difficult to simply have just different
paragraphs for different type of contributor role and just format
the contributor name/email as contacts.

Of course, this does not result yet in an XML formalized contributor role
definition. that would be nice too, but is IMHO primarily an XML issue.

IMHO, we should just allow free-form "role" attributes in author and contact as an XMLv3 extension.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 3 Feb 2022 20:36:17 +0100

> would be very nice to be able to provide more machine readable credit.

Indeed.  Right now you can already add

    contribution: |
      First provided an early review that shaped the progress
      of the draft specification.

to a contributor in the above list, but that of course only adds human-readable text to the auto-generated “Contributors" section.

I think the contributors section should not be free text with the occasional <contact in it, but should be built analog to how “Authors’ Addresses” is built from the <author elements.  But maybe that’s too much ceremony...

Grüße, Carsten