Subject: Chair/datatracker tracking expired WG documents ?

From: Toerless Eckert <[email-masked]>
Date: Fri, 25 Mar 2022 07:46:29 +0100

Is there a way for datatracker on a WG's page to (automatically) show expired WG documents ?

I have one such draft in my WG and it wouldn't show up on the WG page.
Of course, in general one may not want to bother about expired drafts unless
explicitly added, but for WG document IMHO, it would be great if they would automatically
show up in in the WG section unless their status is maybe accordingly updated or the like

Thanks
    Toerless

---

From: Robert Sparks <[email-masked]>
Date: Fri, 25 Mar 2022 03:04:01 -0500

Known issue: https://github.com/ietf-tools/datatracker/issues/3078

Note the edge case of being able to say "no, really, this shouldn't show 
anymore"

RjS

On 3/25/22 1:46 AM, Toerless Eckert wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Valery Smyslov" <[email-masked]>
Date: Fri, 25 Mar 2022 11:04:47 +0300

Hi,

> show up in in the WG section unless their status is maybe accordingly updated or the like

I also think this feature would be useful, because now the expired WG document
is not shown at all at the WG page and it's sometimes difficult to find it
(you need to remember the name).

Regards,
Valery.

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 25 Mar 2022 10:40:54 +0100

As you can manually add related documents, removing actually unwanted 
documents, should be of similar complexity, right?

On 25.03.22 09:04, Robert Sparks wrote:
>> List info (including how to Unsubscribe): 
>> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 25 Mar 2022 10:39:43 +0100

Coincidentally, I was expressing the expressing the exact same sentiment 
in a side-discussion two days ago. I'd really appreciate that feature, 
both as a chair and a contributor.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 25 Mar 2022 10:28:20 +0000

Dear all

> both as a chair and a contributor.

Agreed. It seems like a hard curtain that falls to oblivion, though some work is just stalled, not dead.

Along the same line (though a different problem that we'd need to fork as a separate thread) is our wording for IETF references.
At the moment we indicate that external specs (think say IEEE) must not reference drafts. But when the draft stalls before RFC, this makes the reference completely unusable. Makes no sense to me, and hardly reflected in practice. A better practice would be how we eat our own dogfood, which is that a draft must not be a normative reference when standard X is published, whether by IETF or else.

Interested in following that up too? If so please fork.

Note: this can effectively hurt. Within the last year or 2, I faced that issue with both IEEE and ETSI. At ETSI it was mostly theoretical and we kinda forced our way to reference I-drafts arguing that the doc we are writing is not a standard. OTOH, at IEEE that was harder. We had text in 802.11md about the proxy ARP function and the fact that there's also IPv6 to care about. Incidentally, the text cited a draft in progress for the proxy ND operation (now RFC 8929) as an informational reference (all non-IEEE references are informational). At the last minute, the whole change was removed from .11md on the grounds that the I-D reference was not RFC, and the text was frozen for publication. At that time, the I-draft had been waiting for its turn in the RFC Editor queue for months. The RFC was pulled from the RFC editor queue and published within weeks after the freeze. I discovered the .11 removal only later, appealed, but the freeze is immutable.

Keep safe;

Pascal 

> -----Original Message-----
> From: WGChairs <[email-masked]> On Behalf Of Henk Birkholz
> Sent: vendredi 25 mars 2022 10:40
> To: Valery Smyslov <[email-masked]>; 'Toerless Eckert'
> <[email-masked]>; 'Tools Team Discussion' <[email-masked]>;
> [email-masked]
> Subject: Re: Chair/datatracker tracking expired WG documents ?
> 
> >> Of course, in general one may not want to bother about expired drafts
> >> unless explicitly added, but for WG document IMHO, it would be great
> >> if they would automatically show up in in the WG section unless their
> >> status is maybe accordingly updated or the like
> >
> > I also think this feature would be useful, because now the expired WG
> > document is not shown at all at the WG page and it's sometimes
> > difficult to find it (you need to remember the name).
> >
> > Regards,
> > Valery.
> >
> >> Thanks
> >>      Toerless
> >
> >

---

From: Robert Sparks <[email-masked]>
Date: Fri, 25 Mar 2022 06:43:35 -0500

> documents, should be of similar complexity, right?

Not with the current system.

"manually add" is realized by adding the document to the group's 
community app ruleset, something that can only _include_ things, not 
exclude them.

Instead of adding an excluding filter, this will probably need to be 
based on a new wg state.

>> Note the edge case of being able to say "no, really, this shouldn't 
>> show anymore"
>>
>> RjS
>>
>>

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 25 Mar 2022 08:06:18 -0400

On Fri, Mar 25, 2022 at 6:30 AM Pascal Thubert (pthubert)
<pthubert=[email-masked]> wrote:
> ...

If it is important to have an RFC number for a draft in the RFC Editor
queue for reference by another standards body, you just work through
your AD to have the IESG ask the RFC Editor to assign an RFC number
early and the RFC Editor will generally comply.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]