Subject: [Wish] draft charter

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 11 Dec 2020 19:24:27 +0000

Hi,

I had a look at the draft charter at https://datatracker.ietf.org/doc/charter-ietf-wish/.
Overall, it looks pretty good to me, but I do have a couple questions.

1) Is the intent that any WebRTC server, and any WebRTC client, be able to use this protocol to establish a one way media session to forward its own view of the WebRTC media streams, with or without any alteration, to a broadcast network?
2) I understood from the dispatch session, the time frame for this work to complete is expected to be relatively short. It would be helpful to see milestones with anticipated dates for completion.

Cheers,
Charles

---

From: Adam Roach <[email-masked]>
Date: Fri, 18 Dec 2020 15:21:58 -0600

> 1) Is the intent that any WebRTC server, and any WebRTC client, be able to use this protocol to establish a one way media session to forward its own view of the WebRTC media streams, with or withou…

Server-to-server isn't really in scope, although a server taking media 
that it is receiving and setting up a rebroadcast for it using WISH is 
certainly possible.

> 2) I understood from the dispatch session, the time frame for this work to complete is expected to be relatively short. It would be helpful to see milestones with anticipated dates for completion.

Definitely a good point! Notionally, this is your typical "as long as it 
takes but not any longer" desideratum, but we should have goals. I'd 
love to see a single milestone that is "submit WISH document to IESG for 
publication" with a date sometime in 2021. I know this is aggressive, 
but I'm using MARTINI as my idealized model, and we managed to go from 
first draft to publication requested in 13 months.

/a

---

From: Barry Leiba <[email-masked]>
Date: Fri, 18 Dec 2020 17:53:55 -0500

I’m happy to put in a milestone for Dec 2021, or whatever other month the
proponents want to use.  Murray’s going to get this WG, so I’ve added him
to the TO list in case he wants to comment.

Barry

On Fri, Dec 18, 2020 at 4:22 PM Adam Roach <[email-masked]> wrote:

> > I had a look at the draft charter at
> https://datatracker.ietf.org/doc/charter-ietf-wish/.
> > 1) Is the intent that any WebRTC server, and any WebRTC client, be able
> to use this protocol to establish a one way media session to forward its
> own view of the WebRTC media streams, with or without any alteration, to a
> broadcast network?
>
>
> > 2) I understood from the dispatch session, the time frame for this work
> to complete is expected to be relatively short. It would be helpful to see
> milestones with anticipated dates for completion.
>
>
> --
> Wish mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wish
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 18 Dec 2020 18:12:36 -0800

Sounds good to me.  I've been incommunicado this week but next week is much
more open (technically on vacation as of now) so I'll be catching up.  I
owe EXTRA a big document review too.

-MSK

---

From: Adam Roach <[email-masked]>
Date: Fri, 18 Dec 2020 21:13:06 -0600

BTW, I'm out of the office the next two weeks; but December 2021 is what 
I had in mind.

/a

On 12/18/20 20:12, Murray S. Kucherawy wrote:
> Sounds good to me.  I've been incommunicado this week but next week is 
> much more open (technically on vacation as of now) so I'll be catching 
> up.  I owe EXTRA a big document review too.
>
> -MSK
>
> On Fri, Dec 18, 2020 at 2:54 PM Barry Leiba <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     I’m happy to put in a milestone for Dec 2021, or whatever other
>     month the proponents want to use. Murray’s going to get this WG,
>     so I’ve added him to the TO list in case he wants to comment.
>
>     Barry
>
>     On Fri, Dec 18, 2020 at 4:22 PM Adam Roach <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         > 1) Is the intent that any WebRTC server, and any WebRTC
>         client, be able to use this protocol to establish a one way
>         media session to forward its own view of the WebRTC media
>         streams, with or without any alteration, to a broadcast network?
>
>
>         > 2) I understood from the dispatch session, the time frame
>         for this work to complete is expected to be relatively short.
>         It would be helpful to see milestones with anticipated dates
>         for completion.
>
>
>         [email-masked] <mailto:[email-masked]>