Subject: [Wish] Video ingest over QUIC

From: Alan Frindell <[email-masked]>
Date: Tue, 13 Jul 2021 15:36:59 +0000

Hi, for several years, Facebook has been using its own video ingest protocol over QUIC from our apps to our infra.  While we’ve spoken about it before, we just now published a draft documenting how it works:  https://www.ietf.org/archive/id/draft-kpugin-rush-00.html.

The protocol leverages the advantages of QUIC transport, and features a partially reliable mode using only QUIC v1 RST_STREAM.

We welcome your feedback

Thanks

-Alan Frindell

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 13 Jul 2021 08:39:44 -0700

Alan --

Would you like some time on the IETF 111 AVTCORE Agenda to present this?

On Tue, Jul 13, 2021 at 8:37 AM Alan Frindell <afrind=
[email-masked]> wrote:

> Hi, for several years, Facebook has been using its own video ingest
> protocol over QUIC from our apps to our infra.  While we’ve spoken about it
> before, we just now published a draft documenting how it works:
> https://www.ietf.org/archive/id/draft-kpugin-rush-00.html.
>
> The protocol leverages the advantages of QUIC transport, and features a
> partially reliable mode using only QUIC v1 RST_STREAM.
>
> We welcome your feedback
>
> Thanks
>
> -Alan Frindell
>
>
>
>
>
> _______________________________________________
> Audio/Video Transport Core Maintenance
> [email-masked]
> https://www.ietf.org/mailman/listinfo/avt
>

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Tue, 13 Jul 2021 18:01:51 +0200

Hi Alan,

I think that the correct place for discussing it is AVTCORE as Bernard has
indicated, as  WISH is not chartered to implement any new media protocol.

The draft is very interesting and I would be willing to collaborate, what
is your main interest? Do you want to try to publish it as it is or would
you be accepting feedback and include modifications?

Best regards
Sergio

El mar, 13 jul 2021 a las 17:37, Alan Frindell (<afrind=
[email-masked]>) escribió:

> --
> Wish mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wish
>

---

From: Alan Frindell <[email-masked]>
Date: Tue, 13 Jul 2021 19:02:25 +0000

Hi Sergio, thanks for your interest in the draft.

I’m interested in seeing a video ingest protocol standard that leverages QUIC as a transport, has some partial reliability support, and is less connection-oriented so that servers can go down for maintenance without impacting ingest reliability or having arbitrarily long drain times.  We published our RUSH draft to help kickstart the conversation but we’re open to feedback and modifications if they help advance those goals.

Thanks

-Alan

From: Sergio Garcia Murillo <[email-masked]>
Date: Tuesday, July 13, 2021 at 9:02 AM
To: Alan Frindell <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Kirill Pugin <[email-masked]>
Subject: Re: [Wish] Video ingest over QUIC

Hi Alan,

I think that the correct place for discussing it is AVTCORE as Bernard has indicated, as  WISH is not chartered to implement any new media protocol.

The draft is very interesting and I would be willing to collaborate, what is your main interest? Do you want to try to publish it as it is or would you be accepting feedback and include modifications?

Best regards
Sergio

El mar, 13 jul 2021 a las 17:37, Alan Frindell (<afrind=[email-masked]<mailto:[email-masked]>>) escribió:
Hi, for several years, Facebook has been using its own video ingest protocol over QUIC from our apps to our infra.  While we’ve spoken about it before, we just now published a draft documenting how it works:  https://www.ietf.org/archive/id/draft-kpugin-rush-00.html<https://www.ietf.org/archive/id/draft-kpugin-rush-00.html>.

We welcome your feedback

Thanks

-Alan Frindell

--
Wish mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/wish<https://www.ietf.org/mailman/listinfo/wish>

---

From: Luke Curley <[email-masked]>
Date: Tue, 13 Jul 2021 13:16:03 -0700

Hey Alan, thanks for publishing your protocol!

Twitch has also been working on a video over QUIC protocol, albeit
primarily for video distribution instead of contribution. We're very
interested in collaborating on RUSH and producing a new standard for live
streaming! Would there be broader interest in forming a video over QUIC
working group?

On Tue, Jul 13, 2021 at 12:04 PM Alan Frindell <afrind=
[email-masked]> wrote:

> I’m interested in seeing a video ingest protocol standard that leverages
> QUIC as a transport, has some partial reliability support, and is less
> connection-oriented so that servers can go down for maintenance without
> impacting ingest reliability or having arbitrarily long drain times.  We
> published our RUSH draft to help kickstart the conversation but we’re open
> to feedback and modifications if they help advance those goals.
>
>
>
> Thanks
>
>
>
> -Alan
>
>
>
> *From: *Sergio Garcia Murillo <[email-masked]>
> *Date: *Tuesday, July 13, 2021 at 9:02 AM
> *To: *Alan Frindell <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, Kirill Pugin <[email-masked]>
> *Subject: *Re: [Wish] Video ingest over QUIC
>
>
>
> Hi Alan,
>
>
>

---

From: Roberto Peon <[email-masked]>
Date: Tue, 13 Jul 2021 20:35:04 +0000

Seems like a good idea to me, unless there is a home that is already well suited!
-=R

From: QUIC <[email-masked]> on behalf of Luke Curley <[email-masked]>
Date: Tuesday, July 13, 2021 at 1:16 PM
To: Alan Frindell <afrind=[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Sergio Garcia Murillo <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Kirill Pugin <[email-masked]>
Subject: Re: [Wish] Video ingest over QUIC

Twitch has also been working on a video over QUIC protocol, albeit primarily for video distribution instead of contribution. We're very interested in collaborating on RUSH and producing a new standard for live streaming! Would there be broader interest in forming a video over QUIC working group?

On Tue, Jul 13, 2021 at 12:04 PM Alan Frindell <afrind=[email-masked]<mailto:[email-masked]>> wrote:
Hi Sergio, thanks for your interest in the draft.

Thanks

-Alan

From: Sergio Garcia Murillo <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 13, 2021 at 9:02 AM
To: Alan Frindell <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Kirill Pugin <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Wish] Video ingest over QUIC

Hi Alan,

Best regards
Sergio

We welcome your feedback

Thanks

-Alan Frindell

---

From: Victor Vasiliev <[email-masked]>
Date: Wed, 14 Jul 2021 12:31:34 -0400

Hi Alan,

Excited to see this draft!

Since this isn't technically in scope for either avtcore, wish or quic
working groups, what would people think about making a new mailing list for
video over QUIC?

Cheers,
 Victor.

On Wed, Jul 14, 2021 at 3:27 AM Justin Uberti <
[email-masked]> wrote:

> +1
>
> On Tue, Jul 13, 2021 at 1:35 PM Roberto Peon <fenix=
>> *From: *QUIC <[email-masked]> on behalf of Luke Curley <
>> [email-masked]>
>> *Date: *Tuesday, July 13, 2021 at 1:16 PM
>> *To: *Alan Frindell <afrind=[email-masked]>
>> *Cc: *"[email-masked]" <[email-masked]>, Sergio Garcia Murillo <
>> [email-masked]>, "[email-masked]" <[email-masked]>, "
>> [email-masked]" <[email-masked]>, Kirill Pugin <[email-masked]>
>> I think that the correct place for discussing it is AVTCORE as Bernard
>> has indicated, as  WISH is not chartered to implement any new media
>> protocol.
>>
>>
>>

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 14 Jul 2021 17:59:31 +0100

Thanks for sharing Alan.

> working groups, what would people think about making a new mailing list for

It isn't technically out of scope for the QUIC WG either :-) Our charter
[1] says:

"Specifications describing how new or existing application protocols use
the QUIC transport layer, called application protocol mappings below, need
not be specified in the QUIC WG, although they can. The QUIC WG will
collaborate with other groups that define such application protocols that
intend to use QUIC"

That said, I think between the potential interested parties and the
application mapping not requiring change from QUIC, it warrants the work
taking place somewhere that can focus on more of the video needs. I'd
support another mailing list as a place to continue this conversation. I
think more discussion is required before trying to formulate a WG, the ADs
should definitely have some input here.

Cheers,
Lucas

[1] - https://datatracker.ietf.org/wg/quic/about/

---

From: Mike English <[email-masked]>
Date: Wed, 14 Jul 2021 13:09:59 -0400

I would personally be very interested in a "video over QUIC" working group
or mailing list.

The directness of this draft is perhaps what's most interesting to me.
In particular, the absence of out-of-band signaling / session establishment
stands in striking contrast with another UDP-based media ingest option:
WebRTC.

The signaling needed for session establishment (and the diversity of
implementations for such signaling) has historically been a barrier for
WebRTC adoption as an ingest protocol outside of the browser context.
WISH-WG is working to improve that situation for WebRTC of course, but a
new QUIC-based ingest protocol presents an opportunity to sidestep some of
those known-issues by making an architectural decision up front about
whether that style of session management is necessary in a video
contribution workflow.

I'm hoping others with more experience on these lists can speak to the
history and tradeoffs associated with those approaches, but I just wanted
to call attention to the aspect of the draft that seemed most notable to me
as an operator of a low latency streaming platform where WebRTC egress and
ingest capabilities are provided, but where RTMP is still the de facto
ingest protocol of choice for many users.

Thanks for sharing this work!
-Mike

On Wed, Jul 14, 2021 at 12:32 PM Victor Vasiliev <vasilvv=
[email-masked]> wrote:

>>> *Cc: *"[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>,
>>> "[email-masked]" <[email-masked]>, Kirill Pugin <[email-masked]>
>>> The draft is very interesting and I would be willing to collaborate,
>>> what is your main interest? Do you want to try to publish it as it is or
>>> would you be accepting feedback and include modifications?
>>>
>>>
>>>
>>> Best regards
>>>
>>> Sergio
>>>
>>>
>>>
>>>
>>>
>>>
>>>

---

From: Justin Uberti <[email-masked]>
Date: Tue, 13 Jul 2021 13:38:15 -0700

+1

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 16 Jul 2021 13:35:42 -0500

This is, of course, why ADs get paid the big bucks (ha!), but

> I would personally be very interested in a "video over QUIC" working group

Martin Thompson said (in a reply that, I think, only went to the QUIC
mailing list(*)) that he thought this was big enough to BOF (which doesn't
mean it shouldn't be discussed at DISPATCH at IETF 111), but does say
something about what a mailing list could be used for. Offhand, I can
imagine:

   - discussion of the existing
   https://www.ietf.org/archive/id/draft-kpugin-rush-00.html draft
   - discussion of potential scope for a BOF proposal
   - discussion of proposed text for a BOF request

Could I ask what the people who are expressing interest in a mailing list
are thinking about?

Best,

Spencer

(*) email is archived at
https://mailarchive.ietf.org/arch/msg/quic/ocCm8E-GzP_pn4LBcJyKQeN7GRU/.

> In particular, the absence of out-of-band signaling / session
> establishment stands in striking contrast with another UDP-based media
> ingest option: WebRTC.
>
>>>> I’m interested in seeing a video ingest protocol standard that
>>>> leverages QUIC as a transport, has some partial reliability support, and is
>>>> less connection-oriented so that servers can go down for maintenance
>>>> without impacting ingest reliability or having arbitrarily long drain
>>>> times.  We published our RUSH draft to help kickstart the conversation but
>>>> we’re open to feedback and modifications if they help advance those goals.
>>>>
>>>>
>>>>
>>>> Thanks
>>>>
>>>>
>>>>
>>>> -Alan
>>>>
>>>>
>>>>

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 18 Jul 2021 01:17:57 +0100

On Fri, 16 Jul 2021, 19:36 Spencer Dawkins at IETF, <
[email-masked]> wrote:

>> I would personally be very interested in a "video over QUIC" working
>> group or mailing list.
>>
>

+1. Good questions.

There seems to be some appetite for _something_ that doesn't fit in
existing boxes. Defining exactly what might be would be a sensible step on
the path to a BoF.

Cheers,
Lucas

>>>>> The protocol leverages the advantages of QUIC transport, and features
>>>>> a partially reliable mode using only QUIC v1 RST_STREAM.
>>>>>
>>>>> We welcome your feedback
>>>>>
>>>>> Thanks
>>>>>
>>>>> -Alan Frindell
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Wish mailing list
>>>>> [email-masked]

---

From: Martin Duke <[email-masked]>
Date: Mon, 19 Jul 2021 07:44:30 -0700

This sounds like a side meeting that might lead to a BoF at 112?

On Sat, Jul 17, 2021 at 5:18 PM Lucas Pardue <[email-masked]>
wrote:

>>>>>> I think that the correct place for discussing it is AVTCORE as
>>>>>> Bernard has indicated, as  WISH is not chartered to implement any new media
>>>>>> protocol.
>>>>>>
>>>>>>
>>>>>>

---

From: Alan Frindell <[email-masked]>
Date: Mon, 19 Jul 2021 16:55:50 +0000

Kirill and I are scheduled to present this draft at the ART area session (combined with DISPATCH) on Monday 7/26 from 12-2 Pacific.  We’ve also been approached by the MOPS chairs to present there, though that session conflicts with QUIC.

I also scheduled a side meeting<https://trac.ietf.org/trac/ietf/meeting/wiki/111sidemeetings> during Thursday Session IV (4:30 – 5:30 Pacific, vide conference details TBD) so we can have more time to discuss the general problem space, requirements and mailing list/BoF logistics moving forward.

Thanks

-Alan

From: Martin Duke <[email-masked]>
Date: Monday, July 19, 2021 at 7:45 AM
To: Lucas Pardue <[email-masked]>
Cc: Spencer Dawkins at IETF <[email-masked]>, Victor Vasiliev <[email-masked]>, "[email-masked]" <[email-masked]>, Roberto Peon <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Mike English <[email-masked]>, Alan Frindell <[email-masked]>, QUIC WG <[email-masked]>, Kirill Pugin <[email-masked]>, Luke Curley <[email-masked]>
Subject: Re: [Wish] [AVTCORE] Video ingest over QUIC

On Sat, Jul 17, 2021 at 5:18 PM Lucas Pardue <[email-masked]<mailto:[email-masked]>> wrote:
On Fri, 16 Jul 2021, 19:36 Spencer Dawkins at IETF, <[email-masked]<mailto:[email-masked]>> wrote:
This is, of course, why ADs get paid the big bucks (ha!), but

On Wed, Jul 14, 2021 at 12:10 PM Mike English <[email-masked]<mailto:[email-masked]>> wrote:
I would personally be very interested in a "video over QUIC" working group or mailing list.

Martin Thompson said (in a reply that, I think, only went to the QUIC mailing list(*)) that he thought this was big enough to BOF (which doesn't mean it shouldn't be discussed at DISPATCH at IETF 111), but does say something about what a mailing list could be used for. Offhand, I can imagine:

  *   discussion of the existing https://www.ietf.org/archive/id/draft-kpugin-rush-00.html<https://www.ietf.org/archive/id/draft-kpugin-rush-00.html> draft
  *   discussion of potential scope for a BOF proposal
  *   discussion of proposed text for a BOF request
Could I ask what the people who are expressing interest in a mailing list are thinking about?

+1. Good questions.

There seems to be some appetite for _something_ that doesn't fit in existing boxes. Defining exactly what might be would be a sensible step on the path to a BoF.

Cheers,
Lucas

Best,

Spencer

(*) email is archived at https://mailarchive.ietf.org/arch/msg/quic/ocCm8E-GzP_pn4LBcJyKQeN7GRU/<https://mailarchive.ietf.org/arch/msg/quic/ocCm8E-GzP_pn4LBcJyKQeN7GRU/>.

The directness of this draft is perhaps what's most interesting to me.
In particular, the absence of out-of-band signaling / session establishment stands in striking contrast with another UDP-based media ingest option: WebRTC.

The signaling needed for session establishment (and the diversity of implementations for such signaling) has historically been a barrier for WebRTC adoption as an ingest protocol outside of the browser context. WISH-WG is working to improve that situation for WebRTC of course, but a new QUIC-based ingest protocol presents an opportunity to sidestep some of those known-issues by making an architectural decision up front about whether that style of session management is necessary in a video contribution workflow.

I'm hoping others with more experience on these lists can speak to the history and tradeoffs associated with those approaches, but I just wanted to call attention to the aspect of the draft that seemed most notable to me as an operator of a low latency streaming platform where WebRTC egress and ingest capabilities are provided, but where RTMP is still the de facto ingest protocol of choice for many users.

On Wed, Jul 14, 2021 at 12:32 PM Victor Vasiliev <vasilvv=[email-masked]<mailto:[email-masked]>> wrote:
Hi Alan,

Since this isn't technically in scope for either avtcore, wish or quic working groups, what would people think about making a new mailing list for video over QUIC?

Cheers,
 Victor.

On Wed, Jul 14, 2021 at 3:27 AM Justin Uberti <[email-masked]<mailto:[email-masked]>> wrote:
+1

On Tue, Jul 13, 2021 at 1:35 PM Roberto Peon <fenix=[email-masked]<mailto:[email-masked]>> wrote:
Seems like a good idea to me, unless there is a home that is already well suited!
-=R

From: QUIC <[email-masked]<mailto:[email-masked]>> on behalf of Luke Curley <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 13, 2021 at 1:16 PM
To: Alan Frindell <afrind=[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Sergio Garcia Murillo <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Kirill Pugin <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Wish] Video ingest over QUIC

Thanks

-Alan

Hi Alan,

Best regards
Sergio

We welcome your feedback

Thanks

-Alan Frindell

--
Wish mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/wish<https://www.ietf.org/mailman/listinfo/wish>
--
Wish mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/wish<https://www.ietf.org/mailman/listinfo/wish>
_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/avt<https://www.ietf.org/mailman/listinfo/avt>
--
Wish mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/wish<https://www.ietf.org/mailman/listinfo/wish>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 20 Jul 2021 15:59:23 -0500

Hi, Alan,

On Mon, Jul 19, 2021 at 11:55 AM Alan Frindell <[email-masked]> wrote:

> Kirill and I are scheduled to present this draft at the ART area session
> (combined with DISPATCH) on Monday 7/26 from 12-2 Pacific.  We’ve also been
> approached by the MOPS chairs to present there, though that session
> conflicts with QUIC.
>

We've gotta watch for this conflict ... but

> I also scheduled a side meeting
> <https://trac.ietf.org/trac/ietf/meeting/wiki/111sidemeetings> during
> Thursday Session IV (4:30 – 5:30 Pacific, vide conference details TBD) so
> we can have more time to discuss the general problem space, requirements
> and mailing list/BoF logistics moving forward.
>

Thank you for setting this up. It seems just about right.

Best,

Spencer

> Thanks
>
>
>
> -Alan
>
>
>
> *From: *Martin Duke <[email-masked]>
> *Date: *Monday, July 19, 2021 at 7:45 AM
> *To: *Lucas Pardue <[email-masked]>
> *Cc: *Spencer Dawkins at IETF <[email-masked]>, Victor
> Vasiliev <[email-masked]>, "[email-masked]" <[email-masked]>, Roberto
> Peon <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>, Mike
> English <[email-masked]>, Alan Frindell <[email-masked]>, QUIC WG <
> [email-masked]>, Kirill Pugin <[email-masked]>, Luke Curley <
> [email-masked]>
> *Subject: *Re: [Wish] [AVTCORE] Video ingest over QUIC
>
>
>

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 23 Jul 2021 21:04:07 +0100

On Fri, Jul 23, 2021 at 8:46 PM Das, Dibakar <[email-masked]> wrote:

> Thanks. So, you are making use of Stream ID being pretty long and there is
> no chance of overflow.
>

I'm pretty sure someone in the QUIC WG did a back of a napkin calculation
about how long it would take to overflow QUIC Stream IDs. I can't remember
the figure but it was big, perhaps we should capture that number somewhere
more formally :-D

---

From: Roberto Peon <[email-masked]>
Date: Fri, 23 Jul 2021 20:12:04 +0000

One gets to choose which to overflow—streamID or streamOffset, or both!
Datagram-like things, where we choose the streamID option will use more bits-sum-total across the session to represent the whole address-space
… but likely not enough to matter in net.
-=R

From: QUIC <[email-masked]> on behalf of Lucas Pardue <[email-masked]>
Date: Friday, July 23, 2021 at 1:04 PM
To: "Das, Dibakar" <[email-masked]>
Cc: Sergio Garcia Murillo <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Alan Frindell <afrind=[email-masked]>, "[email-masked]" <[email-masked]>, Kirill Pugin <[email-masked]>
Subject: Re: [Wish] Video ingest over QUIC

On Fri, Jul 23, 2021 at 8:46 PM Das, Dibakar <[email-masked]<mailto:[email-masked]>> wrote:
Thanks. So, you are making use of Stream ID being pretty long and there is no chance of overflow.

I'm pretty sure someone in the QUIC WG did a back of a napkin calculation about how long it would take to overflow QUIC Stream IDs. I can't remember the figure but it was big, perhaps we should capture that number somewhere more formally :-D

---

From: Alan Frindell <[email-masked]>
Date: Fri, 23 Jul 2021 02:33:03 +0000

Scheduling Update:

Our draft will be presented at ART area on Monday and mops on Tuesday.

I moved the side meeting to Friday at 11 Pacific to avoid conflict with iabopen.

Thanks

-Alan

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tuesday, July 20, 2021 at 1:59 PM
To: Alan Frindell <[email-masked]>
Cc: Martin Duke <[email-masked]>, Lucas Pardue <[email-masked]>, Victor Vasiliev <[email-masked]>, "[email-masked]" <[email-masked]>, Roberto Peon <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Mike English <[email-masked]>, QUIC WG <[email-masked]>, Kirill Pugin <[email-masked]>, Luke Curley <[email-masked]>
Subject: Re: [Wish] [AVTCORE] Video ingest over QUIC

Hi, Alan,

On Mon, Jul 19, 2021 at 11:55 AM Alan Frindell <[email-masked]<mailto:[email-masked]>> wrote:
Kirill and I are scheduled to present this draft at the ART area session (combined with DISPATCH) on Monday 7/26 from 12-2 Pacific.  We’ve also been approached by the MOPS chairs to present there, though that session conflicts with QUIC.

Best,

Spencer

Thanks

-Alan

From: Martin Duke <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 19, 2021 at 7:45 AM
To: Lucas Pardue <[email-masked]<mailto:[email-masked]>>
Cc: Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>>, Victor Vasiliev <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Roberto Peon <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Mike English <[email-masked]<mailto:[email-masked]>>, Alan Frindell <[email-masked]<mailto:[email-masked]>>, QUIC WG <[email-masked]<mailto:[email-masked]>>, Kirill Pugin <[email-masked]<mailto:[email-masked]>>, Luke Curley <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Wish] [AVTCORE] Video ingest over QUIC

+1. Good questions.

Cheers,
Lucas

Best,

Spencer

Cheers,
 Victor.

Thanks

-Alan

Hi Alan,

Best regards
Sergio

We welcome your feedback

Thanks

-Alan Frindell

---

From: "Das, Dibakar" <[email-masked]>
Date: Fri, 23 Jul 2021 18:06:54 +0000

Hi Alan,

Thanks for sharing the document. I had a minor clarification question on the following text:

“Connection establishment follows the normal procedure by client sending Connect frame, after that Video and Audio frames are sent using following rules:

·       Each new frame is sent on new bidirectional QUIC stream

·       Frames within same track must have IDs that are monotonically increasing, such that ID(n) = ID(n-1) + 1”

Does this mean each QUIC stream is used for transmitting only 1 or 2 frames ?

Regards,

Dibakar

From: QUIC <[email-masked]> On Behalf Of Alan Frindell
Sent: Tuesday, July 13, 2021 12:02 PM
To: Sergio Garcia Murillo <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Kirill Pugin <[email-masked]>
Subject: Re: [Wish] Video ingest over QUIC

Thanks

-Alan

Hi Alan,

Best regards
Sergio

We welcome your feedback

Thanks

-Alan Frindell

---

From: Kirill Pugin <[email-masked]>
Date: Fri, 23 Jul 2021 18:15:37 +0000

1 stream 1 frame

From: "Das, Dibakar" <[email-masked]>
Date: Friday, July 23, 2021 at 11:07 AM
To: Alan Frindell <afrind=[email-masked]>, Sergio Garcia Murillo <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Kirill Pugin <[email-masked]>
Subject: RE: [Wish] Video ingest over QUIC

Hi Alan,

Regards,

Dibakar

Thanks

-Alan

Hi Alan,

Best regards
Sergio

We welcome your feedback

Thanks

-Alan Frindell

---

From: "Das, Dibakar" <[email-masked]>
Date: Fri, 23 Jul 2021 19:46:21 +0000

From: Kirill Pugin <[email-masked]>
Sent: Friday, July 23, 2021 11:16 AM
To: Das, Dibakar <[email-masked]>; Alan Frindell <afrind=[email-masked]>; Sergio Garcia Murillo <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Wish] Video ingest over QUIC

1 stream 1 frame

From: "Das, Dibakar" <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 23, 2021 at 11:07 AM
To: Alan Frindell <afrind=[email-masked]<mailto:afrind=[email-masked]>>, Sergio Garcia Murillo <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Kirill Pugin <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Wish] Video ingest over QUIC

Hi Alan,

Regards,

Dibakar

From: QUIC <[email-masked]<mailto:[email-masked]>> On Behalf Of Alan Frindell
Sent: Tuesday, July 13, 2021 12:02 PM
To: Sergio Garcia Murillo <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Kirill Pugin <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Wish] Video ingest over QUIC

Thanks

-Alan

Hi Alan,

Best regards
Sergio

We welcome your feedback

Thanks

-Alan Frindell

---

From: Kirill Pugin <[email-masked]>
Date: Fri, 23 Jul 2021 20:14:04 +0000

Yup, exactly leveraging that 😃 I did some back of envelope calculation for how much audio/video would it take to overflow – it was A LOT :D

From: "Das, Dibakar" <[email-masked]>
Date: Friday, July 23, 2021 at 12:46 PM
To: Kirill Pugin <[email-masked]>, Alan Frindell <afrind=[email-masked]>, Sergio Garcia Murillo <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Wish] Video ingest over QUIC

1 stream 1 frame

Hi Alan,

Regards,

Dibakar

Thanks

-Alan

Hi Alan,

Best regards
Sergio

We welcome your feedback

Thanks

-Alan Frindell

---

From: Kirill Pugin <[email-masked]>
Date: Fri, 23 Jul 2021 20:19:54 +0000

I think it ended up 1+ year of 60fps just video.

From: Kirill Pugin <[email-masked]>
Date: Friday, July 23, 2021 at 1:14 PM
To: "Das, Dibakar" <[email-masked]>, Alan Frindell <afrind=[email-masked]>, Sergio Garcia Murillo <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Wish] Video ingest over QUIC

1 stream 1 frame

Hi Alan,

Regards,

Dibakar

Thanks

-Alan

Hi Alan,

Best regards
Sergio

We welcome your feedback

Thanks

-Alan Frindell