Subject: [Wish] Prototype WHIP endpoint in Galene

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 09 Sep 2021 16:34:31 +0200

I've just hacked together a WHIP endpoint in Galene.  It has been shown to
interoperate with Lorenzo's client (for which thanks) when authentication
is disabled in Galene.  I haven't spent any time trying to work out why
authentication fails.

To test:

  git clone -b whip https://github.com/jech/galene
  cd galene
  mkdir groups
  echo '{"presenter":[{}], "allow-anonymous":true}' > groups/test.json
  go run galene.go

Then point your browser at

  https://localhost:8443/group/test

and log-in (empty username, empty password).  Finally, point your
favourite WHIP client at the same URL, for example

  whip-client -l 6 -u https://localhost:8443/group/test -A "audiotestsrc is-live=true wave=red-noise ! audioconvert ! audioresample ! queue ! opusenc ! rtpopuspay pt=100 ssrc=1 ! queue ! application/x-rtp,media=audio,encoding-name=OPUS,payload=100" -V "videotestsrc is-live=true pattern=ball ! videoconvert ! queue ! vp8enc deadline=1 ! rtpvp8pay pt=96 ssrc=2 ! queue ! application/x-rtp,media=video,encoding-name=VP8,payload=96"

and rejoice!

-- Juliusz

---

From: Lorenzo Miniero <[email-masked]>
Date: Thu, 9 Sep 2021 16:47:11 +0200

On Thu, 09 Sep 2021 16:34:31 +0200
Juliusz Chroboczek <[email-masked]> wrote:

> I've just hacked together a WHIP endpoint in Galene.  It has been
> shown to interoperate with Lorenzo's client (for which thanks) when
> authentication is disabled in Galene.  I haven't spent any time
> trying to work out why authentication fails.
> 
> To test:
> 
>   whip-client -l 6 -u https://localhost:8443/group/test -A
> "audiotestsrc is-live=true wave=red-noise ! audioconvert !
> audioresample ! queue ! opusenc ! rtpopuspay pt=100 ssrc=1 ! queue !
> application/x-rtp,media=audio,encoding-name=OPUS,payload=100" -V
> "videotestsrc is-live=true pattern=ball ! videoconvert ! queue !
> vp8enc deadline=1 ! rtpvp8pay pt=96 ssrc=2 ! queue !
> application/x-rtp,media=video,encoding-name=VP8,payload=96"
> 
> and rejoice!
> 
> -- Juliusz

Hi Juliusz,

I can confirm it works from here, thanks for taking the time to test
this, and more importantly giving me feedback to improve the code!

Lorenzo

-- 
I'm getting older but, unlike whisky, I'm not getting any better
https://twitter.com/elminiero