Subject: [Wpack] Bundle preloading update

From: Felipe Erias <[email-masked]>
Date: Thu, 11 Nov 2021 11:52:02 +0900

Hello,

Thank you to everybody involved in organizing yesterday's meeting at 
IETF112.

My slides about our work on bundle preloading should soon be available 
at https://datatracker.ietf.org/meeting/112/session/wpack

As a small summary for those that could not attend, here are the highlights:

- a explainer for our proposal is available at
   * https://github.com/WICG/bundle-preloading

- ongoing effort to converge with the work by the Chromium team
   * https://github.com/WICG/webpackage/issues/699

- the Node.js module for creating and reading Web Bundles has been 
updated to the latest version of the spec
   * https://www.npmjs.com/package/wbn
   * https://github.com/WICG/webpackage/tree/main/js/bundle

- we have a working prototype in JS of Bundle Preloading:
   * the client uses a service worker to request a list of
     bundled resources and cache them one by one;
   * the server is able to serve bundles on the fly containing
     a subset of the resources in the reference bundle file;
   * we have created a couple of simple examples and are
     very interested in hearing about other scenarios that
     people might want to try out;
   * https://github.com/WICG/bundle-preloading/tree/main/prototypes

Future steps:

- better integration with bundler tools (e.g. webpack);
- early benchmarking;
- develop more examples.

Thanks again and best regards,
Felipe

---

From: Sean Turner <[email-masked]>
Date: Mon, 15 Nov 2021 11:45:01 -0500

> On Nov 10, 2021, at 21:52, Felipe Erias <[email-masked]> wrote:
> 
> My slides about our work on bundle preloading should soon be available at https://datatracker.ietf.org/meeting/112/session/wpack

I apologize for not making them available sooner, but they are now up at the location about as well as in the WG’s gh repo:
https://github.com/wpack-wg/wg-materials/tree/main/ietf112

Cheers,
spt