Subject: WCIP/Content-signaling

From: Mike Dahlin <[email-masked]>
Date: Tue, 19 Dec 2000 22:06:29 -0600

At the IETF meeting, there were a number of discussions regarding
"content signalling" (wcip invalidation, etc.)

One of the conclusions in the informal discussions was that there should
be a separate mailing list and web site for this discussion.

These have been set up:
    http://www.content-signaling.org

To subscribe to the mailing list send a message
    To: [email-masked]
with the body
    subscribe content-notification FIRSTNAME LASTNAME

I have posted a summary of the informal discussions to the web page and
mailing list.

-mike

---

From: Mike Dahlin <[email-masked]>
Date: Wed, 20 Dec 2000 12:02:31 -0600

>     subscribe content-notification FIRSTNAME LASTNAME

Sorry. The correct body should be:

    subscribe content-signaling FIRSTNAME LASTNAME

-mike

---

From: Ian Cooper <[email-masked]>
Date: Wed, 20 Dec 2000 20:56:31 +0000

>be a separate mailing list and web site for this discussion.

Unfortunately I wasn't able to make it to either of the informal meetings, 
so I'd be grateful if someone could give me a little background on the 
decision to form this splinter group rather than trying to hash things out 
within the context of the proposed work in WEBI.  It seems that we're 
trying to do very similar things.  I'm a little confused.

---

From: Fred Douglis <[email-masked]>
Date: Wed, 20 Dec 2000 16:20:41 -0500

It's not a "splinter group" per se.  The point is that the people interested 
in this topic (a dozen or so in all) met after the WG/BOF meetings to discuss 
further, and felt that sending all the mail to both CDN and WEBI on this 
particular topic might overwhelm the many more people with much less interest. 
So a separate mailing list was created, just like under CDN there are 
additional lists for the strawman internet drafts, early adopters, and so on.  T
This doesn't mean things won't go to the other lists when appropriate, just 
that the lower-level discussions need not involve so many lists.

The next question is how WCIP relates to RUP, which is maybe what you were 
really asking.  I'll let one of the WCIP authors answer that.

I'm responding to the full lists in the hopes that this satisfies and closes 
the issue, but I know we risk a big email discussion of this.  Since WCIP was 
previously discussed in the context of WREC, I propose that follow-ups go just 
to WREC (webi not being established enough yet).

Fred

---

From: "Abbie Barbir" <[email-masked]>
Date: Wed, 20 Dec 2000 16:29:13 -0500

hi

can somebody post the addresses of the revelant lists.

thanks
abbie

----- Original Message -----
From: "Fred Douglis" <[email-masked]>
To: "Ian Cooper" <[email-masked]>
Cc: "Mike Dahlin" <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Wednesday, December 20, 2000 4:20 PM
Subject: Re: WCIP/Content-signaling

---

From: Dan Li <[email-masked]>
Date: Wed, 20 Dec 2000 16:18:23 -0800

Following Fred's advice, this's copied only to wrec mailing list.

>really asking.  I'll let one of the WCIP authors answer that.

Here is what the discussion summary recorded (see 
http://www.content-signaling.org/)

>2. Architecture
>
>Mark Nottingham described a conceptual architecture for RUP ("Resource
>Update Protocol") in his presentation at the official meeting.
>
>
>RUP  components
>   ---------------------
>   metadata/state -- invalidation, delta/update, ...
>   ---------------------
>   resource selection
>   ---------------------
>   update message "NOTIFICATION?"
>   ---------------------
>   channel
>   ---------------------
>   subscription mechanism   |   reliability
>   ---------------------
>   announcment -- HTTP header, well-known location, ...
>   ---------------------
>
>In later informal discussions, two main issues were raised:
>
>a) To what extent should the group's work focus on a "general
>    framework" v. a specific protocol.
>
>   In particular, there was some concern that focusing on a general
>   framework could slow progress on the invalidation protocol (see
>   discussion above), and that some of the specific protocols that Mark
>   floated as solutions for some of these layers were not mature.
>
>b) How does this conceptual framework match the specific wcip
>    proposal?
>
>   The abstract design and specific instantiation were designed by
>   largely different groups of people and with different immediate
>   goals. A systematic comparison of the two designs may shed light on
>   both.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 Dec 2000 23:50:45 -0800

> >   goals. A systematic comparison of the two designs may shed light on

What I presented was primarily to get discussion going, especially
about the specific tasks that a protocol might have to address -- I'm
wary of calling it a 'design', as it's the product of some quick
whiteboarding about a week before San Diego.

Regarding the 'framework vs. specific protocol' issue, it seems to me
that calling it a framework only denotes that we acknowledge that it
may be used for other purposes in the future, and design with
extensibility/modularity in mind; it does not mean that we should try
and divine those purposes, or be restricted by them. 

Following on your comments above, I'd like to see us go forward by
stepping back and getting an idea of what we'd like to do -- through
a requirements document -- and then hold up the specific proposals
against them. This will allow us to make sure everyone's on the same
page, and to quickly determine how much work is to be done, as well
as whether our requirements are reasonable.

Dan, you've been working on WCIP for a fair amount of time. I'd be
very interested to see some use cases and the requirements that come
out of them, based on your experiences.

Cheers

-- 
Mark Nottingham, Research Scientist
Akamai Technologies (San Mateo, CA)