Subject: [XCON] FW: I-D ACTION:draft-koskelainen-xcon-xcap-cpcp-usage-01.txt

From: [email-masked]
Date: Mon, 27 Oct 2003 09:58:38 +0200

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of ext
> [email-masked]
> Sent: Friday, October 24, 2003 5:54 PM
> Subject: I-D ACTION:draft-koskelainen-xcon-xcap-cpcp-usage-01.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
> 	Title		: An Extensible Markup Language (XML) 
> Configuration Access Protocol (XCAP) Usage for Conference 
> Policy Manipulation
> 	Author(s)	: P. Koskelainen, H. Khartabil
> 	Filename	: draft-koskelainen-xcon-xcap-cpcp-usage-01.txt
> 	Pages		: 36
> 	Date		: 2003-10-23
> 	
> This document describes conference policy data elements and the
> mechanisms to manipulate them at a server via Conference Policy
> Control Protocol (CPCP). Extensible Markup Language (XML)
> Configuration Access Protocol (XCAP) is used to implement CPCP. This
> document specifies an XML Schema and XCAP application usage that are
> needed to implement CPCP.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-koskelainen-xcon-xca
> p-cpcp-usage-01.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body 
> of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-koskelainen-xcon-xcap-cpcp-usage-01.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE 
> /internet-drafts/draft-koskelainen-xcon-xcap-cpcp-usage-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: [email-masked]
Date: Mon, 27 Oct 2003 16:45:19 +0200

The draft has undergone minor changes in trying to meet all the requirements.

There has been one major change from the last version of the draft: The list of privileges that can be assigned to users in a conference has been trimmed down considerably. In fact, there is only one left.

The main reason for such a change is that, due to the nature of XCAP, most of the privileges either allow or disallow a user read/write access to certain parts of the CPCP XML document (eg: who can add users to the dial-out list. Adding a user to the dial-out list is achieved by XCAP). It is envisioned that XCAP would provide a solution whereby an XCAP usage document is accompanied by a privileges usage document (generic XCAP solution) that gives users certain read/write access to the XCAP usage document. It is also envisioned that the XCAP privileges usage document assigns privileges using namespaces. Therefore, you will see that the CPCP usage XML document was divided into namespaces (eg: dial-out list in a separate namespace). The privilege usage document will list the namespaces and the users with read/write access to it.

Please feel free to provide input on such proposal.

Regards,
Hisham

> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> [email-masked]
> Sent: Monday, October 27, 2003 9:59 AM
> To: [email-masked]
> Subject: [XCON] FW: I-D
> ACTION:draft-koskelainen-xcon-xcap-cpcp-usage-01.txt
> 
> 
> 
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon