Subject: [XCON] I-D ACTION:draft-ietf-xcon-cpcp-reqs-01.txt

From: [email-masked]
Date: Tue, 20 Jan 2004 15:43:34 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Centralized Conferencing Working Group of the IETF.

	Title		: Requirements for Conference Policy Control Protocol
	Author(s)	: P. Koskelainen
	Filename	: draft-ietf-xcon-cpcp-reqs-01.txt
	Pages		: 18
	Date		: 2004-1-20
	
The conference policy server allows clients to manipulate and
interact with the conference policy. One mechanism to manipulate the
policy is to use conference policy control protocol (CPCP). This
document gives the requirements for CPCP.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-01.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-xcon-cpcp-reqs-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-xcon-cpcp-reqs-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: [email-masked]
Date: Wed, 21 Jan 2004 15:23:17 +0200

Let me elaborate of the changes that we made to the requirements draft:

- floor control aligned with floor control requirements document
We added a few new requirements for floor control policy (note, not floor control protocol)

- removed the concept of hidden user
As Eric pre-emptively pointed out :)
We concluded that hidden user policy can be local implementation since the moderator of the conference who sets the policy and decides who is hidden and not could be the terrorist himself. Therefore we concluded that hidden users must be allowed by network administrators for any conference and must not result is a modification to the conference policy.

Of course those hidden users must be authenticated and authorised by the network.

- anonymous membership modified
Clarified that support is only for participants that are properly authenticated but appear as anonymous to other users.

- removed "inactive"
We concluded that an administrator requiring to suspend a conference for maintenance reasons can do so by modifying the start time of the conference. It is an implementation issue whether the administrator caches the current participants and invites them back to the conference once it starts again, or requires the participants to invite themselves back in (if on the dial-in list).

- added media type requirement (e.g. audio, video)
It was apparent that a conference creator needs to indicate to the conference server what media types to INVITE uses into the conference with. Some requirements were added to enable the conference creator to set the policy for that.

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> [email-masked]
> Sent: 20.January.2004 22:44
> Cc: [email-masked]
> Subject: [XCON] I-D ACTION:draft-ietf-xcon-cpcp-reqs-01.txt
> 
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon