Subject: RE: [XCON] CPCP Requirement: Repeat times

From: "Even, Roni" <[email-masked]>
Date: Wed, 7 Jan 2004 16:54:14 +0200

Paul,
The question is what is the usage for those parameters. A conference has a
duration. If you want time for reservation what I claim that this is not
enough. The issue of repeat times was mentioned. What about address books so
when reserving a conference you can select the participants. What is the
semantics of the time, will the server let you know if the reservation  is
OK when you reserve, will it let you know what are the resource availability
be time in the response. What I am saying that just having these two
parameter makes sense if you define what they are for, how you use them in
CPCP , what will the conference server do with them and what are the
response you can expect from the conference policy server. This needs to be
defined in order to have consistency between different implementations of
conference policy servers.

My video is that conference policy has nothing to do with reservation. BTW
the 3GPP MRF is only doing ad-hoc and reservation is handled by an
application server.

Roni Even

*************************************
Roni Even

Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099
email:[email-masked]
*******************************************

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Wednesday, January 07, 2004 4:35 PM
To: Even, Roni
Cc: [email-masked]'; [email-masked]; [email-masked]
Subject: Re: [XCON] CPCP Requirement: Repeat times

Roni,

To me this is splitting hairs. I think it makes sense to include start 
and stop time(s) in the conference policy - they are quite consistent 
with other kinds of policy information. How that policy gets acted upon 
is irrelevant, as long as it does get acted upon - it is an 
implementation detail. It might be acted upon directly by the policy 
server, or by a separate conference server, or some other way. The 
simple fact is that you can influence it by changing the policy using CPCP.

Do you really want to standardize another active entity and another 
protocol just for this?

	Paul

Even, Roni wrote:
> Hisham,
> 
> The conference server is not mentioned in
> draft-ietf-sipping-conferencing-framework-01. The framework mentioned the
> conference policy server. As for reservation my view is that reservation
is
> starting an ad-hoc conference when the schedule time has arrived and it
> should not be part of the conference policy. Reservation is a separate
> application from the conference policy. I suggest that if you want to
> address it then we should have a separate element in the frame work which
> will be a reservation server.
> 
> Roni
> 
> *************************************
> Roni Even
> 
> Polycom Israel
> 
> Tel: +972-3-9251200
> Cell: +972-55-481099
> email:[email-masked]
> *******************************************
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, January 07, 2004 11:22 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [XCON] CPCP Requirement: Repeat times 
> 
> 
> No, the focus host (conference server) is the one that handles the
> reservations. The focus is only created and destroyed by the conference
> server according to the start and stop times.
> 
> /Hisham
> 
> 
>>-----Original Message-----
>>From: ext Even, Roni [mailto:[email-masked]]
>>Sent: 06.January.2004 19:06
>>To: Koskelainen Petri (Nokia-NRC/Tampere); Even, Roni; 
>>Khartabil Hisham
>>(Nokia-TP/Helsinki); [email-masked] '
>>Subject: RE: [XCON] CPCP Requirement: Repeat times 
>>
>>
>>Hi Petri,
>>The CPS is a data storage that is used by the focus, so the 
>>focus will have
>>to handle the reservation
>>Roni
>>
>>-----Original Message-----
>>From: [email-masked]
>>To: [email-masked]; [email-masked]; [email-masked]
>>Sent: 06/01/2004 18:50
>>Subject: RE: [XCON] CPCP Requirement: Repeat times 
>>
>>Hi Roni,
>>
>>
>>>My opinion is that the conference policy needs only a 
>>>conference duration parameter if any. 
>>>I think that reservation is an external 
>>>application to the focus. According to the conference 
>>>framework the focus is using the information in the 
>>>conference policy server and the focus is 
>>>not the right place for reservation.
>>
>>The reservation is sent to CPS, not to focus.
>>I think it makes sense to have this (repeat time) capability 
>>in protocol
>>since we need the feature anyway in real-world (either in CPCP
>>or in some new mystery protocol between the user and the reservation
>>application).
>>
>>
>>
>>--
>>Petri
>>
>>
>>
>>>Regards
>>>Roni Even
>>>
>>>-----Original Message-----
>>>From: [email-masked] [mailto:[email-masked]]
>>>Sent: Monday, December 15, 2003 4:57 PM
>>>To: [email-masked]
>>>Subject: [XCON] CPCP Requirement: Repeat times
>>>
>>>
>>>A conference has start and stop times. Although the current proposed
>>>solution has repeat times (eg: meeting repeats weekly), there is no
>>>requirement for such.
>>>
>>>Do we see a need for such capability using CPCP? If so, then 
>>>we need to add
>>>a requirement.
>>
> 
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/xcon
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 07 Jan 2004 11:17:45 -0500

Even, Roni wrote:
> enough. The issue of repeat times was mentioned.

That seems like just another representation for multiple start/stop times.

> What about address books so
> when reserving a conference you can select the participants.

What about them? That seems entirely irrelevant to this discussion. If 
you have address books, then use them with some tool that creates your 
conference policy before submitting it via CPCP.

 > What is the
> be time in the response.

It seems logical to me that the policy server should refuse to accept 
the policy if some attribute in it is unacceptable. A situation where 
the resources aren't available at the specified times seems to fall into 
that category.

If you want a tool that can help you select a time when the resources 
are available, that is a different story. I think it falls into the 
category of a tool for creating policy.

 > What I am saying that just having these two

Well yes, clearly there is some amount of definition that is currently 
lacking. But it doesn't seem like so much.

> the 3GPP MRF is only doing ad-hoc and reservation is handled by an

Just a different way to slice the pie.

In any case, there is probably a role for an application server that 
provides a UI for creating conference policy. I would expect such things 
to be layered on what is being defined here, and not to be standardized.

	Paul