Subject: RE: [XCON] CPCP Requirement: Repeat times

From: [email-masked]
Date: Wed, 21 Jan 2004 15:26:06 +0200

There is no need to blow up a simple requirement of start, stop and repeat times which can easily be handled in CPCP to be the size of calendering that requires a separate protocol that needs to be somehow linked to the corresponding conference policy.

/Hisham

> -----Original Message-----
> From: ext Eric Burger [mailto:[email-masked]]
> Sent: 21.January.2004 15:15
> To: Khartabil Hisham (Nokia-TP/Helsinki); [email-masked]
> Subject: RE: [XCON] CPCP Requirement: Repeat times 
> 
> 
> So the use case isn't "I'm taking the bridge out of service 
> for maintenance", but "I have a weekly meeting, except for next week."
> 
> That would be better handled by a calendaring application 
> (i.e., why it doesn't belong in XCON).
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Wednesday, January 21, 2004 8:10 AM
> > To: Eric Burger; [email-masked]; 
> [email-masked];
> > [email-masked]
> > Subject: RE: [XCON] CPCP Requirement: Repeat times 
> > 
> > 
> > Yes.
> > 
> > We all have weekly meetings with predefined start and stop 
> > times. I think it is a valid use case for a user to create a 
> > conference policy to satisfy this once and once only.
> > 
> > Regards,
> > Hisham
> > 
> > > -----Original Message-----
> > > From: ext Eric Burger [mailto:[email-masked]]
> > > Sent: 20.January.2004 18:01
> > > To: Even, Roni; Khartabil Hisham (Nokia-TP/Helsinki); 
> > > Koskelainen Petri
> > > (Nokia-NRC/Tampere); [email-masked]
> > > Subject: RE: [XCON] CPCP Requirement: Repeat times 
> > > 
> > > 
> > > For that matter, is there a use case for end points (XCON) 
> > > doing such complicated scheduling?  Why don't we just take 
> > > the bridge out of service?
> > > 
> > > Wow!  Agreeing with Roni twice in one day!!!
> > > 
> > > 
> > > > -----Original Message-----
> > > > From: Even, Roni [mailto:[email-masked]]
> > > > Sent: Wednesday, January 07, 2004 4:56 AM
> > > > To: [email-masked]'; Even, Roni;
> > > > [email-masked]; [email-masked]
> > > > Subject: RE: [XCON] CPCP Requirement: Repeat times 
> > > > 
> > > > 
> > > > Hisham,
> > > > 
> > > > The conference server is not mentioned in
> > > > draft-ietf-sipping-conferencing-framework-01. The framework 
> > > > mentioned the
> > > > conference policy server. As for reservation my view is that 
> > > > reservation is
> > > > starting an ad-hoc conference when the schedule time has 
> > > > arrived and it
> > > > should not be part of the conference policy. Reservation is 
> > > a separate
> > > > application from the conference policy. I suggest that if 
> > > you want to
> > > > address it then we should have a separate element in the 
> > > > frame work which
> > > > will be a reservation server.
> > > > 
> > > > Roni
> > > > 
> > > > *************************************
> > > > Roni Even
> > > > 
> > > > Polycom Israel
> > > > 
> > > > Tel: +972-3-9251200
> > > > Cell: +972-55-481099
> > > > email:[email-masked]
> > > > *******************************************
> > > > 
> > > > 
> > > > -----Original Message-----
> > > > From: [email-masked] 
> > [mailto:[email-masked]]
> > > > Sent: Wednesday, January 07, 2004 11:22 AM
> > > > To: [email-masked]; [email-masked]; 
> > > > [email-masked]
> > > > Subject: RE: [XCON] CPCP Requirement: Repeat times 
> > > > 
> > > > 
> > > > No, the focus host (conference server) is the one that 
> handles the
> > > > reservations. The focus is only created and destroyed by the 
> > > > conference
> > > > server according to the start and stop times.
> > > > 
> > > > /Hisham
> > > > 
> > > > > -----Original Message-----
> > > > > From: ext Even, Roni [mailto:[email-masked]]
> > > > > Sent: 06.January.2004 19:06
> > > > > To: Koskelainen Petri (Nokia-NRC/Tampere); Even, Roni; 
> > > > > Khartabil Hisham
> > > > > (Nokia-TP/Helsinki); [email-masked] '
> > > > > Subject: RE: [XCON] CPCP Requirement: Repeat times 
> > > > > 
> > > > > 
> > > > > Hi Petri,
> > > > > The CPS is a data storage that is used by the focus, so the 
> > > > > focus will have
> > > > > to handle the reservation
> > > > > Roni
> > > > > 
> > > > > -----Original Message-----
> > > > > From: [email-masked]
> > > > > To: [email-masked]; [email-masked]; 
> > > > [email-masked]
> > > > > Sent: 06/01/2004 18:50
> > > > > Subject: RE: [XCON] CPCP Requirement: Repeat times 
> > > > > 
> > > > > Hi Roni,
> > > > > 
> > > > > > My opinion is that the conference policy needs only a 
> > > > > > conference duration parameter if any. 
> > > > > > I think that reservation is an external 
> > > > > > application to the focus. According to the conference 
> > > > > > framework the focus is using the information in the 
> > > > > > conference policy server and the focus is 
> > > > > > not the right place for reservation.
> > > > > 
> > > > > The reservation is sent to CPS, not to focus.
> > > > > I think it makes sense to have this (repeat time) capability 
> > > > > in protocol
> > > > > since we need the feature anyway in real-world (either in CPCP
> > > > > or in some new mystery protocol between the user and the 
> > > reservation
> > > > > application).
> > > > > 
> > > > > 
> > > > > 
> > > > > --
> > > > > Petri
> > > > > 
> > > > > 
> > > > > > Regards
> > > > > > Roni Even
> > > > > > 
> > > > > > -----Original Message-----
> > > > > > From: [email-masked] 
> > > [mailto:[email-masked]]
> > > > > Sent: Monday, December 15, 2003 4:57 PM
> > > > > To: [email-masked]
> > > > > Subject: [XCON] CPCP Requirement: Repeat times
> > > > > 
> > > > > 
> > > > > A conference has start and stop times. Although the 
> > > current proposed
> > > > > solution has repeat times (eg: meeting repeats weekly), 
> > > there is no
> > > > > requirement for such.
> > > > > 
> > > > > Do we see a need for such capability using CPCP? If so, then 
> > > > > we need to add
> > > > > a requirement.
> > > > 
> > > 
> > > _______________________________________________
> > > XCON mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/xcon
> > > 
> > > 
> > > 
> > 
> > 
> 
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 21 Jan 2004 08:46:01 -0500

[email-masked] wrote:

> There is no need to blow up a simple requirement of start, stop and
> repeat times which can easily be handled in CPCP to be the size of
> calendering that requires a separate protocol that needs to be
> somehow linked to the corresponding conference policy.

As soon as you have repeat times, you run into the problem that people 
expect to be able to export real calsch-like repeat times ("every other 
Monday, except if it is Dec. 25"), not just the basic subset. We had the 
same discussion for CPL and ended up with calsch, rather than trying to 
do 20% or 50% of it.