Subject: RE: [XCON] CPCP Requirement: de-activating a conference

From: "Even, Roni" <[email-masked]>
Date: Tue, 6 Jan 2004 14:22:09 +0200

Brian,
My suggestion is not to have reservation in the conference policy. The
conference policy is used by the focus according to the conference framework
and the focus is not the place for handling reservation. I think that
reservation is handled by an external application server that will start the
conference using CPCP at the time when the conference scheduled time has
arrived. The focus may use the conference duration information in order to
notify the participants that it the conference end-time is coming and
terminate the conference. Extension of the should be done using CPCP either
by the participant or an application server.
Roni

*************************************
Roni Even
VP Product Planning
Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099
email:[email-masked]
*******************************************

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, December 15, 2003 4:25 PM
To: [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Again, I'm worried about "privileged users".  I think we need to finish
some discussions we started a while ago that essentially are semantics.
What is an "inactivated" conference, and how does it differ from a
conference that can be re-instantiated (a weekly meeting for example)?

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, December 15, 2003 7:57 AM
> To: [email-masked]
> Subject: [XCON] CPCP Requirement: de-activating a conference
> 
> 
> This is in reference to requirement REQ-B9 in 
> http://www.ietf.org/internet-drafts/draft-ietf-xcon-cpcp-reqs-00.txt
> 
>    REQ-B9: It MUST be possible to inactive a conference for defined
>    period of time.
> 
> There are start and stop times for a conference. A conference 
> might live for days, weeks or even months. Should a 
> conference policy, using CPCP, allow a privileged user to 
> de-activate a conference for a period of time within the 
> start and stop times of a conference? Examples are 
> administrator is performing some maintenance.
> 
> Regards,
> Hisham
> 
> _______________________________________________
> XCON mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/xcon
> 

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 6 Jan 2004 09:13:57 -0500

I don't like this idea because I think that we need a standardized interface
for scheduling and "external application server" sounds very proprietary to
me.  I guess I could be convinced we need a separate interface, with a
separate protocol (maybe it could be iCal), but I'm not yet convinced
just specifying a start time in the future isn't a sufficient reservation
mechanism.

Brian

-----Original Message-----
From: Even, Roni [mailto:[email-masked]]
Sent: Tuesday, January 06, 2004 7:22 AM
To: 'Rosen, Brian'; [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian,

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, December 15, 2003 4:25 PM
To: [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 6 Jan 2004 16:22:32 +0200

Brian,
So you see the focus as managing reservation, this means we have to go back
to the framework document and decide how to handle reservation. I did not
see the requirement to have it as part of the conferencing architecture
since it does not apply only to conferencing. Reservation is a general topic
that address also the conference rooms, the people and the equipment. That
is why I think it is outside of the conferencing architecture
Roni Even

Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Tuesday, January 06, 2004 4:14 PM
To: 'Even, Roni'
Cc: [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian

-----Original Message-----
From: Even, Roni [mailto:[email-masked]]
Sent: Tuesday, January 06, 2004 7:22 AM
To: 'Rosen, Brian'; [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian,

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, December 15, 2003 4:25 PM
To: [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 6 Jan 2004 09:46:43 -0500

Clearly, xcon can only address the "equipment" part of the problem.

What is wrong with making the start time in the future?  I think it is
quite sufficient.  The actual mechanism the focus uses to maintain
resource reservation is beyond scope, but the actual reservation seems
to be simple.

Brian

-----Original Message-----
From: Even, Roni [mailto:[email-masked]]
Sent: Tuesday, January 06, 2004 9:23 AM
To: 'Rosen, Brian'; Even, Roni
Cc: [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian,

Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Tuesday, January 06, 2004 4:14 PM
To: 'Even, Roni'
Cc: [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian

-----Original Message-----
From: Even, Roni [mailto:[email-masked]]
Sent: Tuesday, January 06, 2004 7:22 AM
To: 'Rosen, Brian'; [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian,

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, December 15, 2003 4:25 PM
To: [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Brian

---

From: [email-masked]
Date: Tue, 6 Jan 2004 18:50:43 +0200

I agree with Brian.

Petri

> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> Rosen, Brian
> Sent: 06 January, 2004 16:47
> To: 'Even, Roni'
> Cc: Khartabil Hisham (Nokia-TP/Helsinki); [email-masked]

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 13 Jan 2004 16:54:48 -0000

I do not remember seeing the existence of this separate protocol in any of the conferencing documents so far (either in SIPPING or XCON). (If I am wrong then pointers gratefully received). If it exists, then I think we should clearly identify what its scope is, if only to aid the discussion of what the other protocols may or may not do.

We clearly need a start and stop time for conferencing. At the moment the only protocol it can be in is the CPCP. If we are going to have an informed discussion about why it is not in CPCP we need to understand clearly what the alternative protocol is.

regards

Keith

> Sent: 06 January 2004 14:14
> To: 'Even, Roni'

---

From: "Even, Roni" <[email-masked]>
Date: Wed, 14 Jan 2004 10:18:13 +0200

Hi,

I did not think that the conference work was also addressing reservation
systems and that is why it is not clear to me why we need the start and stop
time of a conference in CPCP. If conference reservation is in the scope of
the work then we need some more parameters in CPCP for supporting it. We
also need to understand what it may support for example can I give a start
time in 2050, what about next month, can I learn from CPCP what resources
are available at a specific time.  If the start and stop time are only what
they sound and the application is handled by an application server then what
is the difference between having a start and stop time and letting the
application server start the conference when the scheduled time has arrived
Thanks
Roni Even

Polycom Israel

Tel: +972-3-9251200
Cell: +972-55-481099

-----Original Message-----
From: Drage, Keith (Keith) [mailto:[email-masked]]
Sent: Tuesday, January 13, 2004 6:55 PM
To: 'Rosen, Brian'; 'Even, Roni'
Cc: [email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

I do not remember seeing the existence of this separate protocol in any of
the conferencing documents so far (either in SIPPING or XCON). (If I am
wrong then pointers gratefully received). If it exists, then I think we
should clearly identify what its scope is, if only to aid the discussion of
what the other protocols may or may not do.

We clearly need a start and stop time for conferencing. At the moment the
only protocol it can be in is the CPCP. If we are going to have an informed
discussion about why it is not in CPCP we need to understand clearly what
the alternative protocol is.

regards

Keith

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 14 Jan 2004 11:35:52 -0000

May I was not so clear in my original mail.

I do not propose we define a reservation protocol.

However something like the framework document should clearly identify that things like reservation protocols may exist (if indeed they do), and define its scope.

In considering requirements for CPCP we can then evaluate whether they are in scope for CPCP or in scope for the reservation protocol, rather than seemingly a more ad-hoc judgement of whether it is nice to put it in CPCP.

regards

Keith

> Sent: 14 January 2004 08:18
> To: 'Drage, Keith (Keith)'; 'Rosen, Brian'; Even, Roni

---

From: Michael Hammer <[email-masked]>
Date: Wed, 14 Jan 2004 10:01:59 -0500

Roni,

I am still a little fuzzy on what is/is not being addressed.

For example, if the conference moderator wanted to create breakout sessions 
with defined start and stop times with assigned participants, could this be 
setup with CPCP such that the breakouts are created in 10 minutes, then 
terminate after another 10 minutes?  Note, for certain purposes, one may 
want to disallow independent sidebars using that conference server.

Is this possible?

Mike

---

From: "Even, Roni" <[email-masked]>
Date: Wed, 14 Jan 2004 17:14:15 +0200

Mike,
This is a service that is not available by all conference bridges and will
need to be implemented by an application server that will use CPCP to start
the breakout session and invite the participants to it. 
What happens in the end of the breakout session, does the conference bridge
bring all to the main conference, can the moderator extend it,, all these
are applications and not part of the conference service in my view
Roni

-----Original Message-----
From: Michael Hammer [mailto:[email-masked]]
Sent: Wednesday, January 14, 2004 5:02 PM
To: Even, Roni
Cc: 'Drage, Keith (Keith)'; 'Rosen, Brian'; Even, Roni;
[email-masked]'; [email-masked]
Subject: RE: [XCON] CPCP Requirement: de-activating a conference

Roni,

Is this possible?

Mike

---

From: "Eric Burger" <[email-masked]>
Date: Tue, 20 Jan 2004 11:27:41 -0500

I *very* much agree with Roni here.  I would argue that CPCP should have small primitives that applications can build arbitrarily complex behaviors.

Let us not try to put everything in CPCP.  As Roni has said in a few messages, reservation processing is extremely complex.  There is no reason to put all of this into CPCP.  Just starting and ending a conference is enough.  All of the complex behaviors that people have been discussing can be built on this.

> Sent: Wednesday, January 14, 2004 10:14 AM
> To: 'Michael Hammer'; Even, Roni
> >systems and that is why it is not clear to me why we need 
> the start and
> stop
> >they sound and the application is handled by an application 
> server then
> what