Subject: [XCON] CPCP Start/stop Proposal

From: "Eric Burger" <[email-masked]>
Date: Tue, 10 Feb 2004 01:29:01 -0500

Since I started the thread "CPCP Requirement: Repeat times", which has generated over 200 pages of responses (yes, I print stuff out to read on airplanes), I thought I would give a concrete proposal that I _hope_ will satisfy most of the excellent comments generated.

First, two definitions:

The CPCP Conference Start Time is the earliest mixing opportunity for a conference.  If you want to advertise a user-level start time, like when you can call into a bridge and talk to an IVR system or listen to a wonderful selection of music-on-hold, advertise the user-level start time with SAP.

The CPCP End Time is the time mixing ceases for a conference.  If you want to advertise a user-level stop time, like when everyone is supposed to go out for lunch, but might not be the stop time, if things are going peachy, advertise the user-level stop time with SAP.

A Named Participant is a "special" participant.  Usually this is the conference owner.  I would be happy to replace Named Participant with Conference Owner, but I was thinking about delegating authority, e.g., "Start this conference when I or my secretary join the bridge."  Also, if one examines CPCP End Time condition 2c, one can envision a policy that states, "Keep the bridge up until both the CEO and the COO leave the bridge."

With those definitions, here is the proposal:

The CPCP Start Time is the latter of:
1. A specified Earliest Mixing Time (which can be NOW or a time delta/GMT)
   -  AND ONE OF  -
  2a. The time the first participant arrives
      -  OR  -
  2b. The time a Named Participant arrives

The CPCP End Time is the earlier of:
1. A specified End of Mixing Time (which can be NOW, NEVER, or a time delta/GMT)
   - AND ONE OF  -
  2a. The time the last participant leaves
      -  OR  -
  2b. The time a Named Participant leaves
      -  OR  -
  2c. The time the last Named Participant leaves
      -  OR  -
  2d. Persistent (e.g., only the time (condition 1) matters)

_______________________________________________
XCON mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/xcon

---

From: "Eric Burger" <[email-masked]>
Date: Tue, 10 Feb 2004 10:04:30 -0500

nonononononono!

It is NOT your choice:  it is MY choice!!!

These rules let me do ALL of the things that people want to do.  Isn't that the idea of policy: here are a few, simple rules that let one construct whatever service (meet-me, hard-stop scheduled, end when last leaves, end when time runs out, etc.) one wants?

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, February 10, 2004 3:34 AM
> To: Eric Burger; [email-masked]
> Subject: RE: [XCON] CPCP Start/stop Proposal
> 
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of ext
> > Eric Burger
> > Sent: 10.February.2004 08:29
> > To: IETF XCON Discussion List (E-mail)
> > Subject: [XCON] CPCP Start/stop Proposal
> > 
> > 
> > Since I started the thread "CPCP Requirement: Repeat times", 
> 
> You really think so? Check again ;)
> 
> > which has generated over 200 pages of responses (yes, I print 
> > stuff out to read on airplanes), I thought I would give a 
> > concrete proposal that I _hope_ will satisfy most of the 
> > excellent comments generated.
> > 
> > 
> > First, two definitions:
> > 
> > The CPCP Conference Start Time is the earliest mixing 
> > opportunity for a conference.  If you want to advertise a 
> > user-level start time, like when you can call into a bridge 
> > and talk to an IVR system or listen to a wonderful selection 
> > of music-on-hold, advertise the user-level start time with SAP.
> > 
> > The CPCP End Time is the time mixing ceases for a conference. 
> >  If you want to advertise a user-level stop time, like when 
> > everyone is supposed to go out for lunch, but might not be 
> > the stop time, if things are going peachy, advertise the 
> > user-level stop time with SAP.
> > 
> > A Named Participant is a "special" participant.  Usually this 
> > is the conference owner.  I would be happy to replace Named 
> > Participant with Conference Owner, but I was thinking about 
> > delegating authority, e.g., "Start this conference when I or 
> > my secretary join the bridge."  Also, if one examines CPCP 
> > End Time condition 2c, one can envision a policy that states, 
> > "Keep the bridge up until both the CEO and the COO leave 
> the bridge."
> > 
> > 
> 2a is my choice
> 2d is my choice here as well. Some conferences might still 
> run eventhough there are no current participants.
> 
> Here is what our solution says:
> 
>    If the <Start-time> element is not present, it
>    indicates that the conference starts immediately. If the 
> <Stop-time>
>    is set to zero, then conference occurrence is not bounded, i.e.
>    permanent, though it will not become active until the <Start-time>.
>    If the <Stop-time> element is not present, it indicates that the
>    conference terminates as soon as the last participant leaves the
>    conference.
> 
> /Hisham
> 
> > 
> >

---

From: [email-masked]
Date: Tue, 10 Feb 2004 17:12:06 +0200

Eric, you should be using [email-masked].

/Hisham

> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> Eric Burger
> "Keep the bridge up until both the CEO and the COO leave the bridge."
> 
>

---

From: [email-masked]
Date: Tue, 10 Feb 2004 17:13:01 +0200

> From: Khartabil Hisham (Nokia-TP/Helsinki) 
> Sent: 10.February.2004 10:34
> To: 'ext Eric Burger'; IETF XCON Discussion List (E-mail)

---

From: [email-masked]
Date: Tue, 10 Feb 2004 17:13:31 +0200

> From: ext Eric Burger [mailto:[email-masked]]
> Sent: 10.February.2004 16:57
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]
> These rules let me do ALL of the things that people want to 
> do.  Isn't that the idea of policy: here are a few, simple 
> rules that let one construct whatever service (meet-me, 
> hard-stop scheduled, end when last leaves, end when time runs 
> out, etc.) one wants?
>

---

From: [email-masked]
Date: Tue, 10 Feb 2004 17:13:57 +0200

> From: Khartabil Hisham (Nokia-TP-MSW/Helsinki) 
> Sent: 10.February.2004 17:10
> To: 'ext Eric Burger'; [email-masked]
> Ok, I misunderstood what you meant earlier: You are saying 
> that the creator of the conference needs to have those 
> choices and the policy needs to enable creators to set that choice.
> 
> In this case, I would like to add the start-time a 2c: 
> Persistent (e.g., only the time (condition 1) matters). I 
> would also remove 2c for stop-time.
> 
> /Hisham
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 10 Feb 2004 10:24:38 -0500

Will I beat Eric to the reply.  Stay tuned.

Nope, there is no point in saying start of mixing occurs when there are no
participants.
Remember this isn't a resource reservation mechanism (although it might
trigger
one in the mixer).

2c is the one that counts, I think.  If my admin and I are named, and she
leaves,
I don't want the conference to stop.  2b is the one you could do without.

Brian

> Sent: Tuesday, February 10, 2004 10:14 AM
> To: [email-masked]
> Subject: FW: [XCON] CPCP Start/stop Proposal
> 
> 
> 
>

---

From: "Eric Burger" <[email-masked]>
Date: Tue, 10 Feb 2004 10:45:07 -0500

Considering the user's perspective, is there a difference between

     CPCP Start Time = n/a and Persistent

and

     CPCP Start Time = NOW and Time First Participant Arrives

???

I would offer that from the user's perspective, there is no difference.  However, there may be differences from a resource allocation perspective.

The CPCP Stop Time (2c) parameter is for the distributed stock analyst briefing, where the CxO's are calling in from different locations.  We want the conference to end when the CxO's all leave.  That's easy if they are in the same phone in the same room.  In the old terminology, they are the conference creator and the conference ends when they leave.  However, consider the case where the CFO is traveling and dials in.  The CEO calls in, creating the conference.  The CFO joins in.  The analysts join in.  The CEO needs to drop out for a while.  However, since the CFO is still on the call, the desired behavior is to keep the conference active -- the CFO is still talking.  For this scenario, the CEO and CFO are the Named Participants.  The conference is active so long as one or more Named Participants are still in conference.

I know I have wanted that behavior in the past.

> Sent: Tuesday, February 10, 2004 10:10 AM

---

From: "Eric Burger" <[email-masked]>
Date: Tue, 10 Feb 2004 10:04:30 -0500

Inline.

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Tuesday, February 10, 2004 7:41 AM
> To: Eric Burger; IETF XCON Discussion List (E-mail)
> Several issues, but getting there.
> 
> 1. You don't have a way to specify a traditional MeetMe, which is
> not dependent on Start Time.  So, I would add a 3a)Any participant
> arrives (independent of start time) and 3b) Named participant arrives
> (independent of stop time).

MeetMe:
CPCP Start Time = NOW (1) and Time First Participant Arrives (2a)
CPCP End Time = NEVER (1) and Time Last Participant Leaves (2a)

> 
> 2. Forcing you to back up the stop time just because you 
> ended early is 
> silly.  There is no point in saying end time is later than 
> all participant
> leaving in most cases.  I can come up with a case (you want people to
> come and go, even to the point where there are no people on 
> the bridge,
> but the conference stays up until the stop time is reached.  
> So, I would
> redefine Conference Stop Time to be
> 	2a) All participants leave
> 	2b) All named participants leave
> 	2c) Stop time exceeded
> 	2d) Stop time exceeded and all participants leave
> 	2e) Stop time exceeded and all named participants leave

You don't have to backup the stop time.  If your policy is "when last participant leaves", that is often EARLIER than the CPCP End Time.

> > From: Eric Burger [mailto:[email-masked]]
> > Sent: Tuesday, February 10, 2004 1:29 AM

---

From: [email-masked]
Date: Tue, 10 Feb 2004 17:55:00 +0200

> From: ext Rosen, Brian [mailto:[email-masked]]
> Sent: 10.February.2004 17:25
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki); [email-masked]

We need to assume here that participant joining also means that the focused has dialed out to them. Can I make the assumption that the start-time will also trigger those dial outs?

> I don't want the conference to stop.  2b is the one you could 

Ok.

Hisham

---

From: [email-masked]
Date: Tue, 10 Feb 2004 18:00:53 +0200

> Sent: 10.February.2004 17:04
> To: Rosen, Brian; IETF XCON Discussion List (E-mail)

Well, I guess this depends on the way the solution is specified. For example, the solution can specify a mandatory element <start-time> with a marco value NOW, or it can specify an optional element <start-time> that when not present, means now.

/Hisham

> You don't have to backup the stop time.  If your policy is 
> "when last participant leaves", that is often EARLIER than 
> the CPCP End Time.
> 
> > 
> > 
> > Brian
> >

---

From: Michael Hammer <[email-masked]>
Date: Tue, 10 Feb 2004 11:38:59 -0500

Eric,

"Named Participant" is somewhat vague as to intent.
Could you instead say "Key Participant" and stop when said list=0?

Mike

At 10:45 AM 2/10/2004 -0500, Eric Burger wrote:
>I would offer that from the user's perspective, there is no 
>difference.  However, there may be differences from a resource allocation 
>perspective.
>
>
>The CPCP Stop Time (2c) parameter is for the distributed stock analyst 
>briefing, where the CxO's are calling in from different locations.  We 
>want the conference to end when the CxO's all leave.  That's easy if they 
>are in the same phone in the same room.  In the old terminology, they are 
>the conference creator and the conference ends when they leave.  However, 
>consider the case where the CFO is traveling and dials in.  The CEO calls 
>in, creating the conference.  The CFO joins in.  The analysts join 
>in.  The CEO needs to drop out for a while.  However, since the CFO is 
>still on the call, the desired behavior is to keep the conference active 
>-- the CFO is still talking.  For this scenario, the CEO and CFO are the 
>Named Participants.  The conference is active so long as one or more Named 
>Participants are still in conference.
>

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 11 Feb 2004 11:00:27 -0500

Call it fruit juice if you want :-)

Key Participant is a better term.  Go for it.

> From: Michael Hammer [mailto:[email-masked]]
> Sent: Tuesday, February 10, 2004 11:39 AM
> To: Eric Burger
> Cc: [email-masked]; IETF XCON Discussion List (E-mail)

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 11 Feb 2004 11:00:27 -0500

That's a syntax issue.  Fine w/ me.

> Sent: Tuesday, February 10, 2004 11:01 AM
> To: Eric Burger; [email-masked]; [email-masked]
> Well, I guess this depends on the way the solution is 
> specified. For example, the solution can specify a mandatory 
> element <start-time> with a marco value NOW, or it can 
> specify an optional element <start-time> that when not 
> present, means now.
> 
> /Hisham
> 
> > 
> > >