Subject: [XCON] draft-ietf-xcon-ccmp-02

From: "Duddy, Sean (Sean)" <[email-masked]>
Date: Thu, 9 Apr 2009 17:54:39 +0100

Hi Folks,
    How does a ccmp client request a specify media type for its
conference
(e.g. audio or audio+video or video only)? 
 
Th data model has an <available-media> element but only the server has
the 
information to populate this
(http://tools.ietf.org/html/rfc4575#section-5.3.4)
and the definition of this element alone implies what media is available
and not 
how to request a specific media...
 
Regards
Sean

---

From: "Mary Barnes" <[email-masked]>
Date: Fri, 24 Apr 2009 14:53:23 -0500

Hi Sean,
 
Apologies, as I can't see that anyone ever responded to your question.
Yes, the server would be the one to populate the <available-media>
element. Per the XCON framework this is information that would be part
of the blueprint.  
 
There is a <mixer-type> for each <user> element that contains the type
of media and a <controls> element in the data model that contain basic
video and audio controls.  For each <endpoint> there is a <media>
element in the data model to capture the source of
media(<to-mixer>/<from-mixer>  for a specific endpoint.  These types are
all borrowed from RFC 4575, so they are not described in the xcon
data-model document. 
 
And, there are specific media control elements for floor control.  
 
When a client is joining a conference, the setup of a specific media
type would be negotiated between the signaling and media control client
(e.g., SIP client) and the focus.  And, something like the mediactrl
protocol could be used, which is what is shown in the call flows
document:
http://tools.ietf.org/id/draft-barnes-xcon-examples-01.txt
 
Does that answer your question?
 
Regards,
Mary. 
 
________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Duddy, Sean (Sean)
Sent: Thursday, April 09, 2009 11:55 AM
To: [email-masked]
Subject: [XCON] draft-ietf-xcon-ccmp-02

Hi Folks,

Regards
Sean