Subject: Re: [XCON] draft-ietf-xcon-common-data-model-19

From: "Duddy, Sean (Sean)" <[email-masked]>
Date: Wed, 2 Jun 2010 17:39:54 +0100

Hi All,
    The latest version of the data model defines the conference-password
as single string. In version 17 it was changed to be a list.
Why was this change reverted?
 
Sean

________________________________

From: Oscar Novo [mailto:[email-masked]] 
Sent: 03 February 2010 15:11
To: Duddy, Sean (Sean); [email-masked]
Subject: RE: draft-ietf-xcon-common-data-model-14

Hi Sean,
 
True, the field should be defined as multiple password. I'll change that
in the following version of the draft.
The propose to have different passwords in the flexibility to have
different set of users with different credentials. So, the conference
server can restrict access to a set of users by just removing the
credentials from the server.
 
I think the extension of the <conf-uris> element is not really needed
since the limitations of the credentials can be done using the same
roles (you might want to restrict access to the group of participants A
but not the group of participants B).
 
Regards,
 
Oscar

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Duddy, Sean (Sean)
Sent: 27. tammikuuta 2010 14:14
To: [email-masked]
Subject: [XCON] draft-ietf-xcon-common-data-model-14

Hi all,
    The new password field in  draft-ietf-xcon-common-data-model-14 is
defined as follows:-
 
    <xs:element name="conference-password" type="xs:string"/>

In section 4.2.10, it states that this field contain password(s). What
would be the usecase for multiple passcodes on the same URI?
If it is a valid use case then the xsd type for this should xs::list.
 
Does the purpose field defined in rfc4575 need to be extended to
indicate the type of URI i.e. moderator,particpant etc?
Or how would a client that just created a conference distinguish between
the URIs?
 
Regards
Sean

---

From: Oscar Novo <[email-masked]>
Date: Thu, 3 Jun 2010 09:16:50 +0200

Hello,

Conference-password still is a list of password (check the rnc/rng schema and the text). In the w3c schema the conference-password is a string of multiple passwords.
It was changed because the w3c schema was wrong before.

Cheers,

Oscar
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Duddy, Sean (Sean)
Sent: 2. kesäkuuta 2010 19:40
To: [email-masked]
Subject: Re: [XCON] draft-ietf-xcon-common-data-model-19

Hi All,
    The latest version of the data model defines the conference-password as single string. In version 17 it was changed to be a list.
Why was this change reverted?

Sean

Hi Sean,

True, the field should be defined as multiple password. I'll change that in the following version of the draft.
The propose to have different passwords in the flexibility to have different set of users with different credentials. So, the conference server can restrict access to a set of users by just removing the credentials from the server.

I think the extension of the <conf-uris> element is not really needed since the limitations of the credentials can be done using the same roles (you might want to restrict access to the group of participants A but not the group of participants B).

Regards,

Oscar

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Duddy, Sean (Sean)
Sent: 27. tammikuuta 2010 14:14
To: [email-masked]
Subject: [XCON] draft-ietf-xcon-common-data-model-14

Hi all,
    The new password field in  draft-ietf-xcon-common-data-model-14 is defined as follows:-

In section 4.2.10, it states that this field contain password(s). What would be the usecase for multiple passcodes on the same URI?
If it is a valid use case then the xsd type for this should xs::list.

Does the purpose field defined in rfc4575 need to be extended to indicate the type of URI i.e. moderator,particpant etc?
Or how would a client that just created a conference distinguish between the URIs?

Regards
Sean

---

From: "Duddy, Sean (Sean)" <[email-masked]>
Date: Thu, 3 Jun 2010 10:53:21 +0100

Hi Oscar,
 
Ok before it was of type <xs:list itemType="xs:string"/> now it is of type xs:string.
 
So what is the delimiting character(s) that seperate each password in the string?
 
I would have thought a list is more appropriate...

From: Oscar Novo [mailto:[email-masked]] 
Sent: 03 June 2010 08:17
To: Duddy, Sean (Sean); [email-masked]
Subject: RE: draft-ietf-xcon-common-data-model-19

Hello,

Cheers,
 
Oscar

Hi All,
 
Sean

Hi Sean,

 
Regards,
 
Oscar

Hi all,

 
 
Regards
Sean

---

From: Oscar Novo <[email-masked]>
Date: Thu, 3 Jun 2010 13:45:37 +0200

Hello,

I really recommend you to look at the rng/rnc schema, not at the w3c schema. RELAX NG schema is the 'oficial' schema of the data model. The w3c schema is just an informative schemas and w3c schemas have limitations such as the case you asked me.

Regarding your question, it's up to the implementor but it could be whitespaces if we think that, normally,  a password with whitespaces is not valid.

Cheers,

Oscar

________________________________
From: Duddy, Sean (Sean) [mailto:[email-masked]]
Sent: 3. kesäkuuta 2010 12:53
To: Oscar Novo; [email-masked]
Subject: RE: draft-ietf-xcon-common-data-model-19

Hi Oscar,

Hello,

Cheers,

Oscar

Hi All,

Sean

Hi Sean,

Regards,

Oscar

Hi all,

Regards
Sean