Subject: Re: [Xml-sg-cmt] ekr hates <t indent=0>

From: Robert Sparks <[email-masked]>
Date: Thu, 7 Jan 2021 14:29:14 -0600

Talk to the AD. If I understand correctly this is an IETF stream 
document in C238.

The presence or absence of these things does not change the meaning of 
the standard,  and will not truly affect how/whether it can be implemented.

I understand (I think) the basis for his objection (making diff efforts 
take an extra step).

But I don't think he has ground to hold the document from publication 
based on this - it should just be published and we should move forward 
at best speed. The should talk him past blocking the document because of 
this.

Having EKR make this one change in the code right now isn't the right 
thing to do - we need to address the bigger question of whether we 
reverse the overall decision to populate defaults everywhere. <t> isn't 
special. (but "indent" might be).

RjS

On 1/7/21 2:19 PM, John R. Levine wrote:
> Ticket 585 is about the indent="0" default that xml2rfc adds to <t> 
> tags. It's clearly not needed since we have thousands of <t> tags with 
> no indent attribute so the default can't change, but I can see why the 
> code does it.
>
> Ekr recently noticed all those indent="0" in the AUTH48 for RFC 8844 
> and really really hates them.  He really doesn't want them in his 
> RFC.  I pointed out that there are already 75 RFCs with over 10,000 
> indent="0" but he still doesn't want them in his RFC.
>
> I then pointed out that we currently have nobody maintaining xml2rfc 
> so even if we agree it should go, it'll be a while before it changes.  
> So he said he's willing to make the change.  I said I'd ask the tools 
> team.
>
> While I have opinions about what we should do eventually, I don't have 
> strong opinions either way on whether to take up his offer. I don't 
> even know if he's a good enough python programmer to do it.  Any advice?
>
> Regards,
> John Levine, [email-masked], Primary Perpetrator of "The Internet for 
> Dummies",
> Please consider the environment before reading this e-mail. https://jl.ly

---

From: Robert Sparks <[email-masked]>
Date: Thu, 7 Jan 2021 15:05:56 -0600

On 1/7/21 2:40 PM, John R. Levine wrote:
>> I understand (I think) the basis for his objection (making diff 
>> efforts take an extra step).
>
> That was my original understanding but this is for the published RFC. 
> He's made it quite clear his objection is that it's ugly.

For who? (and is this conversation happening publically anywhere other 
than the short thread on rfc-i)?

Holding up publication on the document while we work this out seems 
counterproductive to me - Having C238 out feels like it would do more 
good in the world.

>> based on this - it should just be published and we should move 
>> forward at best speed. The should talk him past blocking the document 
>> because of this.
>>
>> reverse the overall decision to populate defaults everywhere. <t> 
>> isn't special. (but "indent" might be).
>
> We can made a sensible distnction between attributes that have always 
> been explcit and attributes that haven't.  For the latter group 
> there's no point to start adding explicit defaults.
>
> We can also have a discussion about whether it ever made sense to add 
> all the defaults since they make the XML a lot larger and I'm not 
> aware of any place where it seems useful to change the default.
Hard to prove negatives, and I don't think the default for indent in 
this case _would_ ever change. But the first time we do decide a default 
change _would have been_ useful, then we're stuck with having to 
explicitly state what we wish the default had been. But that's a problem 
that could always be solved by versioning the schema and allowing the 
version to move at a reasonable rate.
> R's,
> John

---

From: Sandy Ginoza <[email-masked]>
Date: Thu, 7 Jan 2021 13:08:39 -0800

FYI - this thread is helpful, as I thought he was offering to strip indent=“0” from the XML; I didn't realize he was offering to update xml2rfc.  I am hopeful that we will not do any manual processing of the prepped files.  

Thanks!
Sandy 

> On Jan 7, 2021, at 12:29 PM, Robert Sparks <[email-masked]> wrote:
> 
> Talk to the AD. If I understand correctly this is an IETF stream document in C238.
> 
> The presence or absence of these things does not change the meaning of the standard,  and will not truly affect how/whether it can be implemented.
> 
> I understand (I think) the basis for his objection (making diff efforts take an extra step).
> 
> But I don't think he has ground to hold the document from publication based on this - it should just be published and we should move forward at best speed. The should talk him past blocking the document because of this.
> 
> Having EKR make this one change in the code right now isn't the right thing to do - we need to address the bigger question of whether we reverse the overall decision to populate defaults everywhere. <t> isn't special. (but "indent" might be).
> 
> RjS
> 
>> Ticket 585 is about the indent="0" default that xml2rfc adds to <t> tags. It's clearly not needed since we have thousands of <t> tags with no indent attribute so the default can't change, but I can see why the code does it.
>> 
>> Ekr recently noticed all those indent="0" in the AUTH48 for RFC 8844 and really really hates them.  He really doesn't want them in his RFC.  I pointed out that there are already 75 RFCs with over 10,000 indent="0" but he still doesn't want them in his RFC.
>> 
>> I then pointed out that we currently have nobody maintaining xml2rfc so even if we agree it should go, it'll be a while before it changes.  So he said he's willing to make the change.  I said I'd ask the tools team.
>> 
>> While I have opinions about what we should do eventually, I don't have strong opinions either way on whether to take up his offer. I don't even know if he's a good enough python programmer to do it.  Any advice?
>> 
>> Regards,
>> John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt

---

From: "John R Levine" <[email-masked]>
Date: 7 Jan 2021 16:09:25 -0500

> For who? (and is this conversation happening publically anywhere other than 
> the short thread on rfc-i)?

It's on the rfc-editor list, came up in AUTH48 of RFC8844.  He seems under 
the impression that I or someone can wave our hand and make the indent="0" 
go away.

> counterproductive to me - Having C238 out feels like it would do more good in 
> the world.

I certainly do not purport to explain his priorities.  I'm just the 
messenger here.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Sandy Ginoza <[email-masked]>
Date: Thu, 7 Jan 2021 13:21:48 -0800

> On Jan 7, 2021, at 1:05 PM, Robert Sparks <[email-masked]> wrote:
> 
> 
>> That was my original understanding but this is for the published RFC. He's made it quite clear his objection is that it's ugly.
> 
> For who? (and is this conversation happening publically anywhere other than the short thread on rfc-i)?
> 
> Holding up publication on the document while we work this out seems counterproductive to me - Having C238 out feels like it would do more good in the world.

FYI: there is some time sensitivity to getting C238 published.  There has been a request to publish C238 by Jan 20 (though, there may be a little wiggle room) so the RFCs can be referenced in W3C specs.  EKR is aware of the request. 

>> We can made a sensible distnction between attributes that have always been explcit and attributes that haven't.  For the latter group there's no point to start adding explicit defaults.
>> 
>> We can also have a discussion about whether it ever made sense to add all the defaults since they make the XML a lot larger and I'm not aware of any place where it seems useful to change the default.
> Hard to prove negatives, and I don't think the default for indent in this case _would_ ever change. But the first time we do decide a default change _would have been_ useful, then we're stuck with having to explicitly state what we wish the default had been. But that's a problem that could always be solved by versioning the schema and allowing the version to move at a reasonable rate.
>> 
>> R's,
>> John
> 
> -- 
> Xml-sg-cmt mailing list
> [email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Thu, 7 Jan 2021 15:27:51 -0600

On 1/7/21 3:09 PM, John R Levine wrote:
> It's on the rfc-editor list, came up in AUTH48 of RFC8844.  He seems 
> under the impression that I or someone can wave our hand and make the 
> indent="0" go away.
>

Well, not entirely - you are necessarily holding a facilitator role in this.

It seems clear from the rfc-i thread that EKR understands there's a 
policy decision that needs to be made.

It's reasonable, IMHO, to ask the cmt to make that decision on that 
policy as it is the body that can decide such things at this time.

It's not up to us whether the document should be held for that decision 
or implementation around it, and specifically, it's not up to us to 
decide whether to block C238 - that's more up to you and the IESG (in 
this case) - I've stated my opinion on _that_ a couple of times now, and 
hope I can stop, but I think you really have to take a position on that.

So, we can ask this team if it's ok to publish RFCs without adding the 
default for indent if it's not present (as opposed to the bigger 
question of anything with a default). If we think that's ok, I can start 
figuring out implementation. Fwiw, I'm ok with that as a first step - I 
think the ramifications of not including the default in the published 
document is pretty clear for this case. I'm less comfortable saying 
that's true for other parameters.

RjS

---

From: "John R Levine" <[email-masked]>
Date: 7 Jan 2021 16:38:33 -0500

> It's reasonable, IMHO, to ask the cmt to make that decision on that policy as 
> it is the body that can decide such things at this time.
>
> It's not up to us whether the document should be held for that decision or 
> implementation around it, and specifically, it's not up to us to decide 
> whether to block C238 - that's more up to you and the IESG (in this case) - 
> I've stated my opinion on _that_ a couple of times now, and hope I can stop, 
> but I think you really have to take a position on that.

Personally, I think it would be ridiculous to hold up C238, but I said I'd ask.

Regards,

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 8 Jan 2021 16:45:18 +0100

> version to move at a reasonable rate.

Not quite.  With the current approach, external renderers don't have to
also read the schema in to know what the defaults are; everything needed
to render the published XML is right there in the XML file.  With
versioned schemas and defaults not expanded, the published XML files aren't
standalone any more -- you need to have, and ingest, the right schema file
in order to render the published XML correctly.

Regards,

	Henrik

---

From: Sandy Ginoza <[email-masked]>
Date: Mon, 11 Jan 2021 14:12:37 -0800

Hi John,

Just checking on the status of this?   Any chance we can make an agreement with ekr that this discussion can continue, but publications will not be held pending the outcome of the discussion.  I want to make sure there are no barriers to getting C238 out the door (or that relevant parties are aware if there are barriers).

Thanks,
Sandy 

> On Jan 8, 2021, at 7:45 AM, Henrik Levkowetz <[email-masked]> wrote:
> 
> 
>

---

From: "John R Levine" <[email-masked]>
Date: 11 Jan 2021 17:21:04 -0500

> Just checking on the status of this?   Any chance we can make an agreement with ekr that this discussion can continue, but publications will not be held pending the outcome of the discussion.  I wa…

I believe he backed down and agreed that whatever we're going to change 
will need consensus.

R's,
John

Regards,

---

From: Sandy Ginoza <[email-masked]>
Date: Tue, 12 Jan 2021 16:12:53 -0800

> On Jan 11, 2021, at 2:21 PM, John R Levine <[email-masked]> wrote:
> 
> I believe he backed down and agreed that whatever we're going to change will need consensus.

Ack - I saw your mail to Eric; thanks for sending that.

Sandy