Subject: [Xml-sg-cmt] references to I-Ds in RFCs -- Re: [irsg] problem with recent drafts on tools.ietf.org? {35440727}

From: Sandy Ginoza <[email-masked]>
Date: Wed, 10 Mar 2021 16:46:05 -0800

Hi team,

We’ve noted this discussion on the WG chairs list.  Carsten is correct - the RFCs point to I-Ds hosted on the tools.ietf.org.  We believe redirects will be put in place, so no action is required for the already published RFCs.  However, we’re wondering if we should change how we’re running xml2rfc — for example, we’re currently running the following: 

xml2rfc --v3 --html --id-reference-base-url="https://tools.ietf.org/html/" --rfc-reference-base-url="https://www.rfc-editor.org/rfc/" --id-is-work-in-progress --metadata-js-url="https://www.rfc-editor.org/js/metadata.min.js" $1

Should we change the way we run xml2rfc (for generating HTML and PDF) as follows?
OLD: --id-reference-base-url="https://tools.ietf.org/html/"
NEW: --id-reference-base-url="https://datatracker.ietf.org/doc/html/"

John, I suggest we update 7322bis per the current reference style for I-Ds <https://www.ietf.org/archive/id/draft-flanagan-7322bis-06.html#name-referencing-internet-drafts>.  Right now, it doesn’t show a URL — assuming the change above, it would be this: 

   [ACP]      Eckert, T., Behringer, M. H., and S. Bjarnason, "An
              Autonomic Control Plane (ACP)", Work in Progress,
              Internet-Draft, draft-ietf-anima-autonomic-control-plane-
              30, 30 October 2020, <https://datatracker.ietf.org/doc/html/draft-
              ietf-anima-autonomic-control-plane-30>.

Background: The tools.ietf.org URLs were used based on discussion with Henrik and Heather.

Thanks,
Sandy 

> Begin forwarded message:
> 
> From: Carsten Bormann <[email-masked]>
> Subject: Re: [irsg] problem with recent drafts on tools.ietf.org? {35440727}
> Date: March 3, 2021 at 5:46:59 PM PST
> To: Bernard Aboba <[email-masked]>
> Cc: Working Chairs <[email-masked]>
> 
> On 2021-03-04, at 02:32, Bernard Aboba <[email-masked]> wrote:
>> 
>> SDOs often reference specification versions on the tools.ietf.org
> 
> … and that list of SDOs includes ourselves.
> I found 785 references out of recent RFCs to tools.ietf.org hosted Internet-Drafts.
> 
> Grüße, Carsten
> 
> Begin forwarded message:
> 
> From: Carsten Bormann <[email-masked]>
> Subject: Re: [irsg] problem with recent drafts on tools.ietf.org? {35440727}
> Date: March 3, 2021 at 5:46:59 PM PST
> To: Bernard Aboba <[email-masked]>
> Cc: Working Chairs <[email-masked]>
> 
> On 2021-03-04, at 02:32, Bernard Aboba <[email-masked]> wrote:
>> 
>> SDOs often reference specification versions on the tools.ietf.org
> 
> … and that list of SDOs includes ourselves.
> I found 785 references out of recent RFCs to tools.ietf.org hosted Internet-Drafts.
> 
> Grüße, Carsten
>

---

From: Robert Sparks <[email-masked]>
Date: Thu, 11 Mar 2021 06:19:37 -0600

> NEW: --id-reference-base-url="https://datatracker.ietf.org/doc/html/"

Yes, I think we're ready for that.

But, keep in mind we have a discussion in front of us (for a large value 
of us) about whether we have a separate site for exposing drafts or 
other things that we want people to just read, engineered to become a 
good stable reference. Several folks have floated something that might 
look like doc.ietf.org/<foo> in the early parts of that conversation. 
So, as you're working through this, keep in mind that location and form 
of the reference may change again.

---

From: "John R Levine" <[email-masked]>
Date: 11 Mar 2021 09:48:30 -0500

> But, keep in mind we have a discussion in front of us (for a large value of 
> us) about whether we have a separate site for exposing drafts or other things 
> that we want people to just read, engineered to become a good stable 
> reference. Several folks have floated something that might look like 
> doc.ietf.org/<foo> in the early parts of that conversation. So, as you're 
> working through this, keep in mind that location and form of the reference 
> may change again.

Does it makes sense to change to datatracker now, or should we wait and 
see if doc.ietf.org happens?

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Robert Sparks <[email-masked]>
Date: Thu, 11 Mar 2021 08:51:45 -0600

On 3/11/21 8:48 AM, John R Levine wrote:
>> But, keep in mind we have a discussion in front of us (for a large 
>> value of us) about whether we have a separate site for exposing 
>> drafts or other things that we want people to just read, engineered 
>> to become a good stable reference. Several folks have floated 
>> something that might look like doc.ietf.org/<foo> in the early parts 
>> of that conversation. So, as you're working through this, keep in 
>> mind that location and form of the reference may change again.
>
> Does it makes sense to change to datatracker now, or should we wait 
> and see if doc.ietf.org happens?
It makes sense to _me_ to change to datatracker now. Something like 
doc.ietf.org is likely months (for your-guess-is-as-good-as-mine number 
of digits of months) away.

---

From: "John R Levine" <[email-masked]>
Date: 11 Mar 2021 10:16:49 -0500

>> John, I suggest we update 7322bis per the current reference style for I-Ds 
>> <https://www.ietf.org/archive/id/draft-flanagan-7322bis-06.html#name-referencing-internet-drafts>. 
>> Right now, it doesn’t show a URL — assuming the change above, it would be 
>> this:
>> 
>>

OK, keeping in mind that it may change to doc.ietf.org someday.  I hope we 
can assume there will be redirects from the datatracker if so.

Regards,