Subject: [Xml-sg-cmt] index question

From: Sandy Ginoza <[email-masked]>
Date: Fri, 12 Mar 2021 14:24:27 -0800

Hi team,

draft-ietf-extra-imap4rev2-30, which is currently in our queue, contains an index.  As noted in ticket 603, xml2rfc crashes when making the PDF file.  Temporarily, we have removed “$” from the <iref>s so we’re able to create the PDF.  

   https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/603

Please note I changed the priority of 603 to critical (it’s not yet a blocker).
We also see <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/418> related to index.

Looking at the index in the output files, we have a few questions/comments.  See
https://www.rfc-editor.org/rfc/v3test/test-index-ietf-extra-imap4rev2-30.html#name-index

a) Does the index look as expected?  The terms appear twice, once as text and once as a link.  

b) In the text, the index is formatted differently.  Also, I think the index needs to be present so the content in the various outputs is the same, but the index is essentially useless because there are no links and no page numbers.  

c) The index does not appear in the toc; I’ll file a ticket for this. 

Partially formatted v3 files are here: 

https://www.rfc-editor.org/rfc/v3test/test-index-ietf-extra-imap4rev2-30.html
https://www.rfc-editor.org/rfc/v3test/test-index-ietf-extra-imap4rev2-30.pdf
https://www.rfc-editor.org/rfc/v3test/test-index-ietf-extra-imap4rev2-30.txt
https://www.rfc-editor.org/rfc/v3test/test-index-ietf-extra-imap4rev2-30.xml

Thanks,
Sandy

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 12 Mar 2021 15:36:48 -0700

Hi Sandy!

> a) Does the index look as expected?  The terms appear twice, once as text and once as a link.  

Yes, that seems off - we'd want one instance but linked.

> b) In the text, the index is formatted differently.  Also, I think the index needs to be present so the content in the various outputs is the same, but the index is essentially useless because ther…

Naturally we can't include links in the TXT files, but page numbers are
essential. :-)

> c) The index does not appear in the toc; I’ll file a ticket for this. 

Thanks.

Peter

---

From: Sandy Ginoza <[email-masked]>
Date: Fri, 12 Mar 2021 14:41:33 -0800

Hi Peter,

Thanks for your quick reply! 

> On Mar 12, 2021, at 2:36 PM, Peter Saint-Andre <[email-masked]> wrote:
> 

In v3, the text is not paginated (e.g., https://www.rfc-editor.org/rfc/v3test/test-index-ietf-extra-imap4rev2-30.txt).  The PDF is the only paginated output.

Thanks,
Sandy

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 12 Mar 2021 15:45:55 -0700

On 3/12/21 3:41 PM, Sandy Ginoza wrote:
>> On Mar 12, 2021, at 2:36 PM, Peter Saint-Andre <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>> b) In the text, the index is formatted differently.  Also, I think
>>> the index needs to be present so the content in the various outputs
>>> is the same, but the index is essentially useless because there are
>>> no links and no page numbers.  
>>
> In v3, the text is not paginated
> (e.g., https://www.rfc-editor.org/rfc/v3test/test-index-ietf-extra-imap4rev2-30.txt
> <https://www.rfc-editor.org/rfc/v3test/test-index-ietf-extra-imap4rev2-30.txt>).
>  The PDF is the only paginated output.

Um yeah, right. ;-)

So what do we point to within the TXT file? The section number seems to
be the nearest we can get.

Peter

---

From: Robert Sparks <[email-masked]>
Date: Mon, 15 Mar 2021 14:11:40 -0500

To be clear, you moved 607 (which is, I think, item c below) to 
critical, not 603.

---

From: Sandy Ginoza <[email-masked]>
Date: Mon, 15 Mar 2021 12:15:19 -0700

Hi Robert,

> On Mar 15, 2021, at 12:11 PM, Robert Sparks <[email-masked]> wrote:
> 
> To be clear, you moved 607 (which is, I think, item c below) to critical, not 603.

My mistake - I did try to move 603 to critical last week; I must not have saved it correctly.  I have done so now.  Sorry for the confusion. 

And correct, 607 was added and marked as critical. 

Please feel free to update these if critical is the wrong priority. 

Thanks,
Sandy 

> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt

---

From: Robert Sparks <[email-masked]>
Date: Mon, 15 Mar 2021 14:18:46 -0500

Related: see <https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/558>

This is not something we can change quickly. There was a decision made 
during the implementation phase, with Heather, (with a lot of 
discussion) to render pdf from the HTML using Weasyprint rather than 
using princexml. In that codeflow, it is not possible to resynthisize 
page numbers. As Julian notes, we could retool and use princexml (which 
IIRC would require some licensing), but there were tradeoffs that we 
would need to reconsider.

RjS

---

From: Alice Russo <[email-masked]>
Date: Tue, 23 Mar 2021 14:37:27 -0700

Hi, 
Just an update here regarding item b below (index in the text output) -- relevant ticket: https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/610

Please speak up if you have any objection to the proposal in comment 3. Essentially, it is to use the section number (in all 3 formats) -- without the word "Section".  And for HTML & PDF that section number is a link to the exact location of the iref (so it could be a paragraph-specific link).

For example:

I-D (draft-ietf-extra-imap4rev2-30.txt) contained:
   T
      TEXT (part specifier)  95
      TEXT <string> (search key)  84
      TO <string> (search key)  84
      TRYCREATE (response code)  111

Proposal from Jennifer:
   T
      TEXT (part specifier)  6.4.5.1
      TEXT <string> (search key)  6.4.4
      TO <string> (search key)  6.4.4
      TRYCREATE (response code)  7.1

where "6.4.5.1" would be a paragraph-specific link to 
rfcNNNN.html#section-6.4.5.1-5
(Example: https://www.rfc-editor.org/v3test/test-index-ietf-extra-imap4rev2-30.html#section-6.4.5.1-5)

Thanks,
Alice

> On Mar 12, 2021, at 2:24 PM, Sandy Ginoza <[email-masked]> wrote:
> 
> Hi team,
>