Subject: [Xml-sg-cmt] Topics for next monday's call

From: Robert Sparks <[email-masked]>
Date: Fri, 9 Apr 2021 11:24:25 -0500

As noted on last weeks call, there are several tickets in xml2rfc's trac 
instance that are in a waiting or under_review state.

I think we can review and close several of these on monday's call. For 
the others, a short conversation to make sure we have shared context 
will be worthwhile.

I think we've already answered this one with the recent conversation 
about what the preptool will leave in the prepped xml

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket460 preptool 
inserts section with author names

I think this one is being OBE through the conversation about deprecating 
relref. Is there anything that should move from it into the implemantion 
of xref?

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket584 <relref> with 
text content should ignore displayFormat

I think we've decided that we're going to leave the indent=0, and can 
close this one

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket585 "Preptool adds 
indent=""0"" to every unindented <t>"

These require discussion

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket438 inconsistent 
rendering for <aside>
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket470 Remove link to 
rfc-local.css
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket547 bare attribute 
has no effect on HTML output (and may not be needed at all)
(see also https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket609)
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket548 Invalid XML 
entities inserted by v2v3 converter
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket560 New RFC txt 
format doesn't conform to RFC7994 (FF characters missing)
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket570 <blockquote> 
not allowed inside of <dd>
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket576 ToC in PDF 
output does not have subordinate appendix subsections
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket589 Don't use 
visibility:hidden to style pilcrows
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket596 Stop rendering 
<em> with underscores
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket602 do not try to 
insert 2 spaces after sentence ends in text mode

These are all a consequence of the behavior of weasyprint

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket463 improved 
placement of page breaks in the PDF
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket468 table cells 
have different background in PDF vs. HTML when using rowspan
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket521 page break 
within table
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket566 bad page breaks 
in the PDF

These I suggest we don't spend time on now -

https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket538 t elements 
under dd elements (waiting for submitter input)
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket553 xml2rfc 
non-determinism (implementation detail)
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket555 XML2RFC 
Internal Error (will be addressed with xml2rfc webservice reimplementation)
https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket562 biblxml library 
runaround, especially on old RFCs (will be addressed with bibxml service 
reimplentation)

Note that there are a few more tickets in the queue that I haven't 
processed yet, so there are probably a few more coming soon.

RjS

---

From: Sandy Ginoza <[email-masked]>
Date: Mon, 12 Apr 2021 06:31:41 -0700

Hi Robert, John,

Robert, thanks for putting this together.  I’m sorry to say, I am unable to make the call this morning.  My son has a fever, so I can’t take him to daycare (and there is no backup plan right these days).  Iirc, Peter and Alice are out today as well.  I will be online by 1:00 pm if you and John want to meet this afternoon, though please feel free to meet without me as well.

Thanks,
Sandy 

> On Apr 9, 2021, at 9:24 AM, Robert Sparks <[email-masked]> wrote:
> 
> As noted on last weeks call, there are several tickets in xml2rfc's trac instance that are in a waiting or under_review state.
> 
> I think we can review and close several of these on monday's call. For the others, a short conversation to make sure we have shared context will be worthwhile.
> 
> I think we've already answered this one with the recent conversation about what the preptool will leave in the prepped xml
> 
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket460 preptool inserts section with author names
> 
> I think this one is being OBE through the conversation about deprecating relref. Is there anything that should move from it into the implemantion of xref?
> 
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket584 <relref> with text content should ignore displayFormat
> 
> I think we've decided that we're going to leave the indent=0, and can close this one
> 
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket585 "Preptool adds indent=""0"" to every unindented <t>"
> 
> These require discussion
> 
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket438 inconsistent rendering for <aside>
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket470 Remove link to rfc-local.css
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket547 bare attribute has no effect on HTML output (and may not be needed at all)
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket548 Invalid XML entities inserted by v2v3 converter
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket560 New RFC txt format doesn't conform to RFC7994 (FF characters missing)
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket570 <blockquote> not allowed inside of <dd>
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket576 ToC in PDF output does not have subordinate appendix subsections
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket589 Don't use visibility:hidden to style pilcrows
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket596 Stop rendering <em> with underscores
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket602 do not try to insert 2 spaces after sentence ends in text mode
> 
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket463 improved placement of page breaks in the PDF
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket468 table cells have different background in PDF vs. HTML when using rowspan
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket521 page break within table
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket566 bad page breaks in the PDF
> 
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket538 t elements under dd elements (waiting for submitter input)
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket553 xml2rfc non-determinism (implementation detail)
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket555 XML2RFC Internal Error (will be addressed with xml2rfc webservice reimplementation)
> https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket562 biblxml library runaround, especially on old RFCs (will be addressed with bibxml service reimplentation)
> 
> Note that there are a few more tickets in the queue that I haven't processed yet, so there are probably a few more coming soon.
> 
> RjS
> 
> 
> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt
>

---

From: "John R Levine" <[email-masked]>
Date: 12 Apr 2021 11:04:53 -0400

> Robert, thanks for putting this together.  I’m sorry to say, I am unable to make the call this morning.  My son has a fever, so I can’t take him to daycare (and there is no backup plan right these…

I suppose the rump group of Henrik, Robert, and me can look at the tickets 
and see if there are any that are simple enough for us to dispose of.

R's,
John

PS: Hope your kid feels better.

>> Note that there are a few more tickets in the queue that I haven't processed yet, so there are probably a few more coming soon.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly