Subject: [Xml-sg-cmt] xml-model questions

From: Alice Russo <[email-masked]>
Date: Mon, 22 Nov 2021 13:32:57 -0800

Hi John,
Re: adding a line such as <?xml-model href="rfc7991bis.rnc"?> to each RFC. Is there a decision to add the xml-model PI to RFCs that are published from a certain point forward? If so:
- When is that point?
- Are you in agreement w/ requesting that the v2-v3 converter be updated to add that line?
- Where will the rfc7991bis.rnc file live?
- Is it correct to assume that this line would not be added to already published RFCs (when pursuing the 'update the files of RFCs of the v3 era, reprep them, and regenerate the 3 publication formats' project)?

Relevant thread from May:
https://mailarchive.ietf.org/arch/search/?qdr=y&start_date=&end_date=&email_list=rfc-interest&q=subject%3A%28document+validation%29&as=1

Thanks,
Alice

---

From: "John R Levine" <[email-masked]>
Date: 23 Nov 2021 13:41:28 -0500

> - Is it correct to assume that this line would not be added to already published RFCs (when pursuing the 'update the files of RFCs of the v3 era, reprep them, and regenerate the 3 publication forma…

If we do it, I'd like to do it when we fix all the XML so everything is 
consistent.

> - Where will the rfc7991bis.rnc file live?

Good question.  I'm thinking some stable place at rfc-editor.org.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly