Subject: [Xml-sg-cmt] question: use of <u> element

From: Alice Russo <[email-masked]>
Date: Thu, 17 Feb 2022 10:49:54 -0800

Greetings,

Should the <u> element be used to get the desired output even when it doesn't include the character itself? The <u> can be used to render the "U+" notation or name of a Unicode code point. For example (from draft-faltstrom-unicode12-07):

This output:
 SPHERICAL ANGLE OPENING UP (U+29A1) existed before IDNA2008 was ...

could be rendered w/ this XML:

A)  <t> <u format="name-num">⦡</u> existed before IDNA2008 was ... </t>

instead of 

B)  <t> SPHERICAL ANGLE OPENING UP (U+29A1) existed before IDNA2008 was ...</t>

Should the RPC be using A? 
It would mean a programmatic check (in addition to a manual check) of whether the submitted text is accurate. (i.e., the author submits a long name and "U+" notation, RPC looks it up and puts the actual char in <u> in the source file, renders output, then checks if it matches what was submitted.) 
 
Thanks,
Alice

---

From: "John R Levine" <[email-masked]>
Date: 17 Feb 2022 14:21:38 -0500

> Should the RPC be using A?

In this case I think not.  Patrik is using the character as an example 
without any plan to render it.  I realize this is quite the corner case.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Alice Russo <[email-masked]>
Date: Fri, 18 Feb 2022 09:20:31 -0800

Hi John,
Ack on the outcome (simply leave it written out).

Re:
> I realize this is quite the corner case.

Hm, I see it as a common case in that the I-Ds we receive contain the data about the code point (e.g., the name and U+ notation) more commonly than the character itself, presumably because that was not possible before the format change.

For example, draft-faltstrom-unicode12-07 contains 30 instances of U+ notation.

Thanks,
Alice

On Feb 17, 2022, at 11:21 AM, John R Levine <[email-masked]> wrote:

> In this case I think not.  Patrik is using the character as an example without any plan to render it.  I realize this is quite the corner case.
> 
> Regards,