Subject: [Xml-sg-cmt] Mismatch, perhaps defect, in representing publishers vs authors

From: Robert Sparks <[email-masked]>
Date: Fri, 18 Feb 2022 13:44:03 -0600

See https://github.com/ietf-ribose/bibxml-service/issues/100

Is this something that we should address with the bis effort, or just 
accept the proposed workaround and push the problem off into the future?

RjS

---

From: "John R Levine" <[email-masked]>
Date: 18 Feb 2022 15:50:06 -0500

> Is this something that we should address with the bis effort, or just accept 
> the proposed workaround and push the problem off into the future?

I'd say it's pretty low priority.  In the absence of an identified author, 
the publisher plausibly takes on the author's role.

It'd be OK to add a publisher field to the vocabulary in the future but we 
are the IETF, not the Library of Congress.  The point of references in 
RFCs is so that people reading them can find the referenced things, and 
publisher as author doesn't hurt that.

R's,
John

PS: It's sort of like complex vs simple postal addresses.  We're not the 
UPU, if you can write the address on a postcard and the post office will 
deliver it, we're done.

---

From: Alice Russo <[email-masked]>
Date: Fri, 18 Feb 2022 14:33:39 -0800

Robert,

FWIW, 'publisher' can have a specific meaning in bibliographic info. I see 2 cases as follows, where the first is mentioned in RFC 7991:
>    Note that an "author" can also be just an organization (by not
>    specifying any of the "name" attributes, but adding the
>    <organization> child element).

(and similar text in the vocab reference [0])

1) Organization as author (common in RFCs)
--> <organization> in RFCXML 
Example from [1]:
International Organization for Standardization. Information and Documentation—Rules for the Abbreviation of Title Words and Titles of Publications. ISO 4. Paris: ISO, 1997.

2) Publisher info (not common in RFCs)
--> <refcontent> in RFCXML 
Example from [2]:
Thomas, Matthew. We Are Not Ourselves. New York: Simon & Schuster, 2014.

[0] https://authors.ietf.org/en/rfcxml-vocabulary#author
[1] "Organization as author" in CMOS https://www.chicagomanualofstyle.org/book/ed17/part3/ch14/psec084.html
[2] "Place, publisher, and date" in CMOS
https://www.chicagomanualofstyle.org/book/ed17/part3/ch14/psec127.html

Thanks,
Alice

> On Feb 18, 2022, at 11:44 AM, Robert Sparks <[email-masked]> wrote:
> 
> Is this something that we should address with the bis effort, or just accept the proposed workaround and push the problem off into the future?
> 
> RjS
> 
> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt
>