Subject: [Xml-sg-cmt] question: line break within a cell of a table

From: Alice Russo <[email-masked]>
Date: Fri, 11 Feb 2022 10:12:29 -0800

Greetings,

Do you have a recommendation for whether <ul> or <br/> is used in this case?
(The XML for one row is pasted below.)

Considerations:
- In the past, we've been told to use <br/> sparingly.
- Also, we were told to use <ul> for this case. (Semantically, it's a list of two items.)
- Aesthetically, <br/> produces slightly better PDF output bc there's less extraneous space within the cell.)

Please compare Table 9 vs. Table 10 here:
https://www.rfc-editor.org/v3test/test9189.pdf#table-9 --> <ul>
https://www.rfc-editor.org/v3test/test9189.pdf#table-10 --> <br/> 

Also available as:
https://www.rfc-editor.org/v3test/test9189.txt
https://www.rfc-editor.org/v3test/test9189.html

To be clear: The need for this XML formatting (to explicitly place the line break) arises only because of the HTML output. The TXT and PDF are fine without <ul> or <br/>.

Thanks,
Alice
--

          <tr>
            <td>GC256B</td>
            <td>
              <ul empty="true" bare="true" spacing="compact">
                <li>id-GostR3410_2001-CryptoPro-XchA-ParamSet</li>
                <li>id-tc26-gost-3410-2012-256-paramSetB</li>
              </ul>
            </td>
          </tr>

vs.

          <tr>
            <td>GC256B</td>
            <td>
              <t>                                                                                                  
                id-GostR3410_2001-CryptoPro-XchA-ParamSet<br/>                                                      
                id-tc26-gost-3410-2012-256-paramSetB                                                                
              </t>
            </td>
          </tr>

---

From: "John R Levine" <[email-masked]>
Date: 11 Feb 2022 13:33:52 -0500

> (The XML for one row is pasted below.)

If it's semantically a list, I'm inclined to make it a list.

If the PDF rendering of compact lists isn't compact enough, that seems 
something we can fix in xml2rfc.

R's,
John

> To be clear: The need for this XML formatting (to explicitly place the line break) arises only because of the HTML output. The TXT and PDF are fine without <ul> or <br/>.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly