Subject: [Xml-sg-cmt] question: artwork type

From: Alice Russo <[email-masked]>
Date: Fri, 11 Feb 2022 12:54:26 -0800

Greetings,
Is it acceptable to continue to not set the type for <artwork> for the common case?This means using <artwork> instead of <artwork type="ascii-art">.

If the recommendation is to set to type="ascii-art" for all artwork that is not type="svg", this will be a change to current procedure.

For background:
- Past guidance was to not use type="call-flow" or "hex-dump".
- This topic was discussed on a recent call re: guidance received (https://notes.ietf.org/cmt-20211213#), but the notes do not include the question above.
- The vocabulary reference (https://authors.ietf.org/en/rfcxml-vocabulary#type) mentions "a consumer of this attribute should not cause a failure when it encounters an unexpected type or no type is specified."   The content there seems accurate except for a "list of the preferred values is maintained on the RFC Editor web site". The website only has a list of values for sourcecode type.
- The preptool does not add the empty type="". Example below.
- Side note: The name "ascii-art" seems unfortunate bc <artwork> can contain non-ASCII chars (without relying on <u>).

Thanks,
Alice
--

Before:
<artwork>

After prep:
<artwork align="left" pn="section-2-3.1">

---

From: "John R Levine" <[email-masked]>
Date: 11 Feb 2022 16:42:14 -0500

> Is it acceptable to continue to not set the type for <artwork> for the common case?This means using <artwork> instead of <artwork type="ascii-art">.

I can see the point of tagging sourcecode since much of it is should be 
amenable to extracting and processing, but what are you going to do with 
artwork other than look at it?

R's,
John