Subject: Re: [Xml-sg-cmt] is "example" an acceptable type within <artwork>

From: "John R Levine" <[email-masked]>
Date: 3 Mar 2022 22:01:30 -0500

> In RFC-to-be 9112 (which is currently in AUTH48), Julian would like to set the type to “example” within the <artwork> elements (since they are not ascii-art).  Is this acceptable, or do you see any issues with this? There are three instances in the text.

I believe that our group agreed that we're not doing semantic typing of 
artwork:

  Unlike sourcecode, where the tagging matters and we have a list of
  defined types, we don’t have or see the need for a list of defined types for
  <artwork> - the only values are “svg” “” (i.e., ASCII). We should
  document this fact and communicate it to authors and tool developers.

R's,
John

>
> One example
>
> Old:
>   <artwork type=“ascii-art"><![CDATA[
>    https://www.example.org/pub/WWW/TheProject.html
>    ]]></artwork>
>
> New:
>   <artwork type=“example"><![CDATA[
>   https://www.example.org/pub/WWW/TheProject.html
>   ]]></artwork>
>
>
> The files are here:
> https://www.rfc-editor.org/authors/rfc9112.txt
> https://www.rfc-editor.org/authors/rfc9112.pdf
> https://www.rfc-editor.org/authors/rfc9112.html
> https://www.rfc-editor.org/authors/rfc9112.xml
>
> Thanks,
> Karen
>
>> Begin forwarded message:
>>
>> From: Julian Reschke <[email-masked]>
>> Subject: Re: AUTH48 [KC]: RFC 9112 <draft-ietf-httpbis-messaging-19.txt> NOW AVAILABLE
>> Date: March 1, 2022 at 11:47:25 AM PST
>> To: Karen Moore <[email-masked]>, "Roy T. Fielding" <[email-masked]>, Mark Nottingham <[email-masked]>
>> Cc: [email-masked], [email-masked], Tommy Pauly <[email-masked]>, "[email-masked]" <[email-masked]>
>>
>> Am 11.02.2022 um 20:21 schrieb Karen Moore:
>>> ...
>>
>> Hi Karen,
>>
>> I found three cases where we have examples in <artwork> elements, and none of these cases are "ascii-art". Please revert (or apply attached XML).
>>
>> Best regards, Julian
>
>

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Karen Moore <[email-masked]>
Date: Thu, 3 Mar 2022 17:17:52 -0800

Hi team,

One example

Old:
          
New:

The files are here:

Thanks,
Karen

---

From: Lynne Bartholomew <[email-masked]>
Date: Thu, 3 Mar 2022 18:45:38 -0800

Hi, KC and everyone.

Thank you for sending this to <[email-masked]>, KC!  A similar question came up for me as well -- this time for <sourcecode>.

draft-ietf-httpbis-priority-12 has four <sourcecode> entries with type="example" and two with type="drawing", so I asked the authors if they would like to request that type="example" and type="drawing" be added to the list of usable sourcecode types on <https://www.rfc-editor.org/materials/sourcecode-types.txt> (because I was under the impression that if a type isn't explicitly listed as acceptable, it shouldn't be used unless someone decides to add it to the list in question, i.e., <artwork> or <sourcecode>).

In the case of both <artwork> and <sourcecode>, is it OK for authors to use whatever type they deem appropriate for their document, even if the type isn't used or listed anywhere else?

Thanks again.

Lynne

> On Mar 3, 2022, at 5:17 PM, Karen Moore <[email-masked]> wrote:
> 
> Hi team,
> 
> <rfc9112-to-be.xml>

---

From: Sandy Ginoza <[email-masked]>
Date: Fri, 4 Mar 2022 15:07:43 -0800

Hi Lynne, xml-sg-cmt,

> In the case of both <artwork> and <sourcecode>, is it OK for authors to use whatever type they deem appropriate for their document, even if the type isn't used or listed anywhere else?

Based on John’s reply, I believe artwork types should only be svg, ascii-art, or empty.  <sourcecode> types are being vetted by xml-sg-cmt before being added to the list.  

For sourcecode type=“example” or type=“drawing” - I expect that the options are:
- specify the type of code 
- leave type empty
- use <artwork>

Is this correct?  Or are these values acceptable sourcecode types? 

Thanks,
Sandy 

> On Mar 3, 2022, at 6:45 PM, Lynne Bartholomew <[email-masked]> wrote:
> 
> Hi, KC and everyone.
> 
> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt

---

From: "John R Levine" <[email-masked]>
Date: 4 Mar 2022 18:34:12 -0500

> - specify the type of code

For type="drawing" it's hard to see it as being anything other than 
artwork with a blank type.

A blank type is appropriate for this tiny instance.  I don't see any point 
in having an "example" type.

>>> New:
>>>   <artwork type=“"><![CDATA[

Regards,

---

From: Julian Reschke <[email-masked]>
Date: Fri, 11 Mar 2022 14:17:02 +0100

Am 05.03.2022 um 00:34 schrieb John R Levine:
> A blank type is appropriate for this tiny instance.  I don't see any
> point in having an "example" type.
>
>>>> New:

Just a reminder: the type attribute can be used to trigger different
rendering behaviors, such as background colors or borders.

To be able to distinguish between something that just happens to be a
string or text message (do be displayed in mono space) from actual ASCII
artwork makes a lot of sense.

Setting type to an empty string or leaving it out means: there is no
type information.

What I'm looking for is a simple way to distinguish between the two most
frequently used cases (inline monospace text block vs actual diagram).

And no, a type for SVG really is not needed.

Best regards, Julian