Subject: [Xml-sg-cmt] Proposed sourcecode types (Fwd: AUTH48 [RE]: RFC 9216 <draft-ietf-lamps-samples-08.txt> NOW AVAILABLE)

From: Sandy Ginoza <[email-masked]>
Date: Fri, 18 Mar 2022 13:00:34 -0700

Hi,

Are these acceptable types of sourcecode?  The files are here:

https://www.rfc-editor.org/authors/rfc9216.html
https://www.rfc-editor.org/authors/rfc9216.pdf
https://www.rfc-editor.org/authors/rfc9216.txt
https://www.rfc-editor.org/authors/rfc9216.xml

Thanks,
Sandy 

> Begin forwarded message:
> 
> From: Daniel Kahn Gillmor <[email-masked]>
> Subject: Re: AUTH48 [RE]: RFC 9216 <draft-ietf-lamps-samples-08.txt> NOW AVAILABLE
> Date: March 16, 2022 at 6:33:36 PM PDT
> To: [email-masked]
> Cc: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
> 
> If it's ok to add to the list, i could see adding three types for use in
> this document (and probably in other documents too):
> 
> - pkcs12 (for the explicitly-identified PKCS #12 objects)
> - pkcs8 (for the private keys)
> - x509 (for the certificates)

---

From: "John R Levine" <[email-masked]>
Date: 18 Mar 2022 16:21:30 -0400

>> - x509 (for the certificates)

pkcs8 and x509 are fine, since they are defined in RFC7468.

As far as I can tell, PKCS #12 objects are always stored in binary form in 
files ending with .p12 or .pfx and I'm not aware of a base64 version.

Kathleen wrote the spec so I will ask her if I've missed something.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "John R Levine" <[email-masked]>
Date: 20 Mar 2022 12:15:23 -0400

I heard back from Kathleen who says that pkcs12 is also OK.

Regards,

---

From: Sandy Ginoza <[email-masked]>
Date: Tue, 22 Mar 2022 05:43:18 -0700

Thanks John; these have been added to the list. 

> On Mar 20, 2022, at 9:15 AM, John R Levine <[email-masked]> wrote:
> 
> -- 
> Xml-sg-cmt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml-sg-cmt
>