Subject: [Xml-sg-cmt] status of items and regrets for 4/12

From: Alice Russo <[email-masked]>
Date: Fri, 8 Apr 2022 16:11:04 -0700

Hi CMT, 
Regrets for the call 4/12; my notes below on a few items.

1) clarifying the definitions of --rfc-base-url vs. --rfc-reference-base-url and determining if any changes are needed for the options used by the RPC. 
- status: ongoing. proposed draft text for 2 definitions pasted below.
- open question orig. raised by Jean: should these options be documented somewhere else besides the --help.

2) proposed change to page breaks in PDF output re: allow <sourcecode> element to be broken across a page when it's over 50 lines. (and no change to handling of <artwork>)
- status: awaiting a decision (leave as is or change).
Kesara gave us PDFs to review. (see mail 2022-03-09 "Re: [Xml-sg-cmt] 9189 was: Re: Ugly pdf hack" for links.) I've reviewed about only 3 of them; I didn't see any unintended consequences; perhaps this needs more review.
- see thread: "Re: Ugly pdf hack"
- background: the doc that raised the question originally - 9189 - was published w/ bad page breaks per author choice. but bad page breaks in PDF are not unique to that document. how much will this proposed change help w/ other docs? not sure.

3) handling of names [here be dragons]
At least 2 topics here:
- potential change for the future (see thread: Re: [Xml-sg-cmt] Suggested update to references)
- potential bug fixes for handling of non-ASCII names for the present (details here: https://github.com/ietf-tools/xml2rfc/issues/750). Currently awaiting word from author of 9218 re: space or no space bc it may help determine which bug fix to prioritize.

Thanks,
Alice
--

Re: 1, draft text to update the definitions from xml2rfc --help.

> old:
>>  --rfc-base-url RFC_BASE_URL
>>                        Base URL for RFC links
>> 
>>  --rfc-reference-base-url RFC_REFERENCE_BASE_URL
>>                        Base URL for RFC reference targets, replacing the
>>                        target="..." value given in the reference entry
> 
> perhaps:
>  --rfc-base-url RFC_BASE_URL
>                      This URL is used when the reference entry is rendered.
> 
>  --rfc-reference-base-url RFC_REFERENCE_BASE_URL
>                      Base URL when xref's section attribute is used, replacing the reference element's target when creating a section-specific URL.
> 
> 
> (and likely a similar update for --id-base-url vs. --id-reference-base-url)

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 12 Apr 2022 10:33:04 -0600

Thanks, Alice, I've added these issues to the agenda:

https://notes.ietf.org/cmt-20220412

Peter