Subject: Re: [xmpp] [Standards] draft-ietf-xmpp-3921bis-13: doubt about "3.3.3. Server Processing of Inbound Unsubscribe"

From: Florian Zeitz <[email-masked]>
Date: Mon, 13 Sep 2010 14:09:15 +0200

On 13.09.2010 11:54, Iñaki Baz Castillo wrote:
> Hi, in draft-ietf-xmpp-3921bis-13 section 3.3.3, romeo has sent
> "unsubscribe" to juliet.
> Juliet's Server has deliver the inboundunsubscribe to all the juliet's
> interested resources and has initiated a roster push to update romeo's
> subscription value.
> 
> However in step 3 it's said:
> 
>    3.  Generate an outbound presence stanza of type "unavailable" from
>        each of the contact's available resources to the user.
> 
>    CS: <presence from=[email-masked]'
>                  id='o5v91w49'
>                  to=[email-masked]'
>                  type='unavailable'/>
> 
> 
> Doubts:
> 
> -  Why should CS generate this presence stanza of type "unavailable"
> in behalf of romeo? AFAIK romeo has sent "unsubscribe" to juliet which
> means romeo is no longer interested in watching juliet's presence
> status. But it doesn't mean that romeo will not allow juliet to see
> his status, so why does juliet's server send presence type
> "unavailable" to juliet's resources in behalf of romeo??
> 
> - It says "Generate an outbound presence stanza", but in fact it is a
> local delivery (from Contact's Server to Contact's Client), a bug? my
> fail?
> 
> - It also says "from each of the contact's available resources to the
> user", but the presence stanza has a bare JID as "from".
> 
> 
> Thanks a lot.
> 
> 
This is indeed a valid concern (Send to WG list and should continue
there). However the text here is correct, it's just that the example is
wrong (I'm not sure whether those are defined to be normative or not).
It's important to understand who the "user" and who the "contact" is.
In this case "user" = [email-masked] and "contact" = [email-masked].
The example should therefore say:

CS: <presence	from=[email-masked]/balcony'
		to=[email-masked]'
		type='unavailable'/>

CS: <presence	from=[email-masked]/chamber'
		to=[email-masked]'
		type='unavailable'/>

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 13 Sep 2010 08:07:50 -0600

> wrong (I'm not sure whether those are defined to be normative or not).

They need to be correct, so bug reports are appreciated.

> CS: <presence	from=[email-masked]/chamber'

Yes, that seems to have been a copy-and-paste error. Fixed in my working
copy.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/