Subject: Re: [xmpp] Alexey Melnikov's DISCUSS and COMMENT on draft-ietf-xmpp-3920bis-19

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 29 Nov 2010 14:48:31 -0700

Replying to only the new items, and once again cc'ing the WG...

On 11/29/10 2:31 PM, Alexey Melnikov wrote:

> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------

<snip/>

> 5) DISCUSS DISCUSS
> 
>    [UNICODE]  The Unicode Consortium, "The Unicode Standard, Version
>               3.2.0", 2000.
> 
>               The Unicode Standard, Version 3.2.0 is defined by The
>               Unicode Standard, Version 3.0 (Reading, MA, Addison-
>               Wesley, 2000.  ISBN 0-201-61633-5), as amended by the
>               Unicode Standard Annex #27: Unicode 3.1
>               (http://www.unicode.org/reports/tr27/) and by the Unicode
>               Standard Annex #28: Unicode 3.2
>               (http://www.unicode.org/reports/tr28/).
> 
> Should this be upgraded to at least Unicode 5.1?

Why not 6.0?

It was 3.2 because of the dependency on 3.2 for stringprep, but that is
not cited from this document so updating it to the most recent version
seems appropriate.

> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------

<snip/>

> ----NEW----
> 
> 8.3.1.  Rules
> 
>    4.  An error stanza MUST contain an <error/> child element.
> 
>    7.  An <error/> child MUST NOT be included if the 'type' attribute
>        has a value other than "error" (or if there is no 'type'
>        attribute).
> 
> Are these 2 in conflict? If they are not, should they be combined into a single rule?

It's not an error stanza if the type is not "error", so I don't think
those two rules are in conflict.

> 8.3.3.13.  policy-violation
> 
>    The entity has violated some local service policy (e.g., a message
>    contains words that are prohibited by the service); the server MAY
>    choose to specify the policy in the <text/> element or in an
>    application-specific condition element; the associated error type
>    SHOULD be "modify" or "wait" depending on the policy being violated.
> 
> 
>    (In the following example, the client sends an XMPP message that is
>    too large according to the server's local service policy.)
> 
> It might be better to change the description to mention prohibited words (e.g. "!!!").
> Otherwise this looks too similar to <not-acceptable/>.
> 
>    C: <message from=[email-masked]/foo'
>                to=[email-masked]'
>                id='vq71f4nb'>
>         <body>%#&@^!!!</body>
>       </message>

Sure, will do. :)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 29 Nov 2010 22:05:12 +0000

>>Should this be upgraded to at least Unicode 5.1?
Sure.

>not cited from this document so updating it to the most recent version
Agree. Besides this document is talking about what is allowed in stanzas 
(among other things). No need to be restrictive here.

Best Regards,
Alexey