Subject: [xmpp] Type in 3920bis-19

From: Jehan Pagès <[email-masked]>
Date: Sun, 21 Nov 2010 21:47:28 +0900

Hi,

I just stepped on a typography error. That's not very serious but
still it is nicer with a nice looking RFC, so if it is not too late:

6.4.1. Exchange of Stream Headers and Stream Features

[...]
   The receiving entity MUST send a response stream header to the
   initiating entity (for which it MUST generate a new stream ID instead
   of re-using the old stream ID).

   R: <stream:stream
        from='im.example.com'
        id='vgKi/bkYME8OAj4rlXMkpucAqe4='
        to=[email-masked]'
        version='1.0'
        xml:lang='en'
        xmlns='jabber:client'
        xmlns:stream='http://etherx.jabber.org/streams'

---------------------

The '>' is missing at the end of the stanza. :-)
Bye.

Jehan

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 22 Nov 2010 12:21:11 -0700

>         xmlns:stream='http://etherx.jabber.org/streams'

Fixed in my working copy. Thanks!

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Jehan Pagès <[email-masked]>
Date: Mon, 29 Nov 2010 02:14:04 +0900

Hi,

> Fixed in my working copy. Thanks!

By working again on the RFC, I noticed this same stream header is on 2
other places in the document with the same typo (probably
copied-pasted):
- 5.4.3.3. TLS Success
- 9.1.2. SASL

Did you see this and fixed them in your working copy as well? If not
some more job for you. ;-)
Bye.

Jehan

---

From: Peter Saint-Andre <[email-masked]>
Date: Sun, 28 Nov 2010 11:43:03 -0700

> some more job for you. ;-)

Yes, I found many instances when I grepped for:

   streams'$