Subject: Re: [xmpp] Stephen Farrell's No Objection on draft-ietf-xmpp-posh-04: (with COMMENT)

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Wed, 9 Sep 2015 08:37:58 -0600

Hi Stephen, here's further follow-up on the fingerprint syntax...

On 8/5/15 4:55 PM, Peter Saint-Andre - &yet wrote:

>> 3.1: fingerprints: sigh, I wish we could agree to just
>> do this kind of thing a few times and not re-do it over
>> and over and over (but we always do;-). RFC6920 could
>> probably have been used there (caveat lector: that's an
>> RFC I'm a co-author on).
>
> Sorry, I should have thought of RFC 6920 in this context. :(
>
> Matt and I will look at this. (He is offline this week so we won't be
> able to sync up until then.) We will also reach out to implementers
> because as I recall we chose this approach in part for ease of
> implementation.

We have investigated the possibility of switching from the syntax 
currently defined to RFC 6920. As far as we can see, that would involve 
something like this:

OLD

{
  "fingerprints": [
   {
    "sha-256":"4/mggdlVx8A3pvHAWW5sD+qJyMtUHgiRuPjVC48N0XQ="
   }
  ],
  "expires": 604800
}

NEW

{
  "fingerprints": [
   {
    "hash":"ni:///sha-256;4/mggdlVx8A3pvHAWW5sD+qJyMtUHgiRuPjVC48N0XQ="
   }
  ],
  "expires": 604800
}

The former requires only JSON parsing, whereas the latter requires both 
JSON parsing and URI parsing. Given that folks have already implemented 
the former, we think that asking them to add URI parsing for (in our 
opinion) somewhat negligible gain isn't worth the effort at this point.

Peter

-- 
Peter Saint-Andre
https://andyet.com/

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 9 Sep 2015 16:06:11 +0100

> opinion) somewhat negligible gain isn't worth the effort at this point.

Yep. It's a bit sad, but there we go.

S.