Subject: Re: [xrblock] WGLC for draft-ietf-xrblock-rtcp-xr-discardandxrblock-rtcp-xr-discard-rle-metrics

From: "Claire Bi(jiayu)" <[email-masked]>
Date: Fri, 15 Jun 2012 11:12:55 +0800 (CST)

I have three minor comments to draft-ietf-xrblock-rtcp-xr-discard:

a. Section 1.1, last paragraph:

Remove "(work in progress)"

b Section 3.2, Definitionof "Discard Type".

Change the order of four Discard type allocated as follows:

NEW TEXT:

"

00: packets are discarded due to too early arrival.

01: packets are discarded due to too late arrival.

10: packets are discarded due to both early arrival and late

arrival.

11: packets are discarded due to other reasons than late

arrival, early arrival, or both (e.g., duplicate, redundant

packets).

"

c. Section 3.2, Definition of "number of packets discarded", last paragraph:

Change "Measurement Identity block" into "Measurement Information block"

------------------------------------------------------------------------------------

I have three comments to draft-ietf-xrblock-rtcp-xr-discard-rle-metrics

a. Section 1, Paragraph 2:

It is better to have a short name for extension Report.

b.Section 1, Paragraph 4:

This draft is referencing non-publication document (i.e.,[I-D.ietf-xrblock-rtcp-xr-burst-gap-discard]) as a normative reference.

It seems such referencing is only possible when referenced document has already passed through LC and reach approval stage.

c.Section 4:

It looks that Bytes Discarded Report Block is more related

to Discard Report Block defined [I-D.ietf-xrblock-rtcp-xr-discard].

Currently Discard draft support four use case. So the question is

should any use case applied to Discard Report block be also applied

to Bytes Discard report block?

Many Thanks & Regards

Claire Bi

---

From: Qin Wu <[email-masked]>
Date: Fri, 15 Jun 2012 11:57:50 +0800

Hi,Claire:
Thank for your review and comments to Discard draft. 
please see my replies inline.

Regards!
-Qin
  ----- Original Message ----- 
  From: Claire Bi(jiayu) 
  To: xrblock 
  Sent: Friday, June 15, 2012 11:12 AM
  Subject: Re: [xrblock] WGLC for draft-ietf-xrblock-rtcp-xr-discardandxrblock-rtcp-xr-discard-rle-metrics

[Qin]: Okay.

[Qin]: Looks good to me since the first 3 events can be detected by time window while the last one not.

[Qin]: Good catch, will fix this.
------------------------------------------------------------------------------------

---

From: Varun Singh <[email-masked]>
Date: Fri, 15 Jun 2012 16:43:32 -0700

Hi,

Quickly responding to the comments here.

>          arrival, early arrival, or both (e.g., duplicate, redundant

The burst gap discard draft requires reporting total discarded packets
in the discard packet and it cites that the discard draft carries this
information. So this needs to be fixed or the dependency on the
discard draft should be removed.

> This draft is referencing non-publication document
> (i.e.,[I-D.ietf-xrblock-rtcp-xr-burst-gap-discard]) as a normative
> reference.
> It seems such referencing is only possible when referenced document has
> already passed through LC and reach approval stage.

It was an error on my part, these references are not normative because
neither Discard RLE nor Discarded bytes rely on the technical aspects
of those two drafts. They should be informative because it would be
good for the implementer to read those two drafts to decide on which
XR block to implement.

> to Bytes Discard report block?

I sent an email on 31 May with regards to it, comments on that are
appreciated. See
http://www.ietf.org/mail-archive/web/xrblock/current/msg00538.html for
my clarification on why just 1 E bit should be sufficient.

Regards,
Varun

>
> Many Thanks & Regards
>
> Claire Bi
>
>
>
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock
>

-- 
http://www.netlab.tkk.fi/~varun/

---

From: Qin Wu <[email-masked]>
Date: Mon, 18 Jun 2012 10:29:19 +0800

----- Original Message ----- 
From: "Varun Singh" <[email-masked]>
To: "Claire Bi(jiayu)" <[email-masked]>
Cc: "xrblock" <[email-masked]>
Sent: Saturday, June 16, 2012 7:43 AM
Subject: Re: [xrblock] WGLC fordraft-ietf-xrblock-rtcp-xr-discardandxrblock-rtcp-xr-discard-rle-metrics

> discard draft should be removed.
[Qin]: That's a good question. However in the version -03 of burst gap draft doesn't
depend on discard draft since "summary statitistics metrics" (e.g., burst discard rate, gap discard rate)
has already been moved to draft-zorn-xrblock-rtcp-xr-al-stat, please see section 3.3 for details.
Now draft-zorn-xrblock-rtcp-xr-al-stat relies
on both burst gap draft and discard draft to calculate "Gap Discard Rate". 
According to section 2.1 of Discard draft and section 2.1 of Burst Gap Discard draft,

Discarded shall be regarded as A packet that arrives within
this time window but is too early or late to be played out.

Therefore I propose the following change to Discard draft:
OLD TEXT:
"
   Discard Type (DT): 2bits

      This field is used to identify the discard type used in this
      report block.  The discard type is defined as follows:

         00: packets are discarded due to other reasons than late
         arrival, early arrival, or both (e.g., duplicate, redundant
         packets)

         01: packets are discarded due to too early arrival.

         10: packets are discarded due to too late arrival.

         11: packets are discarded due to both early arrival and late
         arrival.
"
NEW TEXT:
"
   Discard Type (DT): 2bits

      This field is used to identify the discard type used in this
      report block.  The discard type is defined as follows:

         00: packets are discarded due to too early to be played out.

         01: packets are discarded due to too late to be played out.

         10: packets are discarded due to both early and late to be played out.

         11: packets are discarded due to other reasons than late
         arrival at playout buffer, early arrival at playout buffer, or both (e.g., duplicate, redundant
         packets)
"

Also I propose the following
text in the draft-zorn-xrblock-rtcp-xr-al-stat to get in line with change to Discard draft and discard definition of section 2.1 of Discard draft.

"
   Gap Discard Rate: 16 bits

      The fraction of packets discarded during gaps since the beginning
      of reception expressed as a fixed point number with the binary
      point at the left edge of the field.  This value is calculated by
      dividing the difference between number of packets discarded and
      Packets Discarded in Bursts by the difference between Packets

      Expected and Total Packets expected in Bursts as follows:

      (number of packets discarded - Packets Discarded in Bursts) /
      (Packets Expected - Total Packets expected in Bursts)

      where "number of packets discarded" is obtained from the RTCP XR
      Discard Block [DISCARD] and Packets Expected is calculated as the
      difference between "extended last sequence number" and "extended
      first sequence number" (Interval or Cumulative) provided in the
      Measurement Information block [MEASIDENT]."
NEW TEXT:
"
   Gap Discard Rate: 16 bits

      The fraction of packets discarded during gaps since the beginning
      of reception expressed as a fixed point number with the binary
      point at the left edge of the field.  This value is calculated by
      dividing the difference between number of packets discarded and
      Packets Discarded in Bursts by the difference between Packets

      Expected and Total Packets expected in Bursts as follows:

      (number of packets discarded - Packets Discarded in Bursts) /
      (Packets Expected - Total Packets expected in Bursts)

      where "number of packets discarded" is obtained from the RTCP XR
      Discard Block [DISCARD] with "Discard Type" field set to 2      (i.e.,packets are discarded due to both early to be played out and late to be played out.)       and Packets Expected is calculated as the
      difference between "extended last sequence number" and "extended
      first sequence number" (Interval or Cumulative) provided in the
      Measurement Information block [MEASIDENT]."