Subject: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

From: Shida Schubert <[email-masked]>
Date: Tue, 7 May 2013 18:56:20 -0700

This is an announcement of a 2 weeks XRBLOCK WG last call on 
"Report Block for Synchronization Delay and Offset Metrics Reporting" 
priort o requesting publication of the document as a proposed standard. 

 As per discussion at the last meeting, we are running a second 
WGLC on this draft.

Please send your comments, including nits, to the list by the

22nd of May

If you read the draft and you see no issues, concerns, or nits, please
express the fact that you have no issue progressing the draft on the
list as well. 

The latest version can be found here:

http://www.ietf.org/id/draft-ietf-xrblock-rtcp-xr-synchronization-04.txt

Regards

Shida as co-chair

---

From: Colin Perkins <[email-masked]>
Date: Wed, 8 May 2013 11:57:40 +0100

Shida,

I reviewed this when it was announced, and it addresses the concerns I raised with the previous version.

Colin

On 8 May 2013, at 02:56, Shida Schubert wrote:
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock

-- 
Colin Perkins
http://csperkins.org/

---

From: "Roni Even" <[email-masked]>
Date: Thu, 9 May 2013 17:14:35 +0300

Hi,

I reviewed the latest version. It looks OK.

I have one comment

The "reserved" field in section 3.2 should be 8 bits since the "I" field was
removed.

Another option is to keep the "I" field and say that it should be ignored

Roni Even

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Shida Schubert
Sent: 08 May, 2013 4:56 AM
To: xrblock
Cc: xrblock-chairs
Subject: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

WGLC on this draft.

22nd of May

Regards

Shida as co-chair

---

From: Qin Wu <[email-masked]>
Date: Fri, 10 May 2013 01:05:20 +0000

Hi,Roni:
Thank for your comment, if I understand correctly, Initial Synchronization Delay metric
Only needs to be reported once, i.e., at the beginning of the session since
the value of Initial Synchronization Delay metric usually is fixed and will
Not change at each report interval.
So I think your 1st option is more straightforward.

Regards!
-Qin
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Thursday, May 09, 2013 10:15 PM
To: 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: Re: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi,
I reviewed the latest version. It looks OK.
I have one comment
The "reserved" field in section 3.2 should be 8 bits since the "I" field was removed.
Another option is to keep the "I" field and say that it should be ignored
Roni Even

From: [email-masked] [mailto:[email-masked]] On Behalf Of Shida Schubert
Sent: 08 May, 2013 4:56 AM
To: xrblock
Cc: xrblock-chairs
Subject: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

22nd of May

Regards

Shida as co-chair

---

From: "Roni Even" <[email-masked]>
Date: Sun, 12 May 2013 09:27:52 +0300

Hi Qin,

My only reason for option 2 is to keep the header the same. There is no
other reason

Roni

From: Qin Wu [mailto:[email-masked]] 
Sent: 10 May, 2013 4:05 AM
To: Roni Even; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: RE: [xrblock] 2nd WGLC for
draft-ietf-xrblock-rtcp-xr-synchronization

Hi,Roni:

Thank for your comment, if I understand correctly, Initial Synchronization
Delay metric

Regards!

-Qin

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Roni Even
Sent: Thursday, May 09, 2013 10:15 PM
To: 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: Re: [xrblock] 2nd WGLC for
draft-ietf-xrblock-rtcp-xr-synchronization

Hi,

I have one comment

Roni Even

WGLC on this draft.

22nd of May

Regards

Shida as co-chair

---

From: Qin Wu <[email-masked]>
Date: Mon, 13 May 2013 00:57:07 +0000

I understand your reason. However in other XRBLOCK drafts using I field, at least one type of Interval metric flag is used.
unlike other XRBLOCK drafts using I field, none of Interval metric flags (from I=00 to I=11) is used in this draft.
So I prefer to keep as it does.

From: Roni Even [mailto:[email-masked]]
Sent: Sunday, May 12, 2013 2:28 PM
To: Qin Wu; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: RE: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi Qin,
My only reason for option 2 is to keep the header the same. There is no other reason
Roni

From: Qin Wu [mailto:[email-masked]]
Sent: 10 May, 2013 4:05 AM
To: Roni Even; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: RE: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi,Roni:

Regards!
-Qin
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Thursday, May 09, 2013 10:15 PM
To: 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: Re: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi,

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Shida Schubert
Sent: 08 May, 2013 4:56 AM
To: xrblock
Cc: xrblock-chairs
Subject: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

22nd of May

Regards

Shida as co-chair

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 13 May 2013 01:58:06 +0000

Hi Qin and Roni,

I agree option 1 is more appropriate for this report block. And I'll revise  the "reserved"  field in section 3.2 to 8 bits.
Thanks.

Best Regards!
Rachel

From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Monday, May 13, 2013 8:57 AM
To: Roni Even; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: Re: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi Qin,

Hi,Roni:

Regards!
-Qin

Hi,

22nd of May

Regards

Shida as co-chair

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 13 May 2013 08:46:15 +0000

Any other opinions on this issue?

Roni, I understand that your preference for option 2 is not blocking. Am I correct?

Thanks and Regards,

Dan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Huangyihong (Rachel)
Sent: Monday, May 13, 2013 4:58 AM
To: Qin Wu; Roni Even; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: Re: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi Qin and Roni,

Best Regards!
Rachel

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Monday, May 13, 2013 8:57 AM
To: Roni Even; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: Re: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi Qin,

Hi,Roni:

Regards!
-Qin

Hi,

22nd of May

Regards

Shida as co-chair

---

From: "Roni Even" <[email-masked]>
Date: Mon, 13 May 2013 12:33:50 +0300

Hi Dan,

I am OK with the current structure. Just need to change the reserved to 8
bits

Roni

From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: 13 May, 2013 11:46 AM
To: Huangyihong (Rachel); Qin Wu; Roni Even; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: RE: [xrblock] 2nd WGLC for
draft-ietf-xrblock-rtcp-xr-synchronization

Roni, I understand that your preference for option 2 is not blocking. Am I
correct? 

Thanks and Regards,

Dan

Of Huangyihong (Rachel)

Hi Qin and Roni,

I agree option 1 is more appropriate for this report block. And I'll revise
the "reserved"  field in section 3.2 to 8 bits.

Thanks.

Best Regards!

Rachel

Of Qin Wu

I understand your reason. However in other XRBLOCK drafts using I field, at
least one type of Interval metric flag is used. 

unlike other XRBLOCK drafts using I field, none of Interval metric flags
(from I=00 to I=11) is used in this draft.

Hi Qin,

Roni

Hi,Roni:

Regards!

-Qin

Hi,

I have one comment

Roni Even

WGLC on this draft.

22nd of May

Regards

Shida as co-chair

---

From: Qin Wu <[email-masked]>
Date: Tue, 14 May 2013 02:21:34 +0000

Thanks, Roni. We will fix that.

Regards!
-Qin
From: Roni Even [mailto:[email-masked]]
Sent: Monday, May 13, 2013 5:34 PM
To: 'Romascanu, Dan (Dan)'; Huangyihong (Rachel); Qin Wu; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: RE: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi Dan,
I am OK with the current structure. Just need to change the reserved to 8 bits
Roni

Thanks and Regards,

Dan

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Huangyihong (Rachel)
Sent: Monday, May 13, 2013 4:58 AM
To: Qin Wu; Roni Even; 'Shida Schubert'; 'xrblock'
Cc: 'xrblock-chairs'
Subject: Re: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi Qin and Roni,

Best Regards!
Rachel

Hi Qin,

Hi,Roni:

Regards!
-Qin

Hi,

22nd of May

Regards

Shida as co-chair

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 23 May 2013 10:31:53 +0000

Hi,

Sorry for the delay, but I got only now to reading again the I-D and I noticed the following:

In the Metric Block Structure diagram in section 3.1 the Reserved block occupies 8 bits (from bit 8 to bit 15). However the description in 3.2 says 'Reserved: 6 bits' which seems to be wrong.

Regards,

Dan

From: Shida Schubert [mailto:[email-masked]]
Sent: Wednesday, May 08, 2013 4:56 AM
To: xrblock
Cc: xrblock-chairs
Subject: 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

22nd of May

Regards

Shida as co-chair

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 23 May 2013 10:34:22 +0000

I should have read the comments already made first. I see Roni caught this already, and the resolution proposed by Qin is OK with me.

Regards,

Dan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, May 23, 2013 1:32 PM
To: Shida Schubert; xrblock
Cc: xrblock-chairs
Subject: Re: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Hi,

Regards,

Dan

22nd of May

Regards

Shida as co-chair

---

From: Qin Wu <[email-masked]>
Date: Fri, 24 May 2013 00:41:36 +0000

Fixed, thanks Dan.

Regards!
-Qin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, May 23, 2013 6:34 PM
To: Romascanu, Dan (Dan); Shida Schubert; xrblock
Cc: xrblock-chairs
Subject: Re: [xrblock] 2nd WGLC for draft-ietf-xrblock-rtcp-xr-synchronization

Regards,

Dan

Hi,

Regards,

Dan

22nd of May

Regards

Shida as co-chair