Subject: [xrblock] 答复: FW: New Version Notification for draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt

From: Qin Wu <[email-masked]>
Date: Sat, 2 Nov 2013 21:25:50 +0000

For browser to browser communication, why statistics related to transport need to be sent to web server using Web API? What web server can do about it if one side of communication quality downgrades or both sides downgrade?
Can web server redirect the statistics collocated by one web browser to another web browser?

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Huangyihong (Rachel)
发送时间: 2013年10月17日 11:15
收件人: xrblock
主题: [xrblock] FW: New Version Notification for draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt

Dear all,

In this new version, we adjust the organization of the metrics, which are now arranged in the descending order of importance. Comments are appreciated.

Best regards,
Rachel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 17, 2013 10:59 AM
To: Dan Romascanu; Varun Singh; Huangyihong (Rachel); Roni Even
Subject: New Version Notification for draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt

A new version of I-D, draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt
has been successfully submitted by Rachel Huang and posted to the
IETF repository.

Filename:	 draft-huang-xrblock-rtcweb-rtcp-xr-metrics
Revision:	 02
Title:		 Considerations for Selecting RTCP Extended Report (XR) Metrics for the RTCWEB Statistics API
Creation date:	 2013-10-17
Group:		 Individual Submission
Number of pages: 12
URL:             http://www.ietf.org/internet-drafts/draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt
Status:          http://datatracker.ietf.org/doc/draft-huang-xrblock-rtcweb-rtcp-xr-metrics
Htmlized:        http://tools.ietf.org/html/draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02
Diff:            http://www.ietf.org/rfcdiff?url2=draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02

Abstract:
   This document describes monitoring features related to RTCWEB. It
   provides a list of RTCP XR metrics that are useful and may need to be
   supported in some RTCWEB implementations.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
xrblock mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xrblock

---

From: Varun Singh <[email-masked]>
Date: Sun, 3 Nov 2013 04:41:16 -0800

Hi Qin,

Rewriting the message because the mailing list was not included in the
previous message and my reply was incomplete.

Cheers,
Varun

> Can web server redirect the statistics collocated by one web browser to another web browser?

Technically, yes this should be possible. The endpoint measures and
reports inbound-rtp statistics, it could send these to the web server.
However, the web server would have to handle the encoding and
signaling on its own* (i.e., it is outside the scope of our
documents).

Additionally, if endpoint send corresponding XR metrics to the sender,
the StatsAPI should automatically expose these metrics to the
application as outbound-rtp statistics.

-- 
http://www.netlab.tkk.fi/~varun/

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Sun, 3 Nov 2013 18:12:00 +0000

Hi Qin,

See inline.

Best regards,
Rachel

-----邮件原件-----
发件人: Varun Singh [mailto:[email-masked]] 
发送时间: 2013年11月3日 20:41
收件人: Qin Wu
抄送: Huangyihong (Rachel); xrblock
主题: Re: [xrblock] 答复: FW: New Version Notification for draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt

Hi Qin,

Rewriting the message because the mailing list was not included in the previous message and my reply was incomplete.

Cheers,
Varun

> For browser to browser communication, why statistics related to transport need to be sent to web server using Web API? What web server can do about it if one side of communication quality downgrade…

[Rachel]: Web server could use this information to evaluate network quality that ISPs provide, which may make ISP to do something to update their service if the network quality is seriously bad. This kind of information may also be useful for the regulators which may want to know what the quality of the network for webrtc services looks like.

> Can web server redirect the statistics collocated by one web browser to another web browser?

Technically, yes this should be possible. The endpoint measures and reports inbound-rtp statistics, it could send these to the web server.
However, the web server would have to handle the encoding and signaling on its own* (i.e., it is outside the scope of our documents).

Additionally, if endpoint send corresponding XR metrics to the sender, the StatsAPI should automatically expose these metrics to the application as outbound-rtp statistics.

> 主题: [xrblock] FW: New Version Notification for 
> draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt
>
> Dear all,
>
> Subject: New Version Notification for 
> draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt
>
>
> A new version of I-D, 
> draft-huang-xrblock-rtcweb-rtcp-xr-metrics-02.txt
> has been successfully submitted by Rachel Huang and posted to the IETF 
> repository.
>
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>