Subject: [xrblock] 答复: FW: New Version Notification for draft-singh-xrblock-webrtc-additional-stats-00.txt

From: Qin Wu <[email-masked]>
Date: Sat, 2 Nov 2013 21:41:11 +0000

What the progress of RTCweb Web API is?
How this work get in line with Web API work?

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Varun Singh
发送时间: 2013年10月10日 16:38
收件人: [email-masked]
主题: [xrblock] FW: New Version Notification for draft-singh-xrblock-webrtc-additional-stats-00.txt

Hi all,

We've submitted a new draft to meet the requirement #F38 stated in
(http://tools.ietf.org/html/draft-ietf-rtcweb-use-cases-and-requirements-10)

This draft lists XRBlock metrics that should be added to the IANA registry of WebRTC's statistics API (http://tools.ietf.org/html/draft-alvestrand-rtcweb-stats-registry-00).
We would like the WG to discuss if these metrics along with the ones in the stats-registry are sufficient to meet req #F38.

This document is a proposal made out of the earlier draft discussing XR Metrics, http://tools.ietf.org/html/draft-huang-xrblock-rtcweb-rtcp-xr-metrics-01.

A new version of I-D, draft-singh-xrblock-webrtc-additional-stats-00.txt
has been successfully submitted by Varun Singh and posted to the IETF repository.

Filename: draft-singh-xrblock-webrtc-additional-stats
Revision: 00
Title: Additional RTP Control Protocol (RTCP) Extended Report (XR) Metrics for WebRTC Statistics API Creation date: 2013-10-10
Group: Individual Submission
Number of pages: 7
URL:
http://www.ietf.org/internet-drafts/draft-singh-xrblock-webrtc-additional-stats-00.txt
Status:
http://datatracker.ietf.org/doc/draft-singh-xrblock-webrtc-additional-stats
Htmlized:
http://tools.ietf.org/html/draft-singh-xrblock-webrtc-additional-stats-00

Abstract:
  This document describes a list additional identifiers used in
  WebRTC's Javascript statistics API.  These identifiers are a set of
  RTCP XR metrics related to the transport of multimedia flows.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat
_______________________________________________
xrblock mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xrblock

---

From: Varun Singh <[email-masked]>
Date: Sun, 3 Nov 2013 04:07:03 -0800

Hi Qin,

Format and structure of the StatsAPI has recently been discussed on
the W3C mailing list, the current proposal is documented by Harald at
[1]. I believe the proposal in [1] is still work in progress because
it is currently missing some essential RTCP stats (e.g., fractional
loss, cumulative loss count, and RTT) which are however documented to
be added IANA's stats registry [2]. I've sent an email of the mailing
list [3] pointing to the additional statistics proposal and hopeful
that it generates discussion on the mailing list or during this week.

The additional-stats document [4] intends to add to the identifiers
proposed in [3]. Suggestions and discussions on if the identifiers
currently documented in [4] make sense is deeply appreciated.

Cheers,
Varun

[1] http://www.w3.org/2011/04/webrtc/wiki/Stats
[2] http://tools.ietf.org/html/draft-alvestrand-rtcweb-stats-registry
[3] http://lists.w3.org/Archives/Public/public-webrtc/2013Oct/0107.html
[4] http://tools.ietf.org/html/draft-singh-xrblock-webrtc-additional-stats

-- 
http://www.netlab.tkk.fi/~varun/

---

From: "Claire Bi(jiayu)" <[email-masked]>
Date: Tue, 5 Nov 2013 09:38:07 +0800

Hi Varun,

Thank you for letting us know the latest progress of RTCweb Web API. I noticed that the stats registry [2] you mentioned below has expired since March 28, 2013. Has this draft or related work been upgraded in IETF rtcweb WG? Besides, is there any feedback from IETF rtcweb WG about RTCP XR metrics?

Thanks and Regards,
Claire

> -----Original Message-----
> From:  Varun Singh 
> Date:  2013-11-03  20:07:40 
> To:  Qin Wu 
> Cc:  [email-masked] 
> Subject:  Re: [xrblock]答复: FW: New Version Notification for draft-singh-xrblock-webrtc-additional-stats-00.txt 

Hi Qin,

---

From: Varun Singh <[email-masked]>
Date: Mon, 4 Nov 2013 18:35:14 -0800

Hi Claire,

We've not received any feedback. I presume [2] will be updated as soon
the information in [1] stabilizes.

Cheers,
Varun

On Mon, Nov 4, 2013 at 5:38 PM, Claire Bi(jiayu) <[email-masked]> wrote:
> Hi Varun,
>
>
> Thank you for letting us know the latest progress of RTCweb Web API. I
> noticed that the stats registry [2] you mentioned below has expired since
> March 28, 2013. Has this draft or related work been upgraded in IETF rtcweb
> WG? Besides, is there any feedback from IETF rtcweb WG about RTCP XR
> metrics?
>
>
>
>
> Thanks and Regards,
>
> Claire
>
>
> ________________________________
>> Subject:  Re: [xrblock]答复: FW: New Version Notification for
>> draft-singh-xrblock-webrtc-additional-stats-00.txt
>
> Hi Qin,
>> 主题: [xrblock] FW: New Version Notification for
>> draft-singh-xrblock-webrtc-additional-stats-00.txt
>>
>> Hi all,
>>
>> This draft lists XRBlock metrics that should be added to the IANA registry
>> of WebRTC's statistics API
>> (http://tools.ietf.org/html/draft-alvestrand-rtcweb-stats-registry-00).
>> We would like the WG to discuss if these metrics along with the ones in
>> the stats-registry are sufficient to meet req #F38.
>>
>> This document is a proposal made out of the earlier draft discussing XR
>> Metrics,
>> http://tools.ietf.org/html/draft-huang-xrblock-rtcweb-rtcp-xr-metrics-01.
>>
>>
>> Title: Additional RTP Control Protocol (RTCP) Extended Report (XR) Metrics
>> for WebRTC Statistics API Creation date: 2013-10-10
>> Please note that it may take a couple of minutes from the time of
>> submission until the htmlized version and diff are available at
>> tools.ietf.org.
>>
>>
>> The IETF Secretariat