Subject: [xrblock] 答复: FW: New Version Notification for draft-singh-xrblock-webrtc-additional-stats-01.txt

From: Qin Wu <[email-masked]>
Date: Sat, 2 Nov 2013 21:06:23 +0000

Hi, Varun:
How this draft is related to draft-huang-xrblock-rtcweb-rtcp-xr-metrics?
Is this draft giving a subset of metrics while draft-huang-xrblock-rtcweb-rtcp-xr-metrics gives a complete list of metrics?
Or this draft is intending to replace draft-huang-xrblock-rtcweb-rtcp-xr-metrics?

Also it is not clear to me whether these metrics are provided as input to Web API in Web browser or WebAPI provides those metrics to web browser and then WebAPI can take advantage of them?

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Varun Singh
发送时间: 2013年10月17日 23:54
收件人: [email-masked]
主题: [xrblock] FW: New Version Notification for draft-singh-xrblock-webrtc-additional-stats-01.txt

Hi all,

We updated the draft based on some comments for Colin Perkins, it clarifies the monitoring points and access to the identifiers in the StatsAPI.

Cheers,
Varun

---
A new version of I-D, draft-singh-xrblock-webrtc-additional-stats-01.txt
has been successfully submitted by Varun Singh and posted to the IETF repository.

Filename: draft-singh-xrblock-webrtc-additional-stats
Revision: 01
Title: Additional RTP Control Protocol (RTCP) Extended Report (XR) Metrics for WebRTC Statistics API Creation date: 2013-10-17
Group: Individual Submission
Number of pages: 8
URL:
http://www.ietf.org/internet-drafts/draft-singh-xrblock-webrtc-additional-stats-01.txt
Status:
http://datatracker.ietf.org/doc/draft-singh-xrblock-webrtc-additional-stats
Htmlized:
http://tools.ietf.org/html/draft-singh-xrblock-webrtc-additional-stats-01
Diff:
http://www.ietf.org/rfcdiff?url2=draft-singh-xrblock-webrtc-additional-stats-01

Abstract:
  This document describes a list of additional identifiers used in
  WebRTC's Javascript statistics API.  These identifiers are a set of
  RTCP XR metrics related to the transport of multimedia flows.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

--
http://www.netlab.tkk.fi/~varun/
_______________________________________________
xrblock mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xrblock

---

From: Varun Singh <[email-masked]>
Date: Sun, 3 Nov 2013 04:34:11 -0800

Hi Qin,

See inline.

> How this draft is related to draft-huang-xrblock-rtcweb-rtcp-xr-metrics?

The additional-stats is a concrete proposal for adding relevant
XRBLOCK identifiers to the stats registry used by WebRTC Stats API.

> Is this draft giving a subset of metrics while draft-huang-xrblock-rtcweb-rtcp-xr-metrics gives a complete list of metrics?

The XR metrics draft started as a document to organize our thoughts on
which XR blocks or metrics may be useful for WebRTC. AFAIR, the
current version of the draft reorganizes the metrics in decreasing
order of usefulness (Rachel can confirm if this correct). For example
metrics measuring cumulative counts are prefered over run-length
encoded messages.

> Or this draft is intending to replace draft-huang-xrblock-rtcweb-rtcp-xr-metrics?

The xr-metrics document puts each metrics in context of one another,
which is a useful document to have for reference. My personal view is
that the xr-metrics document complements additional-stats and should
therefore not be replaced. But this is something that the WG should
discuss in the upcoming meeting.

> Also it is not clear to me whether these metrics are provided as input to Web API in Web browser or WebAPI provides those metrics to web browser and then WebAPI can take advantage of them?

These stat identifiers described in the documen are exposed by the web
browser to the WebRTC application using the StatsAPI. The main
proposal is:
1. the receiving endpoint measures the identifiers as described in the
referenced RFC6390 template.
2. when the StatAPI is queried at the the receiving endpoint, the
browser exposes the current measurement value
3. if corresponding XR blocks are implemented, the application at the
sending endpoint can also get the information when querying the Stats
API.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Sun, 3 Nov 2013 17:59:47 +0000

Hi 

See inline.

Best regards,
Rachel

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Varun Singh
发送时间: 2013年11月3日 20:34
收件人: Qin Wu
抄送: [email-masked]
主题: Re: [xrblock] 答复: FW: New Version Notification for draft-singh-xrblock-webrtc-additional-stats-01.txt

Hi Qin,

See inline.

> How this draft is related to draft-huang-xrblock-rtcweb-rtcp-xr-metrics?

The additional-stats is a concrete proposal for adding relevant XRBLOCK identifiers to the stats registry used by WebRTC Stats API.

> Is this draft giving a subset of metrics while draft-huang-xrblock-rtcweb-rtcp-xr-metrics gives a complete list of metrics?

The XR metrics draft started as a document to organize our thoughts on which XR blocks or metrics may be useful for WebRTC. AFAIR, the current version of the draft reorganizes the metrics in decreasing order of usefulness (Rachel can confirm if this correct). For example metrics measuring cumulative counts are prefered over run-length encoded messages.

[Rachel]: Yep. As Varun explained, draft-huang-xrblock-rtcweb-rtcp-xr-metrics discusses a complete set of metrics which may useful in WebRTC applications. Currently, these metrics are reorganized in the updated version in a decreasing order of their importance (the same meaning as Varun explained). While draft-singh-xrblock-webrtc-additional-stats proposes to give registration to a minimal set of metrics which we think are currently most useful for WebRTC from those in draft-huang-xrblock-rtcweb-rtcp-xr-metrics.

> Or this draft is intending to replace draft-huang-xrblock-rtcweb-rtcp-xr-metrics?

The xr-metrics document puts each metrics in context of one another, which is a useful document to have for reference. My personal view is that the xr-metrics document complements additional-stats and should therefore not be replaced. But this is something that the WG should discuss in the upcoming meeting.

> Also it is not clear to me whether these metrics are provided as input to Web API in Web browser or WebAPI provides those metrics to web browser and then WebAPI can take advantage of them?

These stat identifiers described in the documen are exposed by the web browser to the WebRTC application using the StatsAPI. The main proposal is:
1. the receiving endpoint measures the identifiers as described in the referenced RFC6390 template.
2. when the StatAPI is queried at the the receiving endpoint, the browser exposes the current measurement value 3. if corresponding XR blocks are implemented, the application at the sending endpoint can also get the information when querying the Stats API.

> 主题: [xrblock] FW: New Version Notification for 
> draft-singh-xrblock-webrtc-additional-stats-01.txt
>
> Hi all,
>
> A new version of I-D, 
> draft-singh-xrblock-webrtc-additional-stats-01.txt
> Title: Additional RTP Control Protocol (RTCP) Extended Report (XR) 
> Metrics for WebRTC Statistics API Creation date: 2013-10-17