Subject: [xrblock] 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

From: Qin Wu <[email-masked]>
Date: Sat, 2 Nov 2013 21:38:11 +0000

Why not use post repair loss RLE block defined in RFC5725?
You can use run length chunk by setting run type to zero to report post repair loss count?
What am I missing?

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Huangyihong (Rachel)
发送时间: 2013年10月11日 17:24
收件人: xrblock
主题: [xrblock] FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Hi folks,

This new draft has been uploaded several weeks ago. It defines a new RTCP XR report block to support post-repair Non-RLE loss related metrics reporting. Any comments or suggestions are appreciated.

Best regards,
Rachel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, September 16, 2013 2:08 PM
To: Varun Singh; Huangyihong (Rachel)
Subject: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

A new version of I-D, draft-huang-xrblock-post-repair-loss-count-00.txt
has been successfully submitted by Rachel Huang and posted to the
IETF repository.

Filename:	 draft-huang-xrblock-post-repair-loss-count
Revision:	 00
Title:		 RTP Control Protocol (RTCP) Extended Report (XR) for Post-Repair Non-Run Length Encoding (RLE) Loss Count Metrics
Creation date:	 2013-09-16
Group:		 Individual Submission
Number of pages: 9
URL:             http://www.ietf.org/internet-drafts/draft-huang-xrblock-post-repair-loss-count-00.txt
Status:          http://datatracker.ietf.org/doc/draft-huang-xrblock-post-repair-loss-count
Htmlized:        http://tools.ietf.org/html/draft-huang-xrblock-post-repair-loss-count-00

Abstract:
   This document defines an RTP Control Protocol (RTCP) Extended Report
   (XR) Block that allows reporting of post-repair loss count metrics
   for a range of RTP applications.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
xrblock mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/xrblock

---

From: Varun Singh <[email-masked]>
Date: Sun, 3 Nov 2013 04:55:22 -0800

Hi Qin,

RFC5725 reports run-length encoded post-repair loss, i.e., it indicates which
packets were repaired between a given set of sequence numbers (begin_seq
and end_seq).

draft-huang-xrblock-post-repair-loss-count proposes a post-repair Count metrics
i.e., it reports the number of packets repaired and number of packets
not repaired.
It was submitted as a separate draft because we found the cumulative
count metrics
useful for the webrtc-additional-stats draft and also generically applicable.

Cheers,
Varun

-- 
http://www.netlab.tkk.fi/~varun/

---

From: Qin Wu <[email-masked]>
Date: Sun, 3 Nov 2013 18:42:53 +0000

If we use run length chunk, can we set run type to zero and one separately to report the number of packets to be repaired or not repaired between begin_seq and end_seq?

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Varun Singh
发送时间: 2013年11月3日 20:55
收件人: Qin Wu
抄送: xrblock
主题: Re: [xrblock] 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Hi Qin,

RFC5725 reports run-length encoded post-repair loss, i.e., it indicates which packets were repaired between a given set of sequence numbers (begin_seq and end_seq).

draft-huang-xrblock-post-repair-loss-count proposes a post-repair Count metrics i.e., it reports the number of packets repaired and number of packets not repaired.
It was submitted as a separate draft because we found the cumulative count metrics useful for the webrtc-additional-stats draft and also generically applicable.

Cheers,
Varun

On Sat, Nov 2, 2013 at 2:38 PM, Qin Wu <[email-masked]> wrote:
> 主题: [xrblock] FW: New Version Notification for 
> draft-huang-xrblock-post-repair-loss-count-00.txt
>
> Hi folks,
>
> Subject: New Version Notification for 
> draft-huang-xrblock-post-repair-loss-count-00.txt
>
>
> A new version of I-D, 
> draft-huang-xrblock-post-repair-loss-count-00.txt
> has been successfully submitted by Rachel Huang and posted to the IETF 
> repository.
>
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Sun, 3 Nov 2013 21:18:17 +0000

Hi Qin,

Surely you can calculate the number of packets repaired or not from run length encoding chunks. But note that type zero only reports the events that are all the same (either all received or lost). So in a extreme case where packets are lost frequently but discontinuously (e.g. 101010101010101..... and the range is long, say 100.), you'll need many chunks to report the range.

Best regards,
Rachel

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2013年11月4日 2:43
收件人: Varun Singh
抄送: xrblock
主题: [xrblock] 答复: 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Varun Singh
发送时间: 2013年11月3日 20:55
收件人: Qin Wu
抄送: xrblock
主题: Re: [xrblock] 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Hi Qin,

Cheers,
Varun

---

From: Qin Wu <[email-masked]>
Date: Sun, 3 Nov 2013 23:03:44 +0000

My question is :
For the case you described, can we use run length chunk to report if we don't care the order of repaired bit and unrepaired bit?
If not, I think reporting post repair loss count more makes sense.

Regards!
-Qin
-----邮件原件-----
发件人: Huangyihong (Rachel) 
发送时间: 2013年11月4日 5:18
收件人: Qin Wu; Varun Singh
抄送: xrblock
主题: 答复: [xrblock] 答复: 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Hi Qin,

Best regards,
Rachel

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2013年11月4日 2:43
收件人: Varun Singh
抄送: xrblock
主题: [xrblock] 答复: 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Varun Singh
发送时间: 2013年11月3日 20:55
收件人: Qin Wu
抄送: xrblock
主题: Re: [xrblock] 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Hi Qin,

Cheers,
Varun

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 4 Nov 2013 00:39:54 +0000

Hi Qin,

Yes, you can since the cumulative count could be generated by the receivers of this RLE report block. Post-repair loss count is not dedicated to solve the problem that RLE report block can't solve. It just provides a more convenient and simple way to solve problem in some scenarios where applications may not want to use more energy or bandwidth to report the RLE metrics.

Best regards,
Rachel

-----邮件原件-----
发件人: Qin Wu 
发送时间: 2013年11月4日 7:04
收件人: Huangyihong (Rachel); Varun Singh
抄送: xrblock
主题: 答复: [xrblock] 答复: 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

My question is :

Regards!
-Qin
-----邮件原件-----
发件人: Huangyihong (Rachel)
发送时间: 2013年11月4日 5:18
收件人: Qin Wu; Varun Singh
抄送: xrblock
主题: 答复: [xrblock] 答复: 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Hi Qin,

Best regards,
Rachel

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2013年11月4日 2:43
收件人: Varun Singh
抄送: xrblock
主题: [xrblock] 答复: 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Varun Singh
发送时间: 2013年11月3日 20:55
收件人: Qin Wu
抄送: xrblock
主题: Re: [xrblock] 答复: FW: New Version Notification for draft-huang-xrblock-post-repair-loss-count-00.txt

Hi Qin,

Cheers,
Varun