Subject: [xrblock] Future of XRBLOCK

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Wed, 6 Apr 2016 20:10:45 +0000

Following on from the discussion that has just occurred in the face-to-face meeting.

I would first note that one only really needs a WG to deal with new XR block proposals if the required documentation status is standards track. Perhaps it would be appropriate for people to rejustify why this needs to be standards track rather than just first come first served or expert review.

Secondly, when both PAYLOAD and XRBLOCK were created, there was a view that both these were somewhat special, in that they did not necessarily need to meet, but did need to provide a forum for experts "to turn the handle on the process" and produce something where the relevant experts had looked at it; that in IETF speak is a WG rather than just a mailing list. I do incline still to that. 

Maybe speaking with hindsight, but not sure that the meeting that has just occurred was "value for money"; it could all have been done on the mailing list.

Keith

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 6 Apr 2016 14:51:04 -0700

I was sceptical when XRBLOCK was created and my concerns have only grown
since.  With WebRTC gaining more and more prominence in realtime
communications development in virtually every segment (e.g. Web, mobile,
IoT), an important determinant of whether XRBLOCK WG drafts are widely
implemented is whether they are suitable for inclusion in WebRTC
implementations.  The IPR concerns we have seen in this WG bring with them
the potential for XRBLOCK drafts and RFCs to be shunned by browser vendors
- and thus to amount to little more than "vanity RFCs".

This leads me to question the utility of having XRBLOCK remain as a
separate WG, as opposed to having the work reviewed within a WG that is
more widely attended by WebRTC implementers.

On Wed, Apr 6, 2016 at 1:10 PM, Drage, Keith (Nokia - GB) <
[email-masked]> wrote:

> I would first note that one only really needs a WG to deal with new XR
> block proposals if the required documentation status is standards track.
> Perhaps it would be appropriate for people to rejustify why this needs to
> be standards track rather than just first come first served or expert
> review.
>
> Secondly, when both PAYLOAD and XRBLOCK were created, there was a view
> that both these were somewhat special, in that they did not necessarily
> need to meet, but did need to provide a forum for experts "to turn the
> handle on the process" and produce something where the relevant experts had
> looked at it; that in IETF speak is a WG rather than just a mailing list. I
> do incline still to that.
>
> Maybe speaking with hindsight, but not sure that the meeting that has just
> occurred was "value for money"; it could all have been done on the mailing
> list.
>
> Keith
>
> _______________________________________________
> xrblock mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xrblock
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 7 Apr 2016 16:34:13 +0000

I agree concerning the increased relevance of WebRTC. This is why XRBLOCK has sent multiple info messages and more recently liaison messages to the IETF RTCWEB and W3C WebRTC WGs on significant milestones and LCs. At this point we do not know if future metrics will be needed, but in case there will be such work – which WG ‘that is more widely attended by WebRTC implementers’ you find as appropriate?

Regards,

Dan

From: xrblock [mailto:[email-masked]] On Behalf Of Bernard Aboba
Sent: Thursday, April 07, 2016 12:51 AM
To: Drage, Keith (Nokia - GB)
Cc: [email-masked]
Subject: Re: [xrblock] Future of XRBLOCK

I was sceptical when XRBLOCK was created and my concerns have only grown since.  With WebRTC gaining more and more prominence in realtime communications development in virtually every segment (e.g. Web, mobile, IoT), an important determinant of whether XRBLOCK WG drafts are widely implemented is whether they are suitable for inclusion in WebRTC implementations.  The IPR concerns we have seen in this WG bring with them the potential for XRBLOCK drafts and RFCs to be shunned by browser vendors - and thus to amount to little more than "vanity RFCs".

This leads me to question the utility of having XRBLOCK remain as a separate WG, as opposed to having the work reviewed within a WG that is more widely attended by WebRTC implementers.

On Wed, Apr 6, 2016 at 1:10 PM, Drage, Keith (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:
Following on from the discussion that has just occurred in the face-to-face meeting.

Keith

_______________________________________________
xrblock mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/xrblock<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_xrblock&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=-ZwrWSbRUkTMngGJPOlPU2pp7rjmewa6tM7y08QVyg0&s=5yidGUCVlLefWcTKmrZX71pL7NaOR8NT1vIzaJPspUU&e=>

---

From: Alan Clark <[email-masked]>
Date: Thu, 7 Apr 2016 16:52:43 -0400

Bernard, Keith

I concur that the development of drafts that are intended for use within 
WebRTC should be done within the rtcweb WG in IETF.  I don't think that 
XRBLOCK has had many IPR issues (2 ?) however rtcweb would be much more 
rigorous in limiting the development of drafts that have IPR disclosures.

I must admit to being somewhat disappointed with regard to the video 
loss concealment draft episode - firstly in the way in which irrelevant 
IPR was included in the draft, secondly in the way that the IPR was 
disclosed and thirdly in the resistance that was exhibited to the 
removal of the IPR disclosure.  Participants were suggesting that the WG 
should not even be discussing IPR issues, that having an IPR disclosure 
was not a problem as implementers could get opinions from their 
attorneys or from a court......

I think that the WebRTC statistics draft should be transferred to the 
rtcweb WG, it makes no sense to have this done within XRBLOCK. The 
independent burst gap draft should be progressed and then the XRBLOCK WG 
should be wound up.   I'd be more than happy to review any future 
metrics reporting drafts within AVT, rtcweb or wherever they happen to 
be developed.

Part of the motivation in setting up XRBLOCK was that there were a set 
of unfinished xrblock drafts that had been developed within AVT, these 
were sitting on the shelf and it made sense to dust them off and 
complete them. This has now been done, XRBLOCK's work is (almost) 
complete and the IETF has the very sensible practice of avoiding 
self-perpetuating WG's.

Regards

Alan Clark

On 4/6/16 5:51 PM, Bernard Aboba wrote:
> I was sceptical when XRBLOCK was created and my concerns have only 
> grown since.  With WebRTC gaining more and more prominence in realtime 
> communications development in virtually every segment (e.g. Web, 
> mobile, IoT), an important determinant of whether XRBLOCK WG drafts 
> are widely implemented is whether they are suitable for inclusion in 
> WebRTC implementations.  The IPR concerns we have seen in this WG 
> bring with them the potential for XRBLOCK drafts and RFCs to be 
> shunned by browser vendors - and thus to amount to little more than 
> "vanity RFCs".
>
> separate WG, as opposed to having the work reviewed within a WG that 
> is more widely attended by WebRTC implementers.
>
> On Wed, Apr 6, 2016 at 1:10 PM, Drage, Keith (Nokia - GB) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I would first note that one only really needs a WG to deal with
>     new XR block proposals if the required documentation status is
>     standards track. Perhaps it would be appropriate for people to
>     rejustify why this needs to be standards track rather than just
>     first come first served or expert review.
>
>     Secondly, when both PAYLOAD and XRBLOCK were created, there was a
>     view that both these were somewhat special, in that they did not
>     necessarily need to meet, but did need to provide a forum for
>     experts "to turn the handle on the process" and produce something
>     where the relevant experts had looked at it; that in IETF speak is
>     a WG rather than just a mailing list. I do incline still to that.
>
>     Maybe speaking with hindsight, but not sure that the meeting that
>     has just occurred was "value for money"; it could all have been
>     done on the mailing list.
>
>     Keith
>
>     [email-masked] <mailto:[email-masked]>

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 7 Apr 2016 18:06:13 -0300

> On Apr 7, 2016, at 5:52 PM, Alan Clark <[email-masked]> wrote:
> 
> Bernard, Keith
> 
> I concur that the development of drafts that are intended for use within WebRTC should be done within the rtcweb WG in IETF.  I don't think that XRBLOCK has had many IPR issues (2 ?) however rtcweb would be much more rigorous in limiting the development of drafts that have IPR disclosures.  
> 
> I must admit to being somewhat disappointed with regard to the video loss concealment draft episode - firstly in the way in which irrelevant IPR was included in the draft, secondly in the way that the IPR was disclosed and thirdly in the resistance that was exhibited to the removal of the IPR disclosure.  Participants were suggesting that the WG should not even be discussing IPR issues, that having an IPR disclosure was not a problem as implementers could get opinions from their attorneys or from a court......  
> 
> I think that the WebRTC statistics draft should be transferred to the rtcweb WG, it makes no sense to have this done within XRBLOCK.

The document has already been through WGLC and appears to have consensus to have publication requested, so it is effectively already out of the WG.

> The independent burst gap draft should be progressed and then the XRBLOCK WG should be wound up.   I'd be more than happy to review any future metrics reporting drafts within AVT, rtcweb or wherever they happen to be developed.
> 
> Part of the motivation in setting up XRBLOCK was that there were a set of unfinished xrblock drafts that had been developed within AVT, these were sitting on the shelf and it made sense to dust them off and complete them. This has now been done, XRBLOCK's work is (almost) complete and the IETF has the very sensible practice of avoiding self-perpetuating WG’s.

Sounds like folks are in agreement with what seemed to have consensus at the meeting — keep XRBLOCK open until its current documents are with the RFC Editor, find another group in ART (probably AVTEXT but TBC) and re-charter to have future xr block definitions to be in scope, then close XRBLOCK.

Alissa

>> On Wed, Apr 6, 2016 at 1:10 PM, Drage, Keith (Nokia - GB) < <mailto:[email-masked]>[email-masked] <mailto:[email-masked]>> wrote:
>> https://www.ietf.org/mailman/listinfo/xrblock <https://www.ietf.org/mailman/listinfo/xrblock>
>> 
>> 
>> 
>> https://www.ietf.org/mailman/listinfo/xrblock <https://www.ietf.org/mailman/listinfo/xrblock>
>

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Thu, 7 Apr 2016 21:11:18 +0000

This is in publication request because the IPR declaration was made after publication request.

At the moment all I have a verbal indication from the editor, made in the meeting, that something will happen.

I would rather see the formal IPR process completed, and then make my own assessment that the IPR situation is now satisfactory, rather than have the AD make that decision for me.

Regards

Keith

From: EXT Alissa Cooper [mailto:[email-masked]]
Sent: 07 April 2016 22:06
To: Alan Clark
Cc: Bernard Aboba; Drage, Keith (Nokia - GB); [email-masked]
Subject: Re: [xrblock] Future of XRBLOCK

On Apr 7, 2016, at 5:52 PM, Alan Clark <[email-masked]<mailto:[email-masked]>> wrote:

Bernard, Keith

Part of the motivation in setting up XRBLOCK was that there were a set of unfinished xrblock drafts that had been developed within AVT, these were sitting on the shelf and it made sense to dust them off and complete them. This has now been done, XRBLOCK's work is (almost) complete and the IETF has the very sensible practice of avoiding self-perpetuating WG's.

Sounds like folks are in agreement with what seemed to have consensus at the meeting - keep XRBLOCK open until its current documents are with the RFC Editor, find another group in ART (probably AVTEXT but TBC) and re-charter to have future xr block definitions to be in scope, then close XRBLOCK.

Alissa

Regards

Alan Clark

Keith

xrblock mailing list

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 7 Apr 2016 14:12:15 -0700

Alan said:

" I don't think that XRBLOCK has had many IPR issues (2 ?) however rtcweb
would be much more rigorous in limiting the development of drafts that have
IPR disclosures "

[BA] The problem of late disclosure has grown in the IETF ART area.  So I
am concerned that this is an iceberg with much more under the surface than
we have seen so far - and so more forceful action is going to be needed to
prevent this from getting out of control.

"I think that the WebRTC statistics draft should be transferred to the
rtcweb WG, it makes no sense to have this done within XRBLOCK."

[BA] I agree.  We need IETF RTCWEB WG buyin for this draft and the best way
to get this would be to move it to RTCWEB. In particularly, RTCWEB is
likely to push back more strongly on IPR, and this "backpressure" will also
feedback into the XRBLOCK WG for as long as it remains active.

"The independent burst gap draft should be progressed and then the XRBLOCK
WG should be wound up.   I'd be more than happy to review any future
metrics reporting drafts within AVT, rtcweb or wherever they happen to be
developed."

[BA] I agree that the burst gap draft is potentially valuable and should be
progressed (assuming that there are no issues here as well). Overall, burst
loss related statistics are quite important (as is FEC effectiveness
metrics), since this could help allow the characteristics of the FEC to be
adjusted.

On Thu, Apr 7, 2016 at 1:52 PM, Alan Clark <[email-masked]>
wrote:

> I must admit to being somewhat disappointed with regard to the video loss
> concealment draft episode - firstly in the way in which irrelevant IPR was
> included in the draft, secondly in the way that the IPR was disclosed and
> thirdly in the resistance that was exhibited to the removal of the IPR
> disclosure.  Participants were suggesting that the WG should not even be
> discussing IPR issues, that having an IPR disclosure was not a problem as
> implementers could get opinions from their attorneys or from a court......
>
> should be wound up.   I'd be more than happy to review any future metrics
> reporting drafts within AVT, rtcweb or wherever they happen to be developed.
>
> Part of the motivation in setting up XRBLOCK was that there were a set of
> unfinished xrblock drafts that had been developed within AVT, these were
> sitting on the shelf and it made sense to dust them off and complete them.
> This has now been done, XRBLOCK's work is (almost) complete and the IETF
> has the very sensible practice of avoiding self-perpetuating WG's.
>
> Regards
>
> Alan Clark
>
>
>
> <[email-masked]>[email-masked]> wrote:
>
>> Maybe speaking with hindsight, but not sure that the meeting that has
>> just occurred was "value for money"; it could all have been done on the
>> mailing list.
>>
>> Keith
>>
> xrblock mailing [email-masked]://www.ietf.org/mailman/listinfo/xrblock
>
>
>

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 8 Apr 2016 00:48:21 +0000

Just to let the WG know that, the IPR withdraw request has been sent out by the our IPR department colleague.  I copied it below. We’re waiting for the replies.

“
发件人: Wangxinping
发送时间: 2016年4月7日 9:49
收件人: [email-masked]
抄送: Huangyihong (Rachel)
主题: 转发: Request to remove IPR Disclosure //FW: [xrblock] after the IPR Disclosure related to draft-ietf-xrblock-rtcp-xr-video-lc

Dear Sir/Madam,

According to xrblock WG’s consensus and AD’s opinion, Huawei agrees to remove the IPR disclosure related to draft-ietf-xrblock-rtcp-xr-video-lc in order to ensure the smooth progress of standardization of the work. Would you please help us to remove it? Thank you.

---------------------------------------------------------------------------------
Regards & Thanks!
王歆平
华为技术有限公司 Huawei Technologies Co., Ltd.[Company_logo]

发件人: xrblock [mailto:[email-masked]] 代表 Drage, Keith (Nokia - GB)
发送时间: 2016年4月8日 5:11
收件人: EXT Alissa Cooper; Alan Clark
抄送: [email-masked]
主题: Re: [xrblock] Future of XRBLOCK

Regards

Keith

From: EXT Alissa Cooper [mailto:[email-masked]]
Sent: 07 April 2016 22:06
To: Alan Clark
Cc: Bernard Aboba; Drage, Keith (Nokia - GB); [email-masked]<mailto:[email-masked]>
Subject: Re: [xrblock] Future of XRBLOCK

Bernard, Keith

Sounds like folks are in agreement with what seemed to have consensus at the meeting ― keep XRBLOCK open until its current documents are with the RFC Editor, find another group in ART (probably AVTEXT but TBC) and re-charter to have future xr block definitions to be in scope, then close XRBLOCK.

Alissa

Regards

Alan Clark

Keith

xrblock mailing list

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 8 Apr 2016 08:30:01 -0300

> On Apr 7, 2016, at 6:11 PM, Drage, Keith (Nokia - GB) <[email-masked]> wrote:
> 

What do you mean by “this”? The webrtc metrics draft that my note below mentions does not have any IPR disclosures associated with it.

Alissa

> From: EXT Alissa Cooper [mailto:[email-masked] <mailto:[email-masked]>] 
> Cc: Bernard Aboba; Drage, Keith (Nokia - GB); [email-masked] <mailto:[email-masked]>
> On Apr 7, 2016, at 5:52 PM, Alan Clark <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Bernard, Keith
> 
> On Wed, Apr 6, 2016 at 1:10 PM, Drage, Keith (Nokia - GB) <[email-masked] <mailto:[email-masked]>> wrote: