Subject: [yaco-community-tool] Beta server update

From: "Emilio A. Sánchez" <[email-masked]>
Date: Mon, 16 Jan 2012 11:35:17 +0100

Hi all, happy new year :)

    The beta server is updated with all the requests and suggestions 
gathered in this list. I summarize the most important changes:

    Fixes:
    * Fixed a registration bug when the email already exists in the system
    * Fixed the rule that adds drafts that contain certain string.

    Changes:
    * In list views, drafts are shown first and then RFCs
    * RFC number is displayed instead of the original draft filename
    * CSV export files contain all available fields instead of only the 
configured ones in the list display.
    * URLs of public views are changed so now they contain a secret hash 
only know by the owner of the list.

    Server configuration:
    * Configured submission system. Now new drafts and new versions of 
drafts could be submitted to test the notification feature.
    * Fixed permissions of stream_user. Now this user is allowed to 
change the state of any draft.

    Best,

---

From: Robert Sparks <[email-masked]>
Date: Wed, 18 Jan 2012 13:57:25 -0600

Hi Emilio -

<http://beta.community.yaco.es/doc/ad/robert.sparks/> is producing 
incorrect content
(whether logged in or not) - the columns are not right. When logged in 
as an AD (when it's
the "My documents" page), it doesn't make sense for the add/remove from 
my personal list
knobs to be there. It might make sense for them to be there if its 
someone else looking at
the page, but that might not be worth the extra code maintenance.

RjS

On 1/16/12 4:35 AM, "Emilio A. Sánchez" wrote:
>    * URLs of public views are changed so now they contain a secret 
> hash only know by the owner of the list.
>
>    Server configuration:
> _______________________________________________
> yaco-community-tool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yaco-community-tool

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Wed, 18 Jan 2012 21:31:28 +0100

Hi Robert,

    You are right! I didn't realize that the template that renders each 
row of these tables is used in more than one view.

    I've fixed it, now these links are only displayed when you do a 
draft search.

    Thank you for your report!

    Best,

El 18/01/12 20:57, Robert Sparks escribió:
>> * Fixed permissions of stream_user. Now this user is allowed to change
>> the state of any draft.
>>
>> Best,