Subject: [yaco-liaison-tool] Fwd: Weekly Report, Project Finish and Project Start

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 08 Oct 2010 18:26:33 +0200

Hi All,

I'm forwarding (in part) the Liaison Manager developer's weekly report,
for your information, and to indicate that it would be good for you
to revisit the beta site to see that the comments and wishes which
were expressed earlier on this list has been properly followed up
on.

Best,

	Henrik

-------- Original Message --------
Subject: Weekly Report, Project Finish and Project Start
Date: Fri, 08 Oct 2010 17:28:19 +0200
From: "Emilio A. Sánchez López" <[email-masked]>
To: Henrik Levkowetz <[email-masked]>

    Hi Henrik,

    That week has been interesting! The extension for the lsmt project 
are finished. You can test the result in beta.lsmt.yaco.es

    You can see our weekly report at our trac [1]. I copy&paste the 
report at the end of this email.

    I updated the User Manual with the new features [2]. I also attach 
the manual to this email.

    With this changes the LSMT project is over, of course if any bug is 
found we will fix it as soon as possible.

<snip comments regarding a different project>

    Regards,

[1] https://trac.yaco.es/lsmt/wiki/ProjectBook/20101008
[2] https://trac.yaco.es/lsmt/wiki/Documents/UserManual

=====
October 8, 2010 Report
Progress report

     * Send a reminder when a liaison is close to its deadline
     * Take care of liaisons with deadlines
     * Reuse sortable liaison list in related liaison widget
     * User Manual updated

Fixed tasks

#37    Send a reminder when a liaison is close to its deadline
#38    Take care of liaisons with deadlines
=====

---

From: Patrik Fältström <[email-masked]>
Date: Sun, 10 Oct 2010 13:42:54 +0200

Looks good...

1. There is a link in one of two liaisons that reference each other called "Referenced liaison:". Is it possible to get a similar link "in the other direction"?

2. After adding a liaison as external, I got a crash:

AttributeError at /liaison/927/
'PersonOrOrgInfo' object has no attribute 'is_authenticated'
Request Method:	GET
Request URL:	http://beta.lsmt.yaco.es/liaison/927/
Exception Type:	AttributeError
Exception Value:	
'PersonOrOrgInfo' object has no attribute 'is_authenticated'
Exception Location:	/home/yaco/lsmt/trunk/liaison/ietf/liaisons/views.py in _can_take_care, line 178
Python Executable:	/usr/bin/python
Python Version:	2.6.2
Python Path:	['/home/yaco/lsmt/trunk/liaison', '/usr/local/lib/python2.6/site-packages/ipython-0.10-py2.6.egg', '/usr/local/lib/python2.6/site-packages/buildbot-0.8.1-py2.6.egg', '/usr/local/lib/python2.6/site-packages/Jinja2-2.5-py2.6.egg', '/usr/local/lib/python2.6/site-packages/buildbot_slave-0.8.1-py2.6.egg', '/usr/lib/python26.zip', '/usr/lib/python2.6', '/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk', '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload', '/usr/lib/python2.6/site-packages', '/usr/local/lib/python2.6/site-packages']
Server time:	Sun, 10 Oct 2010 04:42:11 -0700

Otherwise, I think it looks pretty ok.

   Patrik

On 8 okt 2010, at 18.26, Henrik Levkowetz wrote:

> <LSMT_user_manual.pdf>_______________________________________________
> yaco-liaison-tool mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yaco-liaison-tool

---

From: "Emilio A. Sánchez López" <[email-masked]>
Date: Mon, 11 Oct 2010 08:26:17 +0200

Hi Patrik,

> 1. There is a link in one of two liaisons that reference each other called "Referenced liaison:". Is it possible to get a similar link "in the other direction"?

    Of course it is possible and easy to do. I made the changes 
yesterday so, you can test it right now in beta.lsmt.yaco.es

> 2. After adding a liaison as external, I got a crash:

    You found a nice bug! I have fixed too.

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 11 Oct 2010 08:34:22 +0200

On 11 okt 2010, at 08.26, Emilio A. Sánchez López wrote:

>   Of course it is possible and easy to do. I made the changes yesterday so, you can test it right now in beta.lsmt.yaco.es

Thanks.

I guess the way the links are set up give that the relationship is a 1:n, so in the case of what you just added, the result might be a list of liaisons?

>   You found a nice bug! I have fixed too.

Thanks!

   paf

> _______________________________________________

---

From: "Emilio A. Sánchez López" <[email-masked]>
Date: Mon, 11 Oct 2010 08:50:00 +0200

> I guess the way the links are set up give that the relationship is a 1:n, so in the case of what you just added, the result might be a list of liaisons?

    You are totally right. A liaison could be referenced by many other 
ones, in that case a list of liaisons will be displayed.

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 11 Oct 2010 15:28:55 +0200

Hi,

Based on Patrik's comments on the updated beta site, we're now
close to acceptance of the liaison project, including the add-
on items.

If you haven't checked out the beta site, please do it soon --
if there are no new bugs discovered, I plan to indicate acceptance
of this work Thursday 14th, followed by a merge into the main database
code corpus.  If the merge goes well, the next release of the
datatracker code will contain the new liaison management tool, and
the release should happen in about one week.

Best regards,

	Henrik

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 11 Oct 2010 16:13:29 +0200

> the release should happen in about one week.

Is it sorted out who is doing all the work with assigning the roles at time of launch?

   Patrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 11 Oct 2010 16:51:57 +0200

Hi Patrik,

> Is it sorted out who is doing all the work with assigning the roles at time of launch?

No.  What would you suggest as the optimal approach?

Best,

	Henrik

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 11 Oct 2010 17:03:07 +0200

> No.  What would you suggest as the optimal approach?

Have whoever handle the [email-masked] do the following:

1. Add the IAB and IETF chairs, wg chairs, area directors etc as apropriate (as described in the document).

2. Add the liaisons in the IETF assigned and named on the IAB list of liaisons.

[done]

Later: Have those liaisons be able to report (or possibly add) the external liaisons that should be able to file incoming liaisons.

   Patrik

---

From: Alexa Morris <[email-masked]>
Date: Tue, 12 Oct 2010 15:02:48 -0700

We have a question about how new liaison organizations are added to  
the tool. As the process currently works, if the Secretariat goes to  
post a new liaison and discovers that the appropriate peer  
organization is not listed as one of the available drop down  
selections, we are able to (via another django tool) add the  
organization so that, once we go back to the liaison tool,  the new  
organization appears as a selection option.

Will this still work the same way or will we need to make a change to  
how we add new peer organizations?

Thanks,
Alexa

> the release should happen in about one week.

-----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: "Stephanie McCammon" <[email-masked]>
Date: Tue, 12 Oct 2010 15:46:30 -0700

Hello,
 
I think this looks really wonderful, and I just have a couple of
questions/comments that I would like to address.
 
1.  When a deadline has passed and action was taken before that deadline
occurred, the liaisons are currently marked as 'Already taken care'.   It
may be more efficient to say 'Resolved' or "Action Taken'.  When the liaison
has not been marked as 'Already taken care', it currently says 'No actions
taked'.  Perhaps this might be improved by saying 'Action Required'.  
 
2.  Are all authorized parties allowed to edit the liaisons they submitted
or are editing abilities limited to the Secretariat?  
 
3.  When you enter an outgoing liaison statement it doesn't seem to show up
in the liaison list once it is submitted.  However, if you attempt to submit
the same liaison a second time it says that a liaison of that name has
already been submitted.
 
Thank you.
 
Sincerely,
 
Stephanie McCammon
IETF Registrar
48377 Fremont Blvd, Ste. 117
Fremont, CA 94538
T: +1.510.492.4081
F: +1.510.492.4001
 
Association Management Solutions (AMS)
Forum Management, Meeting, and Event Planning
www.amsl.com <http://www.amsl.com/> 

  _____  

From: Emilio Sanchez [mailto:[email-masked]] 
Sent: Tuesday, October 12, 2010 1:20 PM
To: Alexa Morris
Cc: Henrik Levkowetz; Russ Housley; Stephanie McCammon
Subject: Re: [yaco-liaison-tool] Acceptance?

   I've manage to fix the server so you can try whenever you want :)

2010/10/12 Alexa Morris <[email-masked]>

Thanks! I'll check back tomorrow and spend some time playing in the tool. 

Much appreciated,
Alexa

On Oct 12, 2010, at 1:12 PM, Emilio Sanchez wrote:

   Hi Alexa,
  
   In the beta server beta.lsmt.yaco.es you have different test users
(username/password):

*	admin/admin 

*	This user is an IETF Liaison Manager 

*	external/external 

*	This user is an SDO Manager of 3GPP and WIPO 

*	This user is an SDO Authorized of IEEE 802 and Open Grid Forum 

*	internal/internal 

*	This user is the Area Director of the Application Area 

*	This user is a Working Group Secretary of 'Performance Metrics for
Other Layers' group. 

*	internal2/internal2 

*	This user is the IETF/IESG Chair 

*	This user is the IAB Executive Chair 

    Probably you want to use admin/admin cause this user is able to do
almost anything.

    By the way, it seems that the beta server is down right now. I'm opening
a ticket to our systems team so it will be fixed tomorrow early in the
morning.

    Regards,

2010/10/12 Alexa Morris <[email-masked]>

Henrik, Emilio,

Looks like the Secretariat should get familiar with the new tool ASAP! :-)

I am reviewing, along with Stephanie McCammon (who processes liaisons for
the Secretariat) the new user manual. And I'd like us to be able to play
with the tool a bit as well, but I'm not sure if we have a username /
password to get into it. We may have received one some time ago, not sure,
but if we did I cannot locate it.

Can someone please create an account on the tool so that we can familiarize
ourselves with it?

Many thanks,
Alexa

Begin forwarded message:

From: Patrik Fältström <[email-masked]>
Date: October 11, 2010 8:03:07 AM PDT
To: Henrik Levkowetz <[email-masked]>
Cc: [email-masked]
Subject: Re: [yaco-liaison-tool] Acceptance? 

Is it sorted out who is doing all the work with assigning the roles at time
of launch?

1. Add the IAB and IETF chairs, wg chairs, area directors etc as apropriate
(as described in the document).

2. Add the liaisons in the IETF assigned and named on the IAB list of
liaisons.

[done]

Later: Have those liaisons be able to report (or possibly add) the external
liaisons that should be able to file incoming liaisons.

 Patrik

-----------

-----------

---

From: Emilio Sanchez <[email-masked]>
Date: Wed, 13 Oct 2010 09:10:27 +0200

Hi Alexa.

2010/10/13 Alexa Morris <[email-masked]>

> We have a question about how new liaison organizations are added to the
> tool. As the process currently works, if the Secretariat goes to post a new
> liaison and discovers that the appropriate peer organization is not listed
> as one of the available drop down selections, we are able to (via another
> django tool) add the organization so that, once we go back to the liaison
> tool,  the new organization appears as a selection option.
>
> Will this still work the same way or will we need to make a change to how
> we add new peer organizations
>

   Of course, any organization added via de django admin interface will be
automatically available in the liaison tool.

---

From: Emilio Sanchez <[email-masked]>
Date: Wed, 13 Oct 2010 09:44:26 +0200

Hi Stephanie,

2010/10/13 Stephanie McCammon <[email-masked]>

> occurred, the liaisons are currently marked as 'Already taken care'.
> It may be more efficient to say 'Resolved' or "Action Taken'.  When the
> liaison has not been marked as 'Already taken care', it currently says 'No
> actions taked'.  Perhaps this might be improved by saying 'Action
> Required'.
>

   That's easy, we have to change just the strings. I can do that change
this morning.

> or are editing abilities limited to the Secretariat?

   The editing abilities are limited to Secretariat and Liaison Manager
(I'll explain what is an IETF Liaison Manager in another mail).

> the same liaison a second time it says that a liaison of that name has
     When you send an outgoing liaison you have to mark that you have prior
approval to send it. There is a checkbox to do this. Probably you didn't
check it so the liaison is not public until someone approves it. The person
who can approve the liaison depends on who you select the liaison comes from
(If the liaison comes from a WG then the Area director can approve, if it
comes from the IETF then the IETF chair should approve it.

     If you check that checkbox when creating the liaison then is supposed
you have obtained prior approval so the liaison will go public without any
other user interaction.

Thank you.
> www.amsl.com
>  ------------------------------
> *From:* Emilio Sanchez [mailto:[email-masked]]
> *Sent:* Tuesday, October 12, 2010 1:20 PM
> *To:* Alexa Morris
> *Cc:* Henrik Levkowetz; Russ Housley; Stephanie McCammon
>
> *Subject:* Re: [yaco-liaison-tool] Acceptance?
>
>>    - admin/admin
>>       - This user is an IETF Liaison Manager
>>
>>
>>    - external/external
>>       - This user is an SDO Manager of 3GPP and WIPO
>>       - This user is an SDO Authorized of IEEE 802 and Open Grid Forum
>>
>>
>>    - internal/internal
>>       - This user is the Area Director of the Application Area
>>       - This user is a Working Group Secretary of 'Performance Metrics
>>       for Other Layers' group.
>>
>>
>>    - internal2/internal2
>>       - This user is the IETF/IESG Chair
>>       - This user is the IAB Executive Chair
>>
>>     By the way, it seems that the beta server is down right now. I'm
>> opening a ticket to our systems team so it will be fixed tomorrow early in
>> the morning.
>>
>>     Regards,
>>
>>> Can someone please create an account on the tool so that we can
>>> familiarize ourselves with it?
>>>
>>> Many thanks,
>>> Alexa
>>>
>>> Begin forwarded message:
>>>
>>>> 1. Add the IAB and IETF chairs, wg chairs, area directors etc as
>>>> apropriate (as described in the document).
>>>>
>>>> Later: Have those liaisons be able to report (or possibly add) the
>>>> external liaisons that should be able to file incoming liaisons.
>>>>
>>>>  Patrik
>>>>

---

From: Alexa Morris <[email-masked]>
Date: Wed, 13 Oct 2010 08:26:37 -0700

See inline:

On Oct 13, 2010, at 12:44 AM, Emilio Sanchez wrote:

>
>
> 3.  When you enter an outgoing liaison statement it doesn't seem to  
> show up in the liaison list once it is submitted.  However, if you  
> attempt to submit the same liaison a second time it says that a  
> liaison of that name has already been submitted.
>
>
>      When you send an outgoing liaison you have to mark that you  
> have prior approval to send it. There is a checkbox to do this.  
> Probably you didn't check it so the liaison is not public until  
> someone approves it. The person who can approve the liaison depends  
> on who you select the liaison comes from (If the liaison comes from  
> a WG then the Area director can approve, if it comes from the IETF  
> then the IETF chair should approve it.
>
>      If you check that checkbox when creating the liaison then is  
> supposed you have obtained prior approval so the liaison will go  
> public without any other user interaction.
>
>

This is very helpful, thanks! What should we do if we forget to click  
"obtained prior approval"? Would it be possible (or desirable?) to get  
a "you have not indicated that you have prior approval to post this  
liaison. If you do not, please obtain approval before proceeding" or  
some such warning? Otherwise it seems that it: 1) people may be  
confused about what step to take next or 2) the liaison may not get  
posted, without the person quite realizing it that they failed to post  
it correctly.

>>    In the beta server beta.lsmt.yaco.es you have different test  
>> users (username/password):
>>
>> admin/admin
>> This user is an IETF Liaison Manager
>> external/external
>> This user is an SDO Manager of 3GPP and WIPO
>> This user is an SDO Authorized of IEEE 802 and Open Grid Forum
>> internal/internal
>> This user is the Area Director of the Application Area
>> This user is a Working Group Secretary of 'Performance Metrics for  
>> Other Layers' group.
>> internal2/internal2
>> This user is the IETF/IESG Chair
>> This user is the IAB Executive Chair
>>     Probably you want to use admin/admin cause this user is able to  
>> do almost anything.
>>
>>     By the way, it seems that the beta server is down right now.  
>> I'm opening a ticket to our systems team so it will be fixed  
>> tomorrow early in the morning.
>>
>>     Regards,
>>
>> I am reviewing, along with Stephanie McCammon (who processes  
>> liaisons for the Secretariat) the new user manual. And I'd like us  
>> to be able to play with the tool a bit as well, but I'm not sure if  
>> we have a username / password to get into it. We may have received  
>> one some time ago, not sure, but if we did I cannot locate it.
>>

-----------

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 13 Oct 2010 18:14:16 +0200

Hi Alexa,

On 2010-10-13 17:26 Alexa Morris said:
> some such warning?

That may seem desirable if one is mainly posting _with_ prior approval,
but adds an extra unwanted 'are you sure' prompt for those who should
get post-approval...  It doesn't seem to be fatal to forget to click
this box, as it will then just go to the appropriate approval level for
approval -- it won't be sitting waiting forever, I think?

> Otherwise it seems that it: 1) people may be  

1) can be handled by a note in the page coming up after posting which
indicates that the post has been sent to so-and-so for approval, maybe?

2) should never occur, as the post will then go for approval in a
normal manner, no?

Regards,

	Henrik

---

From: Alexa Morris <[email-masked]>
Date: Wed, 13 Oct 2010 09:52:20 -0700

Ah, got it. Thanks, all of that seems perfect then, thanks. Though I  
think that a note indicating that the liaison has been sent to the  
appropriate person for approval would be helpful, if it's not too much  
to add.

Alexa

-----------

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 13 Oct 2010 20:55:28 +0200

I think the default behaviour to start with is that all postings made DO have prior approval. I.e. this tool is not for approval, or editing of things before something is posted. One day it might be that the default is that people do NOT have approval, but that is not the case today.

So I think we are fine. People are just asked "do you have approval" as a last resort check "please think before you post".

Not as a formal approval/editing system, because that is happening out of bound.

   Patrik

On 13 okt 2010, at 18.52, Alexa Morris wrote:

> Ah, got it. Thanks, all of that seems perfect then, thanks. Though I think that a note indicating that the liaison has been sent to the appropriate person for approval would be helpful, if it's not too much to add.
> 
> Alexa
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 14 Oct 2010 12:27:04 +0200

Hi Patrik,

One thought, inline:

On 2010-10-13 20:55 Patrik Fältström said:
> I think the default behaviour to start with is that all postings made
> DO have prior approval. I.e. this tool is not for approval, or
> editing of things before something is posted. One day it might be
> that the default is that people do NOT have approval, but that is not
> the case today.

So should the 'prior approval' checkbox be checked by default, for now?

Best,

	Henrik

> So I think we are fine. People are just asked "do you have approval"
> as a last resort check "please think before you post".
> 
> Not as a formal approval/editing system, because that is happening
> out of bound.> 
>    Patrik
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 14 Oct 2010 13:48:52 +0200

On 2010-10-14 12:50 Patrik Faltstrom (pfaltstr) said:
> On 14 okt 2010, at 12:28, "Henrik Levkowetz" <[email-masked]> wrote:
...
> No, I think it is good if people have to check it.

Ah.  Ok, then.

Best,

	Henrik