Subject: Re: [yaco-liaison-tool] The liaison tool: Status Update

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 06 Apr 2011 14:28:41 +0200

(Adding the yaco-liaison-tool list, as this belongs there).

Emilio,

As a test, I temporarily added myself as a liaison manager to be able to
see what they see, and I find the comment below correct -- I see no way
in the liaison edit form to edit the information mentioned by Patrik below:
person, deadline_date, related_to.

Could you have a look at this, please?

	Henrik

On 2011-04-06 07:21 Patrik Fältström said:
> While asking how the tool works...I have not understood how to edit a
> liaison...for example who holds the action item, the final date, and
> the links to what liaison it references (something that MUST be
> edited and set correctly).
> 
> Btw, I have added Eliot, the new liaison from IETF to ITU-T, as cc on this.
> 
>    Patrik Fältström
>    Distinguished Consulting Engineer
>    Office of the CTO
> 
>    For corporate legal information go to:
>    http://www.cisco.com/web/about/doing_business/legal/cri/index.html
> 
> 
> On 5 apr 2011, at 23.40, Stephanie McCammon wrote:
> 
>>
>>
>> Hi All,
>>
>> Alexa sent an email earlier today about Adrian Farrel not being able to edit the cc field in the new liaison tool, and I realized while I was trying to post his liaison that I don't have that capability either.  Is this something that can be changed?
>>
>> Thanks,
>>
>> Stephanie McCammon
>> IETF Registrar
>> 48377 Fremont Blvd, Ste. 117
>> Fremont, CA 94538
>> T: +1.510.492.4081
>> F: +1.510.492.4001
>>
>> Association Management Solutions (AMS)
>> Forum Management, Meeting, and Event Planning
>> www.amsl.com
>>
>>
>>
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 06 Apr 2011 14:34:12 +0200

(Adding the yaco-liaison-tool list, as this belongs there)

Stephanie,

I tested this on an arbitrary liaison statement, and for that one
the Cc: field seems to be editable.  Which specific liaison statement
did your report below relate to?  Was this when posting, or in the
edit form after posting?

Regards,

	Henrik

On 2011-04-05 23:40 Stephanie McCammon said:
> 
> 
> Hi All,
> 
> Alexa sent an email earlier today about Adrian Farrel not being able
> to edit the cc field in the new liaison tool, and I realized while I
> was trying to post his liaison that I don't have that capability
> either.  Is this something that can be changed?

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Wed, 06 Apr 2011 16:03:39 +0200

Hi all,

    I have check the edit form of a liaison and I see that you can edit 
the deadline and the related liaison without problems. Note that if you 
have selected 'For information' or 'In response' in the purpose selector 
then the deadline field is removed cause it is not needed.

    Any information in the detail view of the liaison is editable in the 
edit form except the submission date.

    I don't understand what data want's to edit Patrik when he say 'who 
holds the action item'. If he refers to the person who can 'take care' 
of a liaison, this person is selected automatically.

    Best,

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Wed, 06 Apr 2011 16:17:57 +0200

Hi,

    I check that one to. The cc field is always filled automatically 
when creating the liaison (we have talked about that in previous 
emails). But it seems that when you send an outgoing liaison (from one 
IETF entity to one SDO) then the field remains void and is not filled 
automatically.

    Is this the problem Stephanie?

    I see in the code that I introduce a bug when we made the very last 
changes to the tool in 
http://trac.tools.ietf.org/tools/ietfdb/changeset/2790

    It's a really silly bug so I'm going to fix it, but please confirm 
that this is the error you are talking about.

    Regards,

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Wed, 06 Apr 2011 16:24:08 +0200

Hi,
El 06/04/11 16:17, "Emilio A. Sánchez" escribió:
> Hi,
>
> I check that one to. The cc field is always filled automatically when
> creating the liaison (we have talked about that in previous emails). But
> it seems that when you send an outgoing liaison (from one IETF entity to
> one SDO) then the field remains void and is not filled automatically.
>
> It's a really silly bug so I'm going to fix it, but please confirm that
> this is the error you are talking about.

    I have fixed the bug in 
http://trac.tools.ietf.org/tools/ietfdb/changeset/3025 As you can see 
this was an easy one :)

    Henrik, I have commited the changes to the liaison tool branch so 
you'll have to merge it.

    Best,

---

From: Stephanie McCammon <[email-masked]>
Date: Wed, 6 Apr 2011 08:31:56 -0700

Hi Henrik,

I was attempting to add a new liaison statement, not edit an existing one.  

Thanks,

Stephanie

Stephanie McCammon
IETF Registrar

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 07 Apr 2011 10:25:10 +0200

Hi Emilio,

On 2011-04-06 16:03 "Emilio A. Sánchez" said:
...

> of a liaison, this person is selected automatically.

But if the SDO Liaison Manager is changing, then liaisons which still
need to be taken care of will need to be updated, no?

	Henrik

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Thu, 07 Apr 2011 10:54:20 +0200

Hi.

> need to be taken care of will need to be updated, no?

    I'm revising the code. The persons who are allowed to 'take care' of 
a liaison are:

    * The secretariat (always)
    * Any person whose email is listed under 'cc', 'reply_to', 'poc', 
'response_contact', 'technical_contact' and the submitter. Of course 
only if this person has an user in the datatracker.

    One option is edit one of this field (but this is so ugly).

    I think that the best option is allow to the 'take care' a if the 
current user is allowed to edit the liaison (This check is done on the 
fly and checks if the user is currently an sdo manager of the liaison).

    Best,

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Thu, 07 Apr 2011 11:08:12 +0200

Hi Patrik,

El 07/04/11 10:34, Patrik Fältström escribió:
> On 7 apr 2011, at 10.25, Henrik Levkowetz wrote:
>
>> Hi Emilio,
>>
> Any individual that have a role that have edit access to certain liaisons (depending on whether the liaison is incoming, outgoing and what external organisation is involved) must be able to update the action date and responsible person (that holds the token of action).

    If you can edit a liaison then you can change its deadline date.

> I have also seen cases when for example responses of some kind of liaisons have been added without having "link to older liaison" has not been set, so that kind of "cleanup" must also be possible.

    Same here, if you can edit the liaison then you can add the 
reference to other liaison.

> For example, as liaison to Unicode Consortium from IETF, I should have such edit rights on the liaisons that have to do with Unicode Consortium (in or out).
>
> ITU-T liaison (Eliot) should have such edit rights to any ITU-T related liaison.
>
> Normally otherwise, an individual only have edit rights to either liaisons they have posted, or liaisons they are token holders of.
>
> Or something like that.
>
> The important thing is to be able to update the liaisons. And we can trust our (IETF) liaisons, so to get fine-grained access rights is not so important. The ability to get things right in the database is. Having bad data in the database -- as now -- is not working in the long(er) run.

    I suppose, as I said in my previous mail, that the problem is who 
can 'take care' (mark as done) a liaison. Right now this action can be 
done by anyone whose email is listed in the liaison. But probably I 
should add the people that can edit the liaison to the ones that can 
'take care' of it.

    Best,

>     Patrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 07 Apr 2011 11:16:05 +0200

Hi Emilio,

I'm not sure you, Patrik and myself are talking about the same thing
here.  See more below.

> fly and checks if the user is currently an sdo manager of the liaison).

There's an entry in the LiaisonDetails class which is 'person'.
This would be the person who holds the token to handle a liaison,
maybe?  If so, I think that's the entry Patrik would like to update.

But if this entry isn't used anywhere, then we need to figure out
the distinction between the set of people who 'can take care of' a
liaison, and the person who has the token.

Best,

	Henrik

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Thu, 07 Apr 2011 11:26:49 +0200

El 07/04/11 11:19, Patrik Fältström escribió:
> On 7 apr 2011, at 11.08, Emilio A. Sánchez wrote:
>
>>    I suppose, as I said in my previous mail, that the problem is who can 'take care' (mark as done) a liaison. Right now this action can be done by anyone whose email is listed in the liaison. But probably I should add the people that can edit the liaison to the ones that can 'take care' of it.
>
> That imply that someone from ITU-T that is the receiver of a liaison can log in an edit an outgoing liaison that they receive... "interesting feature"...
>
> You have an access right already today when one add a liaison, right? That access algorithm say whether you as a user can add certain data in the to/from fields.

    No, no, no. He can use the button "Take care of" (the one that 
appears in the detail of a liaison next to 'No actions taken') cause he 
(as a receiver) can now if the liaison has been taken care.

    People who can edit a liaison are:

    * The secretariat (always)
    * A Liaison Manager with these conditions:
       * For outgoing liaisons: If the liaison was sent to its SDO
       * For incoming liaisons: If the liaison was sent from its SDO

> 1. An external party, for example someone from ITU SG2, should only be able to add a liaison that is incoming to IETF from SG2, but with various receivers on the IETF side.
>
> 2. An internal party, for example liaison to ITU-T SG2, should only be able to add liaisons to or from IETF and that external party.
>
> 3. An internal party that has power gloves, like the liaison to ITU-T should be like (2) but for more SG's than one
>
> 4. Secretariat should be able to access everything
>
> Easiest way of course for 1, 2 and 3 is to have the ability for each user to map that to one relationship, and whether the access is incoming or outgoing. For example:
>
> A. A user have access to some external groups (zero or more).
>
> B. If the user is _incoming_ then the user can only add incoming liaisons.
>
> C. If the user is _outgoing_ then the user can add incoming, outgoing liaisons AND edit the liaisons.
>
> But once again, I am not so worried about giving people "too much access" to start with, because we have had problems for years with having not enough access in the tool.
>
> So lets start with what you now have created! Sounds fine!
>
>     Patrik
>

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Thu, 07 Apr 2011 11:37:19 +0200

Hi,

    Right now the field person of the LiaisonDetail model stores the 
PersonOrOrgInfo of the user that creates the liaison. The real one so if 
the secretariat is sending a liaisons the person field has the 
secretariat user person.

    But this info is not used to grant any privilege over the liaisons.

    Best,

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 07 Apr 2011 12:59:24 +0200

Hi Emilio,

>     But this info is not used to grant any privilege over the liaisons.

Ah.  If I read that correctly, there's simply no concept of 'token
holder' in the current tool, then.

Right?

	Henrik

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Thu, 07 Apr 2011 13:03:57 +0200

> holder' in the current tool, then.

    You are right.

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 7 Apr 2011 10:34:45 +0200

Or something like that.

   Patrik

---

From: Patrik Fältström <[email-masked]>
Date: Thu, 7 Apr 2011 11:19:34 +0200

Patrik

---

From: Eliot Lear <[email-masked]>
Date: Thu, 07 Apr 2011 12:09:34 +0200

Hi Emilio and all,

I wonder if we could have a call to catch me up on all that is going on
with the tool?  Would that be possible sometime next week?

Eliot

On 4/7/11 11:37 AM, "Emilio A. Sánchez" wrote:
> PersonOrOrgInfo of the user that creates the liaison. The real one so
> if the secretariat is sending a liaisons the person field has the
> secretariat user person.
>

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Thu, 07 Apr 2011 12:33:34 +0200

Hi Eliot,

    I think we are complicating things cause we have sent many emails in 
the last days.

    If I'm not wrong (please, anyone correct me if I am) there are two 
main issues:

    * The Cc: field is not editable when sending a liaison

    * There is a bit confusion regarding who can edit a liaison and who 
can 'take care' of a liaison. This issue involves resolving which person 
has the token and if we need to edit that person.

    In order to not mix things I think that is better if we open two new 
threads in the list so we can discuss each issue.

    If everyone is agree I can open these two threads with a summary and 
a explanation of how the current tool works.

    Best,

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 07 Apr 2011 13:31:43 +0200

So the response below opens the question:

Do we need to add the concept of Token Holder to the tool?
If so, I think that's a new feature, and we need to get approval
for the funding.  That doesn't mean we shouldn't add that if it's
a clear need for it.

Patrik?  Others?

Best,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 07 Apr 2011 13:36:22 +0200

Hi,

>     But this info is not used to grant any privilege over the liaisons.

Ah.  So that field could more properly have been called 'creator'.  Ok.

Best,

	Henrik

---

From: Stephanie McCammon <[email-masked]>
Date: Fri, 8 Apr 2011 10:58:18 -0700

Hello Everyone,

I just tried to post an outgoing liaison and received an error that said I was not allowed to send an outgoing liaison to ITU-T SG15.  I was attempting to post it on behalf of Adrian Farrel who is listed as the liaison manager for ITU-T SG 15.  Can this be fixed?

Thank you,

Stephanie

Stephanie McCammon
IETF Registrar

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Mon, 11 Apr 2011 11:33:37 +0200

Hi,

    I have fixed this issue in 
http://trac.tools.ietf.org/tools/ietfdb/ticket/648

    Now the tool takes into account which user are you imporsonating in 
order to check if he/she is allowed to send a liaison to an specific SDO.

    Regards,

El 08/04/11 19:58, Stephanie McCammon escribió:
>
>
> Hello Everyone,
>
> I just tried to post an outgoing liaison and received an error that said
> I was not allowed to send an outgoing liaison to ITU-T SG15. I was
> attempting to post it on behalf of Adrian Farrel who is listed as the
> liaison manager for ITU-T SG 15. Can this be fixed?
>
> Thank you,
>
> Stephanie
>
>
> www.amsl.com <http://www.amsl.com/>
>
>
>

---

From: Stephanie McCammon <[email-masked]>
Date: Tue, 12 Apr 2011 08:24:56 -0700

Hi Emilio,

I have just tried to post the liaison on behalf of Adrian Farrel and it still says that I am not allowed to send it and reverts the form back to saying that it is from me.  Could you please look into this again?

Thank you,

Stephanie

On Apr 11, 2011, at 2:33 AM, Emilio A. Sánchez wrote:

>   Hi,
> 
>   I have fixed this issue in http://trac.tools.ietf.org/tools/ietfdb/ticket/648
> 
>   Now the tool takes into account which user are you imporsonating in order to check if he/she is allowed to send a liaison to an specific SDO.
> 
>   Regards,
> 

Stephanie McCammon
IETF Registrar

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Tue, 12 Apr 2011 17:28:25 +0200

Hi Stephanie.

    The last fix is applied in a repository branch, it needs to be 
merged into trunk and then update the code of the production server.

    Henrik, could you do the merge?

    Best,

El 12/04/11 17:24, Stephanie McCammon escribió:
>
>
> Hi Emilio,
>
> I have just tried to post the liaison on behalf of Adrian Farrel and it
> still says that I am not allowed to send it and reverts the form back to
> saying that it is from me. Could you please look into this again?
>
> Thank you,
>
> Stephanie
>
>
>>> www.amsl.com <http://www.amsl.com> <http://www.amsl.com/>
>>>
>>>
>>>
>>
>
> Stephanie McCammon
> IETF Registrar

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 12 Apr 2011 17:34:10 +0200

Hi Emilio, Stephanie,

>      Henrik, could you do the merge?

Yes, I plan to do a merge and then a release; hopefully today but maybe it will
be tomorrow.  This is slower than my normal pace, but on the other hand, I'm on
vacation and supposed to relax and recuperate ,;-)

Best,

	Henrik

>>>> www.amsl.com<http://www.amsl.com>  <http://www.amsl.com/>
>>>>
>>>>
>>>>
>>>
>>
>> Stephanie McCammon
>> IETF Registrar
>> www.amsl.com<http://www.amsl.com/>
>>
>>
>>
>
>

---

From: Stephanie McCammon <[email-masked]>
Date: Fri, 15 Apr 2011 13:23:47 -0700

Hello everyone,

Henrik was able to do the merge, however the tool is still not functioning properly.  It still tells me that I am not allowed to send a liaison to the ITU-T SG 15.  Please look into this as soon as you have a chance.

Adrian,

The new liaison tool will not let me post the response liaison to the ITU-T SG 15 regarding COM15-LS293-E, and while we are working this out you may want to try posting it for yourself.  The CC field should now be editable for you.  Please let me know if you have any questions.

Sincerely,

Stephanie

On Apr 12, 2011, at 8:28 AM, Emilio A. Sánchez wrote:

>   Hi Stephanie.
> 
>   The last fix is applied in a repository branch, it needs to be merged into trunk and then update the code of the production server.
> 

Stephanie McCammon
IETF Registrar

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 15 Apr 2011 22:07:01 +0100

Thanks Stephanie,
 
Do you know whether if *I* post it, it will show all the dates right and not
send another copy?
 
There is no really great urgency to getting a copy of the LS into the tracker,
but I would like to avoid any snafus with what is ultimately recorded and what
might get sent.
 
Cheers,
Adrian
 
PS - Tanks to all for working on the tool!
 
From: Stephanie McCammon [mailto:[email-masked]] 
Sent: 15 April 2011 21:24
To: Emilio A. Sánchez
Cc: Henrik Levkowetz; Patrik Fältström; Alexa Morris; Russ Housley; Eliot Lear;
Ray Pelletier; Barney Glen; [email-masked]; [email-masked]
Subject: Re: The liaison tool: Status Update

Hello everyone
 
Henrik was able to do the merge, however the tool is still not functioning
properly.  It still tells me that I am not allowed to send a liaison to the
ITU-T SG 15.  Please look into this as soon as you have a chance.
 
Adrian,
 
The new liaison tool will not let me post the response liaison to the ITU-T SG
15 regarding COM15-LS293-E, and while we are working this out you may want to
try posting it for yourself.  The CC field should now be editable for you.
Please let me know if you have any questions.
 
Sincerely,
 
Stephanie

  Hi Stephanie.

  The last fix is applied in a repository branch, it needs to be merged into
trunk and then update the code of the production server.

  Best,

 
 
Hi Emilio,

Thank you,
 
Stephanie

Hi,

 
Regards,

Hello Everyone,

Thank you,
 
Stephanie

Hi,

Right now the field person of the LiaisonDetail model stores the
PersonOrOrgInfo of the user that creates the liaison. The real one
so if
the secretariat is sending a liaisons the person field has the
secretariat user person.

 
Best,
 
Henrik
 
Best,

 

 
I don't understand what data want's to edit Patrik when he say 'who
holds the action item'. If he refers to the person who can 'take
care'
of a liaison, this person is selected automatically.
 
But if the SDO Liaison Manager is changing, then liaisons which
still
need to be taken care of will need to be updated, no?

 
 
I think that the best option is allow to the 'take care' a if the
current user is allowed to edit the liaison (This check is done
on the
fly and checks if the user is currently an sdo manager of the
liaison).

Best,
 
Henrik

Stephanie McCammon
IETF Registrar

 

Stephanie McCammon
IETF Registrar

 

Stephanie McCammon
IETF Registrar

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Mon, 18 Apr 2011 08:30:47 +0200

Hi Stephanie.

    It seems that Henrik merged an old branch. Well, this is good cause 
in that branch there were unmergched changes.

    Henrik, do you remember that you create a new liaison branch to work 
over the same tool currently deployed? The changeset that resolves 
Stephanie's problem is 
http://trac.tools.ietf.org/tools/ietfdb/changeset/3040

    Best,

El 15/04/11 22:23, Stephanie McCammon escribió:
>
>
> Hello everyone,
>
> Henrik was able to do the merge, however the tool is still not
> functioning properly. It still tells me that I am not allowed to send a
> liaison to the ITU-T SG 15. Please look into this as soon as you have a
> chance.
>
> Adrian,
>
> The new liaison tool will not let me post the response liaison to the
> ITU-T SG 15 regarding COM15-LS293-E, and while we are working this out
> you may want to try posting it for yourself. The CC field should now be
> editable for you. Please let me know if you have any questions.
>
> Sincerely,
>
> Stephanie
>
>
>> The last fix is applied in a repository branch, it needs to be merged
>> into trunk and then update the code of the production server.
>>
>>>>> www.amsl.com <http://www.amsl.com> <http://www.amsl.com>
>>>>> <http://www.amsl.com/>
>>>>>
>>>>>
>>>>>
>>>>
>>>
>>> Stephanie McCammon
>>> IETF Registrar

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 18 Apr 2011 08:57:48 +0200

Hi Emilio,

Aargh! Mea culpa! I'll merge and release the right one today.

Sorry!

    Henrik

On 18 Apr 2011, at 08:30, "Emilio A. Sánchez" <[email-masked]> wrote:

>   Hi Stephanie.
> 
>   It seems that Henrik merged an old branch. Well, this is good cause in that branch there were unmergched changes.
> 
>   Henrik, do you remember that you create a new liaison branch to work over the same tool currently deployed? The changeset that resolves Stephanie's problem is http://trac.tools.ietf.org/tools/ietfdb/changeset/3040
> 
>   Best,
>

---

From: Alexa Morris <[email-masked]>
Date: Thu, 21 Apr 2011 12:15:54 -0700

Adrian:

When you post a liaison, it will show the date it was posted -- there  
is no option (at least for us) to change the date to make it show the  
original submission date.

Henrik, Emilio:
is there an option -- or should there be -- to update the date so that  
it reflects the actual submission date and not the (now very delayed)  
date that it will be posted? There is another liaison in the queue  
that Stephanie could not post, but now can, that will be similarly  
impacted.

And to Adrian's other question, when the Secretariat posts a liaison,  
we have the option to "post only" or "post and send". Does a regular  
liaison manager have the ability to make such a distinction as well?  
It sounds as if Adrian might want to avoid a duplicate announcement  
since he already copied a bunch of folks on his initial attempt at  
posting the liaison.

Thanks,
Alexa

On Apr 15, 2011, at 2:07 PM, Adrian Farrel wrote:

> Thanks Stephanie,
>
> Do you know whether if *I* post it, it will show all the dates right  
> and not send another copy?
>
> There is no really great urgency to getting a copy of the LS into  
> the tracker, but I would like to avoid any snafus with what is  
> ultimately recorded and what might get sent.
>
> Cheers,
> Adrian
>
> Cc: Henrik Levkowetz; Patrik Fältström; Alexa Morris; Russ Housley;  
> Eliot Lear; Ray Pelletier; Barney Glen; [email-masked]; [email-masked]
> functioning properly.  It still tells me that I am not allowed to  
> send a liaison to the ITU-T SG 15.  Please look into this as soon as  
> you have a chance.
>
> Adrian,
>
> The new liaison tool will not let me post the response liaison to  
> the ITU-T SG 15 regarding COM15-LS293-E, and while we are working  
> this out you may want to try posting it for yourself.  The CC field  
> should now be editable for you.  Please let me know if you have any  
> questions.
>
> Sincerely,
>
> Stephanie
>
>

-----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Russ Housley <[email-masked]>
Date: Thu, 21 Apr 2011 15:30:14 -0400

Yes there should be an option -- for two reasons.

(1) Incoming Liaison Statements - sometimes other SDOs send them to Chairs or ADs, which then get forwarded at some later point for posting.  They should reflect the date that they were originally received.

(2) Outgoing Liaison Statements - again, mistakes happen.  If the tool is not used to send it in the first place, when it is posted it should reflect the date it was actually sent to the recipient SDO.

Russ

On Apr 21, 2011, at 3:15 PM, Alexa Morris wrote:

> Adrian:
> 
> When you post a liaison, it will show the date it was posted -- there is no option (at least for us) to change the date to make it show the original submission date. 
> 
> Henrik, Emilio: 
> is there an option -- or should there be -- to update the date so that it reflects the actual submission date and not the (now very delayed) date that it will be posted? There is another liaison in the queue that Stephanie could not post, but now can, that will be similarly impacted. 
> 
> And to Adrian's other question, when the Secretariat posts a liaison, we have the option to "post only" or "post and send". Does a regular liaison manager have the ability to make such a distinction as well? It sounds as if Adrian might want to avoid a duplicate announcement since he already copied a bunch of folks on his initial attempt at posting the liaison.
> 
> Thanks,
> Alexa
> 
> 
>> Do you know whether if *I* post it, it will show all the dates right and not send another copy?
>>  
>> There is no really great urgency to getting a copy of the LS into the tracker, but I would like to avoid any snafus with what is ultimately recorded and what might get sent.
>>  
>> Cheers,
>> Adrian
>>  
>> Cc: Henrik Levkowetz; Patrik Fältström; Alexa Morris; Russ Housley; Eliot Lear; Ray Pelletier; Barney Glen; [email-masked]; [email-masked]

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Mon, 25 Apr 2011 18:19:33 +0200

It seems that anyone allowed to send liaisons (incoming or outgoing) 
may need to change the submission date.

    So, I think the best option is to add a submission date field into 
the form (prepopulated with the current date but editable).

    In that case anyone allowed to send liaisons will be able to falsify 
the submission date. If that's right I can do the appropriate changes in 
the code to add this field.

    Best,

El 21/04/11 21:30, Russ Housley escribió:
> (1) Incoming Liaison Statements - sometimes other SDOs send them to
> Chairs or ADs, which then get forwarded at some later point for posting.
> They should reflect the date that they were originally received.
>
> (2) Outgoing Liaison Statements - again, mistakes happen. If the tool is
> not used to send it in the first place, when it is posted it should
> reflect the date it was actually sent to the recipient SDO.
>
> Russ
>
>
>>> There is no really great urgency to getting a copy of the LS into the
>>> tracker, but I would like to avoid any snafus with what is ultimately
>>> recorded and what might get sent.
>>> Cheers,
>>> Adrian
>>> *From:*Stephanie McCammon [mailto:[email-masked]]
>>> *Sent:*15 April 2011 21:24
>>> *To:*Emilio A. Sánchez
>>> *Cc:*Henrik Levkowetz; Patrik Fältström; Alexa Morris; Russ Housley;
>>> Eliot Lear; Ray Pelletier; Barney Glen;[email-masked]
>>> <mailto:[email-masked]>;[email-masked]
>>> <mailto:[email-masked]>
>>> *Subject:*Re: The liaison tool: Status Update
>>> Hello everyone
>>> functioning properly. It still tells me that I am not allowed to send
>>> a liaison to the ITU-T SG 15. Please look into this as soon as you
>>> have a chance.
>>> Adrian,
>>> ITU-T SG 15 regarding COM15-LS293-E, and while we are working this
>>> out you may want to try posting it for yourself. The CC field should
>>> now be editable for you. Please let me know if you have any questions.
>>> Sincerely,
>>> Stephanie
>>>                                     I don't understand what data
>>>                                     want's to edit Patrik when he say
>>>                                     'who
>>>
>>>             www.amsl.com <http://www.amsl.com/><http://www.amsl.com
>>>             <http://www.amsl.com/>> <http://www.amsl.com/>
>>>
>>>     Stephanie McCammon
>>>
>>>     IETF Registrar
>>>
>>>     www.amsl.com <http://www.amsl.com/><http://www.amsl.com/>
>>>
>>> Stephanie McCammon
>>> IETF Registrar
>> Email: [email-masked] <mailto:[email-masked]>
>>

---

From: Russ Housley <[email-masked]>
Date: Mon, 25 Apr 2011 15:58:49 -0400

You might want to pop up a warning if the date is seriously different than now, just to confirm that the person means to use the provided date.

Russ

On Apr 25, 2011, at 12:19 PM, Emilio A. Sánchez wrote:

>   It seems that anyone allowed to send liaisons (incoming or outgoing) may need to change the submission date.
> 
>   So, I think the best option is to add a submission date field into the form (prepopulated with the current date but editable).
> 
>   In that case anyone allowed to send liaisons will be able to falsify the submission date. If that's right I can do the appropriate changes in the code to add this field.
> 
>   Best,
>

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Wed, 27 Apr 2011 13:50:58 +0200

Hi all,

    I have done the changes needed to add the new field. See 
http://trac.tools.ietf.org/tools/ietfdb/ticket/653

    Now the user can enter the submission date when sending a new 
liaison (or when editing an existing one).

    If the date enter is more than 30 days different than now a warning 
will be displayed when submitting the form.

    Best,

El 25/04/11 21:58, Russ Housley escribió:
>>>>>             www.amsl.com<http://www.amsl.com/><http://www.amsl.com
>>>>>     www.amsl.com<http://www.amsl.com/><http://www.amsl.com/>
>>>>>
>>>>> Stephanie McCammon
>>>>> IETF Registrar
>>>> Email: [email-masked]<mailto:[email-masked]>
>>>>