Subject: Re: [yaco-liaison-tool] The liaison tool: Status Update

From: Stephanie McCammon <[email-masked]>
Date: Wed, 11 May 2011 08:31:12 -0700

Hi Emilio,

Thank you for doing this, however I don't see the editable field for submission date in the tool.  Could you please look into why this field isn't visible?

Thank you,

Stephanie

On Apr 27, 2011, at 4:50 AM, Emilio A. Sánchez wrote:

>   Hi all,
> 
>   I have done the changes needed to add the new field. See http://trac.tools.ietf.org/tools/ietfdb/ticket/653
> 
>   Now the user can enter the submission date when sending a new liaison (or when editing an existing one).
> 
>   If the date enter is more than 30 days different than now a warning will be displayed when submitting the form.
> 
>   Best,
> 
> El 25/04/11 21:58, Russ Housley escribió:
>> You might want to pop up a warning if the date is seriously different than now, just to confirm that the person means to use the provided date.
>> 
>> Russ
>> 
>> 
>> On Apr 25, 2011, at 12:19 PM, Emilio A. Sánchez wrote:
>> 
>>>   It seems that anyone allowed to send liaisons (incoming or outgoing) may need to change the submission date.
>>> 
>>>   So, I think the best option is to add a submission date field into the form (prepopulated with the current date but editable).
>>> 
>>>   In that case anyone allowed to send liaisons will be able to falsify the submission date. If that's right I can do the appropriate changes in the code to add this field.
>>> 
>>>   Best,
>>> 
>>> El 21/04/11 21:30, Russ Housley escribió:
>>>> Yes there should be an option -- for two reasons.
>>>> 
>>>> (1) Incoming Liaison Statements - sometimes other SDOs send them to
>>>> Chairs or ADs, which then get forwarded at some later point for posting.
>>>> They should reflect the date that they were originally received.
>>>> 
>>>> (2) Outgoing Liaison Statements - again, mistakes happen. If the tool is
>>>> not used to send it in the first place, when it is posted it should
>>>> reflect the date it was actually sent to the recipient SDO.
>>>> 
>>>> Russ
>>>> 
>>>> 
>>>> On Apr 21, 2011, at 3:15 PM, Alexa Morris wrote:
>>>> 
>>>>> Adrian:
>>>>> 
>>>>> When you post a liaison, it will show the date it was posted -- there
>>>>> is no option (at least for us) to change the date to make it show the
>>>>> original submission date.
>>>>> 
>>>>> Henrik, Emilio:
>>>>> is there an option -- or should there be -- to update the date so that
>>>>> it reflects the actual submission date and not the (now very delayed)
>>>>> date that it will be posted? There is another liaison in the queue
>>>>> that Stephanie could not post, but now can, that will be similarly
>>>>> impacted.
>>>>> 
>>>>> And to Adrian's other question, when the Secretariat posts a liaison,
>>>>> we have the option to "post only" or "post and send". Does a regular
>>>>> liaison manager have the ability to make such a distinction as well?
>>>>> It sounds as if Adrian might want to avoid a duplicate announcement
>>>>> since he already copied a bunch of folks on his initial attempt at
>>>>> posting the liaison.
>>>>> 
>>>>> Thanks,
>>>>> Alexa
>>>>> 
>>>>> 
>>>>> On Apr 15, 2011, at 2:07 PM, Adrian Farrel wrote:
>>>>> 
>>>>>> Thanks Stephanie,
>>>>>> Do you know whether if *I* post it, it will show all the dates right
>>>>>> and not send another copy?
>>>>>> There is no really great urgency to getting a copy of the LS into the
>>>>>> tracker, but I would like to avoid any snafus with what is ultimately
>>>>>> recorded and what might get sent.
>>>>>> Cheers,
>>>>>> Adrian
>>>>>> PS - Tanks to all for working on the tool!
>>>>>> *From:*Stephanie McCammon [mailto:[email-masked]]
>>>>>> *Sent:*15 April 2011 21:24
>>>>>> *To:*Emilio A. Sánchez
>>>>>> *Cc:*Henrik Levkowetz; Patrik Fältström; Alexa Morris; Russ Housley;
>>>>>> Eliot Lear; Ray Pelletier; Barney Glen;[email-masked]
>>>>>> <mailto:[email-masked]>;[email-masked]
>>>>>> <mailto:[email-masked]>
>>>>>> *Subject:*Re: The liaison tool: Status Update
>>>>>> Hello everyone
>>>>>> Henrik was able to do the merge, however the tool is still not
>>>>>> functioning properly. It still tells me that I am not allowed to send
>>>>>> a liaison to the ITU-T SG 15. Please look into this as soon as you
>>>>>> have a chance.
>>>>>> Adrian,
>>>>>> The new liaison tool will not let me post the response liaison to the
>>>>>> ITU-T SG 15 regarding COM15-LS293-E, and while we are working this
>>>>>> out you may want to try posting it for yourself. The CC field should
>>>>>> now be editable for you. Please let me know if you have any questions.
>>>>>> Sincerely,
>>>>>> Stephanie
>>>>>> On Apr 12, 2011, at 8:28 AM, Emilio A. Sánchez wrote:
>>>>>> 
>>>>>> 
>>>>>> Hi Stephanie.
>>>>>> 
>>>>>> The last fix is applied in a repository branch, it needs to be merged
>>>>>> into trunk and then update the code of the production server.
>>>>>> 
>>>>>> Henrik, could you do the merge?
>>>>>> 
>>>>>> Best,
>>>>>> 
>>>>>> El 12/04/11 17:24, Stephanie McCammon escribió:
>>>>>> 
>>>>>>    Hi Emilio,
>>>>>> 
>>>>>>    I have just tried to post the liaison on behalf of Adrian Farrel
>>>>>>    and it
>>>>>> 
>>>>>>    still says that I am not allowed to send it and reverts the form
>>>>>>    back to
>>>>>> 
>>>>>>    saying that it is from me. Could you please look into this again?
>>>>>> 
>>>>>>    Thank you,
>>>>>> 
>>>>>>    Stephanie
>>>>>> 
>>>>>>    On Apr 11, 2011, at 2:33 AM, Emilio A. Sánchez wrote:
>>>>>> 
>>>>>>        Hi,
>>>>>> 
>>>>>>        I have fixed this issue in
>>>>>> 
>>>>>>        http://trac.tools.ietf.org/tools/ietfdb/ticket/648
>>>>>> 
>>>>>>        Now the tool takes into account which user are you
>>>>>>        imporsonating in
>>>>>> 
>>>>>>        order to check if he/she is allowed to send a liaison to an
>>>>>>        specific SDO.
>>>>>> 
>>>>>>        Regards,
>>>>>> 
>>>>>>        El 08/04/11 19:58, Stephanie McCammon escribió:
>>>>>> 
>>>>>>            Hello Everyone,
>>>>>> 
>>>>>>            I just tried to post an outgoing liaison and received an
>>>>>>            error that said
>>>>>> 
>>>>>>            I was not allowed to send an outgoing liaison to ITU-T
>>>>>>            SG15. I was
>>>>>> 
>>>>>>            attempting to post it on behalf of Adrian Farrel who is
>>>>>>            listed as the
>>>>>> 
>>>>>>            liaison manager for ITU-T SG 15. Can this be fixed?
>>>>>> 
>>>>>>            Thank you,
>>>>>> 
>>>>>>            Stephanie
>>>>>> 
>>>>>>            On Apr 7, 2011, at 4:36 AM, Henrik Levkowetz wrote:
>>>>>> 
>>>>>>                Hi,
>>>>>> 
>>>>>>                On 2011-04-07 11:37 "Emilio A. Sánchez" said:
>>>>>> 
>>>>>>                    Hi,
>>>>>> 
>>>>>>                    Right now the field person of the LiaisonDetail
>>>>>>                    model stores the
>>>>>> 
>>>>>>                    PersonOrOrgInfo of the user that creates the
>>>>>>                    liaison. The real one
>>>>>> 
>>>>>>                    so if
>>>>>> 
>>>>>>                    the secretariat is sending a liaisons the person
>>>>>>                    field has the
>>>>>> 
>>>>>>                    secretariat user person.
>>>>>> 
>>>>>>                    But this info is not used to grant any privilege
>>>>>>                    over the liaisons.
>>>>>> 
>>>>>>                Ah. So that field could more properly have been
>>>>>>                called 'creator'. Ok.
>>>>>> 
>>>>>>                Best,
>>>>>> 
>>>>>>                Henrik
>>>>>> 
>>>>>>                    Best,
>>>>>> 
>>>>>>                    El 07/04/11 11:16, Henrik Levkowetz escribió:
>>>>>> 
>>>>>>                        Hi Emilio,
>>>>>> 
>>>>>>                        I'm not sure you, Patrik and myself are
>>>>>>                        talking about the same thing
>>>>>> 
>>>>>>                        here. See more below.
>>>>>> 
>>>>>>                        On 2011-04-07 10:54 "Emilio A. Sánchez" said:
>>>>>> 
>>>>>>                            Hi.
>>>>>> 
>>>>>>                            El 07/04/11 10:25, Henrik Levkowetz escribió:
>>>>>> 
>>>>>>                                Hi Emilio,
>>>>>> 
>>>>>>                                On 2011-04-06 16:03 "Emilio A.
>>>>>>                                Sánchez" said:
>>>>>> 
>>>>>>                                ...
>>>>>> 
>>>>>>                                    I don't understand what data
>>>>>>                                    want's to edit Patrik when he say
>>>>>>                                    'who
>>>>>> 
>>>>>>                                    holds the action item'. If he
>>>>>>                                    refers to the person who can 'take
>>>>>> 
>>>>>>                                    care'
>>>>>> 
>>>>>>                                    of a liaison, this person is
>>>>>>                                    selected automatically.
>>>>>> 
>>>>>>                                But if the SDO Liaison Manager is
>>>>>>                                changing, then liaisons which
>>>>>> 
>>>>>>                                still
>>>>>> 
>>>>>>                                need to be taken care of will need to
>>>>>>                                be updated, no?
>>>>>> 
>>>>>>                            I'm revising the code. The persons who
>>>>>>                            are allowed to 'take care' of
>>>>>> 
>>>>>>                            a liaison are:
>>>>>> 
>>>>>>                            * The secretariat (always)
>>>>>> 
>>>>>>                            * Any person whose email is listed under
>>>>>>                            'cc', 'reply_to', 'poc',
>>>>>> 
>>>>>>                            'response_contact', 'technical_contact'
>>>>>>                            and the submitter. Of course
>>>>>> 
>>>>>>                            only if this person has an user in the
>>>>>>                            datatracker.
>>>>>> 
>>>>>>                            One option is edit one of this field (but
>>>>>>                            this is so ugly).
>>>>>> 
>>>>>>                            I think that the best option is allow to
>>>>>>                            the 'take care' a if the
>>>>>> 
>>>>>>                            current user is allowed to edit the
>>>>>>                            liaison (This check is done
>>>>>> 
>>>>>>                            on the
>>>>>> 
>>>>>>                            fly and checks if the user is currently
>>>>>>                            an sdo manager of the
>>>>>> 
>>>>>>                            liaison).
>>>>>> 
>>>>>>                        There's an entry in the LiaisonDetails class
>>>>>>                        which is 'person'.
>>>>>> 
>>>>>>                        This would be the person who holds the token
>>>>>>                        to handle a liaison,
>>>>>> 
>>>>>>                        maybe? If so, I think that's the entry Patrik
>>>>>>                        would like to update.
>>>>>> 
>>>>>>                        But if this entry isn't used anywhere, then
>>>>>>                        we need to figure out
>>>>>> 
>>>>>>                        the distinction between the set of people who
>>>>>>                        'can take care of' a
>>>>>> 
>>>>>>                        liaison, and the person who has the token.
>>>>>> 
>>>>>>                        Best,
>>>>>> 
>>>>>>                        Henrik
>>>>>> 
>>>>>>            Stephanie McCammon
>>>>>> 
>>>>>>            IETF Registrar
>>>>>> 
>>>>>>            48377 Fremont Blvd, Ste. 117
>>>>>> 
>>>>>>            Fremont, CA 94538
>>>>>> 
>>>>>>            T: +1.510.492.4081
>>>>>> 
>>>>>>            F: +1.510.492.4001
>>>>>> 
>>>>>>            Association Management Solutions (AMS)
>>>>>> 
>>>>>>            Forum Management, Meeting, and Event Planning
>>>>>> 
>>>>>>            www.amsl.com<http://www.amsl.com/><http://www.amsl.com
>>>>>>            <http://www.amsl.com/>>  <http://www.amsl.com/>
>>>>>> 
>>>>>>    Stephanie McCammon
>>>>>> 
>>>>>>    IETF Registrar
>>>>>> 
>>>>>>    48377 Fremont Blvd, Ste. 117
>>>>>> 
>>>>>>    Fremont, CA 94538
>>>>>> 
>>>>>>    T: +1.510.492.4081
>>>>>> 
>>>>>>    F: +1.510.492.4001
>>>>>> 
>>>>>>    Association Management Solutions (AMS)
>>>>>> 
>>>>>>    Forum Management, Meeting, and Event Planning
>>>>>> 
>>>>>>    www.amsl.com<http://www.amsl.com/><http://www.amsl.com/>
>>>>>> 
>>>>>> Stephanie McCammon
>>>>>> IETF Registrar
>>>>>> 48377 Fremont Blvd, Ste. 117
>>>>>> Fremont, CA 94538
>>>>>> T: +1.510.492.4081
>>>>>> F: +1.510.492.4001
>>>>>> 
>>>>>> Association Management Solutions (AMS)
>>>>>> Forum Management, Meeting, and Event Planning
>>>>>> www.amsl.com<http://www.amsl.com/>
>>>>>> 
>>>>>> 
>>>>> 
>>>>> -----------
>>>>> Alexa Morris / Executive Director / IETF
>>>>> 48377 Fremont Blvd., Suite 117, Fremont, CA 94538
>>>>> Phone: +1.510.492.4089 / Fax: +1.510.492.4001
>>>>> Email: [email-masked]<mailto:[email-masked]>
>>>>> 
>>>>> Managed by Association Management Solutions (AMS)
>>>>> Forum Management, Meeting and Event Planning
>>>>> www.amsl.com<http://www.amsl.com>  <http://www.amsl.com/>
>>>>> 
>>>> 
>>> 
>> 
> 

Stephanie McCammon
IETF Registrar
48377 Fremont Blvd, Ste. 117
Fremont, CA 94538
T: +1.510.492.4081
F: +1.510.492.4001

Association Management Solutions (AMS)
Forum Management, Meeting, and Event Planning
www.amsl.com

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Wed, 11 May 2011 18:39:07 +0200

Hi Stephanie,

    I suppose that Henrik have to merge the changes and update the 
production server. Then you will able to use the new features.

    Best,

El 11/05/11 17:31, Stephanie McCammon escribió:
>
>
> Hi Emilio,
>
> Thank you for doing this, however I don't see the editable field for
> submission date in the tool. Could you please look into why this field
> isn't visible?
>
> Thank you,
>
> Stephanie
>
>
>> I have done the changes needed to add the new field. See
>> http://trac.tools.ietf.org/tools/ietfdb/ticket/653
>>
>> If the date enter is more than 30 days different than now a warning
>> will be displayed when submitting the form.
>>
>> Best,
>>
>>> You might want to pop up a warning if the date is seriously different
>>> than now, just to confirm that the person means to use the provided date.
>>>
>>> Russ
>>>
>>>
>>>> So, I think the best option is to add a submission date field into
>>>> the form (prepopulated with the current date but editable).
>>>>
>>>> In that case anyone allowed to send liaisons will be able to falsify
>>>> the submission date. If that's right I can do the appropriate
>>>> changes in the code to add this field.
>>>>
>>>> Best,
>>>>
> www.amsl.com <http://www.amsl.com/>
>
>
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 11 May 2011 18:53:58 +0200

Hi Emilio,

> production server. Then you will able to use the new features.

I believe I've done so, but can't see the submission date field when
I look at a liaison edit field with secretariat permissions.

Emilio, can you point me to a page on the beta server where I can see
how this should look, so I can try to find out what's happening here?

Best regards,

	Henrik

---

From: Stephanie McCammon <[email-masked]>
Date: Wed, 18 May 2011 11:29:11 -0700

Hi Emilio,

I'm trying to add an outgoing liaison however I'm running into an issue with the drop down menu in the 'From' section.  The problem I'm having is with the drop down for the person that it's from.  Do you know how these drop down menus are populated and where I can go to add someone?  I've been digging around in the Liaisons Administration area but can't find a way to do it.

Thank you,

Stephanie

Stephanie McCammon
IETF Registrar

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Mon, 23 May 2011 08:45:23 +0200

> Hi Emilio,

    Hi Stephanie

> I'm trying to add an outgoing liaison however I'm running into an issue
> with the drop down menu in the 'From' section. The problem I'm having is
> with the drop down for the person that it's from. Do you know how these
> drop down menus are populated and where I can go to add someone? I've
> been digging around in the Liaisons Administration area but can't find a
> way to do it.

    When you try to add an outgoing liaison as secretariat you can 
select one user in the from field from all the users allowed to send 
outgoing liaisons on behalf of the entity you have selected in the from 
field.

    The users allowed to send liaisons on behalf of one IETF entities are:

    * On behalf of any entity: Any SDO manager.

    * On behalf of the IETF/IESG: The IETF/IESG chair.

    * On behalf of the IAB: The IAB chair and the IAB Executive director.

    * On behalf of an Area: The area directors.

    * On behalf of an IETF WG: The WG chairs.

    So you can add people to the list in the following ways:

    * Adding a new SDO manager in the django admin interface.

    * Changing the IETF/IESG/IAB chair, probably you don't want to do 
this :)

    * Adding a new Area director or a new WG Chair. Of course only if he 
or she is an are Area director or a WG Chair.

    If the person you want to add to the list already meets any of these 
conditions and is not on the list then maybe there is some bug in the tool.

    Best,

>>>> www.amsl.com <http://www.amsl.com> <http://www.amsl.com/>
>>>>
>>>>
>>>>
>>>
>>>
>>
>
> Stephanie McCammon
> IETF Registrar

---

From: Eliot Lear <[email-masked]>
Date: Mon, 23 May 2011 08:48:34 +0200

On 5/23/11 8:45 AM, "Emilio A. Sánchez" wrote:
> outgoing liaisons on behalf of the entity you have selected in the
> from field.
>

I certainly don't see this behavior.
>    * Adding a new Area director or a new WG Chair. Of course only if
> he or she is an are Area director or a WG Chair.
>
>    If the person you want to add to the list already meets any of
> these conditions and is not on the list then maybe there is some bug
> in the tool.
>
>    Best,
>
>
>
>
>> Thank you,
>>
>> Stephanie
>>
>>
>>>>>> Now the user can enter the submission date when sending a new
>>>>>> liaison
>>>>>> (or when editing an existing one).
>>>>>>
>>>>>>>> It seems that anyone allowed to send liaisons (incoming or
>>>>>>>> outgoing)
>>>>>>>> may need to change the submission date.
>>>>>>>>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 23 May 2011 11:56:32 +0200

Hi Eliot,

On 2011-05-23 08:48 Eliot Lear said:

<<snip>>

> I certainly don't see this behavior.

You shoudn't (unless you've joined the secretariat :) -- this capability
is only available when logged in as secretariat staff.

Best,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 23 May 2011 12:16:05 +0200

Hi Stephanie,

On 2011-05-23 08:45 "Emilio A. Sánchez" said:

<<snip>>

>     * Adding a new SDO manager in the django admin interface.

And more specifically, you need to go to:
  http://datatracker.ietf.org/admin/liaisons/liaisonmanagers/

There are several steps you need to go through to add a brand new
Liaison Manager.  This will be simplified a lot with the new database
schema, but for now, with the old layout, it's a bit messy:

* If the person you wish to add as a Liaison Manager isn't in the list at
  all, you click on the grey "Add SDO Liaison Manager" field above the
  table to the right, and use the looking-glass to search for the person
  and select the appropriate SDO in the drop-down list.  Click 'Save' and
  you'll be back in the list of Liaison Managers.

  (If he doesn't even exist as a person in the system yet, he needs to be
  added first -- you probably would do that through the rolodex app, although
  it can be done directly in the Django admin interface too).

* If the Person who is now a liaison manager doesn't have a login for the
  system, you'll see 'Add login: <<email-addr>>' with <<email-addr>> in red
  in the fourth column of the table for your new Liaison Manger.  Click on
  the red link and fill in the needed information in the form this leads to.
  Then go back to the list of Liaison Managers and refresh it.

* If the new Liaison Manager doesn't have an entry as a Liaison User, the
  fourth column for him will now show 'Add liaison User <<name>>', with <<name>>
  in red.  Click on the red link and check the information which has been auto-
  filled in the form.  Fix if needed and click 'Save'.  Go back to the list
  of LiaisonManagers and refresh.

Your new liaison manager should now be set up with everything needed, and
you should see him in the drop-down list when you go to edit a liaison.  If
not, there's a bug, as Emilio said ,;-)

Best regards,

	Henrik

---

From: Stephanie McCammon <[email-masked]>
Date: Tue, 24 May 2011 14:53:47 -0700

Hi Emilio,

I realized today that you can only have one related liaison selected in the tool.  Is it possible to add the functionality to have multiple related liaisons?

Thank you,

Stephanie

Stephanie McCammon
IETF Registrar