Subject: Re: [yaco-wgchair-tracker] Test driving the new WG Chair Tracker

From: "Emilio A. Sánchez López" <[email-masked]>
Date: Mon, 04 Apr 2011 13:14:52 +0200

Hi Alexa,

    Thank you for the link, it really helps me to find whats wrong with 
the code.

    Basically, when a WG Chair or Delegate tries to edit the state of a 
draft that has no stream defined he can assing this draft to his WG and 
change it to the 'Call for adoption' state.

    The code checks if the user is WG Chair or Delegate of more than one 
WG so a select with all the allowed WGs are show. In that piece of code 
was the bug. You as secretariat have permission to change the state but 
you are not a WG Chair or Delegate so you have no WG related.

    I have fixed it. As a secretariat user you can select any of the 
existing WGs.

    Regards,

El 01/04/11 08:16, Alexa Morris escribió:
> Thanks Emilio. I am getting error messages for every document I try to
> update. But I've included one of the error messages below:
>
> IndexError at /streams/draft-penno-alto-ipv4v6/edit/state/
> list index out of range
> Request Method:
> GET
> Request URL:
> http://beta.wgchairs.yaco.es/streams/draft-penno-alto-ipv4v6/edit/state/
> Exception Type:
> IndexError
> Exception Value:
> list index out of range
> Exception Location:
> /var/www/django_ietf/wgchairs/ietf/ietfworkflows/forms.py in __init__,
> line 63
> Python Executable:
> /usr/bin/python
> Python Version:
> 2.6.2
> Python Path:
> ['/var/www/django_ietf/wgchairs', '/var/www/django_ietf/wgchairs/ietf',
> '/usr/lib/python26.zip', '/usr/lib/python2.6',
> '/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk',
> '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload',
> '/usr/lib/python2.6/site-packages',
> '/usr/local/lib/python2.6/site-packages']
> Server time:
> Thu, 31 Mar 2011 23:14:13 -0700
>
> -Alexa
>
> On Mar 31, 2011, at 6:54 AM, Emilio A. Sánchez wrote:
>
>> Hi Alexa,
>>
>> I have log in as Secretariat but I don't get any error when editing
>> states of a document.
>>
>> In which document you are trying these links (or in which url)? This
>> information will aid me to track the error.
>>
>> Thank you.
>>
>> El 31/03/11 13:42, Alexa Morris escribió:
>>> Emilio,
>>>
>>> Now when I log in as Secretariat I do see the options to change state,
>>> change draft stream, etc -- great! Unfortunately, I get an error message
>>> when I click on any of them, so something is still not quite right.
>>>
>>> Thanks,
>>> Alexa
>>>
>>> On Mar 10, 2011, at 10:31 AM, Alexa Morris wrote:
>>>
>>>> Quick question re Secretariat login: accessing the tool that way does
>>>> not show any of the additional features. So far the only way we have
>>>> been able to view the additions is as a WG Chair. Can someone look
>>>> into this please?
>>>>
>>>> Thanks,
>>>> Alexa
>>>>
>>>> On Mar 2, 2011, at 2:21 AM, Henrik Levkowetz wrote:
>>>>
>>>>> Thank you, Emilio.
>>>>>
>>>>> So for now, let's use the following mapping:
>>>>>
>>>>> amorris alto_chair
>>>>> barryleiba hybi_chair
>>>>> cloos calcify_chair
>>>>> cmorgan karp_chair
>>>>> edj eai_chair
>>>>> joseph hokey_chair
>>>>> kmoreland karp_chair
>>>>> mankin manet_chair
>>>>> michaelrf mif_chair
>>>>> paul pcp_chair
>>>>> sm savi_chair
>>>>> tme trill_chair
>>>>>
>>>>> Subscribers from the secretariat are additionally encouraged to
>>>>> log in as secretariat/secretariat, and comment on the tool from
>>>>> that perspective.
>>>>>
>>>>>
>>>>> Best,
>>>>>
>>>>> Henrik
>>>>>
>>>>>
>>>>> If anyone listed above is here just to monitor, not to e
>>>>>
>>>>> On 2011-03-01 18:24 "Emilio A. Sánchez López" said:
>>>>>> Hi,
>>>>>>
>>>>>> I create the following users that are chairs of the respective
>>>>>> working group:
>>>>>>
>>>>>> * alto_chair
>>>>>> * calsify_chair
>>>>>> * eai_chair
>>>>>> * hybi_chair
>>>>>> * hokey_chair
>>>>>> * karp_chair
>>>>>> * manet_chair
>>>>>> * mif_chair
>>>>>> * pcp_chair
>>>>>> * savi_chair
>>>>>> * trill_chair
>>>>>>
>>>>>>
>>>>>> Following Henrik's recommendation I chose working groups starting
>>>>>> with the letters of the subscribers emails. Unfortunately there is no
>>>>>> group beginning with 'j' so I use 'hokey' group.
>>>>>>
>>>>>> Best,
>>>>>>
>>>>>> El 24/02/11 17:17, Henrik Levkowetz escribió:
>>>>>>> Hi Emilio,
>>>>>>>
>>>>>>> Please see Paul's comment below -- would it be possible for you
>>>>>>> to set
>>>>>>> up additional accounts, one for each mailing list member and some
>>>>>>> additional spare accounts? Currently we have 11 subscribers
>>>>>>> (excepting
>>>>>>> yourself), with email addresses beginning with:
>>>>>>>
>>>>>>> * a
>>>>>>> * c
>>>>>>> * e
>>>>>>> * h
>>>>>>> * j
>>>>>>> * k
>>>>>>> * m
>>>>>>> * m
>>>>>>> * p
>>>>>>> * s
>>>>>>> * t
>>>>>>>
>>>>>>> Maybe we could use active working groups starting with these
>>>>>>> letters, to
>>>>>>> keep things orderly and separated?
>>>>>>>
>>>>>>>
>>>>>>> Best,
>>>>>>>
>>>>>>> Henrik
>>>>>>>
>>>>>>>
>>>>>>> On 2011-02-24 16:56 Paul Hoffman said:
>>>>>>>> On 2/24/11 7:40 AM, Henrik Levkowetz wrote:
>>>>>>>>> Hello, and welcome.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> This mailing list is for information about and discussion of
>>>>>>>>> the new
>>>>>>>>> WG Chair Tracker. It is currently running in a beta version on a
>>>>>>>>> separate beta server, so nothing that you do will actually change
>>>>>>>>> the ietf production database.
>>>>>>>>>
>>>>>>>>> Please bang on it and send questions and comments to this list.
>>>>>>>>>
>>>>>>>>> The developer (Emilio) is also on this list, so comments and
>>>>>>>>> questions
>>>>>>>>> will be directly available to him.
>>>>>>>>>
>>>>>>>>> The beta server URL is
>>>>>>>>>
>>>>>>>>> http://beta.wgchairs.yaco.es/wg/alto/
>>>>>>>>>
>>>>>>>>> and here are the username/passwords which have been set up for
>>>>>>>>> the beta
>>>>>>>>> server:
>>>>>>>>>
>>>>>>>>> * secretariat/secretariat: An user in the secretariat group
>>>>>>>>> * alto_chair/alto_chair: Chair of the alto working group
>>>>>>>>
>>>>>>>> That sounds fine, but it might not get you the results you want,
>>>>>>>> because
>>>>>>>> you can't tell who is doing the banging that might break things.
>>>>>>>> If you
>>>>>>>> want more differentiated banging, maybe let people from the list
>>>>>>>> ask you
>>>>>>>> to "chair" a random group and you give us each password pairs
>>>>>>>> similar to
>>>>>>>> the above.
>>>>>>>> _______________________________________________
>>>>>>>> yaco-wgchair-tracker mailing list
>>>>>>>> [email-masked]
>>>>>>>> https://www.ietf.org/mailman/listinfo/yaco-wgchair-tracker
>>>>>>>>
>>>>>>
>>>>>>
>>>>> _______________________________________________
>>>>> yaco-wgchair-tracker mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/yaco-wgchair-tracker
>>>>>
>>>>
>>>> -----------
>>>> Alexa Morris / Executive Director / IETF
>>>> 48377 Fremont Blvd., Suite 117, Fremont, CA 94538
>>>> Phone: +1.510.492.4089 / Fax: +1.510.492.4001
>>>> Email: [email-masked]
>>>>
>>>> Managed by Association Management Solutions (AMS)
>>>> Forum Management, Meeting and Event Planning
>>>> www.amsl.com <http://www.amsl.com/>
>>>>
>>>> _______________________________________________
>>>> yaco-wgchair-tracker mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/yaco-wgchair-tracker
>>>>
>>>
>>> -----------
>>> Alexa Morris / Executive Director / IETF
>>> 48377 Fremont Blvd., Suite 117, Fremont, CA 94538
>>> Phone: +1.510.492.4089 / Fax: +1.510.492.4001
>>> Email: [email-masked]
>>>
>>> Managed by Association Management Solutions (AMS)
>>> Forum Management, Meeting and Event Planning
>>> www.amsl.com <http://www.amsl.com/>
>>>
>>> _______________________________________________
>>> yaco-wgchair-tracker mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/yaco-wgchair-tracker
>>
>> _______________________________________________
>> yaco-wgchair-tracker mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/yaco-wgchair-tracker
>>
>
> -----------
> Alexa Morris / Executive Director / IETF
> 48377 Fremont Blvd., Suite 117, Fremont, CA 94538
> Phone: +1.510.492.4089 / Fax: +1.510.492.4001
> Email: [email-masked]
>
> Managed by Association Management Solutions (AMS)
> Forum Management, Meeting and Event Planning
> www.amsl.com <http://www.amsl.com/>
>

-- 
Emilio A. Sánchez
[email-masked]

---

From: Alexa Morris <[email-masked]>
Date: Tue, 5 Apr 2011 12:14:06 -0700

Thanks Emilio, that worked!

I think I found another small bug. I was here: http://beta.wgchairs.yaco.es/doc/draft-dulinski-alto-inter-alto-protocol/ 
  and tried to "Change Draft Writeup". I got the message below:

Page not found (404)
Request Method:
GET
Request URL:
http://beta.wgchairs.yaco.es/wg/none/management/shepherds/draft-dulinski-alto-inter-alto-protocol/writeup/
No IETFWG matches the given query.
You're seeing this error because you have DEBUG = True in your Django  
settings file. Change that to False, and Django will display a  
standard 404 page.

-Alexa

On Apr 4, 2011, at 4:14 AM, Emilio A. Sánchez López wrote:

>   Hi Alexa,
>
>   Thank you for the link, it really helps me to find whats wrong  
> with the code.
>
>   Basically, when a WG Chair or Delegate tries to edit the state of  
> a draft that has no stream defined he can assing this draft to his  
> WG and change it to the 'Call for adoption' state.
>
>   The code checks if the user is WG Chair or Delegate of more than  
> one WG so a select with all the allowed WGs are show. In that piece  
> of code was the bug. You as secretariat have permission to change  
> the state but you are not a WG Chair or Delegate so you have no WG  
> related.
>

-----------

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Wed, 06 Apr 2011 21:12:16 +0200

Yes it seems a little bug. Thank you Alexa for all the testing.

    I'm checking it right now.

    I'll notify it when it gets fixed.

    Best,

El 05/04/11 21:14, Alexa Morris escribió:
> I think I found another small bug. I was here:
> http://beta.wgchairs.yaco.es/doc/draft-dulinski-alto-inter-alto-protocol/ and
> tried to "Change Draft Writeup". I got the message below:
>
> Page not found (404)
> Request Method:
> GET
> Request URL:
> settings file. Change that to False, and Django will display a standard
> 404 page.
>
> -Alexa
>
>> draft that has no stream defined he can assing this draft to his WG
>> and change it to the 'Call for adoption' state.
>>
>> WG so a select with all the allowed WGs are show. In that piece of
>> code was the bug. You as secretariat have permission to change the
>> state but you are not a WG Chair or Delegate so you have no WG related.
>>