Subject: Re: [yam] WGLC for draft-ietf-yam-rfc1652bis

From: Tony Hansen <[email-masked]>
Date: Thu, 04 Feb 2010 14:26:41 -0500

Reminder: the WGLC for draft-ietf-yam-rfc1652bis-01 ends today.

If you have any further comments on it, please send them in ASAP.

- Tony Hansen

Tony Hansen wrote:
> Now that draft-ietf-yam-rfc1652bis-01 is out, it needs the usual 2-week 
> WGLC, starting today Thursday 1/20 and ending Thursday 2/4.
> 
>     Tony Hansen
> 
> [email-masked] wrote:
>> A New Internet-Draft is available from the on-line Internet-Drafts 
>> directories.
>> This draft is a work item of the Yet Another Mail Working Group of the 
>> IETF.
>>
>>
>>     Title           : SMTP Service Extension for 8-bit MIME Transport
>>     Author(s)       : J. Klensin, et al.
>>     Filename        : draft-ietf-yam-rfc1652bis-01.txt
>>     Pages           : 7
>>     Date            : 2010-01-20
>>
>> This memo defines an extension to the SMTP service whereby an SMTP
>> content body consisting of text containing octets outside of the US-
>> ASCII octet range (hex 00-7F) may be relayed using SMTP.
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-yam-rfc1652bis-01.txt

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 11 Feb 2010 10:33:36 -0800

Folks,

(this concerns rfc1652bis)

On 1/25/2010 1:55 AM, Alessandro Vesely wrote:
> On 20/Jan/10 23:45, [email-masked] wrote:
> Should section 2 mention that the extension is valid for both SMTP and
> Submit? I haven't got that bit quite straight, yet...

Given that an extension like this declares its intended venue -- note "/SMTP/ 
Service Extension"  I would guess that it should also declare other venues that 
it is valid for.  So yeah, it might be appropriate to have it declare that it's 
for Submit, also.

But I'm not positive.  I'm particularly concerned that there might be a subtle 
issue here that I'm missing.

Comments?

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 11 Feb 2010 20:06:08 +0000

> Folks,

Hi Dave,

> Given that an extension like this declares its intended venue -- note 
> "/SMTP/ Service Extension"  I would guess that it should also declare 
> other venues that it is valid for.  So yeah, it might be appropriate 
> to have it declare that it's for Submit, also.
>
> But I'm not positive.  I'm particularly concerned that there might be 
> a subtle issue here that I'm missing.

Newer SMTP extensions explicitly declare themselve as suitable (or not 
suitable) for Submit. I personally don't see any issue with that.