Subject: Re: [yang-doctors] Feedback on options for issue #1 in TE tunnel YANG

From: Benoit Claise <[email-masked]>
Date: Wed, 7 Sep 2016 12:32:34 +0200

Tarek,

Do you have the answers you need?

Regards, B.
> Hi Tarek,
>
> your analysis of available solutions seems correct and exhaustive. Maybe
> I don't fully understand option #3 but I think you could achieve a
> reasonable level of "object-orientedness" and separation of
> technology-specific data by defining appropriate hierarchy of identities
> (possibly with multiple inheritance, which is now possible in YANG 1.1),
> and then using conditional augments.
>
> As for option #2, the design of schema mount could perhaps include some
> means for refering to data nodes and/or definitions in the parent
> schema. This would however make the subschema usable only in a specific
> context.
>
> Lada
>
> "Tarek Saad (tsaad)" <[email-masked]> writes:
>
>> Hi YANG doctors,
>>
>> We have a requirement to reuse generic data across multiple technology model instantiations for model we’re driving in draft-ietf-teas-yang-te. For this, we've identified a number of proposals and tried to summarize them in slides 7-10 in the deck @ http://www.ietf.org/proceedings/96/slides/slides-96-teas-3.pptx
>>
>> We are seeking your expert advice on the best way of the options to proceed with and whether there’s a precedence in other IETF models that have solved similar issues.
>>
>> Regards,
>> Tarek (and co-authors)
>> _______________________________________________
>> yang-doctors mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Tue, 13 Sep 2016 01:59:17 +0000

Hi Benoit/Yang Drs,

Thanks, and sorry for delayed response. We discussed this amongst the authors. From Lada’s response, we are interested in functionality extension he mentioned below. I am not sure if the authors of “draft-ietf-netmod-schema-mount” have this planned in their next version update or not. However, if not, we will consider the way to proceed from our side with the remaining other options.

    > schema. This would however make the subschema usable only in a specific

Regards,
Tarek

On 2016-09-07, 6:32 AM, "Benoit Claise (bclaise)" <[email-masked]> wrote:

    Tarek,

    Regards, B.