Subject: [yang-doctors] AUGEMNTATION AND ENUMERATIONS

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Fri, 18 Nov 2016 12:33:33 +0900

Hi, I am sitting here in the SUPA WG and the

discussion is thet ENUMS are not extensible via AUGMENTATION.

So They used Identities instead.

Is this indeed the only way, and if so, is this

an acceptable approach?

Bert

---

From: Benoit Claise <[email-masked]>
Date: Fri, 18 Nov 2016 12:43:29 +0900

> discussion is thet ENUMS are not extensible via AUGMENTATION.
NEW: discussion is thet ENUMS are not extensible via AUGMENTATION in 
submodules.

Regards, Benoit
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
> .
>

---

From: Andy Bierman <[email-masked]>
Date: Fri, 18 Nov 2016 05:17:15 +0000

Yes
By design only identities can be extended from another module
Enumerated can be extended in a new version of the original module

Andy