Subject: [yang-doctors] review of IEEE P802.1Qcp

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 5 Mar 2017 11:38:34 +0100

Hi,

attached is my review of P802.1Qcp. As usual, there are things related
to YANG usage (is the YANG usage correct and proper?) and there are
things related to the data model of the bridge technology (is the YANG
model correct and proper?). Since I am not an expert on bridge
technology, I can't really judge the later but from the way the data
model is written it seems not everything is a correct model.

If you want to substantially improve the model and the trust in the
model being correct, here is what I recommend you to do:

- Find volunteers familiar with bridg technology (not editors of the
  YANG data model) and let them write configurations and state data
  according to the YANG data model, ideally a few simple bridge
  configs and a few more complex ones. We sometimes call these configs
  instance documents. There are tools to validate instance documents
  against the data model.

- Usually the volunteers writing instance documents spot bugs where
  the model is wrong (I do not know how I configure XYZ in the model)
  and they spot points where instance documents are unnecessarily
  verbose or complex.

- Get the YANG data model editor and the volunteers writing instance
  documents together to resolve all conflicts until the instance
  documents are all nice and complete.

Sounds like a lot of work and yes it is a lot of work. But it is
essential to do this exercise if you want to have a high quality
product.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Holness, Marc" <[email-masked]>
Date: Sun, 5 Mar 2017 20:49:52 +0000

Hello Juergen,

Thank you immensely for this. Outstanding. I have converted all your comments to our comments template. As a reference, please find it attached. I will formally address your comments within the IEEE 802.1 comment resolution process.

In addition, in order to improve the model (and increase the trust that the model is correct), I will request a few bridge technology experts to generate "config instance documents". This is a good idea.

If I'm at a meeting with you in the future, I'll buy you lunch or dinner or something. Thanks!

Best regards,

Marc.

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Sunday, March 05, 2017 5:39 AM
To: [email-masked]
Cc: Janos Farkas <[email-masked]>; Holness, Marc <[email-masked]>
Subject: review of IEEE P802.1Qcp

Hi,

attached is my review of P802.1Qcp. As usual, there are things related to YANG usage (is the YANG usage correct and proper?) and there are things related to the data model of the bridge technology (is the YANG model correct and proper?). Since I am not an expert on bridge technology, I can't really judge the later but from the way the data model is written it seems not everything is a correct model.

If you want to substantially improve the model and the trust in the model being correct, here is what I recommend you to do:

Sounds like a lot of work and yes it is a lot of work. But it is essential to do this exercise if you want to have a high quality product.

/js

---

From: János Farkas <[email-masked]>
Date: Mon, 6 Mar 2017 10:47:38 +0100

Dear Jürgen,

I can only join Marc; thank you very much for your efforts!

Marc, you left cells empty; which would not work with the comment 
database. I've made Proposed Change = "as per comment" "Must Be 
Satisfied = "Yes" for each comments. I filled in missing Page, 
Sub-clause, Line #, sometimes just copied the values right above.

Jürgen, do you want to submit the ballot comments yourself? Or do you 
want Marc or me to submit them for you? WE are happy tu submit them on 
your behalf if you prefer.
I do not know whether or not it is possible to send mail to the 802.1 
list without being subscribed: 
(http://www.ieee802.org/1/email-pages/joining.html).

If you want to send it yourself, then please attach the xls to the email 
and follow the template:

email to: [email-masked]

email subject: P802.1Qcp/D1.0 - Comments (with abstain)

email body:
==========================
P802.1Qcp/D1.0 EMAIL BALLOT
==========================
TO: Marc Holness,
Editor, P802.1Qcp
SUBJECT: P802.1Qcp/D1.0 - Bridges and Bridged Networks — Amendment: YANG 
Data Model

_____ I Approve (may attach non-binding comments below)
_____ I Disapprove (must attach binding comments below)
__x__ I Abstain for the following reasons (may attach non-binding 
comments below):
______ Lack of Time
______ Lack of Expertise
___x__ Other: _non-voting_________________________________________

_Juergen Schoenwaelder_______________________
(Name)
_Jacobs University Bremen_____________________
(Affiliation)

Best regards,
János

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 6 Mar 2017 15:15:54 +0100

János,

I suggest you submit the comments in whatever way is best for IEEE to
track and handle them, I do not have a special interest of being
involved in this.

/js

On Mon, Mar 06, 2017 at 10:47:38AM +0100, János Farkas wrote:
> Marc, you left cells empty; which would not work with the comment database.
> I've made Proposed Change = "as per comment" "Must Be Satisfied = "Yes" for
> each comments. I filled in missing Page, Sub-clause, Line #, sometimes just
> copied the values right above.
> 
> Jürgen, do you want to submit the ballot comments yourself? Or do you want
> Marc or me to submit them for you? WE are happy tu submit them on your
> behalf if you prefer.
> I do not know whether or not it is possible to send mail to the 802.1 list
> without being subscribed:
> If you want to send it yourself, then please attach the xls to the email and
> follow the template:
> 
> __x__ I Abstain for the following reasons (may attach non-binding comments
> below):
> ______ Lack of Time
> ______ Lack of Expertise

---

From: "Holness, Marc" <[email-masked]>
Date: Mon, 6 Mar 2017 15:26:36 +0000

Janos,

They are *not* all "must be satisfied". Some are queries that I plan to respond to.

At any rate ...

Marc.

-----Original Message-----
From: János Farkas [mailto:[email-masked]] 
Sent: Monday, March 06, 2017 4:48 AM
To: Juergen Schoenwaelder <[email-masked]>; Holness, Marc <[email-masked]>
Cc: [email-masked]
Subject: Re: review of IEEE P802.1Qcp

Dear Jürgen,

Marc, you left cells empty; which would not work with the comment database. I've made Proposed Change = "as per comment" "Must Be Satisfied = "Yes" for each comments. I filled in missing Page, Sub-clause, Line #, sometimes just copied the values right above.

Jürgen, do you want to submit the ballot comments yourself? Or do you want Marc or me to submit them for you? WE are happy tu submit them on your behalf if you prefer.
I do not know whether or not it is possible to send mail to the 802.1 list without being subscribed: 
(http://www.ieee802.org/1/email-pages/joining.html).

If you want to send it yourself, then please attach the xls to the email and follow the template:

email body:
==========================
P802.1Qcp/D1.0 EMAIL BALLOT
==========================
TO: Marc Holness,
Editor, P802.1Qcp
SUBJECT: P802.1Qcp/D1.0 - Bridges and Bridged Networks - Amendment: YANG Data Model

_____ I Approve (may attach non-binding comments below) _____ I Disapprove (must attach binding comments below) __x__ I Abstain for the following reasons (may attach non-binding comments below):
______ Lack of Time
______ Lack of Expertise
___x__ Other: _non-voting_________________________________________

Best regards,
János

On 3/5/2017 9:49 PM, Holness, Marc wrote:
> From: Juergen Schoenwaelder 
> [mailto:[email-masked]]

---

From: "Holness, Marc" <[email-masked]>
Date: Sat, 11 Mar 2017 23:27:06 +0000

Good day,

I've addressed Juergen's  comments, and incorporated the changes into the updated 802.1Qcp YANG modules:

  * ieee802-types.yang
  * ieee802-dot1q-types.yang
  * ieee802-dot1q-bridge.yang
  * ieee802-dot1q-tpmr.yang
  * ieee802-dot1q-vlan-bridge.yang
  * ieee802-dot1q-pb.yang

The changes can now be found in GitHub. In addition, the comment resolution responses to these comments are captured, and attached to this E-mail.

I will be pursuing "instance documents" as well.

Best Regards,

Marc.

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Sunday, March 05, 2017 5:39 AM
To: [email-masked]
Cc: Janos Farkas <[email-masked]>; Holness, Marc <[email-masked]>
Subject: review of IEEE P802.1Qcp

Hi,

/js

---

From: Benoit Claise <[email-masked]>
Date: Sun, 12 Mar 2017 15:49:00 +0100

Hi Marc,

Great.
I see some improvements at 
http://www.claise.be/IEEEStandardYANGPageCompilation.html
Still a warning with ieee802-dot1q-tpmr.yang and ieee802-dot1x.yang 
(even if this one is not in your list below).
Note also this one: 
http://www.claise.be/IEEEExperimentalYANGPageCompilation.html

Regards, Benoit

> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: "Holness, Marc" <[email-masked]>
Date: Mon, 13 Mar 2017 16:30:28 +0000

Ahh ... Thanks for this Benoit.

I'm getting closer. I will make the appropriate changes and submit to GitHub. I will let you know when they are in the repository.

In addition, I will follow up with my IEEE 802 colleagues related to the modules found in the "experimental/ieee" folder. We need to get those cleaned up as well.

Regards,

Marc.

From: Benoit Claise [mailto:[email-masked]]
Sent: Sunday, March 12, 2017 10:49 AM
To: Holness, Marc <[email-masked]>; Juergen Schoenwaelder <[email-masked]>; [email-masked]
Cc: Janos Farkas <[email-masked]>
Subject: Re: [yang-doctors] review of IEEE P802.1Qcp

Hi Marc,

Great.
I see some improvements at http://www.claise.be/IEEEStandardYANGPageCompilation.html
Still a warning with ieee802-dot1q-tpmr.yang and ieee802-dot1x.yang (even if this one is not in your list below).
Note also this one: http://www.claise.be/IEEEExperimentalYANGPageCompilation.html

Regards, Benoit

Good day,

  * ieee802-types.yang

  * ieee802-dot1q-pb.yang

Best Regards,

Marc.

-----Original Message-----

To: [email-masked]<mailto:[email-masked]>

Cc: Janos Farkas <[email-masked]><mailto:[email-masked]>; Holness, Marc <[email-masked]><mailto:[email-masked]>

Hi,

  against the data model.

  verbose or complex.

/js

[email-masked]<mailto:[email-masked]>