Subject: Re: [yang-doctors] binary encoded YANG data: side meeting in Chicago?

From: Andy Bierman <[email-masked]>
Date: Wed, 1 Mar 2017 08:34:24 -0800

Hi,

Looking at the schedule, perhaps this slot will work

Monday 15:20 to 16:50.
There is 1 OPS meeting (casm - a BoF on Coordinated Address Space
Management)

Andy

On Mon, Feb 20, 2017 at 6:49 AM, Mahesh Jethanandani <
[email-masked]> wrote:

> Ditto.
>
> > On Feb 20, 2017, at 3:56 AM, Radek Krejčí <[email-masked]> wrote:
> >
> > +1
> >
> > Radek
> >
> >
> > Dne 20.2.2017 v 08:06 Ladislav Lhotka napsal(a):
> >> Hi Andy,
> >>
> >> I would be interested in attending that meeting.
> >>
> >> Lada
> >>
> >>> On 19 Feb 2017, at 21:05, Andy Bierman <[email-masked]> wrote:
> >>>
> >>> Hi,
> >>>
> >>> The CORE WG is working on some standards for an IoT version of
> RESTCONF.
> >>> The CBOR encoding is relevant to RESTCONF for some applications like
> YANG push.
> >>>
> >>> I am trying to organize a side meeting about YANG to CBOR and
> >>> SID (numeric schema node identifiers). The goal of the meeting is
> >>> understand how it works (and doesn't work).  Hopefully there will be a
> >>> 1 hour slot open for this meeting, and a room available.
> >>> The first step is determining if any YANG doctors care about what
> >>> the CORE WG is doing with YANG.
> >>>
> >>> Another topic: YANG to GPB? Better approach? Where is it documented?
> >>> Does an algorithm exist that works for YANG augment?
> >>>
> >>> CORE WG drafts:
> >>>
> >>> YANG to CBOR
> >>> https://datatracker.ietf.org/doc/draft-ietf-core-yang-cbor/
> >>>
> >>> SID
> >>> https://datatracker.ietf.org/doc/draft-ietf-core-sid/
> >>>
> >>>
> >>> CoMI
> >>> https://datatracker.ietf.org/doc/draft-ietf-core-comi/
> >>>
> >>>
> >>> Andy
> >>>
> >>> _______________________________________________
> >>> yang-doctors mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/yang-doctors
> >> --
> >> Ladislav Lhotka, CZ.NIC Labs
> >> PGP Key ID: 0xB8F92B08A9F76C67
> >>
> >>
> >>
> >>
> >>
> >> _______________________________________________
> >> yang-doctors mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/yang-doctors
> >
> > --
> > Radek Krejci
> > mobile  : +420 732 212 714
> > office  : +420 234 680 256
> > e-mail  : [email-masked]
> > LinkedIn: http://www.linkedin.com/in/radekkrejci
> >
> > CESNET, Association of Legal Entities
> > Zikova 4
> > 160 00 Praha 6
> > Czech Republic
> >
> > _______________________________________________
> > yang-doctors mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/yang-doctors
>
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 1 Mar 2017 17:52:46 +0100

> On 1 Mar 2017, at 17:34, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> There is 1 OPS meeting (casm - a BoF on Coordinated Address Space Management)

Works for me.

Thanks, Lada

> 
> 
> Andy
> 
> 
> On Mon, Feb 20, 2017 at 6:49 AM, Mahesh Jethanandani <[email-masked]> wrote:
> Ditto.
> 
> >>> The CORE WG is working on some standards for an IoT version of RESTCONF.
> >>> The CBOR encoding is relevant to RESTCONF for some applications like YANG push.
> >>>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 10 Mar 2017 18:59:48 +0100

>> There is 1 OPS meeting (casm - a BoF on Coordinated Address Space Management)
Note that CASM wants to specify YANG models for prefix management.

Regards, B.

---

From: Andy Bierman <[email-masked]>
Date: Fri, 10 Mar 2017 10:08:56 -0800

>> Note that CASM wants to specify YANG models for prefix management.
Tuesday 14:50 to 16:20

Thursday 1520 - 17:20

Are these slots better?

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 10 Mar 2017 19:36:36 +0100 (CET)

> >> Note that CASM wants to specify YANG models for prefix management.

I would like to attend this meeting, but unfortunately I will have to
leave Wednesday evening, so I prefer the Mon or Tue timeslots.

/martin

---

From: Andy Bierman <[email-masked]>
Date: Fri, 10 Mar 2017 10:48:02 -0800

> leave Wednesday evening, so I prefer the Mon or Tue timeslots.

so you will miss the netmod meeting on Thursday?
(Given that some people have a massive NETCONF/YANG rewrite planned, thought
you would be interested in netmod :-)

I suggest we keep the Monday slot.
The discussion may be relevant to yang-push which might be discussed
Tuesday morning.

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 10 Mar 2017 19:53:27 +0100 (CET)

> so you will miss the netmod meeting on Thursday?

Yep :(  I was happy when the preliminary agenda had the two netmod
meetings early, but that changed...

/martin

---

From: Andy Bierman <[email-masked]>
Date: Fri, 10 Mar 2017 11:36:41 -0800

>> Note that CASM wants to specify YANG models for prefix management.
I think we will keep the Monday slot.

Regards, B.

---

From: Kent Watsen <[email-masked]>
Date: Sat, 11 Mar 2017 16:02:40 +0000

>> (Given that some people have a massive NETCONF/YANG rewrite
>> planned, thought you would be interested in netmod :-)
>>
>
> Yep :(  I was happy when the preliminary agenda had the two
> netmod meetings early, but that changed...

I think the discussion is more about refactoring than rewriting ;)

Still, NETMOD will, in traditional fashion, have the more important
presentations on the first day, so Martin hopefully won't miss much!

K.