Subject: [yang-doctors] question on normative language in YANG descriptions?

From: Kent Watsen <[email-masked]>
Date: Tue, 16 May 2017 14:23:09 +0000

Just wondering, is there any issue with having RFC2119 language in YANG description statements?

Obviously, this is for a YANG module in an IETF draft, not a YANG module from any other SDO...

Kent

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 16 May 2017 16:33:11 +0200

> On 16 May 2017, at 16:23, Kent Watsen <[email-masked]> wrote:
> 
> 

It's used e.g. in ietf-routing. The module description also contains the paragraph

        The key words 'MUST', 'MUST NOT', 'REQUIRED', 'SHALL', 'SHALL
        NOT', 'SHOULD', 'SHOULD NOT', 'RECOMMENDED', 'MAY', and
        'OPTIONAL' in the module text are to be interpreted as described
        in RFC 2119.

Lada

> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67