Subject: [yang-doctors] [YANG Doctors] Request for New YANG Data Module

From: Sudhanshu Kumar Srivastav <[email-masked]>
Date: Mon, 11 Sep 2017 07:16:17 +0000

Dear Yang Doctors,

Myself sudhanshu kumar srivastav, working on YANG Data Models in Samsung
organization.

I want to contribute to YANG space in IETF by using my on job learning.

I have developed a DRAFT for a new YANG module. I want to float that YANG
module to NETMOD group for their opinion and reviews.

Request you to kindly let me know how can I float it for review.

regards

Sudhanshu

---

From: Sudhanshu Kumar Srivastav <[email-masked]>
Date: Mon, 11 Sep 2017 07:20:09 +0000

Dear Yang Doctors,

I have developed a DRAFT for a new YANG module. I want to float that YANG
module to YANG Doctors group for their opinion and reviews.

regards

Sudhanshu

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 11 Sep 2017 13:06:24 -0700

Sudhanshu,

If you are starting out new on writing YANG modules, a good place to start would be on the wiki here <https://trac.ietf.org/trac/ops/wiki/YANGDoctorsFAQ>. After that go to for details on authors guidelines.

https://tools.ietf.org/html/draft-ietf-netmod-rfc6087bis-14 <https://tools.ietf.org/html/draft-ietf-netmod-rfc6087bis-14>

As an example of what a model looks like, start with the model below. Granted, it is a bis draft and may yet see some changes, but hopefully small.

https://tools.ietf.org/html/draft-bjorklund-netmod-rfc7223bis-00 <https://tools.ietf.org/html/draft-bjorklund-netmod-rfc7223bis-00>

HTH.

> On Sep 11, 2017, at 12:20 AM, Sudhanshu Kumar Srivastav <[email-masked]> wrote:
> 
> Dear Yang Doctors,
>  
> _______________________________________________
> yang-doctors mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/yang-doctors <https://www.ietf.org/mailman/listinfo/yang-doctors>
Mahesh Jethanandani
[email-masked]