Subject: Re: [yang-doctors] [netmod] Quirky YANG

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 3 Oct 2018 21:41:22 +0000

Are YD reviews optional for IETF YANG modules? I assumed it was mandatory.

On 2018-10-03, 12:11 PM, "netmod on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

    I wonder if anyone else on this list has looked at
     https://datatracker.ietf.org/doc/draft-ietf-softwire-yang/
    currently in IETF Last Call.
    
    It provides management for three tunnel types, Lw4o6, MAP-E and MAP-T
    betweeen CPE and Border Relay.  It defines a CPE module, a BR module and
    a module of common definitions.
    
    It does not provide identities for the three tunnel types; rather, where
    it augments "/if:interfaces/if:interface" it specifies
        when "if:type = 'ianaift:tunnel'";
    which to me says that a MAP-E (e.g.) specific object will get added to
    each and every tunnel of whatever type, which seems excessive.
    
    Second, it defines four features, softwire-ce:algorithm (i.e.
    MAP-E/MAP-T) and softwire-ce:binding (i.e. Lw4o6) in the CPE module and
    then again softwire-br:algorithm and softwire-br:binding in the BR
    module.  It is unclear to me, from the I-D, whether support is for MAP-T
    and MAP-E; or either MAP-T or MAP-E - I find the I-D ambiguous on that
    point - but I would have expected there to be either two - Lw4o6 and
    MAP-ET - or three - Lw4o6, MAP-E and MAP-T features, not four; and for
    the features to be defined, along with tunnel identities, in the common
    module.
    
    Odd, IMHO.
    
    Tom Petch
    
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 3 Oct 2018 16:38:18 -0700

> On Oct 3, 2018, at 2:41 PM, Reshad Rahman (rrahman) <[email-masked]> wrote:
> 

Here is what it says on the YD page:

All YANG documents will be passed by a YANG doctor reviewer before they will be approved by the IESG. The YANG doctor review must be done after the Working Group Last Call and before the IETF Last Call. ADs and WG chairs responsible on I-Ds that include YANG documents should ask the OPS ADs for a review as soon as the document completed WGLC. Failing that request, the review will be conducted during the IETF Last Call.

Mahesh Jethanandani
[email-masked]

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 3 Oct 2018 23:51:35 +0000

Thanks Mahesh. So the IESG is supposed to ask for YD review at this point for draft-ietf-softwire-yang?

From: Mahesh Jethanandani <[email-masked]>
Date: Wednesday, October 3, 2018 at 7:38 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: tom petch <[email-masked]>, "[email-masked]" <[email-masked]>, YANG Doctors <[email-masked]>
Subject: Re: [yang-doctors] [netmod] Quirky YANG

On Oct 3, 2018, at 2:41 PM, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 3 Oct 2018 17:14:45 -0700

[Adding softwire chairs, document shepherd, and AD, and moving netmod to Bcc]

Yes.

> On Oct 3, 2018, at 4:51 PM, Reshad Rahman (rrahman) <[email-masked]> wrote:
> 
>   <>
>> On Oct 3, 2018, at 2:41 PM, Reshad Rahman (rrahman) <[email-masked] <mailto:[email-masked]>> wrote:
>>  
> [email-masked] <mailto:[email-masked]>
Mahesh Jethanandani
[email-masked]

---

From: "Mehmet Ersue" <[email-masked]>
Date: Thu, 4 Oct 2018 11:36:58 +0100

Unfortunately there is no mechanism yet which "ensures" that such a review
gets done at the latest during IETF LC.

For the time being ADs or WG chairs are responsible (and only able) to
request such a review. 

We discussed this earlier and recommended to optimize the datatracker review
tool in a way that a draft going into IETF LC gets flagged and the original
reviewer gets a request to re-review. In case the draft did not have any
review yet the YD secretary should get a request to initiate the necessary
review.

The ticket is at: https://tools.ietf.org/tools/ietfdb/ticket/2389 

Cheers,

Mehmet

From: yang-doctors <[email-masked]> On Behalf Of Mahesh
Jethanandani
Sent: Thursday, October 4, 2018 1:15 AM
To: Reshad Rehman <[email-masked]>
Cc: Ian Farrer <[email-masked]>; tom petch <[email-masked]>; Yong
Cui <[email-masked]>; YANG Doctors <[email-masked]>;
[email-masked]; Sheng Jiang <[email-masked]>
Subject: Re: [yang-doctors] [netmod] Quirky YANG

[Adding softwire chairs, document shepherd, and AD, and moving netmod to
Bcc]

Yes.

On Oct 3, 2018, at 4:51 PM, Reshad Rahman (rrahman) <[email-masked]
<mailto:[email-masked]> > wrote:

Thanks Mahesh. So the IESG is supposed to ask for YD review at this point
for draft-ietf-softwire-yang?

From: Mahesh Jethanandani <[email-masked]
<mailto:[email-masked]> >
Date: Wednesday, October 3, 2018 at 7:38 PM
To: "Reshad Rahman (rrahman)" <[email-masked] <mailto:[email-masked]>
Cc: tom petch <[email-masked] <mailto:[email-masked]> >,
"[email-masked] <mailto:[email-masked]> " <[email-masked]
<mailto:[email-masked]> >, YANG Doctors <[email-masked]
<mailto:[email-masked]> >
Subject: Re: [yang-doctors] [netmod] Quirky YANG

On Oct 3, 2018, at 2:41 PM, Reshad Rahman (rrahman) <
<mailto:[email-masked]> [email-masked]> wrote:

All YANG documents will be passed by a YANG doctor reviewer before they will
be approved by the IESG. The YANG doctor review must be done after the
Working Group Last Call and before the IETF Last Call. ADs and WG chairs
responsible on I-Ds that include YANG documents should ask the OPS ADs for a
review as soon as the document completed WGLC. Failing that request, the
review will be conducted during the IETF Last Call.

Mahesh Jethanandani

 <mailto:[email-masked]> [email-masked]

Mahesh Jethanandani

---

From: "Mehmet Ersue" <[email-masked]>
Date: Thu, 4 Oct 2018 11:59:34 +0100

As it was under my fingers and one click away I started a YD review.

BTW: Anybody can send his/her comments on the draft to Softwire WG and
ietf.org maillists during IETF LC.

Cheers,

Mehmet

From: Mehmet Ersue 
Sent: Thursday, October 4, 2018 11:37 AM
To: Mahesh Jethanandani <[email-masked]>; Reshad Rehman
<[email-masked]>
Cc: Ian Farrer <[email-masked]>; tom petch <[email-masked]>; Yong
Cui <[email-masked]>; YANG Doctors <[email-masked]>;
[email-masked]; Sheng Jiang <[email-masked]>; Dan
Romascanu <[email-masked]>
Subject: RE: [yang-doctors] [netmod] Quirky YANG

Cheers,

Mehmet

From: yang-doctors <[email-masked]
<mailto:[email-masked]> > On Behalf Of Mahesh Jethanandani
Sent: Thursday, October 4, 2018 1:15 AM
To: Reshad Rehman <[email-masked] <mailto:[email-masked]> >
Cc: Ian Farrer <[email-masked] <mailto:[email-masked]> >; tom petch
<[email-masked] <mailto:[email-masked]> >; Yong Cui
<[email-masked] <mailto:[email-masked]> >; YANG Doctors
<[email-masked] <mailto:[email-masked]> >;
[email-masked] <mailto:[email-masked]> ; Sheng Jiang
<[email-masked] <mailto:[email-masked]> >
Subject: Re: [yang-doctors] [netmod] Quirky YANG

Yes.

 

Mahesh Jethanandani

Mahesh Jethanandani

---

From: Terry Manderson <[email-masked]>
Date: Thu, 4 Oct 2018 11:01:18 +0000

Thank you Mehmet for your attention to this. For some reason I thought it was already automagically passed to yang doctors. My apologies.

Looking forward to your review.

Thanks
Terry
- Gorilla typing on iPhone.

On 4 Oct 2018, at 17:59, Mehmet Ersue <[email-masked]<mailto:[email-masked]>> wrote:

BTW: Anybody can send his/her comments on the draft to Softwire WG and ietf.org<http://ietf.org> maillists during IETF LC.

Cheers,
Mehmet

From: Mehmet Ersue
Sent: Thursday, October 4, 2018 11:37 AM
To: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>; Reshad Rehman <[email-masked]<mailto:[email-masked]>>
Cc: Ian Farrer <[email-masked]<mailto:[email-masked]>>; tom petch <[email-masked]<mailto:[email-masked]>>; Yong Cui <[email-masked]<mailto:[email-masked]>>; YANG Doctors <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Sheng Jiang <[email-masked]<mailto:[email-masked]>>; Dan Romascanu <[email-masked]<mailto:[email-masked]>>
Subject: RE: [yang-doctors] [netmod] Quirky YANG

Unfortunately there is no mechanism yet which “ensures” that such a review gets done at the latest during IETF LC.
For the time being ADs or WG chairs are responsible (and only able) to request such a review.

We discussed this earlier and recommended to optimize the datatracker review tool in a way that a draft going into IETF LC gets flagged and the original reviewer gets a request to re-review. In case the draft did not have any review yet the YD secretary should get a request to initiate the necessary review.

Cheers,
Mehmet

From: yang-doctors <[email-masked]<mailto:[email-masked]>> On Behalf Of Mahesh Jethanandani
Sent: Thursday, October 4, 2018 1:15 AM
To: Reshad Rehman <[email-masked]<mailto:[email-masked]>>
Cc: Ian Farrer <[email-masked]<mailto:[email-masked]>>; tom petch <[email-masked]<mailto:[email-masked]>>; Yong Cui <[email-masked]<mailto:[email-masked]>>; YANG Doctors <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Sheng Jiang <[email-masked]<mailto:[email-masked]>>
Subject: Re: [yang-doctors] [netmod] Quirky YANG

Yes.

On Oct 3, 2018, at 4:51 PM, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

From: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 3, 2018 at 7:38 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
Cc: tom petch <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, YANG Doctors <[email-masked]<mailto:[email-masked]>>
Subject: Re: [yang-doctors] [netmod] Quirky YANG

Mahesh Jethanandani

Mahesh Jethanandani