Subject: Re: [yang-doctors] Hi Reshad, the issues about igmp snooping model are addressed. Thanks a lot!

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 1 Oct 2018 14:07:04 +0000

Hi Hongji, Reshad,
I agree with Reshad. While both hierarchies have been implemented on various network devices, it is more straight forward to include protocol interface configuration and state in the hierarchy of the protocol instance rather than have it on the interface itself. The only time you want to place it on the interface is when the protocol instance is scoped to a single interface (e.g., VRRP).
Thanks,
Acee

From: yang-doctors <[email-masked]> on behalf of "Reshad Rahman (rrahman)" <[email-masked]>
Date: Monday, October 1, 2018 at 9:22 AM
To: Hongji Zhao <[email-masked]>
Cc: YANG Doctors <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [yang-doctors] Hi Reshad, the issues about igmp snooping model are addressed. Thanks a lot!

Hi Hongji,

I understand that these statistics are interface specific, but I still don’t understand why you think augmenting if:interface is better, can you please explain? For me these counts are IGMP/MLD snooping specific, so should be under the snooping instance.

As an example, take a look at section 2.7 of draft-ietf-ospf-yang, the per-interface OSPF counters are under OSPF protocol container, not augment of if:interface.

Regards,
Reshad.

From: Hongji Zhao <[email-masked]>
Date: Tuesday, September 25, 2018 at 12:30 AM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, YANG Doctors <[email-masked]>
Subject: RE: Hi Reshad, the issues about igmp snooping model are addressed. Thanks a lot!

Hi Reshad,

The statistics are related with igmp-mld-snooping, not only with mrouter interface.
The query is the number of  igmp query messages. The membership-report-v1/2/3 indicates the number of membership report v1/2/3 messages. The leave indicates the number of leave messages.
The pim is the number of pim hello messages. They are used to generate and maintain the entries for l2 multicast forwarding, multicast router interface, IGMP&MLD snooping membership, etc.

So I think keeping them under augment of if:interface is better.  What do you think of that?
Thanks!

BR/Hongji
赵宏吉

From: Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, September 20, 2018 8:26 PM
To: Hongji Zhao <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; YANG Doctors <[email-masked]<mailto:[email-masked]>>
Subject: Re: Hi Reshad, the issues about igmp snooping model are addressed. Thanks a lot! Re: [yang-doctors] Yangdoctors early review of draft-ietf-pim-igmp-mld-snooping-yang-03

Hi Hongji,

It looks like those statistics are needed only for interfaces (not for PWs) , so you could keep them under augment of if:interface, or put those stats under bridge-mrouter-interface and l2vpn-mrouter-interface-ac in the snooping-instance. My preference is for the latter.

Regards,
Reshad.

From: Hongji Zhao <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 17, 2018 at 10:28 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, YANG Doctors <[email-masked]<mailto:[email-masked]>>
Subject: RE: Hi Reshad, the issues about igmp snooping model are addressed. Thanks a lot! Re: [yang-doctors] Yangdoctors early review of draft-ietf-pim-igmp-mld-snooping-yang-03

Hi Reshad,

In augment /if:interfaces/if:interface, besides mrouter related data, there are still some statistics related with igmp-mld-snooping.
If take out the whole augmentation of if:interfaces, the statistics will be lost.  What do you think of that?

augment /if:interfaces/if:interface:
    +--rw igmp-mld-snooping
       +--ro statistics
          +--ro received
          |  +--ro query?                  yang:counter64
          |  +--ro membership-report-v1?   yang:counter64
          |  +--ro membership-report-v2?   yang:counter64
          |  +--ro membership-report-v3?   yang:counter64
          |  +--ro leave?                  yang:counter64
          |  +--ro non-member-leave?       yang:counter64
          |  +--ro pim?                    yang:counter64
          +--ro sent
             +--ro query?                  yang:counter64
             +--ro membership-report-v1?   yang:counter64
             +--ro membership-report-v2?   yang:counter64
             +--ro membership-report-v3?   yang:counter64
             +--ro leave?                  yang:counter64
             +--ro non-member-leave?       yang:counter64
             +--ro pim?                    yang:counter64

BR/Hongji
赵宏吉

---

From: Hongji Zhao <[email-masked]>
Date: Tue, 9 Oct 2018 02:44:49 +0000

Hi Reshad & Acee,

I see your points and I plan to move the statistics under the snooping instance as below.   Is it ok?   Thanks a lot!

module: ietf-igmp-mld-snooping
    +--rw igmp-snooping-instances
    |  +--rw igmp-snooping-instance* [name]
    |     +--rw name                                 string
    |     ...
    |     +--ro interfaces
          |        +--ro interface* [name]
          |           +--ro name                   if:interface-ref
                      +--ro statistics
                         +--ro received
                         |  +--ro query?                  yang:counter64
                         |  +--ro membership-report-v1?   yang:counter64
                         |  +--ro membership-report-v2?   yang:counter64
                         |  +--ro membership-report-v3?   yang:counter64
                         |  +--ro leave?                  yang:counter64
                         |  +--ro non-member-leave?       yang:counter64
                         |  +--ro pim?                    yang:counter64
                         +--ro sent
                            +--ro query?                  yang:counter64
                           +--ro membership-report-v1?   yang:counter64
                            +--ro membership-report-v2?   yang:counter64
                            +--ro membership-report-v3?   yang:counter64
                            +--ro leave?                  yang:counter64
                            +--ro non-member-leave?       yang:counter64
                            +--ro pim?                    yang:counter64

BR/Hongji
赵宏吉

From: Acee Lindem (acee) <[email-masked]>
Sent: Monday, October 01, 2018 10:07 PM
To: Reshad Rahman (rrahman) <[email-masked]>; Hongji Zhao <[email-masked]>
Cc: YANG Doctors <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [yang-doctors] Hi Reshad, the issues about igmp snooping model are addressed. Thanks a lot!

Hi Hongji, Reshad,

From: yang-doctors <[email-masked]<mailto:[email-masked]>> on behalf of "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, October 1, 2018 at 9:22 AM
To: Hongji Zhao <[email-masked]<mailto:[email-masked]>>
Cc: YANG Doctors <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [yang-doctors] Hi Reshad, the issues about igmp snooping model are addressed. Thanks a lot!

Hi Hongji,

Regards,
Reshad.

Hi Reshad,

BR/Hongji
赵宏吉

Hi Hongji,

Regards,
Reshad.

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 10 Oct 2018 12:52:39 +0000

Hi Hongji,

This structure looks good to me.

Regards,
Reshad.

From: Hongji Zhao <[email-masked]>
Date: Monday, October 8, 2018 at 10:44 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: YANG Doctors <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>
Subject: RE: [yang-doctors] Hi Reshad, the issues about igmp snooping model are addressed. Thanks a lot!

Hi Reshad & Acee,

BR/Hongji
赵宏吉

Hi Hongji, Reshad,

Hi Hongji,

Regards,
Reshad.

Hi Reshad,

BR/Hongji
赵宏吉

Hi Hongji,

Regards,
Reshad.