Subject: Re: [yang-doctors] [pim] I-D Action: draft-ietf-pim-msdp-yang-13.txt

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 1 Mar 2020 17:47:01 -0800

On Thu, Feb 27, 2020 at 10:17:37PM +0800, [email-masked] wrote:
> Hi Tom,
> 
> 
> 
> 
> 
> 
> Thank you very much for your review!
> 
> 
> Because the usage referenced to RFC4271 is an optional leaf. I am not sure if it can be in informatinve reference.
> 
> 
> If the rule is mandatory, I will change it. :-)

Per
https://www.ietf.org/about/groups/iesg/statements/normative-informative-references/
being an optional feature does not affect the normative vs. informative
status of the corresponding reference.

-Ben

---

From: <[email-masked]>
Date: Mon, 2 Mar 2020 11:00:22 +0800 (CST)

Hi Ben, Tom,

Thank you very much!

I read the guideline before, and I am confused with the two sentences:

“Normative references specify documents that must be read to understand or implement the technology in the new RFC, or whose technology must be present for the technology in the new RFC to work."

"Note 1: Even references that are relevant only for optional features must be classified as normative if they meet the above conditions for normative references. "

The reason that I put the reference in "informative" is that the users can also use the model even if they know nothing about RFC4271.

But now, I think you are right, according to "note 1", the reference should be normative.

I'll update it.

Thank you again for your guidance!

Best regards,

Sandy

原始邮件

发件人：BenjaminKaduk <[email-masked]>
收件人：张征00007940;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2020年03月02日 09:47
主 题 ：Re: [pim] I-D Action: draft-ietf-pim-msdp-yang-13.txt

Per

-Ben