Subject: [yang-doctors] YANG documentation for "must" and "when" statement semantics and syntax

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 30 Sep 2020 19:15:14 +0000

Is there any place where this is documented? Including operators such as “not “? I wanted to provide a reference but couldn’t find out.
Thanks,
Acee

---

From: Martin Björklund <[email-masked]>
Date: Thu, 01 Oct 2020 08:25:17 +0200 (CEST)

"Acee Lindem \(acee\)" <acee=[email-masked]> wrote:
> Is there any place where this is documented? Including operators
> such as “not “? I wanted to provide a reference but couldn’t find
> out.

RFC 7950 has the reference:

   [XPATH]    Clark, J. and S. DeRose, "XML Path Language (XPath)
              Version 1.0", World Wide Web Consortium Recommendation
              REC-xpath-19991116, November 1999,
              <http://www.w3.org/TR/1999/REC-xpath-19991116>.

/martin