Subject: Re: [yang-doctors] Yangdoctors last call review of draft-ietf-pim-igmp-mld-snooping-yang-19

From: Hongji Zhao <[email-masked]>
Date: Tue, 5 Oct 2021 09:58:16 +0000

Hi Reshad,

Please check inline. Thanks a lot.

BR/Hongji

-----Original Message-----
From: Reshad Rahman via Datatracker <[email-masked]> 
Sent: 2021年9月30日 11:09
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Yangdoctors last call review of draft-ietf-pim-igmp-mld-snooping-yang-19

Reviewer: Reshad Rahman
Review result: Ready with Nits

This is my 3rd review of the document. While I have focused on changes done since my last review, some comments apply to parts of the YANG model which hasn't changed recently.

Main comments
=============

- Feature immediate-leave mentions “fast leave” in the description. RFC3376 mentions fast leave but not immediate leave. Should the feature, and the leaf node which depends on it, be renamed to fast-leave?
[Authors] Accepted

- Leaf send-query, description says that it cooperates with parameter querier-source. I believe there should be enforcement that send-query can only be set if querier-source is also set (must statement)? Also querier-source in IGMP mentions VLAN, no such mention in MLD, is that correct?
[Authors] The description of leaf send-query is not clear and easily causes confusion. It will be updated.
                   The description of querier-source in both IGMP and MLD part are not proper, and will be updated.

Questions
========

- Feature static-l2-multicast-group. The description mentions L2 multicast static-group. Is it a static multicast group or a multicast static group? I believe it’s the former and the description should be changed?
[Authors] It is static multicast group, and the description will be updated.

- igmp-version and mld-version are both uint8 with a range (1..3 and 1..2). If we get a new version someday, the range will have to be changed. I don’t recall if this was brought up before. Another option is to use an identity. I realize we don’t spin out a new version frequently so this may not be an issue. And probably with a new version other changes would be needed anyway…
[Authors] Your last statement is what we considered. When new protocol version is introduced, we need a lot of changes.

- Last-reporter is present under the group and also under each source entry. Is the one under the group the last host from all sources?
[Authors] Yes

- Leaf node require-router-alert. What happens if it’s set to true and the IP hdr does not contain RA? Consider updating description and/or adding a reference.
[Authors] In that case, the report messages will be ignored. We will adding a reference.

Minor
=====

- Typo in bridge-router-interface: dynamicly.
[Authors] Accepted

- No need to mention the leaf name in description, e.g. in l2-service-type
[Authors] Accepted

- Leaf “host-address”, rename to “address” since the list is called host (no need to duplicate host).
[Authors] Accepted

Regards,
Reshad.

---

From: Reshad Rahman <[email-masked]>
Date: Tue, 5 Oct 2021 12:06:40 +0000 (UTC)

Thank you Hongji for addressing the coments, all good with me.
Regards,Reshad.
    On Tuesday, October 5, 2021, 05:58:21 AM EDT, Hongji Zhao <[email-masked]> wrote:  
 
 Hi Reshad,

BR/Hongji

-----Original Message-----
From: Reshad Rahman via Datatracker <[email-masked]> 
Sent: 2021年9月30日 11:09
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Yangdoctors last call review of draft-ietf-pim-igmp-mld-snooping-yang-19

Reviewer: Reshad Rahman

Main comments
=============

Questions
========

Minor
=====

Regards,
Reshad.

---

From: Hongji Zhao <[email-masked]>
Date: Fri, 8 Oct 2021 09:45:01 +0000

Hi Reshad,

I have addressed your comments in draft-ietf-pim-igmp-mld-snooping-yang-20.  Please have a check. Thanks a lot.

https://datatracker.ietf.org/doc/draft-ietf-pim-igmp-mld-snooping-yang/

BR/Hongji

From: Reshad Rahman <[email-masked]>
Sent: 2021年10月5日 20:07
To: [email-masked]; Hongji Zhao <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Yangdoctors last call review of draft-ietf-pim-igmp-mld-snooping-yang-19

Regards,
Reshad.

On Tuesday, October 5, 2021, 05:58:21 AM EDT, Hongji Zhao <[email-masked]<mailto:[email-masked]>> wrote:

Hi Reshad,

BR/Hongji

-----Original Message-----
From: Reshad Rahman via Datatracker <[email-masked]<mailto:[email-masked]>>
Sent: 2021年9月30日 11:09
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Yangdoctors last call review of draft-ietf-pim-igmp-mld-snooping-yang-19

Reviewer: Reshad Rahman

Main comments
=============

Questions
========

Minor
=====

Regards,
Reshad.

---

From: Reshad Rahman <[email-masked]>
Date: Fri, 8 Oct 2021 14:32:59 +0000 (UTC)

Hi Hongji,
LGTM.
Regards,Reshad.
    On Friday, October 8, 2021, 05:45:05 AM EDT, Hongji Zhao <[email-masked]> wrote:  

Hi Reshad,

 

BR/Hongji

 

Regards,
 
Reshad.

 

Hi Reshad,

BR/Hongji

-----Original Message-----
From: Reshad Rahman via Datatracker <[email-masked]>
Sent: 2021年9月30日 11:09
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Yangdoctors last call review of draft-ietf-pim-igmp-mld-snooping-yang-19

Reviewer: Reshad Rahman

Main comments
=============

Questions
========

Minor
=====

Regards,
Reshad.