Subject: [yang-doctors] [IANA #1208742] YANG modules and XML-based registries

From: "Michelle Cotton via RT" <[email-masked]>
Date: Mon, 29 Nov 2021 22:26:07 +0000

Thanks Benoit (so great to hear from you!)

Just curious...if ftp.iana.org were not available, would having it only available via rsync be OK?  Or would that cause a problem?

Just trying to fully understand the need.

Thanks!

--Michelle

 On Fri Nov 26 15:05:04 2021, [email-masked] wrote:
> Hi Michelle,
> 
> Sorry for the delay in getting back to you.
> Here is the reason behind this note.
>  At
>  https://www.iana.org/assignments/yang-parameters/yang-
> parameters.xhtml,
> you see the column "IANA maintained".
>  How can someone know that there is a new revision for an IANA-
> maintained
> YANG module?
> And if we know, how to retrieve it?
> Typical example: iana-if-types
>  Hence, the only solution is to have a cron job that will query IANA
> on
> regular basis.
>  That's what we do in yangcatalog.org. I believe my initial code was
> done
> with rsync.
> Including Miroslav (and other partners in crime) to double-check this.
> 
> Regards, Benoit
> 
> 
> On 10/27/2021 12:51 AM, Michelle Cotton via RT wrote:
> > Hello Benoit,
> >
> > I hope this message finds you well.
> >
> > We were just having an internal discussion and had a question for
> > you.
> >
> > On our website for yang modules, we have a note that says the
> > following:
> >
> > "YANG modules are additionally available for bulk retrieval
> > by Rsync (rsync.iana.org::assignments/yang-parameters/) or
> > FTP (ftp://ftp.iana.org/assignments/yang-parameters/)."
> >
> > Are folks actually using ftp.iana.org to get yang modules?  What are
> > they doing with them?  The reason this came up is we are exploring
> > potentially decommissioning ftp.iana.org, similar to what the IETF
> > recently did with their ftp server.  If it did happen it would be
> > still a ways in the future.
> >
> > Can you provide any insight regarding the use of ftp.iana.org for
> > yang modules?
> >
> > Thanks in advance.
> >
> > Michelle
> >
> > *****
> > Michelle Cotton
> > IANA Services
> >
> > .

---

From: Benoit Claise <[email-masked]>
Date: Mon, 29 Nov 2021 23:44:34 +0100

Hi Michelle,
> Thanks Benoit (so great to hear from you!)
Yes, I've been missing our IPFIX and YANG registry discussions :-)
>
> Just curious...if ftp.iana.org were not available, would having it only available via rsync be OK?
That would be ok IMO.
Miroslav, do you confirm from an YC.o development point of view?

Regards, Benoit
> Or would that cause a problem?
>