Subject: Re: [yang-doctors] [IANA #1208742] YANG modules and XML-based registries

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 2 Dec 2021 13:47:09 +0000

Could using HTTPS even be simpler ? There is a date in the HTTP header indicated the revision date of the file and this could be useful as well for yangcatalog.org (even if rsynch is probably more efficient)

-éric

On 29/11/2021, 23:45, "Benoit Claise" <[email-masked]> wrote:

    Hi Michelle,
    > Thanks Benoit (so great to hear from you!)
    Yes, I've been missing our IPFIX and YANG registry discussions :-)
    >
    > Just curious...if ftp.iana.org were not available, would having it only available via rsync be OK?
    That would be ok IMO.
    Miroslav, do you confirm from an YC.o development point of view?

    Regards, Benoit
    > Or would that cause a problem?
    >
    > Just trying to fully understand the need.
    >
    > Thanks!
    >
    > --Michelle
    >
    >
    >   On Fri Nov 26 15:05:04 2021, [email-masked] wrote:
    >> Hi Michelle,
    >>
    >> Sorry for the delay in getting back to you.
    >> Here is the reason behind this note.
    >>   At
    >>   https://www.iana.org/assignments/yang-parameters/yang-
    >> parameters.xhtml,
    >> you see the column "IANA maintained".
    >>   How can someone know that there is a new revision for an IANA-
    >> maintained
    >> YANG module?
    >> And if we know, how to retrieve it?
    >> Typical example: iana-if-types
    >>   Hence, the only solution is to have a cron job that will query IANA
    >> on
    >> regular basis.
    >>   That's what we do in yangcatalog.org. I believe my initial code was
    >> done
    >> with rsync.
    >> Including Miroslav (and other partners in crime) to double-check this.
    >>
    >> Regards, Benoit
    >>
    >>
    >> On 10/27/2021 12:51 AM, Michelle Cotton via RT wrote:
    >>> Hello Benoit,
    >>>
    >>> I hope this message finds you well.
    >>>
    >>> We were just having an internal discussion and had a question for
    >>> you.
    >>>
    >>> On our website for yang modules, we have a note that says the
    >>> following:
    >>>
    >>> "YANG modules are additionally available for bulk retrieval
    >>> by Rsync (rsync.iana.org::assignments/yang-parameters/) or
    >>> FTP (ftp://ftp.iana.org/assignments/yang-parameters/)."
    >>>
    >>> Are folks actually using ftp.iana.org to get yang modules?  What are
    >>> they doing with them?  The reason this came up is we are exploring
    >>> potentially decommissioning ftp.iana.org, similar to what the IETF
    >>> recently did with their ftp server.  If it did happen it would be
    >>> still a ways in the future.
    >>>
    >>> Can you provide any insight regarding the use of ftp.iana.org for
    >>> yang modules?
    >>>
    >>> Thanks in advance.
    >>>
    >>> Michelle
    >>>
    >>> *****
    >>> Michelle Cotton
    >>> IANA Services
    >>>
    >>> .
    > .

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 2 Dec 2021 15:04:33 +0100

> Could using HTTPS even be simpler ? There is a date in the HTTP header indicated the revision date of the file and this could be useful as well for yangcatalog.org (even if rsynch is probably more…

Yes, in iana-yang project [1] I first get the "Last-Modified" header via 
curl to check if the XML representation of a registry has changed.

Lada

[1] https://github.com/llhotka/iana-yang

> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
> 

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Miroslav Kováč <[email-masked]>
Date: Mon, 6 Dec 2021 06:15:55 +0000

Hello everyone,

I am sorry for late answer, I was on a holiday and just got back. I am adding Slavomir Mazur to this conversation since he is the main developer right now.

> Could using HTTPS even be simpler ? There is a date in the HTTP header indicated the revision date of the file and this could be useful as well for yangcatalog.org (even if rsynch is probably more…

I believe that yes. It would give more information and it is always good. About efficient I am not sure right now. We came with an algorithm in yangcatalog ourselves which is already checking if the file is new/updated or nothing at all which is quiet fast and has to be done for each file added to yangcatalog anyway. Slavomir please check if this information is any useful for us or we actually do not need it.

> Just curious...if ftp.iana.org were not available, would having it only available via rsync be OK?

Yes we are using only rsync - no ftp.

Regrads,

Miroslav Kovac

________________________________
Od: Ladislav Lhotka <[email-masked]>
Odoslané: štvrtok, 2. decembra 2021 15:04:33
Komu: Eric Vyncke (evyncke); Benoit Claise; [email-masked]
Kópia: [email-masked]; Miroslav Kováč
Predmet: Re: [yang-doctors] [IANA #1208742] YANG modules and XML-based registries

Lada