Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

From: Jeffrey Haas <[email-masked]>
Date: Wed, 1 Dec 2021 16:48:55 -0500

Rob,

Thanks for your patience.  Mahesh was good enough to help us avoid coordination issues by getting this centralized in github.

https://github.com/mjethanandani/rfc9127-bis/tree/v01/draft <https://github.com/mjethanandani/rfc9127-bis/tree/v01/draft>

You will find the target draft, and the diff in the above portion of the repo.

What I think the next steps look like:
- Yang doctors confirm they're happy with things.
- We post the draft and request BFD WG review as part of immediate last-call and give a few days for that review.
- Submit 9127-bis draft and simultaneously request RFC Editor to clear blocks on pending cluster documents since the issue is resolved without changes needed.

I think the RFC Editor may need to be requested to revert the changes Acee had started with when we began this.

-- Jeff

> On Nov 19, 2021, at 4:56 AM, Rob Wilton (rwilton) <[email-masked]> wrote:
> 
> Hi Jeff, Mahesh,
> 
> Any update on that diff?
> 
> Thanks,
> Rob
> 
> 
> -----Original Message-----
> From: Jeffrey Haas <[email-masked]> 
> Sent: 10 November 2021 23:26
> To: Rob Wilton (rwilton) <[email-masked]>
> Cc: Martin Björklund <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Reshad Rahman <[email-masked]>
> Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms
> 
> I spent some time talking to Mahesh this afternoon and think we’re in sync. 
> 
> Expect a complete diff from him soon. 
> 
> Jeff
> 
>> On Nov 10, 2021, at 4:42 PM, Rob Wilton (rwilton) <[email-masked]> wrote:
>> 
>> [Resending with Reshad's correct address]
>> 
>> Hi,
>> 
>> Thanks for the input so far.
>> 
>> Having chatted with Alvaro and John, I believe that we are looking for a solution such that (1) we know what is being done in RFC 9127bis, and (2) allows the Auth48 of the protocol drafts to complete so that they can be published.  I.e., it is okay to delay Auth48 by a couple of weeks so that we know exactly what changes need to be made to the modules in Auth48, but not to delay publishing of the protocol drafts until RFC 9217bis has gone through the process.
>> 
>> We would like to reach an agreement on what the plan/changes are no later than Nov 24th, sooner if possible.
>> 
>> My reading of the consensus so far so that it is acceptable to make non-backwards-compatible changes to RFC 9217bis, if necessary, but we should not make non-backwards-compatible changes without a good justification.
>> 
>> I think, if I understand the proposals correctly, that I'm leaning towards option (2) that Martin described below.
>> 
>> Regards,
>> Rob
>> 
>> 
>> -----Original Message-----
>> From: Martin Björklund <[email-masked]> 
>> Sent: 10 November 2021 15:26
>> To: [email-masked]
>> Cc: Rob Wilton (rwilton) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
>> Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms
>> 
>> Jeffrey Haas <[email-masked]> wrote:
>>>> On Wed, Nov 10, 2021 at 03:24:19PM +0100, Martin Björklund wrote:
>>>> I'm not ok with this violation in general, but I am ok with it in this
>>>> particular case.  Hence my questions.
>>> 
>>> Understood.
>>> 
>>>> If it turns out that in the end
>>>> you modify the AUTH48-docs and wait for the bis anyway, then I don't
>>>> think this is the right way to go.
>>> 
>>> So, your preference is "ship AUTH48 docs unchanged, even though it'd have a
>>> potentially redundant 'feature bfd'"?
>> 
>> Of course my preference is to not violate the upgrade rules, if
>> possible.
>> 
>> 1.  publish the auth48-docs now with redundant "bfd" feature
>> 2.  publish the auth48-docs now and remove the redundant "bfd" feature
>> 3.  remove the redundant "bfd" feature and wait for -bis
>> 
>> I am not sure I understand what the proposal is at this point (as I
>> understood it, your original proposal was (1), but also w/o "bfd" in
>> -bis).
>> 
>> With (2), the published docs won't be very useful until the -bis is
>> published, right?
>> 
>> In the case of (3), I think it is better to make a proper fix to -bis.
>> 
>> And in the case of (1), you could as well introduce redundant
>> "client-cfg-param" features (as I suggested earlier), and avoid the
>> proposed -bis YANG upgrade rule violation.
>> 
>> Anyway, if you still decide to go with (1) or (2), I am ok with the
>> proposed -bis.  (I prefer (2) over (1)).
>> 
>> 
>> 
>> /martin
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 3 Dec 2021 20:24:54 +0000

I don’t feel that strongly but it seems strange that the feature identifier, client-cfg-parms, is the same as the existing grouping. It seems the new feature should be more granular, e.g., extended-client-cfg-parms.
Thanks,
Acee

From: yang-doctors <[email-masked]> on behalf of Jeff Haas <[email-masked]>
Date: Wednesday, December 1, 2021 at 4:49 PM
To: "Rob Wilton (rwilton)" <[email-masked]>
Cc: Routing ADs <[email-masked]>, YANG Doctors <[email-masked]>
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

Rob,

https://github.com/mjethanandani/rfc9127-bis/tree/v01/draft

-- Jeff

On Nov 19, 2021, at 4:56 AM, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jeff, Mahesh,

Any update on that diff?

Thanks,
Rob

-----Original Message-----
From: Jeffrey Haas <[email-masked]<mailto:[email-masked]>>
Sent: 10 November 2021 23:26
To: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>
Cc: Martin Björklund <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Reshad Rahman <[email-masked]<mailto:[email-masked]>>
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

Jeff

On Nov 10, 2021, at 4:42 PM, Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,
Rob

-----Original Message-----
From: Martin Björklund <[email-masked]<mailto:[email-masked]>>
Sent: 10 November 2021 15:26
To: [email-masked]<mailto:[email-masked]>
Cc: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

Jeffrey Haas <[email-masked]<mailto:[email-masked]>> wrote:

Understood.

/martin

---

From: Reshad Rahman <[email-masked]>
Date: Fri, 3 Dec 2021 21:38:41 +0000 (UTC)

The feature name I believe is slightly different: client-cfg-parameters, but I see your point. I can live with the suggestion below although I'm not sure about "extended". I don't feel strongly about this either.
Regards,Reshad (no hat).
    On Friday, December 3, 2021, 03:25:18 PM EST, Acee Lindem (acee) <acee=[email-masked]> wrote:  

Thanks,
Acee

From:yang-doctors <[email-masked]> on behalf of Jeff Haas <[email-masked]>

Rob,

 

 

 

 
-- Jeff

  

 
Hi Jeff, Mahesh,

Any update on that diff?

Thanks,
Rob

-----Original Message-----
From: Jeffrey Haas <[email-masked]> 
Sent: 10 November 2021 23:26
To: Rob Wilton (rwilton) <[email-masked]>
Cc: Martin Björklund <[email-masked]>; [email-masked]; [email-masked];[email-masked]; Reshad Rahman <[email-masked]>
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

Jeff

Hi,

Regards,
Rob

-----Original Message-----
From: Martin Björklund <[email-masked]> 
Sent: 10 November 2021 15:26
To: [email-masked]
Cc: Rob Wilton (rwilton) <[email-masked]>;[email-masked]; [email-masked]; [email-masked];[email-masked]
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

 

Understood.

/martin

  
 _______________________________________________
yang-doctors mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 3 Dec 2021 14:08:26 -0800

Hi Acee,

I agree with Reshad that ‘extended’ is probably not the right connotation for the feature statement. The feature allows for inclusion of BFD client configuration parameters. They are not extending an already defined set of client configuration parameters. Would it help to call the feature ‘bfd-client-cfg-parameters’?

Thanks.

> On Dec 3, 2021, at 1:38 PM, Reshad Rahman <[email-masked]> wrote:
> 
> Reshad (no hat).
> On Nov 19, 2021, at 4:56 AM, Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]>> wrote:
> 
>  
> Hi Jeff, Mahesh,
> 
> Any update on that diff?
> 
> Thanks,
> Rob
> 
> 
> From: Jeffrey Haas <[email-masked] <mailto:[email-masked]>> 
> To: Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]>>
> Cc: Martin Björklund <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; Reshad Rahman <[email-masked] <mailto:[email-masked]>>
> On Nov 10, 2021, at 4:42 PM, Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]>> wrote:
> 
> From: Martin Björklund <[email-masked] <mailto:[email-masked]>> 
> To: [email-masked] <mailto:[email-masked]>
> Cc: Rob Wilton (rwilton) <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Jeffrey Haas <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/yang-doctors <https://www.ietf.org/mailman/listinfo/yang-doctors>
> 

Mahesh Jethanandani
[email-masked]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 3 Dec 2021 23:10:45 +0000

Hi Mahesh,
How about client-base-cfg-parms since that matches the base-cfg-parms grouping?  In all honesty, I think the worse thing we can do is obsess about this… You guys have much more disposable time than me and I don’t want to debate this ad infinitum.
Thanks,
Acee

From: Mahesh Jethanandani <[email-masked]>
Date: Friday, December 3, 2021 at 5:08 PM
To: Reshad Rehman <[email-masked]>
Cc: Jeff Haas <[email-masked]>, "Rob Wilton (rwilton)" <[email-masked]>, Acee Lindem <[email-masked]>, Routing ADs <[email-masked]>, YANG Doctors <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

Hi Acee,

Thanks.

On Dec 3, 2021, at 1:38 PM, Reshad Rahman <[email-masked]<mailto:[email-masked]>> wrote:

Regards,
Reshad (no hat).

On Friday, December 3, 2021, 03:25:18 PM EST, Acee Lindem (acee) <acee=[email-masked]<mailto:acee=[email-masked]>> wrote:

Thanks,
Acee

From: yang-doctors <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Haas <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 1, 2021 at 4:49 PM
To: "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>
Cc: Routing ADs <[email-masked]<mailto:[email-masked]>>, YANG Doctors <[email-masked]<mailto:[email-masked]>>
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

Rob,

-- Jeff

Hi Jeff, Mahesh,

Any update on that diff?

Thanks,
Rob

-----Original Message-----
From: Jeffrey Haas <[email-masked]<mailto:[email-masked]>>
Sent: 10 November 2021 23:26
To: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>
Cc: Martin Björklund <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Reshad Rahman <[email-masked]<mailto:[email-masked]>>
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

Jeff

Hi,

Regards,
Rob

-----Original Message-----
From: Martin Björklund <[email-masked]<mailto:[email-masked]>>
Sent: 10 November 2021 15:26
To: [email-masked]<mailto:[email-masked]>
Cc: Rob Wilton (rwilton) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [yang-doctors] Dealing with BFD RFC 9127 client-cfg-parms for PIM, OSPF, ISIS and other BFD clients on some platforms

Understood.

/martin

[email-masked]<mailto:[email-masked]>

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 6 Dec 2021 08:30:11 -0500

On Fri, Dec 03, 2021 at 11:10:45PM +0000, Acee Lindem (acee) wrote:
> How about client-base-cfg-parms since that matches the base-cfg-parms
> grouping?

I'm supportive of that name.

>  In all honesty, I think the worse thing we can do is obsess
> about this… You guys have much more disposable time than me and I don’t
> want to debate this ad infinitum.

The lesson ADs learn is "don't comment on it unless you want the responses".
:-)

Mahesh, Reshad, if we're good on this change my recommendation is to post
the draft as draft-ietf-bfd-rfc9127-bis and we'll see what we can do to push
this through WG review.

-- Jeff

---

From: Reshad Rahman <[email-masked]>
Date: Mon, 6 Dec 2021 13:32:49 +0000 (UTC)

Yes client-base-cfg-parms is good with me.
Regards,Reshad.
    On Monday, December 6, 2021, 08:30:14 AM EST, Jeffrey Haas <[email-masked]> wrote:  

-- Jeff

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 6 Dec 2021 20:10:06 -0800

> On Dec 6, 2021, at 5:30 AM, Jeffrey Haas <[email-masked]> wrote:
> 

Done.

Mahesh Jethanandani
[email-masked]