Subject: [yang-doctors] Yangdoctors early review of draft-ietf-opsawg-yang-vpn-service-pm-05

From: Ladislav Lhotka via Datatracker <[email-masked]>
Date: Fri, 08 Apr 2022 05:30:55 -0700

Reviewer: Ladislav Lhotka
Review result: Ready with Nits

**** General comments

The Internet-Draft contains a large YANG module that augments the network
topology model with L2/L3 VPN performance monitoring statistics. The module is
well designed and documented, I found no issues in it.

Examples of JSON instance data are useful for readers of the I-D, but less so
if they contain errors (see below). If possible, I'd suggest to validate the
examples with appropriate tools, or at least carefully check after each change
in the data model.

**** Specific comments

***** Section 5
- File name in <CODE BEGINS> line should be [email-masked]

***** Appendix A.2
- module "ietf-network-topo" doesn't exist, should it be "ietf-network"?

***** Appendix A.3
- leaf "middle-percentile" should probably be "intermediate-percentile".
- leaf "unit-values" should be "unit-value"
- The leaf "ietf-network-vpn-pm:inter-vpn-access-interface"
  is illegal (probably misplaced)

---

From: "Wubo (lana)" <[email-masked]>
Date: Wed, 13 Apr 2022 02:28:16 +0000

Hi Lada,

Many thanks for your helpful review. We'll fix the errors in these examples in the next version. Please see inline for details.

Thanks,
Bo

-----Original Message-----
From: Ladislav Lhotka via Datatracker [mailto:[email-masked]] 
Sent: Friday, April 8, 2022 8:31 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Yangdoctors early review of draft-ietf-opsawg-yang-vpn-service-pm-05

**** General comments

The Internet-Draft contains a large YANG module that augments the network topology model with L2/L3 VPN performance monitoring statistics. The module is well designed and documented, I found no issues in it.

Examples of JSON instance data are useful for readers of the I-D, but less so if they contain errors (see below). If possible, I'd suggest to validate the examples with appropriate tools, or at least carefully check after each change in the data model.

**** Specific comments

***** Section 5
Bo Wu: Fixed.

***** Appendix A.2
- module "ietf-network-topo" doesn't exist, should it be "ietf-network"?
Bo Wu: Yes. Thanks for pointing this out. 

***** Appendix A.3
Bo Wu: Thanks for catching this. We sill fix these.